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 1
I n t r o d u c t i o n
The Earth Science Module Model Library contains write-ups and documentation 
for a number of geophysical and environmental scenarios. Many of the tools 
discussed here will help your modeling in this module and elsewhere in COMSOL 
Multiphysics. We encourage you to browse and explore. An important strength of 
COMSOL Multiphysics is the inheritance that comes from a community of 
researchers across many different disciplines. Tapping into the variety available in 
COMSOL Multiphysics will enhance your modeling. Guaranteed.

In this library, the example models fall into five groups:

• Fluid flow

• Solute transport

• Flow and deformation

• Heat transfer

• Multiphysics.

The models typically involve one or more application modes from the Earth Science 
Module. Others, such as the poroelasticity and electrokinetic volcano flow 
examples, use application modes from elsewhere in COMSOL Multiphysics. The 
models serve as a reference and also provide a head start for your own analyses. The 
 1



2 |  C H A P T E R  1
ready-to-run models come with theoretical background as well as instructions that 
illustrate how to set them up. You can freely modify the model files, change the 
geometries and material properties, alter the equations, and add new physics to the file. 
Building on the shoulders of others saves time and adds insight.

Some models come from experts using COMSOL Multiphysics in their work and 
research. Others were put together by our staff engineers who have years of experience 
in Earth science; they are your peers, using the language and terminology needed to 
get across the sophisticated concepts in these advanced topics. Many of the models 
have analytic solutions. Some are benchmark models designed to test the metal of 
dedicated physics programs. 

The model descriptions range in detail. Those that describe each step are useful as 
tutorials. Others are in-depth examples that focus on advanced or unusual options that 
you can use once you are familiar with COMSOL Multiphysics modeling. Before 
tackling the in-depth models, we urge you to take a look at a few of the basic variety.

The Earth Science Module User’s Guide covers the equation set up, offers some 
insights on the underlying physics, and includes some fundamental modeling 
techniques for each application mode. The COMSOL Multiphysics User’s Guide and 
the COMSOL Multiphysics Quick Start and Quick Reference manual provide 
additional information about modeling in the graphical user interface. For details 
about modeling with a programming language, look to the COMSOL Multiphysics 
MATLAB Interface Guide.

Each example comes with a COMSOL Multiphysics Model MPH-file that you can 
browse, modify and postprocess. This allows you to follow along with every step along 
the way whether you make the model or not. A few of the models also include 
application modes from other optional packages from COMSOL.

Model Library Guide

The table below summarizes key information about each entry in the Earth Science 
Module Model Library. The models are grouped according to the application area. 
The table also shows the equations used in each model.

The solution time is the elapsed time measured on a machine running Windows Vista 
with a 2.6 GHz AMD Athlon X2 Dual Core 500 CPU and 2 GB of RAM. For models 
:  I N T R O D U C T I O N



TABLE

MODE

O
T

H
E

R

FLUID

Pore

Fluid

Fluid

Fluid

Perfo

Cou

Tran
Navi

Poro

Varia

Inter

Two-

Two-

Two-

Aqui

Forc

SOLID

Terza

Biot 

Poro
Ope

SOLU

Solut

Buoy
Elder
with a sequential solution strategy, the Solution Time column shows the combined 
elapsed time for all solution steps.
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-Scale Flow 8 27 s  √

 Flow to Wells: Finite Well 20 1 s  √

 Flow to Wells: Leaky Well 30 1 s  √

 Flow to Wells: Wellbore Storage 35 1 s  √

rated Well 41 11 s  √

pled Flow Laws 53 1 s  √  √

sitional Flow: Darcy-Brinkman–
er-Stokes

68 19 s  √  √  √

us Media Flow: Discrete Fracture 83 35 s  √

bly Saturated Flow 97 4 s  √

polation for Unsaturated Flow 114 5 min  √

Phase Flow: Air/Water 129 4 min  √

Phase Flow: Air/Oil 129 3 min  √

Phase Flow: Oil/Water 129 3 min  √

fer Characterization¤ 152 22 min  √  √

hheimer Flow 175 8 s √ √
 DEFORMATION

ghi Compaction 186 1 s  √

Poroelasticity 199 5 s  √  √

elastic Flow and Deformation: 
n-Hole Multilateral Well

217 23 s  √  √

TE TRANSPORT

e Injection 234 2 s  √  √

ancy Flow with Darcy’s Law: The 
 Problem

250 37 s  √  √
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Varia
Tran

Pesti
Soil†

Aqui

HEAT

Buoy

Free

Phas

MULT

Elect
Insid

Elect
Insid

TABLE 

MODE

O
T

H
E

R

 ¤ This model requires the Optimization Lab. 
 † This model requires the COMSOL Reaction Engineering Lab. 
 ‡ This model requires the AC/DC Module.

Typographical Conventions

All COMSOL manuals use a set of consistent typographical conventions that should 
make it easy for you to follow the discussion, realize what you can expect to see on the 
screen, and know which data you must enter into various data-entry fields. In 
particular, you should be aware of these conventions:

• A boldface font of the shown size and style indicates that the given word(s) appear 
exactly that way on the COMSOL graphical user interface (for toolbar buttons in 
the corresponding tooltip). For instance, we often refer to the Model Navigator, 
which is the window that appears when you start a new modeling session in 
COMSOL; the corresponding window on the screen has the title Model Navigator. 
As another example, the instructions might say to click the Multiphysics button, and 

bly Saturated Flow and 
sport: Sorbing Solute

267 6 min  √  √

cide Transport and Reaction in 288 17 min  √  √

fer Water Table Calculation 306 55 s √ √ √
 TRANSFER

ancy Flow in Free Fluids 328 2 min  √  √

 Convection in Porous Media 338 14 s  √  √

e Change 348 6 s  √
IPHYSICS

rokinetic and Magnetic Fields 
e a Volcano 2D‡

360 14 s  √  √

rokinetic and Magnetic Fields 
e a Volcano 3D‡

360 2 min  √  √
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the boldface font indicates that you can expect to see a button with that exact label 
on the COMSOL user interface.

• The names of other items on the graphical user interface that do not have direct 
labels contain a leading uppercase letter. For instance, we often refer to the Draw 
toolbar; this vertical bar containing many icons appears on the left side of the user 
interface during geometry modeling. However, nowhere on the screen will you see 
the term “Draw” referring to this toolbar (if it were on the screen, we would print 
it in this manual as the Draw menu).

• The symbol > indicates a menu item or an item in a folder in the Model Navigator. 
For example, Physics>Equation System>Subdomain Settings is equivalent to: On the 
Physics menu, point to Equation System and then click Subdomain Settings. 
COMSOL Multiphysics>Heat Transfer>Conduction means: Open the COMSOL 

Multiphysics folder, open the Heat Transfer folder, and select Conduction.

• A Code (monospace) font indicates keyboard entries in the user interface. You might 
see an instruction such as “Type 1.25 in the Current density edit field.” The 
monospace font also indicates code.

• An italic font indicates the introduction of important terminology. Expect to find 
an explanation in the same paragraph or in the Glossary. The names of books in the 
COMSOL documentation set also appear using an italic font.
 |  5
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 2
F l u i d  F l o w  M o d e l s
This chapter contains a suite of models demonstrating the fluid-flow modeling 
capabilities in the Earth Science Module for modeling, for example, fluid flow to 
wells, porous media flow, and two-phase flow.
 7
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Po r e - S c a l e  F l ow

Introduction

This unconventional model of porous media flow uses the Navier-Stokes equations in 
the interstices of a porous media. The model comes from pore-scale flow experiments 
conducted by Arturo Keller, Maria Auset, and Sanya Sirivithayapakorn of the 
University of California, Santa Barbara. To produce the model geometry they scanned 
electron microscope images. This type of non-conventional pore-scale modeling with 
COMSOL Multiphysics sheds new light on the movement of large particulates, 
colloids, moving through variable-pore geometries in the subsurface. Several of these 
researchers have published results from their COMSOL Multiphysics modeling in the 
publication Water Resources Research (Ref. 1 and Ref. 2). 

Keller, Auset, and Sirivithayapakorn designed their lab experiments on the basis of 
scanning electron microscope (SEM) images of thinly sliced rock sections 
(Figure 2-1). They etched the geometric patterns from the images onto a solid with an 
elaborate process similar to the etching of silicon wafers. They then transferred these 
images to DXF files, which they finally imported into COMSOL Multiphysics.

Figure 2-1: Scanning electron microscope image of the repeat pattern in the silicon wafer. 
The scale at bottom indicates that pore throat and body dimensions are on the order of 
1 µm–100 µm (Ref. 1).
2 :  F L U I D  F L O W  M O D E L S



It is typical to represent fluid flow in the subsurface as a continuum process using 
average or “continuous” properties for the bulk rather than detailing the shape and 
orientation of each solid particle within a porous medium. Inserting the bulk 
properties into an equation such as Darcy’s law gives an average flow rate for the total 
volume. While bulk approximations typically produce excellent estimates sufficient for 
considering flow over large areas, they miss the between-grain nuances that a close-up 
Navier-Stokes analysis describes. 

This example takes one of the 2D micromedia images of Keller, Auset, and 
Sirivithayapakorn and solves for velocities and pressures of pore fluids using the 
Navier-Stokes equations for Cartesian coordinates. The exercise imports the geometry 
as a DXF file and does not mesh any unneeded regions. Plotting includes 
3-dimensionalizing a 2D surface plot by adding height data. Boundary integration 
quantitatively evaluates fluxes.

Model Definition

The entire model covers 640 µm by 320 µm. Water generally moves from right to left 
across the geometry. Flow is laminar in the pores and does not enter the grains. The 
inlet and outlet fluid pressures are known. Assume flow is symmetric about the top and 
bottom boundaries. The primary zone of interest is the rectangular region with an 
upper left corner at (0, 0) µm and lower right coordinates at (581.6, −265.0) µm.

Assuming fluids in the pore spaces are at constant density and also that temperature is 
constant, the incompressible Navier-Stokes equations describe the flow. Owing to the 
problem’s small scale, the model does not include a body force that accounts for 
gravity.

At the model’s physical boundaries, the inlet pressure and the outlet pressure are 
known. Velocities are zero at the grain boundaries, which implies a no-slip condition. 
Flow is symmetric about the top and bottom boundaries. Table 2-1 summarizes the 
boundary conditions.

Here p0 is a specified pressure drop.

TABLE 2-1:  BOUNDARY CONDITIONS

BOUNDARY TYPE BOUNDARY CONDITION VALUE

Inlet Pressure, no viscous stress  p = p0

Outlet Pressure, no viscous stress  p = 0

Grain walls Wall -

Symmetry sides Symmetry -
P O R E - S C A L E  F L O W  |  9
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Table 2-2 collects the relevant model data.

Results and Discussion

Figure 2-2 shows the COMSOL Multiphysics solution predicted with a Navier-Stokes 
analysis for the fluid velocity field in the pore spaces of a micro-scale porous medium. 
The velocity magnitude is higher in the narrowest pores than at the inlet, tending to 
decrease in stretches where the cross-sectional area for the flow increases.

Figure 2-2: Surface and arrow plots of the velocity field.

TABLE 2-2:  MODEL DATA

QUANTITY VALUE DESCRIPTION

 ρ0 1000 kg/m3 Fluid density

 η0 0.001 kg/(m·s) Dynamic viscosity

 p0 0.715 Pa Pressure drop
 2 :  F L U I D  F L O W  M O D E L S



Figure 2-3 gives the velocity field plotted with a height that corresponds to pressure 
head. The figure clearly shows stagnant zones that exist within the dead-end reaches 
of big pores.

Figure 2-3: Velocity field (color) and pressure head (height, µm) within the study section.

The figure reveals that the highest velocities tend to occur in narrow pores with high 
pressure drops, as you might expect. Figure 2-4 shows a close-up view of a region near 
the exit, revealing that high velocities also develop in wide channels where pressure 
gradients are relatively small but multiple “tributaries” combine.
P O R E - S C A L E  F L O W  |  11
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Figure 2-4: Close-up of velocity magnitude (color) and pressure head (height) near the 
outlet.

The domain plot in Figure 2-5 shows the x-velocity at the outlet. The velocities are 
negative because the flow is moving in the negative x direction.

Figure 2-5: Normal velocity along the outlet boundaries.
 2 :  F L U I D  F L O W  M O D E L S
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Model Library path: Earth_Science_Module/Fluid_Flow/pore_scale

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and in the Space dimension list select 2D.

2 From the list of application modes choose 
Earth Science Module>Fluid Flow>Incompressible Navier-Stokes. Click OK.

G E O M E T R Y  M O D E L I N G

1 Import the geometry from the DXF file. From the File menu, select 
Import>CAD Data From File and then navigate to pore_scale.dxf.

2 Accept the default settings for the geometry import. Click OK.

3 Click the Coerce to Solid button on the Draw toolbar.
P O R E - S C A L E  F L O W  |  13



14 |  C H A P T E R
4 Click the Split Object button on the Draw toolbar.

5 With the mouse, select the object CO2, which corresponds to the open flow region.

6 Copy the geometry object by pressing Ctrl+C.

7 Select all objects by pressing Ctrl+A. Delete all objects by pressing the Delete key.

8 Paste the copied object by pressing Ctrl+V, then click OK in the Displacement dialog 
box that appears.

9 Click the Zoom Extents button on the Main toolbar to center the geometry in the 
field of view.

The geometry’s dimensions is in microns. To take advantage of COMSOL 
Multiphysics’ unit-handling capabilities, finish the geometry modeling stage by 
rescaling the geometry to the SI length unit meter:

10 Click the Scale button on the Draw toolbar.

11 In the Scale factor area, type 1e-6 in the x and y edit fields. Click OK.

12 Click the Zoom Extents button once again.

The geometry in the drawing area on your screen should now look like that in the 
figure below.

O P T I O N S  A N D  S E T T I N G S

1 From the Physics menu, select Model Settings.

2 Clear the Simplify expressions check box, then click OK.

3 From the Options menu, select Constants.
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4 Enter the following names, expressions, and (optionally) descriptions; when done, 
click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings
From the Physics menu, select Subdomain Settings. Select Subdomain 1, then enter 
material properties from the following table; when done, click OK.

Boundary Conditions
From the Physics menu, select Boundary Settings. For the various boundaries in the 
following table, enter the corresponding settings; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 On the Global page, click the Custom mesh size button, then enter the following data:

3 On the Boundary page, select Boundaries 1–6.

4 In the Maximum element size edit field type 3.

NAME EXPRESSION DESCRIPTION

rho0 1000[kg/m^3] Fluid density

eta0 0.001[kg/(m*s)] Dynamic viscosity

p0 0.715[Pa] Pressure drop

VARIABLE SUBDOMAIN 1

 ρ rho0

 η eta0

SETTINGS BOUNDARIES 1–6 BOUNDARIES 7–25 BOUNDARIES 26, 27 ALL OTHERS

Boundary type Outlet Symmetry boundary Inlet Wall

Boundary 
condition

Pressure, no 
viscous stress

- Pressure, no 
viscous stress

No slip

p0 0 p0

GLOBAL MESH PARAMETERS EXPRESSION

Maximum element size 1e-5

Element growth rate 1.6

Mesh curvature factor 0.3
P O R E - S C A L E  F L O W  |  15
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5 On the Advanced page, set the Resolution of geometry to 20.

6 Click the Remesh button. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 2-2 follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 On the General page, select the Surface and Arrow check boxes.

3 Click the Surface tab. From the Predefined quantities list on the Surface Data page, 
select Velocity field. In the Unit edit field, type um/s to display the velocity in the unit 
µm/s.

4 Click the Arrow tab. From the Predefined quantities list on the Subdomain Data page, 
select Velocity field.

5 In the Arrow positioning area, in both the x points and y points edit fields enter 40.

6 Click Apply.

To generate Figure 2-3 continue with these steps:

1 Return to the Plot Parameters dialog box and clear the Arrow plot check box on the 
Arrow page.

2 On the Surface page, click the Height Data tab. Select the Height data check box, and 
in the Expression edit field enter p/(rho0*9.82[m/s^2]). From the Unit list, select 
um to display the pressure head in µm.

3 Click OK.

To generate Figure 2-4 continue with this step:

Define the area of interest. Go to the 3D Draw toolbar and activate the Dolly In/Out 
icon, or go to the Main toolbar and select the Zoom Window tool.

To generate Figure 2-5 continue with these steps:

1 From the Postprocessing menu, open the Domain Plot Parameters dialog box 
(because you are evaluating quantities on boundaries).

2 Click the Line/Extrusion tab. In the Boundary selection list select Boundaries 1–6.

3 From the Predefined quantities list in the y-axis data area, select x-velocity.

4 In the x-axis data area, click the lower option button and then the Expression button.
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5 In the X-Axis Data dialog box, type y in the Expression edit field and um/s in the Unit 
edit field. Click OK.

6 Click OK to close the Domain Plot Parameters dialog box and generate the plot.

To visualize particle tracing based on Stokes law continue with the following steps.

1 From the Options menu, open the Constants dialog box.

2 Add the following constants; when done, click OK.

As already mentioned, the small model dimensions allow you to ignore the effects 
of gravity. Including the constant g with value zero facilitates adapting the model to 
situations where gravity plays a significant role.

3 From the Solve menu, select Update Model.

4 From the Postprocessing menu, open the Plot Parameters dialog box.

5 On the Surface page, clear the Height data check box on the Height Data page.

6 On the General page, select the Arrow and Particle tracing check boxes in the 
Plot type area (leave the Surface and Geometry edges check boxes selected).

7 Click the Particle Tracing tab. In the Mass edit field, type p_mass.

8 In the Fx edit field, type -6*pi*p_rad*eta0*(partu-u), and in the Fy edit field, 
type (p_mass-rho0*p_vol)*g-6*pi*p_rad*eta0*(partv-v).

9 Click the Start Points tab. In the x edit field, type 600e-6.

10 Click the Edit button to the right of the y edit field.

11 In the Edit dialog box, enter the following data; when done, click Add.

12 On the Initial Values page, set the Initial velocity components to u, v, and 0.

13 On the Line Color page, click the Color button. Select yellow, then click OK.

14 Click OK in the Plot Parameters dialog box.

NAME EXPRESSION EXPRESSION

p_mass 1[ug] Particle mass

p_rad 1[um] Particle radius

p_vol 4/3*pi*p_rad^3 Particle volume

g 0[m/s^2] Acceleration due to gravity

First value -275e-6

Last value -80e-6

Number of values 25
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F l u i d  F l ow t o  We l l s

Analyzing fluid flow to and from wells is critical in managing groundwater and oil 
resources, excavating subsurface structures, and cleaning up pollution. 

The following figure shows a well withdrawing fluids from a reservoir. The well sits 
within a casing of relatively large diameter. The fluids moving to it are under pressure 
because the reservoir section that the well taps is bounded above and below, in a layer 
cake, by relatively impermeable materials or confining layers. The pumping generates 
a cone of depression in the hydraulic potential field that both expands outward and 
deepens with time. However, because the fluids completely fill the pore spaces, the 
cone of depression represents drawdown in the pressure potential rather than the fluid 
content.

Figure 2-6: Schematic flow to a well in a confined aquifer. After Hsieh (Ref. 1).

This model demonstrates three analyses of flow to wells following lectures and class 
notes from Paul Hsieh of the U.S. Geological Survey and Stanford University (Ref. 1). 
In the first example, the well has a finite radius such that the hydraulic potential inside 
it equals the potential at the edge. In the second example, the confining layers make 

confining layer

confining layer

well casing

land surface

∆h∆hw

initial head h0

head at t>0 h

rc

rw

Unpumped reservoir

Pumped reservoir

confining layer
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imperfect seals, so fluids from overlying reservoirs leak into the pumped aquifer. In the 
third analysis, the fluids inside the well or wellbore storage must be removed before 
reservoir fluids are extracted. This example compares COMSOL Multiphysics 
solutions to classic examples from Theis (Ref. 2), Hantush and Jacob (Ref. 3), and 
Papadopoulos and Cooper (Ref. 4).

This simple sequence of 1D axisymmetric models uses the Darcy’s Law application 
mode from the Earth Science Module to analyze time-dependent flow to wells. The 
model domain is semi-infinite, but the analyses zoom in on a relatively small zone of 
interest and uses convenient commands for setting timed outputs over long durations.

To account for the finite well radius in the first analysis, this study extends results at the 
well edge over the well interior using extrusion coupling variables. To account for 
leakage in the second example, it adds a source term to the governing equation. To 
include wellbore storage impacts in the third example, you add an ordinary differential 
equation as boundary condition using weak formulations (with a “dweak” term). The 
model also demonstrates how to include externally generated solutions or data in 
COMSOL Multiphysics plots. For a 2D example involving a point well, see “Solute 
Injection” on page 234. A 3D well analysis appears in the section “Perforated Well” 
on page 41.
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F l u i d  F l ow t o  We l l s :  F i n i t e  Rad i u s  
We l l

Introduction

This first example in the model sequence “Fluid Flow to Wells” on page 18 defines 
transient flow to a well of finite radius in a confined aquifer. This discussion then 
compares the results from this analysis to the well-known solution for flow to a point 
well (Theis, Ref. 2). What distinguishes this model from the Theis problem is the well 
geometry because the analytical solution describes the well as a point source that 
produces unphysical results inside the wellbore. The COMSOL Multiphysics analysis 
produces a physically based solution in the well using extrusion-coupling variables to 
extend the results at the well edge over the well interior.

Apart from the well geometry, assumptions underlying the Theis problem apply. The 
reservoir is of infinite horizontal extent and is confined above and below by 
impermeable layers. As the well fully penetrates the reservoir, withdrawals are uniform 
along its length, making flow entirely horizontal. The problem neglects storage in the 
well. Fluids are released instantaneously from storage in the aquifer. Prior to pumping, 
the flow field is at steady state. Flow is horizontal, does not vary with depth, and 
equipotentials are axisymmetric about the wellhead.

Taking advantage of symmetry, you can approximate the semi-infinite aquifer as a long 
line, here 10 km. A 1-km segment represents the zone of interest. The well radius is 
0.1 m. The hydraulic conductivity, K, is 10−4 m/s, and the thickness, b, is 50 m. The 
storage coefficient for pressure, S (m·s2/kg), equals Ss/ρf g. Ss is the specific storage 
for hydraulic head of 10−5 m−1, ρf represents the fluid density (kg/m3), and g is 
gravity (m/s2). The pumping rate, W, of 0.05 m3/s is constant. The initial pressure, 
p0, is 9.82·105 Pa. The period of interest is 107 s or roughly four months.

Model Definition

You typically define fluid flow in the subsurface by inserting Darcy’s law for fluid 
velocity into an equation of continuity. For a dependent variable of pressure p (kg/
(m·s2)), the governing equation reads
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.

where S is the storage coefficient (m·s2/kg); K is the hydraulic conductivity (m/s); D 
is the vertical coordinate (m), to be specified in such a way that  becomes the unit 
vector in the vertical direction; and Qs is a volumetric flow rate per unit volume of 
aquifer (1/s). In this analysis you set D to zero because the analysis is 1D horizontal.

The drawdown, dr (m), is

where p0 is the pressure at the onset of pumping. Fluid moves into the well with a 
velocity described by Darcy’s law (here with  set to zero)

where W (m3·s) is the volumetric pumping rate for a cylindrical wellbore, rw (m) 
represents the well radius, and b (m) gives the vertical length of the pumping interval, 
in this case the aquifer thickness. The distill boundary is sufficiently far from the well 
that the pumping does not affect it.

The boundary and initial conditions for this model are

where n is the normal to the boundary.

Implementation: Extrusion Coupling Variables

The finite element method is sufficiently robust to estimate the pressure precisely at 
the well screen, r = rw, rather than averaging over a square (finite difference) or 
reducing the well to a point (analytic). Because pressure is continuous in fluids, the 
pressure inside the well equals the pressure just outside of it.

This axisymmetric model begins at the center of the well, at r = 0. If you “turn off” 
equations inside the well, where r < rw, the well screen becomes a boundary. To see 

S p∂
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the pressure in the well, extrude the solution at rw through the well interior using 
coupling variables. Extrusion-coupling variables take information from one type of 
model domain (such as the boundary at the well radius) and extrude it over other 
domain types (such as the subdomain inside the well). This can be very powerful 
modeling feature. For example, with coupling variables you can express material 
properties that depend on the solution at some critical zone in the model, or define 
one boundary using results for another to give identical conditions. For more 
information on coupling variables, refer to “Using Coupling Variables” on page 269 
of the COMSOL Multiphysics User’s Guide.

Results

Figure 2-7 illustrates the COMSOL Multiphysics solution for flow to a finite radius 
well. The results at varying times for a 1000-m extent show the cone of depression the 
pumping produces. Because the solution never reaches steady state, pressures drop 
with time.

Figure 2-7: COMSOL Multiphysics solution for fluid pressure near a finite radius well 
along the line r < 1000 m. Results are for logarithmically spaced times from 0 to 11.5 days.
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Figure 2-8 plots the solution as drawdown versus time at five points in the aquifer; it 
also gives the Theis estimates for drawdown. Unlike the pressure solution, the 
drawdown increases with time and decreases with distance from the well. The author 
calculated the Theis estimates within COMSOL Multiphysics and added them to the 
plot.

Figure 2-8: COMSOL Multiphysics results (solid lines with circles) shown with the Theis 
(Ref. 2) analytic solution (dashed lines) for drawdown in the aquifer at r = rw, 1 m, 10 m, 
100 m, and 1000 m.

The COMSOL Multiphysics and Theis estimates are very similar outside the well. 
What happens inside the well, however, is critical in many analyses. Figure 2-9 is a 
close-up view showing that COMSOL Multiphysics gives a physically-based solution 
inside the wellbore. The analytic estimates change unrealistically inside the wellbore 
because they represent withdrawals from a point.
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Figure 2-9: COMSOL Multiphysics drawdown solution for the finite radius well (solid 
lines with circles) shown with the Theis estimates for a point well (dashed lines) along the 
line r < 0.3 m.

The solution at the well radius appears inside the wellbore via extrusion-coupling 
variables from COMSOL Multiphysics.
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Model Library path: Earth_Science_Module/Fluid_Flow/finite_well

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator. From the Space dimension list select Axial symmetry (1D).

2 In the list of application modes select 
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis>Transient analysis. 
Click OK.

G E O M E T R Y  M O D E L I N G

1 From the Draw menu, select Specify Objects>Line.

2 In the Coordinates: r edit field, enter 0 0.1 1000 10000. Click OK.

3 Click the Zoom Extents button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

1 Select the menu item Options>Constants, then enter the following names, 
expressions, and descriptions (optional); when done, click OK.

2 Choose Options>Expressions>Scalar Expressions.

NAME EXPRESSION DESCRIPTION

rho_f 1000[kg/m^3] Fluid density

Ks 1e-4[m/s] Hydraulic conductivity

Ss 1e-5[1/m] Specific storage for hydraulic head

W 0.05[m^3/s] Pumping rate

b 50[m] Thickness

r_w 0.1[m] Well radius

p0 9.82e5[Pa] Initial pressure
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3 Enter the following names and expressions; when done, click OK.

4 Choose Options>Expressions>Subdomain Expressions. 

5 Define the following expressions on the indicated domains; when done, click OK.

6 Choose Options>Extrusion Coupling Variables>Boundary Variables.

7 On the Source page, select Boundary 2 and enter the following data in the table:

8 Click the General transformation option button.

9 Click the Destination tab, then specify the following settings:

10 Click OK.

P H Y S I C S  S E T T I N G S

Application Scalar Variables
1 Choose Physics>Scalar Variables.

2 Change the elevation coordinate D_esdl to 0 (because the model is 1D axisymmetric 
in the horizontal plane).

3 Click OK to close the Application Scalar Variables dialog box.

Subdomain Settings
1 From the Physics menu, open the Subdomain Settings dialog box.

2 Select Subdomain 1. Clear the Active in this domain check box.

NAME EXPRESSION

u Ss*r^2/(4*Ks*t)

Wu (-0.5772+u-0.25*u^2+0.055*u^3-0.01*u^4+0.001*u^5-log(u))* 
(u<1)+(exp(-u)*(u^4+8.58*u^3+18.06*u^2+8.64*u+0.27)/ 
(u^4+9.57*u^3+25.63*u^2+21.1*u+3.96)/u)*(u>=1)

Theis W/(4*pi*Ks*b)*Wu

NAME SUBDOMAIN 1 SUBDOMAINS 2, 3

pressure p_well p

drawdown (p0-p_well)/(rho_f*g_esdl) (p0-p)/(rho_f*g_esdl)

NAME EXPRESSION

p_well p

LEVEL SUBDOMAIN SELECTION

Subdomain 1
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3 Select Subdomains 2 and 3. From the Storage term list, select User defined.

4 Go to the other drop-down list and change the setting from Permeability to 
Hydraulic conductivity. Enter the following expressions:

5 Click the Init tab, and in the Initial value edit field enter p0. Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Enter the following boundary conditions; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters. 

2 Click the Subdomain tab, select Subdomain 2, and in the Maximum element size edit 
field enter 10.

3 Click the Boundary tab, select Boundary 2, and in the Maximum element size edit field 
enter 0.001. Click OK.

4 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box. Verify in the Solver list 
that Time dependent is selected.

2 To specify output times for the model, click the General tab and go to the 
Time stepping area. In the Times edit field type 0, then click the Edit button on the 
right. In the Edit dialog box, enter the First value -2, the Last value 6, and set the 
Number of values to 81. From the Function to apply to all values list, select exp10.

3 Click Add to close the Edit dialog box and append a range of 81 exponentially 
increasing times from 10−2 to 106 time units to the Times edit field.

4 Click OK to close the Plot Parameters dialog box.

5 Click the Solve button on the Main toolbar.

PROPERTY EXPRESSION

S Ss/(rho_f*g_esdl)

Ks Ks

BOUNDARY CONDITION QUANTITY BOUNDARY 2 BOUNDARY 4

Inward flux N0 -W/(2*pi*r_w*b)

Pressure p0 p0
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 2-7 proceed as follows:

1 From the Postprocessing menu, select Domain Plot Parameters.

2 In the Solutions to use list select 0.01, 0.1, 1, 10, 100, 1000, 10000, 100000, and 10e5.

3 Click the Title/Axis button. Enter a title as appropriate, then click OK.

4 Click the Line/Extrusion tab. Select Subdomains 1 and 2.

5 From the Predefined quantities list, select Pressure.

6 In the x-axis data area, click first the lower option button and then the Expression 
button. In the X-Axis Data dialog box, type r in the Expression edit field. Click OK.

7 Click the Line Settings button. From the Line marker list, select Cycle. Select the 
Legend check box, then click OK to close the Line Settings dialog box.

8 Click OK to close the Domain Plot Parameters dialog box and generate the plot.

To generate Figure 2-8, continue with these steps:

1 From the Postprocessing menu, select Cross-Section Plot Parameters.

2 In the resulting dialog box, click the Point tab.

3 In the y-axis data area, enter drawdown in the Expression edit field.

4 In the Coordinates area, enter 0.1 1 10 100 1000 in the r edit field.

5 Click the Line Settings button. In the Line marker list select Circle. Select the Legend 
check box, then click OK.

6 Click Apply.

7 Click the General tab, then select the Keep current plot check box.

8 Return to the Point page, and in the Expression edit field type Theis.

9 Click the Line Settings button. In the Line style list select Dashed line and in the Line 

marker list select None. Clear the Legend check box, then click OK.

10 Click OK.

To generate Figure 2-9, continue with these steps:

1 From the Postprocessing menu, select Domain Plot Parameters. 

2 Click the Line/Extrusion tab. Go to the y-axis data area and in the Expression edit field 
enter drawdown.

3 Click the Line Settings button and modify the line appearance as appropriate.
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4 Click the General tab. In the Solutions to use list select 0.01, 0.1, 1, 10, 100, 1000, 
10000, 100000, and 1000000. Make sure the Keep current plot check box is selected. 
Click Apply.

5 Return to the Line/Extrusion page and in the Expression edit field enter Theis. Click 
the Line Settings button, and change the line settings as appropriate. Click OK.

6 Click OK to close the Domain Plot Parameters dialog box and generate the plot.

7 Zoom in on the results for r < 0.3 m using the rubber band tool you access with the 
Zoom Window toolbar button in the figure window.

S A V I N G  T H E  M O D E L

This completes the initial well model. You will add new equations and terms in the next 
sections. To use this model for the next two analyses, save it by going to File>Save As 

and entering an appropriate file name. Click OK and leave the model file open.
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Introduction

In layered sedimentary sequences, confining units often sandwich viable reservoirs. 
Such is the case in the system depicted in Figure 2-6. If the confining units create less 
than perfect seals, fluids from an overlying reservoir can leak into the pumped reservoir 
below it. Often the pumping from the lower reservoir does not change flow in the 
unpumped one above. In these cases you can model the leakage through the imperfect 
confining unit as a distributed source of fluid to the lower reservoir, in the same fashion 
as recharge or precipitation.

This example is the second model in the series overviewed in “Fluid Flow to Wells” on 
page 18. This analysis builds on the example “Fluid Flow to Wells: Finite Radius Well” 
on page 20 to simulate pumping from a leaky aquifer. The discussion compares 
COMSOL Multiphysics results to the analytic problem of Hantush and Jacob (Ref. 1). 
The 3-part analysis builds on a lecture series from Hsieh (Ref. 2).

Model Definition

The governing equation for this problem is

where K' (m/s) and b' (m) are the hydraulic conductivity and thickness of the 
overlying confining unit, respectively. With p0 being the pressure prior to pumping, 
the term K'(p0 − p)/(b b') amounts to Darcy’s law for flow through the semi-pervious 
confining unit. The thickness of the pumped reservoir, b, appears in the denominator 
because the incoming fluid is distributed through the aquifer volume.

The boundary and initial conditions are the same as in the finite-well model:
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The geometry, the material properties, and the pumping rates come from the 
finite-well flow model. To describe the leakage through the confining layer, you specify 
its hydraulic conductivity, K', as 5·10−8 m/s and its thickness, b', as 2 m.

Results

Figure 2-10 shows the COMSOL Multiphysics solution for the distribution of 
pressures in a pumped aquifer with leakage from an overlying layer. Even for a relatively 
impermeable confining unit, with hydraulic conductivity K' = K/100, the leakage is 
significant. For example, this figure depicts a far less extensive cone of depression than 
the one in Figure 2-7 which characterizes pumping in the same aquifer but without the 
leakage.

Figure 2-10: Solution for the fluid pressure near a finite-radius well in a leaky aquifer. 
Results are for logarithmically spaced times from 0 to 11.5 days along the line r < 1000 m.

The plot in Figure 2-11 converts the solution to the leaky aquifer to drawdown 
(defined on page 21) and plots it against time; it also shows the results for the case 
without leakage from Figure 2-8. The later time drawdown for the leaky case is almost 
constant by comparison. At early times, fluid reaching the wells comes from the storage 
in the pumped reservoirs. At later times, fluids pumped from the leaky aquifer derive 
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mostly from the unpumped aquifer above it. Figure 2-11 also provides the analytic 
solution of Hantush and Jacob (Ref. 1). The COMSOL Multiphysics results fit the 
analytic solution well.

Figure 2-11: COMSOL Multiphysics drawdown estimates for a leaky confined aquifer 
(dashed lines) compared with the analytic solution (dots) from Hantush and Jacob (Ref. 
1). Also shown are results of simulations without the leakage (solid lines). Results are for 
r = rw, 0.1 m, 1 m, 10 m, 100 m, and 1000 m.
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Model Library path: Earth_Science_Module/Fluid_Flow/leaky_well
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and click the Model Library tab.

2 Open the Earth Science Module folder.

3 Find the Fluid Flow folder and select the file finite well.

4 Click OK.

P R E L I M I N A R I E S

Before adding to the model, create a cross-section plot of the results already in 
memory for use in a comparison plot with results from the modified model.

1 From the Postprocessing menu, open the Cross-Section Plot Parameters dialog box.

2 Click the Point tab, and in the Expression edit field enter drawdown.

3 In the Coordinates area, enter 0.1 1 10 100 1000 in the r edit field.

4 Click the Line Settings button. Set the Line style to Solid line and Line marker to None. 
Select the Legend check box, then click OK.

5 Click OK to close the dialog box and generate the plot. Leave the figure window 
open.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, open the Constants dialog box.

2 Add these names, expressions, and descriptions (optional); when done, click OK.

S U B D O M A I N  S E T T I N G S

1 From the Physics menu, open the Subdomain Settings dialog box.

2 Select Subdomains 2 and 3, then enter the following data; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

NAME EXPRESSION DESCRIPTION

Kpr 5e-8[m/s] Hydraulic conductivity of confining layer

bpr 2[m] Thickness of confining layer

NAME EXPRESSION

Qs Kpr/(rho_f*g_esdl)*(p0-p)/(b*bpr)
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 2-10, follow the instructions for Figure 2-7 already given.

To create Figure 2-11, begin by adding the current results to the plot you generated 
in the section “Preliminaries” on page 33.

1 From the Postprocessing menu, open the Cross Section Plot Parameters dialog box.

2 On the General page, click the Title/Axis button. Provide new titles for the plot as 
appropriate, then click OK.

3 Make certain that the Keep current plot check box is selected. If you run COMSOL 
Multiphysics with MATLAB, choose MATLAB Figure for the new plot.

4 Click the Point tab, then in the Expression edit field, type drawdown. Find the 
Coordinates area and make sure the expression in the r edit field is 0.1 1 10 100 
1000.

5 Click the Line Settings button. From the Line style list, select Dashed line. Click OK.

6 Click Apply.

If you have MATLAB, you can add a plot of the analytic solution as follows:

7 Go the command line and enter the following code:

hold on
load leaky_analytic.txt
t = leaky_analytic(:,1);
A = leaky_analytic(:,2);
plot(t,A,'k.')

The file leaky_analytic.txt should be available in your path.

8 Click the Edit Plot button in the figure window’s toolbar, and edit the axis and line 
settings as needed.
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Introduction

Pumping from a finished well removes whatever fluids are in the well and the casing 
around it before fluids from the reservoir enter the well. The magnitude and duration 
of the wellbore storage’s impact is related to the size of the well and casing. These 
effects stand out particularly at early times, typically when engineers assess the viability 
of reservoirs. For large-scale projects with big wells, these “early time” effects can 
linger for many months and significantly inhibit production.

Wellbore storage effects have been the subject of much study in hydrogeology and 
petroleum engineering. Being particularly difficult to analyze, they are rarely 
considered in conventional numerical models. This section models wellbore storage by 
adding a time-dependent ordinary differential equation to the well boundary. The 
results shown here match the analytic solution of Papadopoulos and Cooper (Ref. 1). 
The method this analysis uses extends to account for skin effects.

Model Definition

This analysis of wellbore storage is the final example in the sequence described in 
“Fluid Flow to Wells” on page 18. It builds directly on the 1D axisymmetric model 
“Fluid Flow to Wells: Finite Radius Well” on page 20. As before, the equation 
governing the flow is

What changes is the mathematical model for flow at the well. The expression used here 
accounts for wellbore storage as follows:

Here rc is the radius of the well casing, and pw(t), normalized by the specific gravity 
ρf  g, is the drawdown in the well. This equation states that withdrawals from the well 
consist of two parts: First is the flux into the well from the aquifer, and second is the 
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water coming from the wellbore itself. The foregoing specifies that the pressure just 
inside the well, pw(t), equals the pressure just outside of it, p(rw, t). In other words, 
pw(t) = pw(rw, t). A skin effect produces a discontinuity in pressure from just inside the 
well to just outside of it. To model the discontinuity, you also would add a third term 
to account for the step change.

The boundary and initial conditions for the Wellbore Storage model are

where n is the unit vector normal to the boundary.

To simplify this analysis, use material properties and pumping rates from the original 
Finite Well model and add the radius of the well casing, rc (set to 0.15 m as a start). 
With this parameterization, interesting results occur very early. To zoom in on these 
results you can reduce the simulation period.

Results

Figure 2-12 shows the COMSOL Multiphysics solution for drawdown as a function of 
time for five observation points near a well with wellbore storage impacts. The figure 
also provides the corresponding results for the case without wellbore storage (see 
Figure 2-8). The difference in the two solutions is the reduction in reservoir 

n K
ρf g
---------∇p–⎝ ⎠

⎛ ⎞⋅ W
πrc

2

ρf g
---------

dpw
dt

-----------+
⎝ ⎠
⎜ ⎟
⎛ ⎞

– 2πrwb( ) 1–
= Ω well∂

p p0= Ω ∞∂

p p0= t 0=
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withdrawals owing to fluids present in the wellbore. This impact, as expected, 
diminishes with distance and time.

Figure 2-12: Drawdown estimates predicted with (dashed lines) and without (solid lines) 
wellbore storage. Results are for the well boundary and points at increasing distance from 
it.

Figure 2-13 compares a time series of drawdown from simulations including wellbore 
storage with different casing radii. COMSOL Multiphysics gives a near-perfect match 
to the analytic solution in Ref. 1. The markerless line corresponds to the solution 
without wellbore storage (rc = 0 m). The next curve (marked with triangles) 
corresponds to a well casing with the same radius as the screened interval (rc = 0.1 m). 
Subsequent curves are for increasing casing radii, as the legends indicate. The plot 
shows that as the casing radius increases, the pumping removes less and less fluid from 
the reservoir for longer and longer times.
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Figure 2-13: Drawdown at the well (r = 0.1 m) for increasing well-casing radii (lines 
with markers) and without wellbore storage impacts (markerless line). The legends give the 
well-casing radii in meters. The results almost exactly match the analytic solution of 
Papadopoulos and Cooper (Ref. 1).

Reference

1. I.S. Papadopoulos and H.H. Cooper Jr., “Drawdown in a Well of Large Diameter,” 
Water Resources Research, vol. 3, no. 1, 1967.

Model Library path: Earth_Science_Module/Fluid_Flow/wellbore_storage

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator and click the Model Library tab.

2 Find the file Earth Science Module>Fluid Flow>finite well.
 2 :  F L U I D  F L O W  M O D E L S



3 Click OK.

P R E L I M I N A R I E S

Before adding to the current model, create a cross-section plot of the results already in 
memory by following the instructions given in the section “Preliminaries” on page 33.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, open the Constants dialog box.

2 Add the following constant; when done, click OK.

P H Y S I C S  S E T T I N G S

Boundary Conditions
Alter the boundary condition on the well as follows:

1 From the Physics menu, open the Boundary Settings dialog box.

2 Select Boundary 2. In the N0 edit field for Inward flux, enter -(W+pi*r_c^2*pt/
(rho_f*g_esdl))/(2*pi*r_w*b).

3 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar or choose Solve>Solver 

Parameters.

2 Change the output time expression in the Times edit field to 
0 10^(range(-3,0.05,2)), then click OK.

3 Solve the model as before by clicking the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The steps to generate Figure 2-12 follow the instructions outlined for Figure 2-11 in 
the previous model.

To reproduce Figure 2-13 you need to solve the model for a set of different values for 
the casing radius, rc; this example uses rc = 0, 0.1, 0.15, 0.2, 0.25, and 0.3.

1 From the Options menu, choose Constants. Change the value of r_c to 0, then click 
Apply.

2 Click the Restart button on the Main toolbar.

NAME EXPRESSION DESCRIPTION

r_c 0.15[m] Radius of the well casing
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3 From the Postprocessing menu, open the Cross-Section Plot Parameters dialog box.

4 Click the Point tab, go to the y-axis data area, and check that the value in the 
Expression edit field is drawdown; if not, enter it.

5 In the Coordinates area, enter 0.1 in the r edit field.

6 Click the Line Settings button. Set the Line style to Solid line, then click OK.

7 On the General page, select New figure from the Plot in list. Select the Keep current 

plot check box, then click Apply.

8 In the Constants dialog box, change the value of r_c to 0.1. Click Apply.

9 Click the Restart button on the Main toolbar.

10 In the Cross-Section Plot Parameters dialog box, click Apply.

11 Repeat the previous three steps for the rc values 0.15, 0.2, 0.25, and 0.3, except for 
the last value click OK instead of Apply to close the dialog boxes.

12 In the figure window, click the Edit Plot toolbar button.

13 Select Axes from the tree view and edit the title and axis labels.

14 Similarly, select each line and edit the line marker and legends to finish the plot.

15 When done, click OK to close the Edit Plot dialog box.
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Pe r f o r a t e d  We l l

Introduction

Analysis of fluid flow into wells often begins with the assumption that the intake of 
fluid is uniform along the entire length of wellbore. This assumption runs into trouble 
when applied to the modeling of perforated wells. When engineers emplace these wells 
they line a deep bore hole with impermeable materials. Later a machine pierces the 
lining so the well takes in fluids in the productive reservoir zones and nowhere else. 
The perforations are relatively small, typically less than 0.5 m long and with a diameter 
of less than 5 cm. They are typically oriented at regular intervals cycling down the 
casing axis.

Figure 2-14: Meshed model geometry (radius 6 m, height 0.3 m) with a close-up view of 
the wellbore (radius 0.1 m, height 0.3 m) with cylindrical perforations. (The geometry and 
mesh are from Dr. M. Jamiolahmady, Institute of Petroleum Engineering, Heriot-Watt 
University.)

The ability to describe how fluids funnel into tiny perforations oriented about a 
wellbore is the subject of a rapidly growing number of analyses including those in Ref. 
1, Ref. 2, and Ref. 3. Because the perforations are isolated piercings as opposed to 
rings, the flow field is not suited for axisymmetric analyses—fully 3D simulations are 
required.

This model characterizes 3D flow to a perforated well using the Darcy’s Law 
application mode. The analysis is based on a geometry contributed by the Institute of 
Petroleum Engineering at Heriot-Watt University. Dr. Jamiolahmady, an expert in 
non-Darcy flow, used a MATLAB script to produce and mesh incrementally different 
geometries for iterative simulation and analyses. Here you build the geometry using 
the COMSOL Multiphysics graphical user interface. Readers interested in applying an 
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iterative simulation approach can employ parametric solutions in COMSOL 
Multiphysics or scripting with MATLAB.

This example demonstrates several useful COMSOL Multiphysics features. Included 
are instructions for using Lagrange multipliers to calculate a high-accuracy flux on a 
relatively low density mesh. The model also shows how to set up boundary-integration 
coupling variables to automate flux calculations. The following sections provide an 
overview of the model, and following it come tabulated on parameter values.

Model Definition

In this model, a well sits at the center of a thin (roughly 0.25 m), horizontal 
production reservoir that is confined above and below by impermeable units 
(Figure 2-14). For simplicity, the producing zone is homogeneous and isotropic with 
respect to permeability and porosity, and the oil has constant density and viscosity. The 
geometry is a reach of reservoir with a radius of approximately 6 m, which by design 
is 60 times greater than the well radius of 0.1 m. The model assumes that the oil 
moving into the well comes uniformly from the reservoir circumference, and the 
pressure is known at all perforations. Pumping proceeds initially at a given rate. The 
withdrawals come strictly through the perforations. This example contains an analysis 
of a steady flow field.

Darcy’s law defines the velocity in the continuity equation that governs this problem. 
For a dependent variable of pressure, the governing equation reads

where κ is permeability (m2); η represents dynamic viscosity (kg/(m·s)); ρf is the fluid 
density (kg/m3); g equals the acceleration of gravity (m/s2); D denotes the coordinate 
for vertical elevation (m); and Qs is the volumetric flow rate per unit volume of 
reservoir for a fluid source (1/s).

At steady state, the flux through the circumference of the reservoir must satisfy the 
withdrawal at the well. Described by Darcy’s law, the flux is

where W is the volumetric pumping rate (m3/s); rres gives the reservoir radius (m); 
and b is the length of the well interval (m) that takes in fluids (known as the production 
interval). The gravitational pressure drop term  is tangential to the boundary 

∇ κ
η
--- p∇ ρf g D∇+( )–⋅ Qs=

κ
η
---∇p–

W
2πrresb
---------------------=

ρf g D∇
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and thus does not contribute to the flux through the reservoir’s circumference. 
Because all other boundaries are impermeable to flow, the boundary conditions are

where n is the unit vector normal to the boundary.

COMSOL Multiphysics Implementation—Boundary Flux

In this model you calculate the flux through the perforations using boundary 
integration-coupling variables. You can perform integration as a postprocessing step 
from the COMSOL Multiphysics menus, but creating the variables automates the 
calculations and also makes the results available for plotting.

Integration coupling variables give the value of an integral over a boundary, a 
subdomain, or a point (the source domain); they also transmit the information from 
one domain to, for example, other boundaries, subdomains, and points (the 
destination domain). You calculate the total flux through all of the perforation 
boundaries as

where ∂Ω represents the boundary. This equation takes the absolute value because the 
flux is everywhere an outflow, but the normals to the perforations do not all point in 
the same direction. To know more about the normals to boundaries, consider the 
following. In a simple model geometry, such as a rectangle, it is straightforward that 
the normals should point outward. If you add a complicated geometry inside the 
rectangle, where should the normals point? There is no unambiguously universal rule. 
You can visualize normals to boundaries by plotting them as arrows—specify nx, ny, 
and nz in the vector expression fields for boundary arrows as a postprocessing option.

n κ
η
---∇p⋅ W

2πrresb
---------------------–= Ω rres∂

p pwell= Ω perforations∂

n κ
η
--- p∇ ρf g D∇+( )⋅ 0= Ω casing∂

n κ
η
--- p∇ ρf g D∇+( )⋅ 0= Ω confining layer∂

flux n κ
η
---∇p⋅ Sd

Ω∂
∫∑=
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COMSOL Multiphysics Implementation—High-Accuracy Flux 
Computation

You will find that the flux calculated as outlined above does not match the expected 
pumping rate. This discrepancy results from using a low-density mesh. You might try 
to a achieve a high-accuracy flux by zooming in on the region of interest with finer 
elements. However, that reasoning applied to the tiny perforations amounts to a good 
formula for a bad hit in needless computational cost.

You often can get a high-accuracy flux and save on computation time using the 
Lagrange multipliers µ that COMSOL Multiphysics generates through an integral or 
weak PDE form. The Lagrange multiplier takes on the value of the flux at boundaries 
with strong constraints that assign the same pressure everywhere along the perforation 
edges. To access the Lagrange multipliers in this problem, use the non-ideal weak 
constraints at the boundaries of the perforations. With the weak constraints, the 
boundary pressure integral over the element is constrained rather than pointwise in the 
Lagrange points. Furthermore, a high accuracy flux can be accessed at the element 
boundary. Now you can calculate the flux with the boundary integration described 
above, except that you replace the normal equation for a boundary flux with the 
Lagrange multiplier µ. To find out more, see “Computing Accurate Fluxes” on page 
266 of the COMSOL Multiphysics User’s Guide.

Model Data

The data used in this model are as follows:

VARIABLE UNITS DESCRIPTION VALUE

 gr m/s2 Gravity 9.82

 ρf kg/m3 Fluid density 900

 ηf Pa·s Dynamic viscosity 0.002

 κ m2 Permeability 10-11

 θs Porosity/void fraction 0.2

 hwell m Thickness of reservoir 0.3048

 rres m Reservoir radius 6.5722

 rw m Well radius 0.1095

 W m3/s Pumping rate 0.001

 pwell Pa Pressure at perforations 105
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Results

Figure 2-15 shows the solution for oil flow to a well centered at the origin. From this 
view, the pressure distribution and velocity field appear uniform. Note that the velocity 
is almost constant in the far field.

Figure 2-15: COMSOL Multiphysics solution of Darcy flow to a perforated wellbore: 
pressure (isosurface), velocity field (slice), and velocities (arrows).

Figure 2-16 gives a close-up view of the velocity field (wire-mesh isosurfaces) and 
pressure distribution (slice) immediately around the perforations in the well. The 
velocity results in Figure 2-16 are clearly nonuniform. The flow funnels to the 
perforations produce an antisymmetric swirl over the length of the wellbore. 
Comparing the pressure estimates in Figure 2-16 with those in Figure 2-15 indicates 
P E R F O R A T E D  W E L L  |  45



46 |  C H A P T E R
that the nonuniformity produced by the perforations covers a relatively small section 
of the flow field.

Figure 2-16: Close-up view of flow to a perforated wellbore: pressure (slices) and velocity 
field (wire-mesh isosurface).

To evaluate the accuracy of the simulation, compare the total flux through the 
perforations with the known pumping rate of 0.001 m3/s. With the relatively coarse 
mesh (still with 40,000 elements), ordinary boundary integration gives a flux of 
0.0014 m3/s. A calculation in COMSOL Multiphysics with Lagrange multipliers, 
however, gives a flux of 0.00102 m3/s. Adding the Lagrange multipliers improves the 
accuracy of the calculation to within 0.01% of the known pumping rate without 
increasing computational overhead.
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Figure 2-17: Estimates of fluid flux to perforations in a wellbore.

Figure 2-17 depicts the flux to individual perforations. With this geometry and 
orientation, a given perforation withdraws anywhere from 22% to 28% of the total 
pumping. The perforations closest to the impermeable confining units (above and 
below) withdraw significantly less fluid from the reservoir than those near the 
horizontal center line of the producing layer. This leads to the economically significant 
conclusion that changes in the orientation change the producing capability of a 
perforation by 6%.

References

1. A. Behie and A. Settari A, “Perforation Design Models for Heterogeneous 
Multiphase Flow,” SPE Rocky Mountain Regional/Low Permeability Reservoir 
Symp., Denver, Colorado, paper 25901, pp. 591–602, 1993.

2. M. Jamiolahmady, A. Danesh, D.H. Terhani, G.D. Henderson, and D.B. Duncan, 
“Flow around a rock perforation surrounded by damaged zone: Experiments vs. 
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3. M. Muskat, “The effect of casing perforations on well productivity,” Petroleum 
Trans. AIME, vol. 151, pp. 175–187, 1943.

Model Library path: Earth_Science_Module/Fluid_Flow/perforated_well

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and from the Space dimension list select 3D.

2 From the list of application modes select 
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis.

3 Click OK.

G E O M E T R Y  M O D E L I N G

1 Draw three cylinders by going to the Draw menu, selecting Cylinder and entering 
these settings:

2 Draw four small cylinders using the following data:

3 Go to the Draw toolbar on the left side of the user interface and click the Create 

Composite Object button.

4 In the Set formula edit field enter the following expression: 
CYL1+CYL2-(CYL3+CYL4+CYL5+CYL6+CYL7); when done, Click OK.

NAME CYL1 CYL2 CYL3

Radius 6.5722 1.0954 0.1095

Height 0.3048 0.3048 0.3048

NAME CYL4 CYL5 CYL6 CYL7

Radius 0.0254 0.0254 0.0254 0.0254

Height 0.1857 0.1857 0.1857 0.1857

Axis 
base point

0, 0, 0.0381 -0.1857, 0, 
0.1905

0, 0, 0.1143 0, -0.1857, 
0.2667

Axis 
direction vector

1, 0, 0 1, 0, 0 0, 1, 0 0, 1, 0
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O P T I O N S  A N D  S E T T I N G S

1 From the Physics menu, select Scalar Variables.

2 In the resulting dialog box enter the following names and expressions.

3 From the Options menu, open the Constants dialog box.

4 Enter the following names, expressions, and descriptions (optional); when done, 
click OK.

5 From the Options menu, select Integration Coupling Variables>Boundary Variables. In 
the dialog box, create these boundary integration coupling variables, each on a 
separate row in the table; when done, click OK.

P H Y S I C S  S E T T I N G S

Application Mode Properties
1 From the Physics menu, select Properties.

NAME EXPRESSION

g_esdl 9.82

D_esdl z

NAME EXPRESSION DESCRIPTION

p_well 100[kPa] Pressure at perforations

W 0.001[m^3/s] Pumping rate

r_res 6.5722[m] Reservoir radius

h_well 0.3048[m] Thickness of reservoir

k_int 1e-11[m^2] Permeability

eta 0.002[Pa*s] Dynamic viscosity

rho_f 900[kg/m^3] Fluid density

r_well 0.1095[m] Well radius

SOURCE BOUNDARY 
SELECTION

NAME EXPRESSION INTEGRATION 
ORDER

GLOBAL 
DESTINATION

9–13, 16–21, 24, 
25, 28, 29, 32-36

flux abs(flux_esdl) 4 yes

16–18, 24, 25 lmflux1 abs(lm1) 4 yes

9–13 lmflux2 abs(lm1) 4 yes

19–21, 28, 29 lmflux3 abs(lm1) 4 yes

32–36 lmflux4 abs(lm1) 4 yes
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2 Select On in the Weak constraints list and Non-ideal in the Constraint type list, then 
click OK.

Subdomain Settings
1 Choose Physics>Subdomain Settings.

2 Enter the following material properties; when done, click OK.

Boundary Conditions
From the Physics menu, open the Boundary Settings dialog box, then enter the 
following settings; when done, click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, open the Free Mesh Parameters dialog box.

2 In the Predefined mesh sizes list, select Fine.

3 Click the Subdomain tab.

4 In the Subdomain selection list, choose 2.

5 Set the Maximum element size to 0.1, then click OK.

6 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box.

2 The default solver cannot handle the weak constraints. Therefore go to the Linear 

system solver list and select GMRES, then go to the Preconditioner list and select 
Incomplete LU. Click OK.

3 Click the Solve button on the Main toolbar.

VARIABLE SUBDOMAINS 1, 2

 κs k_int

 ρf rho_f

 η eta

 Qs 0

SETTINGS BOUNDARIES 1, 2, 22, 31 BOUNDARIES 9–13, 16–21, 24, 
25, 28, 29, 32–36 

ALL OTHERS

Boundary 
condition

Inward flux Pressure Zero flux/ 
Symmetry

N0 W/(2*pi*r_res*h_well) - -

p0 - p_well -
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To create Figure 2-15 on page 45, follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 On the General page, go to the Plot type area and select the check boxes for Slice, 
Isosurface, and Arrow.

3 Click the Isosurface tab. On the Isosurface Data page, choose Pressure from the 
Predefined quantities list. Go to the Isosurface levels area, click the Vector with 

isolevels option button, and in the corresponding edit field enter 
range(5e4,5e4,5.5e5).

4 Click the Slice tab. In the Slice data area, select Velocity field from the Predefined 

quantities list. In the Slice positioning area, in both the x levels and y levels edit fields 
enter 1, and in the z levels edit field enter 0.

5 Click the Arrow tab. On the Subdomain Data page, select Velocity field from the 
Predefined quantities list. In the Arrow positioning area, in both the x points and y 
points edit fields enter 15, and in the z points edit field enter 1.

6 In the Arrow parameters area, click the Color button. In the Arrow Color dialog box, 
select black, then click OK.

7 Clear the Auto check box for the Scale factor and in the associated edit field type 0.5.

8 Click OK.

To create Figure 2-16 on page 46, follow these steps:

1 From the Postprocessing menu open the Plot Parameters dialog box.

2 Go to the General page, and in the Plot type area clear the Arrow check box.

3 Click the Isosurface tab. On the Isosurface Data page, change the selection in the 
Predefined quantities list to Velocity field.

4 In the Isosurface levels area, click the Number of levels option button, then type 30 
in the associated edit field.

5 In the Coloring and fill area, select Wireframe from the Fill style list.

6 In the Isosurface color area, select Thermal from the Color table list.

7 On the Slice page, change the selection in the Predefined quantities list to Pressure.

8 Click OK.

9 Click the Zoom In button on the Main toolbar five times to zoom in on the wellbore. 
Click and drag in the drawing area to adjust the view.

To create Figure 2-17 on page 47, follow these steps:
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1 Go to Options>Expressions>Boundary Expressions and define a boundary expression 
variable, lmflux, according to:

2 From the Solve menu, select Update Model to update the model with the new 
expression variable.

3 From the Postprocessing menu, open the Plot Parameters dialog box.

4 On the General page, go to the Plot type area and select only the check boxes for 
Boundary and Geometry edges.

5 Click the Boundary tab. In the Expression edit field, type p.

6 In the Boundary color area, select Thermal from the Color table list.

7 Click OK.

BOUNDARY SELECTION NAME EXPRESSION 

16–18, 24, 25 lmflux lmflux1

9–13 lmflux lmflux2

19–21, 28, 29 lmflux lmflux3

32–36 lmflux lmflux4
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Coup l e d  F l ow Law s

Introduction

Understanding what happens during the transition from slow flow in porous media to 
fast flow in a channel is critical in many environmental cases and applied problems This 
type of flow appears near rivers, estuaries, wellbores, caverns, and lava tubes, to name 
a few examples.

Traditionally, the quantitative assessment of transitioning flows has been the domain 
of those with time and tools to work out their own code because it requires switching 
between mathematical expressions for different flow laws. Darcy’s law describes slow 
flow at a distance from the channel; the Navier-Stokes equations govern free or 
open-channel flows; and in between, where the fluid moves in porous media but shear 
is nonnegligible, the Brinkman or Forcheimer equations apply. This example 
demonstrates how to model such a transition using predefined equations in the Earth 
Science Module.

The following model examines transitioning flow by zooming in on oil movement to 
and within a perforated well. The analysis begins by coupling Darcy’s law and the 
Brinkman equations to represent flow in porous media that quickens toward a 
perforation in the well casing. Next, it examines fluid movement into and within the 
well by coupling the Navier-Stokes equations to the Darcy-Brinkman model. Albeit 
counterintuitive, time-dependent Brinkman and Navier-Stokes are well known to be 
relatively easy to solve. This model instead analyzes a steady-state system.

By giving you the ability to link flow laws, modify predefined equations, and even 
freely define your own governing equations, COMSOL Multiphysics sees abundant 
use in analyzing conventional, coupled, and nonconventional flows (see Ref. 1 and 
Ref. 2).

Model Definition

This Darcy-Brinkman example begins by overviewing the model setup and continues 
with the equations and the boundary conditions used in the analysis. Implementation 
details follow the mathematical background. The model triggers weak variables to 
implement the coupling between Darcy’s law and the Brinkman equations. Finally this 
discussion reviews results and outlines the mechanics for building the model. The next 
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example (Transitional Flow: Darcy-Brinkman–Navier-Stokes on page 68) adds the 
Navier-Stokes equations directly on top of the Darcy–Brinkman model file.

First examine a general description of the Darcy–Brinkman model depicted in 
Figure 2-18. Oil moves through a thin porous layer towards a perforation to a well. 
The fluid flow follows Darcy’s law in the far field (that is, 1 m < x < 4 m) and the 
Brinkman equations near the well opening (between 0.1 m < x < 1 m). The layer is 
0.875 m thick and bounded above and below by impermeable materials that confine 
the permeable reservoir layer. For simplicity, assume the layer has homogeneous and 
isotropic hydraulic properties, and the fluid has constant density and viscosity. You 
know the flux of fluid at the inlet and the pressure at the perforations. The flow field 
is steady state.

Figure 2-18: Model geometry showing boundary conditions for coupling Darcy’s law (1 m 
< r < 4 m) and the Brinkman equations (0.1 m < r < 1 m).

D A R C Y ’ S  L A W

Darcy’s law describes fluid flow driven by gradients in pressure and elevation potential. 
The dependent variable in Darcy’s law is pressure, p. The flows are slow enough that 
velocity head is negligible. For a steady state, the governing equation is

In this equation, κ denotes the permeability (m2), η is the dynamic viscosity (kg/
(m·s)), ρf gives the fluid density (kg/m3), and g the acceleration of gravity (m/s2). 
Further, D is the coordinate for vertical elevation (m), and Qs is the volumetric flow 

∇ κ
η
---∇ pdl ρf gD+( )–⋅ Qs=
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rate per unit volume of reservoir for a fluid source (1/s). You set D to zero in this 
problem because elevation potential is negligible given that the flow field is very thin. 
Because this model deals with multiple flow laws, this equation appends the “dl” 
subscript to p to denote the Darcy’s law equation.

With a steady state, flow into the reservoir study area must equal the pumping rate. 
The Darcy velocity gives the inlet condition as 

where W is the volumetric pumping rate for the perforated interval (m3/s), rres equals 
the reservoir radius (m), and b is the reservoir thickness (m).

For a continuous solution across the interface between the zones of Darcy and 
Brinkman flow, the pressure and velocities from Darcy’s law must equal the pressure 
and velocities from the Brinkman equations. Because a Neumann statement on flux 
already defines the inlet boundary, use the following constraint on pressure for the 
Darcy–Brinkman interface:

In this equation, the subscript “br” denotes the Brinkman equations. This expression 
is a Dirichlet boundary statement.

With no flow through the confining units that overlie and underlie the permeable 
reservoir zone, the boundary conditions for Darcy’s law are

where n is the unit vector normal to the boundary. 

B R I N K M A N  E Q U A T I O N S

The Brinkman equations describe fluid flow in porous media where velocities are high 
enough that momentum transport by shear stress is important. Brinkman problems 
combine a momentum balance in the r and z directions with the continuity equation, 

udl
κ
η
---∇pdl–

W
2πrresb
---------------------= =

pdl pbr=

n κ
η
--- ∇pdl( )⎝ ⎠
⎛ ⎞⋅ W

2πrresb
---------------------–= ∂Ω inlet

pdl pbr= ∂Ω Darcy-Brinkman interface

n κ
η
--- ∇pdl( )⎝ ⎠
⎛ ⎞⋅ 0= ∂Ω Confining layers
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giving dependent variables of directional velocities u and v as well as the pressure p. 
The Brinkman equations for steady state flow are

 (2-1)

where ρ is density (kg/m3), η gives the dynamic viscosity (kg/(m·s)) u equals the 
velocity vector (m/s), p is pressure (kg/(m·s)), ε is the porosity, and k (m2) denotes 
the permeability. The equation can account for the influence of small gravity and 
compressibility effects in the force term, F (N/m3), which in this example equals zero. 
Some argue that k in the Brinkman equations differs slightly from κ in Darcy’s law 
(Ref. 2), but this example calls for the same permeability in both flow zones.

From the Brinkman side of the Darcy–Brinkman interface you constrain velocity 
because the boundary condition on the Darcy side fixes the pressure. The velocity 
constraint on the Brinkman side of the interface reflects that velocities are dependent 
variables in the Brinkman equations but not in Darcy’s law. The boundary condition 
on velocities is

To implement the condition, use the Darcy velocities, udl, that COMSOL 
Multiphysics automatically calculates.

The confining layer and well casing are impermeable to flow. Approximate this 
situation with the no-slip condition

This equation eliminates all components of the velocity vector at the boundary.

Getting a unique solution to this problem requires defining the pressure at the well 
because the model prescribes flux conditions for all other boundaries. The constraint 
on pressure is the simple statement that

For the Brinkman problem, the boundary conditions are now

∇ η
ε
--- ∇ubr ∇ubr( )T

+( )⋅–⎝ ⎠
⎛ ⎞ η

k
---ubr ∇pbr F–+⎝ ⎠
⎛ ⎞– 0=

∇ ubr⋅ 0=

ubr udl=

ubr 0=

pbr pwell=
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Modeling in COMSOL Multiphysics

The two equations in this analysis are fundamentally compatible as both describe fluid 
flow, pressure distributions, and velocities. Even so, the dependent variable in Darcy’s 
law is pressure alone, whereas pressure and directional velocities are the dependent 
variables in the Brinkman equations. The difference in the number of dependent 
variables amounts to a slight incompatibility in form, which you circumvent by 
imposing non-ideal weak constraints on the equation system. The weak constraints 
provide new integral equations in which the Lagrange multipliers µ1 are dependent 
variables. The constraints add one Lagrange multiplier to Darcy’s law and two to the 
Brinkman equations to make up for the difference in the number of degrees of freedom 
given by the two governing equation systems on the boundaries. Adding the new 
Lagrange multipliers is easy: go to the Application Mode Properties dialog boxes, find 
the Weak constraints list, and select On. To make the weak constraints non-ideal, select 
Non-ideal from the Constraint type list.

To find out more about weak constraints and weak formulation equations, see “Using 
Weak Constraints” on page 350 in the COMSOL Multiphysics Modeling Guide.

Model Data

The data for parameterizing the model are:

VARIABLE UNITS DESCRIPTION EXPRESSION

 gr m/s2 Acceleration due to gravity 9.82

 ρf kg/m3 Fluid density 900

 ηf Pa·s Dynamic viscosity 0.002

 ε Porosity 0.4

 κ m2 Permeability 10-10

 b m Thickness of layer 1

 rres m Reservoir radius 4

 rw m Well radius 0.1

ubr udl=    ∂Ω Darcy-Brinkman interface

ubr 0              =       ∂Ω Confining layers

ubr 0  =      ∂Ω Well casing

pbr pwell = ∂Ω Perforation
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Results and Discussion

Figure 2-19 shows the solution to the Darcy-Brinkman problem where Darcy’s law 
governs slow flow far from the well, but near it the Brinkman equations apply. The 
impact of the switch between flow laws occurs at x = 1 m. The streamlines show the 
fluid moving from the inlet at the right to the well on the left. The streamlines funnel 
because the flow is moving into a break or perforation in the well casing.

Figure 2-19: COMSOL Multiphysics solution for Darcy’s law (1 m < r < 4 m) and the 
Brinkman equations (0.1 m < r < 1 m). The results shown are pressure (surface plot and 
contours) and velocities (streamlines). Note that the vertical axis is expanded.

Figure 2-20 and Figure 2-21, respectively, illustrate the pressure and velocity estimates 
from the perforation to a distance of 2 m beyond the Darcy-Brinkman interface. These 
estimates vary smoothly across the Brinkman-Darcy interface. Pressure increases with 
distance from the well, and it moves the fluid to the perforation. The velocities 
decrease with distance from the well until they reach an almost constant value in the 

 W m3/s Pumping rate 10-3

 pwell Pa Pressure at perforation 105

VARIABLE UNITS DESCRIPTION EXPRESSION
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Darcy flow zone. The fact that the pressure estimates vary smoothly from Brinkman 
(r < 1 m) to Darcy (r > 1 m) flow indicates a stable solution.

Figure 2-20: Pressure across the Darcy-Brinkman interface. Cross section along z = -0.5 m 
from r = 0.1 to 3.0 m.

Figure 2-21: Velocity across the Darcy-Brinkman interface. Cross section along z = -0.5 m 
from r = 0.1 to 3.0 m.
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This COMSOL Multiphysics example describes a straightforward protocol to couple 
two compatible flow laws with different dependent variables, the Darcy and Brinkman 
flow equations. Both Darcy’s law and the Brinkman equations characterize flow in 
porous media. Because Darcy’s law provides for no momentum transport by shear, it 
can overpredict flow rates in fast flow zones. Coupling to the Brinkman equations 
describes the added energy transformation.

The model is easy to modify and apply to a number of transitional flow scenarios 
including a river bottom, quickening flow near a well, and fluid moving in and around 
fractures. The next example adds the Navier-Stokes equations in the well to 
characterize the full transition between porous media and free surface flow.
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Model Library path: Earth_Science_Module/Fluid_Flow/darcy_brinkman

Modeling Using the Graphical User Interface

To begin the model, first add the Darcy’s Law and the Brinkman equation application 
modes to the model file.

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and from the Space dimension list select 2D axisymmetry.

2 In the list of application modes select 
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis>Steady-state analysis.

3 In the Application mode name edit field change the name to dl. In the Dependent 

variables edit field enter pdl.

4 Click the Multiphysics button, then click Add. Keep the window open.
 2 :  F L U I D  F L O W  M O D E L S



5 In the list of application modes select Earth Science Module>Fluid Flow>Brinkman 

Equations.

6 In the Application mode name edit field change the name to chbr. In the Dependent 

variables edit field enter ubr vbr pbr.

7 Click Add, then click OK.

G E O M E T R Y  M O D E L I N G

Create the geometry by drawing three rectangles and adding a line at the perforation.

1 From the Draw menu select Specify Objects>Rectangle. In the dialog box, specify 
these settings for the rectangles; in each case, when done, click OK.

2 Click the Zoom Extents button on the Main toolbar.

3 From the Draw menu select Specify Objects>Line. In the Coordinates: r edit field enter 
0.1 0.1; in the Coordinates: z edit field enter -0.45 -0.55.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

These variables reference the different solutions for each subdomain.

1 From the Options menu, choose Constants.

2 Enter the following names, expressions, and descriptions (optional):

3 Click OK.

PARAMETER R1 R2 R3

width 0.1 0.9 3

height 1 1 1

r 0 0.1 1

z -1 -1 -1

NAME EXPRESSION DESCRIPTION

pwell 1e5[Pa] Pressure at perforation

W 1[l/s] Pumping rate

b 1[m] Layer thickness

perm 1e-10[m^2] Permeability

eta 0.002[Pa*s] Dynamic viscosity

rho 900[kg/m^3] Fluid density

rres 4[m] Reservoir radius
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P H Y S I C S

First set up the Darcy’s Law application mode, then follow up with the Brinkman 
equations.

Darcy’s Law Application Mode
1 In the Multiphysics menu select Darcy’s Law (dl).

2 Go to the menu item Physics>Subdomain Settings. Click the Coefficients tab. 
Deactivate the subdomain where the Brinkman equations apply; to do so, select 
Subdomains 1 and 2, then clear the Active in this domain check box.

3 Select Subdomain 3 and enter the settings from the following table in the user 
interface as shown.

4 Click the Init tab. In the Initial value edit field enter pwell.

5 Click OK.

6 From the Physics menu, choose Boundary Settings.

TERM SUBDOMAIN 1

 κs perm

 ρf rho

 η eta
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7 Enter the settings from the following table; when done, click OK.

8 From the Physics menu, choose Properties. In the Weak constraints list select On and 
in the Constraint type list select Non-ideal; when done, click OK.

Brinkman Equations
1 In the Multiphysics menu, select Brinkman Equations (chbr).

2 Choose Physics>Subdomain Settings. Click the Physics tab. Deactivate the subdomain 
where Darcy’s law and the Navier-Stokes equations applies; to do so, select 
Subdomains 1 and 3, then clear the Active in this domain check box.

SETTINGS BOUNDARY 9 BOUNDARY 12 BOUNDARIES 10, 11

Boundary condition Pressure Inward flux Zero flux/Symmetry

p0 pbr

N0 W/(2*pi*rres*b)
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3 Select Subdomain 2, then enter the following settings:

4 Click the Init tab. Enter the following settings; when done, click OK.

5 From the Physics menu choose Boundary Settings. Enter the following settings; when 
done, click OK.

6 From the Physics menu, choose Properties. In the Weak constraints list choose On 
and in the Constraint type list select Non-ideal. Click OK.

TERM SUBDOMAIN 2 

 κ perm

 εp 0.4

 η eta

 ρ rho

TERM SUBDOMAIN 2

ubr W/(2*pi*r*b)

vbr eps

pbr pwell

SETTINGS BOUNDARY 6 BOUNDARY 9 BOUNDARIES 4, 5, 7, 8

Boundary type Outlet Inlet Wall

Boundary condition Pressure, no 
viscous stress

Velocity No slip

p0 pwell

u u_dl

v v_dl
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M E S H  G E N E R A T I O N

The solution is sensitive to mesh size; the figures in this section arose from the 
following mesh setup.

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Subdomain tab. Select Subdomain 2, then set the Maximum element size to 
0.066. Select Subdomain 3 and specify a Maximum element size of 0.133.

3 Click the Boundary tab. Select Boundary 6 and in the Maximum element size edit field 
type 0.005. Select Boundary 9 and specify a Maximum element size of 0.02.

4 Click OK.

5 Click the Initialize Mesh button on the Main toolbar.

We generated the figures for this chapter by also clicking Remesh, but note that 
doing so adds significant computational effort to the simulation.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

A glance at the resulting figure indicates an incomplete view of the results—only those 
for Darcy’s law appears. To view the solutions for both application modes at the same 
time, set up a few postprocessing variables that reference the different solutions for 
each subdomain.

1 Choose Options>Expressions>Subdomain Expressions.

2 Define the following expressions for Subdomains 2 and 3; when done, click OK.

Here, visU displays the total velocity, visu displays the r-velocity, visv displays the 
z-velocity, and visp displays the pressure. As specified at the outset, the application 
mode name is chbr for the Brinkman equations and dl for Darcy’s law. When you 
reference an application mode variable, you give the application mode name as a suffix. 
For example, because velocity is not a dependent variable in the Darcy’s Law (dl) 
application mode but a variable COMSOL Multiphysics automatically creates for it, 

NAME SUBDOMAIN 2 SUBDOMAIN 3

visU U_chbr U_dl

visu ubr u_dl

visv vbr v_dl

visp pbr pdl
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use the suffix _dl to reference it. You do not reference the application mode name to 
reference the pressure pdl from Darcy’s law because it is a dependent variable.

For the variables to take effect, you must update the model.

3 From the Solve menu select Update Model.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2-19 on page 58, follow these instructions:

1 Choose Postprocessing>Plot Parameters.

2 Click the General tab. In the Plot type area, select the Surface, Contour, Arrow, and 
Streamline check boxes to activate those plots. Clear the Geometry edges check box.

3 Click the Surface tab. On the Surface Data page, enter visp in the Expression edit 
field, in the process typing over the current information in the edit field. Go to the 
Surface color area, and in the Color table list select Thermal.

4 Click the Contour tab. On the Contour Data page, enter visp in the Expression edit 
field, also here typing over the current information. In the Number of levels edit field 
enter 20. In the Contour color area click the Uniform color option button. Click the 
Color button, change the color to black, and then click OK.

5 Click the Streamline tab. On the Streamline Data page, type visu in the r component 
edit field and visv in the z component edit field.

6 Go to the Start Points page, click the Specify start point coordinates button. In the r 
edit field type 4 4 4 4 4 4 4 4. In the z edit field enter -0.85 -0.75 -0.65 
-0.55 -0.45 -0.35 -0.25 -0.15.

7 Click the Advanced button. In the Maximum number of integration steps edit field 
type 10000. In both the Integration tolerance and Stationary point stop tolerance edit 
fields type 0.00001. Click OK.

8 Click the Color button. Select the color black, then click OK.
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9 Click the Arrow tab. On the Subdomain Data page find the r edit field and enter visu, 
and in the z edit field enter visv.

10 In the Arrow positioning area click both Vector with coordinates option buttons. In 
the associated r points edit field, type  
3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 1.5 

1.5 1.5 1.5 1.5 1.5 1.5 1.5 0.75 0.75 0.75 0.75 0.75 0.75 0.75 0.75.

11 In the corresponding z points edit field, type  
-0.85 -0.75 -0.65 -0.55 -0.45 -0.35 -0.25 -0.15 -0.85 -0.75 -0.65 

-0.55 -0.45 -0.35 -0.25 -0.15 -0.85 -0.75 -0.65 -0.55 -0.45 -0.35 

-0.25 -0.15 -0.85 -0.75 -0.65 -0.55 -0.45 -0.35 -0.35 -0.25.

12 Go to the Arrow parameters area. In the Arrow type list select cone, and in the Arrow 

length list select Normalized. Click the Color button, choose the uniform color black, 
and then click OK. Click OK to close the Plot Parameters dialog box and generate the 
plot.

To generate Figure 2-20 on page 59, follow these steps:

1 Select the menu item Postprocessing>Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab. In the y-axis data area, type visp in the Expression edit 
field. In the Cross-section line data area, set r0 to 0.1, r1 to 3.0, and both z0 and z1 
to -0.5. Click Apply.

Finally, generate Figure 2-21 on page 59 with these steps:

1 Still on the Line/Extrusion page of the Cross-Section Plot Parameters dialog box, 
change the Expression in the y-axis data area to visU.

2 Click OK.
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T r a n s i t i o n a l  F l ow :  Da r c y - B r i n kman–
Nav i e r - S t o k e s

Introduction

This example characterizes a transition in flow regimes: slow flow in porous media 
quickens to a perforation in a well casing and ultimately moves into and up the well. 
Darcy’s law describes flow velocities at a distance from the well; closer to the 
perforation the Brinkman equations apply; the Navier-Stokes equations describe 
movement of fluid in the well. This example starts with a model that couples Darcy’s 
law with the Brinkman equations. Adding the Navier-Stokes equations in the wellbore 
produces a fully coupled simulation for three different flow laws.

Figure 2-22: Geometry and boundary conditions used in COMSOL Multiphysics to couple 
the Darcy’s law, Brinkman equations, and Navier-Stokes application modes.

The following pages describe the model. The first section reviews the Darcy, 
Brinkman, and Navier-Stokes equations and the boundary conditions. Next comes the 
solution procedure along with a data table. The final sections show results and gives 
step-by-step instructions for building the model in the COMSOL Multiphysics user 
interface.
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Model Definition

Figure 2-22 illustrates the geometry and equation coupling in this example. Flow 
moves from r = 4 m within a permeable reservoir zone and exits to a well. The fluid 
entering the well combines with fluids moving upward from a permeable reservoir 
layer below the one in the model. In the study area, Darcy’s law governs flow in the 
far field for r > 1 m. The Brinkman equations govern flow from the well casing at 
0.1 m < r < 1 m. The interface between the Darcy and Brinkman flow zones occurs at 
r = 1 m. Within the well at r < 0.1 m the Navier-Stokes equations apply. The interface 
between the Brinkman and Navier-Stokes flow zones is the perforation at the midpoint 
of the casing. Otherwise there is no flow across the casing.

The problem setup for this example is identical to the Darcy–Brinkman model from 
the previous pages except for the boundary condition at the perforation and details 
inside the well. The model is 2D axisymmetry, covering a permeable zone 1 m deep 
over a reservoir radius of 4 m. The Darcy–Brinkman example specified that flow at 
r = 4 m satisfies the pumping rate and gives the pressure at the perforation. In this 
example, let COMSOL Multiphysics solve for the fluid pressure at the perforation and 
instead fix the pressure at the top of the well. The layer is homogeneous, isotropic, thin 
(specifically, 0.875 m), bounded above and below by impermeable materials, and the 
fluid has constant density and viscosity. You know the pumping rate and the pressure 
at the outlet, and you seek a steady-state solution to the flow field.

Darcy’s Law

Darcy’s law describes fluid flow in porous media driven by gradients in pressure alone. 
You can neglect elevation gradients in this problem because the flow field is very thin. 
For flow at steady state, the governing equation is

where κ is permeability (m2), η equals the dynamic viscosity (kg/(m·s)), and Qs is the 
volumetric flow rate per unit volume of reservoir for a fluid source (1/s).

The interface between the zones governed by Darcy’s law and the Brinkman equations 
requires continuity in pressure and velocities. Because pressure is the dependent 
variable in Darcy’s law, the boundary condition at the Darcy-Brinkman interface is a 
constraint on pressure,

∇ κ
η
---∇pdl–⎝ ⎠

⎛ ⎞⋅ Qs=

pdl pbr=
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where the subscripts “dl” and “br” refer to Darcy’s law and the Brinkman equations, 
respectively. 

The remaining boundary conditions include constraints on the flow velocity at the 
reservoir inlet and at the impermeable confining layer; at the inlet, it is sufficient to 
satisfy the pumping rate, while there is no flow across the confining layer. The 
boundary conditions for the Darcy’s law problem are

where n is the normal to the boundary, rres is the reservoir radius (m), b is the layer 
thickness (m), and W denotes the extraction rate from the permeable zone (m3/s).

Brinkman Equations

The Brinkman equations describe flow during the transition from Darcy to 
Navier-Stokes laws. With dependent variables of directional velocities and pressure, the 
Brinkman equations are

 (2-2)

In the equations, ρ denotes fluid density (kg/m3), η is viscosity (kg/(m·s)), u 
represents the velocity vector (m/s), p is pressure (kg/(m·s)), ε is the porosity, and κ 
denotes the permeability (m2).

The Brinkman model constrains the velocity at the Darcy–Brinkman interface: the 
Brinkman velocity equals the Darcy velocity on the boundary. Except for the 
perforation, this example defines all other boundaries in the flow model with no-slip 
conditions, which is a statement about velocity. On the perforation, the model requires 
a condition that represents continuity in stress. The boundary conditions on the 
Brinkman flow zone are

n κ
η
--- ∇pdl( )⎝ ⎠
⎛ ⎞⋅ W

2πrresb
---------------------–= ∂Ω Inlet

pdl pbr= ∂Ω  Darcy-Brinkman interface

n κ
η
--- ∇pdl( )⎝ ⎠
⎛ ⎞⋅ 0 = ∂Ω Confining layer

∇ η
ε
--- ∇ubr ∇ubr( )T

+( )⋅–⎝ ⎠
⎛ ⎞ η

κ
---ubr ∇pbr+⎝ ⎠
⎛ ⎞– 0=

∇ ubr⋅ 0=
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Navier-Stokes Equations

The governing statement for flow in the wellbore comes from the Navier-Stokes 
equations, which combine a momentum balance with an equation of continuity:

The Navier-Stokes equations and the Brinkman equations solve for dependent 
variables u and p. The “ns” subscript denotes the Navier-Stokes equation.

From the Navier-Stokes model, the interface to the Brinkman flow zone is the 
constraint on velocity as in

This equation states that the velocity at the perforation just inside the well equals the 
velocity just outside of it. Linking the Navier-Stokes and Brinkman velocities 
completes a chain that interconnects three flow laws beginning at the Brinkman-Darcy 
interface. In the chain, pressures and velocities for coupled flow laws link on opposite 
sides of an interface.

The remaining boundaries for the Navier-Stokes problem are a set of constraints on 
velocity and pressure. The velocity in the well drops to zero at the well casing, which 
corresponds to a no-slip condition. You also know the volume flow rate into the base 
of the well, the lower inlet. The well’s centerline is a symmetry condition. Finally, you 
know the pressure at the well’s upper outlet. In summary,

ubr udl= ∂Ω Darcy-Brinkman interface

ubr 0= ∂Ω Confining layers

ubr 0= ∂Ω Well casing

pbrI– η ∇u ∇u( )T
+( )+( )n 0= ∂Ω Perforation

∇ η ∇uns ∇uns( )T
+( )⋅– ρuns ∇⋅ uns ∇pns+ + 0=

∇ uns⋅ 0=

uns ubr=
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where rwell denotes the well radius (m) and Win refers to the volume flow rate (m3/s).

Implementation: Navier-Stokes Initial Guess

Systems involving Navier-Stokes equations are notoriously sensitive to the initial guess, 
even for a steady-state flow model such as this one. In this example, the 
Darcy-Brinkman problem solves readily, but establishing good initial conditions for 
the Navier-Stokes zone requires an extra measure. A series of dummy simulations with 
the parametric solver helps to obtain iteratively better guesses about the velocities and 
the pressures throughout the wellbore. The parameter that varies in the simulations is 
the fluid viscosity. You start with a viscosity several orders of magnitude higher than 
the true value and solve for decreasing viscosity values. You also can get good initial 
guesses for Navier-Stokes problems by varying velocity values with the parametric 
solver.

Implementation: Coupling with Weak Constraints

This model employs non-ideal weak constraints to facilitate the coupling of flow laws 
with different dependent variables. This manual provides a foundation on the use of 
non-ideal weak constraints in previous model description for the Darcy-Brinkman 
interface. Nonetheless, this section provides the following reminder.

This model couples three compatible flow laws with different dependent variables. In 
Darcy’s law the dependent variable is pressure alone, whereas pressure and directional 
velocities are dependent variables in the Brinkman and Navier-Stokes equations. To 
make up for the slight incompatibility of the equation forms, add non-ideal weak 
constraints to the equation system. The weak constraints add Lagrange multipliers that 
equalize the degrees of freedom between the three equation systems. You activate the 
non-ideal weak constraints by clicking an option button in the Application Mode 

Properties dialog box. For more information about weak constraints and weak 

uns ubr= ∂Ω Perforations

u 0= ∂Ω Casing

n u⋅
Win

πrwell2

------------------= ∂Ω Well inlet (lower)

n u⋅ 0= ∂Ω Well centerline
p pwell= ∂Ω Well outlet (upper)
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formulation equations, see “Using Weak Constraints” on page 350 in the COMSOL 
Multiphysics Modeling Guide.

Data

The following table lists data used in this model:

Results

Figure 2-23 shows the solution to the model for flow that transitions from Darcy’s law 
in the far field (r > 1 m), to the Brinkman equations in the intermediate zone 
(0.1 m < r <1 m), to the Navier-Stokes equation in the well (r < 0.1 m). The pressure 
distribution (surface plot and contours) and velocities (arrows and streamlines) vary 
smoothly with no disruption at either the Darcy–Brinkman interface (r = 1) or the 

VARIABLE UNITS DESCRIPTION EXPRESSION

 gr m/s2 Acceleration due to gravity 9.82

 ρf kg/m3 Fluid density 900

 ηf Pa·s Dynamic viscosity 0.002

  κ m2 Permeability 1·10-10

 ε Porosity 0.4

 b m Thickness of layer 0.875

 rres m Reservoir radius 4

 rwell m Well radius 0.1

 W m3/s Extraction rate from the modeled permeable 
zone

1·10-3

 Win m3/s Pumpage from underlying reservoirs moving 
through lower well inlet

1·10-4

 pwell Pa Pressure at well outlet 1·105
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Brinkman-Navier-Stokes interface (r = 0.1 m). The streamlines show fluid moving 
through the perforation and up the well.

Figure 2-23: Distribution of pressure (surface plot and contours) and velocities 
(streamlines). Fluid flow follows Darcy’s law (1 m < r < 4 m), the Brinkman equations 
(0.1 m < r < 1 m), and the Navier-Stokes equations (r < 0.1 m). The vertical axis is 
expanded for clarity.

In creating Figure 2-23 the author removed the pressure in the wellbore because it is 
almost uniform and disrupts the view of the streamlines. The small pressure drop in 
the well might seem disconcerting; however, it is reasonable and physically based. The 
well is an open channel. Within it a relatively small pressure drop can produce large 
volumetric flows because rocks do not impede fluid movement in the well.

Figure 2-24 is a close-up view of the velocity (surface plot) and pressure (contours) 
from the center of the well to r = 2 m. The figure covers the Navier-Stokes flow in the 
well, the Brinkman zone just beyond the well, and 1 m of the Darcy’s law flow zone. 
Simulating the rapid velocity change in the well requires a good initial condition. In 
COMSOL Multiphysics you can obtain a good estimate for the distribution of starting 
velocities with a quick series of dummy simulations without the need to switch model 
files.
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Figure 2-24: Close-up view of velocities (surface plot) and pressures (contours) within and 
near the wellbore. Fluid flow follows Darcy’s law (1 m < r), the Brinkman equations 
(0.1 m < r < 1 m), and the Navier-Stokes equations (r < 0.1 m). The vertical axis is 
expanded for clarity.

Figure 2-25 shows the pressure along a cross section beginning in the well 
(Navier-Stokes) and ending a small distance beyond the well casing (Brinkman). The 
pressure is almost constant within the well because the flow in the well is vertical. The 
pressure rises smoothly beyond the Brinkman-Navier-Stokes interface. It is this 
pressure gradient that drives fluid into the well perforation.
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Figure 2-25: Pressure distribution at z = -0.5 m along the line r = 0.05 to 0.5 m.

Figure 2-26 provides a cross section of total velocity over the full transition between 
three different flow laws. It shows high velocities at the center of the well and no break 
in the profile at either the Brinkman-Navier-Stokes interface at r = 0.1 m or at the 
Darcy-Brinkman interface at r = 1 m.

Figure 2-26: Velocity distribution at z = -0.5 m along the line r = 0.05 to 3.0 m.
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This example demonstrates modeling of flows that transition through three different 
governing equations: the Navier-Stokes equations for free flow, the Brinkman 
equations for fast porous media flow, and Darcy’s law for slow flow where you do not 
expect any energy dissipation by shear. This particular model describes the 
transitioning flow to a well, but the concept applies to many other environmental and 
applied scenarios including rivers, tubes, pipes, and springs. In the past, the transition 
between flow laws has often been the domain of academic research efforts because 
most off-the-shelf software packages focus on one flow type or another. COMSOL 
Multiphysics, though, can link together a number of different flow equations.

Model Library path: Earth_Science_Module/Fluid_Flow/darcy_brinkman_ns

Modeling Using the Graphical User Interface

To begin the model, first open the Darcy-Brinkman example and add the 
Navier-Stokes equations to the model file.

M O D E L  N A V I G A T O R

1 Open the Model Navigator and click the Model library tab. From the model tree select 
Earth Science Module>Fluid Flow>darcy brinkman. Click OK.

2 After the model loads, go to the Multiphysics menu and select Model Navigator.

3 In the list of application modes select Earth Science Module>Fluid 

Flow>Incompressible Navier-Stokes equations. In the Application mode name edit field 
replace the existing text by entering ns, and in the Dependent variables edit field 
replace the existing text with uns vns pns. Click Add.

4 Click the Application Mode Properties button. Choose On in the Weak constraints list 
and Non-ideal in the Constraint type list. Click OK.
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5 Click OK to close the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 Several variables reference the different solutions for each subdomain. To set them 
up, go to the menu item Options>Constants.

2 Enter the following names, expressions, and descriptions (optional); when done, 
click OK.

3 For viewing the entire solution, add the Navier-Stokes results to the processing 
variables that already reference the Darcy’s law and Brinkman results in 
corresponding subdomains. To do so, go to the menu item 
Options>Expressions>Subdomain Expressions. In the resulting dialog box enter the 
following expressions for the three subdomains; when done, click OK.

In this table, visU describes total velocity, visu is the x-velocity, visv gives the 
y-velocity, and visp is the pressure. The application mode name is chns for the 
Navier-Stokes equations, chbr for the Brinkman equations, and dl for Darcy’s law. 
No suffix is needed to reference the dependent variable in an equation. For 
calculated variables the application mode name is a suffix. For example, because 
velocity is not a dependent variable in the Darcy’s law application mode but is a 
variable automatically created for it, reference it with the suffix _dl.

P H Y S I C S

Set up the Navier-Stokes application mode and solve it for a dummy simulation.

Navier-Stokes Application Mode
1 From the Physics menu select Subdomain Settings.

2 Click the Physics tab. Select Subdomains 2 and 3, then clear the Active in this domain 
check box to deactivate the subdomains where the Brinkman equations apply.

NAME EXPRESSION DESCRIPTION

rwell 0.1[m] Well radius

Win W/10 Pumpage from underlying reservoirs moving 
through lower well inlet

NAME SUBDOMAIN 1 SUBDOMAIN 2 SUBDOMAIN 3

visU U_chns U_chbr U_dl

visu uns ubr u_dl

visv vns vbr v_dl

visp pns pbr pdl
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3 Select Subdomain 1. In the η edit field for Dynamic viscosity enter 2*damp, and in 
the ρ edit field for Density enter rho.

The reason why the Unit column entry for η turns red is that the quantity damp is 
undefined and consequently has an unspecified unit.

4 Click the Init tab. Enter the following settings; when done, click OK.

5 From the Physics menu, choose Boundary Settings. For the various boundaries enter 
the settings from the following table; when done, click OK.

SETTINGS SUBDOMAIN 1

uns(t0) eps

vns(t0) W/(pi*rwell^2)

pns(t0) pwell

SETTINGS BOUNDARY 1 BOUNDARY 2 BOUNDARY 3 BOUNDARY 6 BOUNDARIES 4, 7

Boundary 
type

Symmetry 
boundary

Inlet Outlet Inlet Wall

Boundary 
condition

Axial 
symmetry

Velocity Pressure, no 
viscous stress

Velocity No slip

p0 pwell

u0 eps ubr

v0 (-s^2+1)*2*Win
/(pi*rwell^2)

vbr
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In the previous table, s is the arc length of a boundary, which goes from 0 at the 
start point to 1 at the end point. COMSOL Multiphysics denotes the end point with 
an arrow on the boundary. Use s to give a parabolic velocity profile at the well inlet.

Brinkman Equations
1 From the Multiphysics menu, select Brinkman Equations (chbr).

2 From the Physics menu, select Boundary Settings. Select Boundary 6. Select the 
Boundary type Outlet and the Boundary condition Pressure. In the p0 edit field for 
Pressure enter pns. Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Subdomain tab. Select Subdomain 1, then in the Maximum element size edit 
field enter 0.02. Select Subdomain 2, then in the Maximum element size edit field 
enter 0.066. Select Subdomain 3 and specify a Maximum element size of 0.133.

3 Click the Boundary tab. Select Boundary 6 and in the Maximum element size edit field 
enter 0.005. Select Boundary 9 and specify a Maximum element size of 0.02.

4 Click the Point tab. Select Points 4 and 5, then in the Maximum element size edit field 
enter 0.001. For Growth rate enter 1.1, then click OK.
 2 :  F L U I D  F L O W  M O D E L S



5 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

To solve the model, first clear the old solution then iterate to solve the 3-way coupled 
problem.

1 Go to the Solve menu and return to the Solver Parameters dialog box. From the 
Solver list, click Parametric. For Parameter names enter damp. For Parameter values 
enter 0.1 0.01 0.005 0.0025 0.001. Click OK.

2 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2-23 on page 74 follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box. 

2 Click the General tab. In the Plot type area, click the Surface, Contour, and Streamline 
check boxes. Clear the Geometry check box.

3 Click the Surface tab. On the Surface Data page, enter visp in the Expression edit 
field, typing over the current information. In the Surface color area, find the Color 

table list and select Thermal.

4 Click the Contour tab. On the Contour Data page, enter visp in the Expression edit 
field, again typing over current information. In the Contour levels area, enter 20 in 
the Number of levels edit field. Proceed to the Contour color area. Click first the 
Uniform color option button and then the Color button. Choose black, then click OK.

5 Click the Streamline tab. On the Streamline Data page, enter visu and visv in 
r component and z component edit fields, respectively. On the Start Points page, click 
the Specify start point coordinates option button. In the r component edit field enter 
0.02 0.04 0.06 0.08 4 4 4 4 4 4 4 4, and in the z component edit field enter 
-1 -1 -1 -1 -0.85 -0.75 -0.65 -0.55 -0.45 -0.35 -0.25 -0.15. Click 
the Advanced button. In the Maximum number of integration steps edit field enter 
10000. In both the Integration tolerance and the Stationary point stop tolerance edit 
fields enter 0.00001, then click OK. Click the Color button, set the color to black, 
and then click OK.

6 Click the Arrow tab. On the Subdomain Data page enter visu in the r component edit 
field and visv in the z component edit field. In the Arrow positioning area click both 
Vector with coordinates option buttons.

7 In the edit field associated with r points enter 
3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5 2.5  
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1.5 1.5 1.5 1.5 1.5 1.5 1.5 1.5 0.75 0.75 0.75 0.75 0.75 0.75 0.75 

0.75.

8 In the edit field associated with z points enter  
-0.85 -0.75 -0.65 -0.55 -0.45 -0.35 -0.25 -0.15 -0.85 -0.75 -0.65 

-0.55 -0.45 -0.35 -0.25 -0.15 -0.85 -0.75 -0.65 -0.55 -0.45 -0.35 

-0.25 -0.15 -0.85 -0.75 -0.65 -0.55 -0.45 -0.35 -0.35 -0.25.

9 In the Arrow parameters area, find the Arrow type list and select Cone. In the Arrow 

length list, select Normalized. Click the Color button, set the color to black, and then 
click OK.

10 Click OK to close the Plot Parameters dialog box and generate the plot.

To generate Figure 2-24 on page 75, continue with these steps:

1 From the Postprocessing menu, select Plot Parameters. 

2 On the General page, clear the Streamline and Arrow check boxes.

3 Click the Surface tab. On the Surface Data page, enter visU in the Expression edit 
field, typing over the current information. Go to the Surface color area, and in the 
Color table list choose Rainbow.

4 Click the Contour tab. On the Contour Data page, enter visp in the Expression edit 
field, typing over the current information. In the Contour levels area, enter 10 in the 
Number of levels edit field. In the Contour color area, click first the Uniform color 
option button, then click the Color button. Change the color to white, then click OK.

5 Click OK to close the Plot Parameters dialog box.

6 Use the Zoom Window tool on the Main toolbar to zoom in on the area of interest.

To generate Figure 2-25 on page 76, continue with these steps:

1 Select the menu item Postprocessing>Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab. In the y-axis data area, enter visp in the Expression edit 
field. In the Cross-section line data area, set r0 to 0.05, r1 to 0.5, and both z0 and 
z1 to -0.5. Click Apply.

To generate Figure 2-26 on page 76, continue with these steps:

3 In the y-axis data area, change the Expression to visU.

4 In the Cross-section line data area, change r1 to 3.0. Click OK.
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Po r ou s  Med i a  F l ow :  D i s c r e t e  F r a c t u r e

Introduction

Fluids in fractured porous media move quickly through the fractures but also migrate, 
albeit relatively slowly, through the tiny pores within the surrounding matrix blocks. 
Some fluid transfers between the fractures and the matrix blocks, so fluid pressure is 
continuous across the fracture from block to block. Accurately predicting fracture and 
matrix flow is often critical to assessing well productivity, to delineating migrating 
pollution, and to designing pollution cleanup strategies, to name just a few uses.

This example demonstrates an efficient and accurate method to jointly model the 
fracture and matrix flows in a fractured block. You build it by representing the fractures 
as the boundaries between adjacent matrix blocks (Figure 2-27). Darcy’s law governs 
velocities in the matrix blocks, while you set up flow in the fractures on boundaries by 
accounting for the fracture’s thickness. Representing the fracture as an interior 
boundary is especially efficient because it eliminates the need to create a geometry with 
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a high aspect ratio with a very long and narrow fracture domain that otherwise would 
require a dense mesh consisting of great number of tiny elements.

Figure 2-27: Geometry for a COMSOL Multiphysics analysis of a discrete fracture.

Model Definition

The geometry in Figure 2-27 is a block of fractured porous media that measures 1 m 
on each side. The fracture is far more permeable to fluid than the matrix block and has 
a thickness of 0.0001 m, which is much smaller than the block dimensions. Here the 
walls of the block are impermeable to flow except at the fracture edges, but such need 
not be the case. Fluid moves from left to right through the block entering at the lower 
fracture edge and exiting at the upper edge. The fluid initially does not move within 
the volume. Pressure at the outlet edge drops with time., while pressure at the inlet 
edge remains at the initial pressure throughout the simulation. The simulation period 
is 1000 s. At the end of this discussion a tabulation of the data values appears.

F L U I D  F L O W — M A T R I X  B L O C K

Time-dependent fluid flow in the matrix block is governed by Darcy’s law

χfθs χs 1 θs–( )+[ ]∂p
∂t
------ ∇

κm
η

-------∇p⎝ ⎠
⎛ ⎞⋅– 0= Ω matrix block
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where the dependent variable, p, is the fluid’s pressure in the pore space (Pa), θs is the 
void fraction, or porosity, of the matrix blocks (m3/m3), χf and χp are the 
compressibilities (1/Pa) of the fluid and solid, respectively, κm gives the permeability 
of the matrix blocks (m2), and η equals the fluid’s dynamic viscosity (Pa·s).

In the blocks, the predefined velocity variable, uesdl (m/s), gives the Darcy velocity, 
which is a volume flow rate per unit area of porous media:

The fluid’s linear velocity within the small interstices in the block, ulin = |uesdl|/θs, is 
higher than the Darcy velocity, which describes the velocity as if it were distributed 
over both solids and voids.

Along all faces of the block the zero flow boundary condition applies:

Here n is the outward-pointing normal to the boundary. This means that there is no 
flow across the boundary.

F L U I D  F L O W — F R A C T U R E

The fracture in the model is a sequence of interior boundaries. Typically at a boundary 
you define flow across or normal to the boundary instead of along it. In this model, 
however, you employ special tangential options from COMSOL Multiphysics that 
allow for defining flow along the interior boundaries or fracture.

For this type of analysis to be valid, the equation on the fracture must solve for the 
same dependent variable as the equation for the matrix block, p. In this particular 
example, the equation for velocity in the fracture follows a modified form of that 
within the matrix block, namely Darcy’s law. You modify the equation coefficients to 
account for a relatively small resistance to flow on the fracture and the fracture 
thickness, which gives dimensional consistency between the fracture and matrix:

In this equation, Sfrac is the fracture-storage coefficient (1/Pa), κfrac describes the 
fracture’s permeability (m2), and dfrac is the fracture’s thickness (m).

Because thickness appears in the fracture flow equation, the predefined variable uesdl 
gives the volume flow rate per unit fracture length on the fracture:

uesdl
κm
η

-------∇p–= Ω matrix block

n uesdl⋅ 0= Ω  block face∂

Sfrac dfrac
∂p
∂t
------ ∇

κfrac
η

----------- dfrac∇p⎝ ⎠
⎛ ⎞⋅– 0= ∂Ω fracture
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Here  denotes the gradient operator restricted to the fracture’s tangential plane. 
The linear fluid velocity within the fracture is ulin ≡ uesdl/dfrac (m/s).

Bounding the fracture are edges that intersect the porous media block. The pressure is 
known at the inlet and outlet edges: at the inlet, the pressure is constant and at the 
outlet it decreases linearly in time. There is no flow through the other edges.

Implementation

To trigger flow on the fracture that interacts with flow in the matrix, you add weak 
form terms with tangential derivatives on the interior boundaries. The weak PDE 
formulation is the extremely powerful and flexible integral form that underlies the 
finite element method. The tangential derivatives pTx, pTy, and pTz describe the 
change in pressure along, rather than across, the boundary.

With weak PDEs, the time rate of change in pressure goes into a dweak expression that 
combines with velocities and sources in weak expressions to completely describe the 
physics. To find out more about the use of the weak PDE form see “The Weak Form” 
on page 345 in the COMSOL Multiphysics Modeling Guide.

Results

The following figures contain screen shots from the analysis of time-dependent flow in 
a fractured porous media block. The isosurfaces in Figure 2-28 show the contours of 
fluid pressure throughout the block at the final output time of 1000 s. The pressure is 
continuous across the fracture from block to block. Even so, the bends in the 
isosurfaces indicate different flow regimes in the fracture and the matrix blocks. The 

uesdl
κfrac

η
------------dfrac pT∇–= Ω  fracture∂

∇T

p p0= ∂2Ω inlet edge

p p0 t 10 Pa/s⋅–= ∂2Ω outlet edge

κfrac
η

------------dfrac∇p 0=– ∂2Ω other edges
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arrows indicate velocities on the fracture. The fluid moves from the inlet to the outlet 
along the fracture with a velocity field that is uniform across the block.

Figure 2-28: Results at time 1000 s for the analysis of flow in a porous media block with a 
fracture running through it. Shown are the pressure (isosurface plot) and linear velocity 
along the fracture (boundary and arrows). Pressure isosurfaces go from 91.5 to 100 kPa 
at 1.5 kPa increments. The maximum velocity on the fracture is 1.13 m/s.

Figure 2-29 shows the linear velocities of the fluid in the matrix along with the 
pressure isosurfaces from Figure 2-28. With no flow out of the matrix, the only fluid 
source is the fracture. The arrows indicate that fluid exits from the fracture at the inlet. 
The matrix flow feeds the fracture at the outlet. The wireframe slice plot shows that 
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the linear velocity in the matrix is orders of magnitude smaller than the average linear 
velocity along the fracture.

Figure 2-29: Results from the analysis of a porous media block with a discrete fracture; it 
shows fluid pressure (isosurfaces), velocities in the matrix blocks (arrows), and matrix 
linear velocity relative to average linear fracture velocity (slice plot).

Figure 2-30 illustrates the flow field in the fractured block evolving over the 1000 s 
simulation period. The isosurfaces stack up in the block as the pressure drop increases 
but stay centered on the fracture.
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Figure 2-30: Postprocessing images from the analysis of flow on a discrete fracture in a 
matrix block. Shown are fluid pressure (isosurfaces), velocities in the matrix blocks 
(arrows), and matrix linear velocity relative to average linear fracture velocity (slice).

Conclusions

This example shows how to model flow in a discrete fracture that interacts with fluid 
flow in the porous matrix that surrounds it. The method used here is especially efficient 
computationally. With COMSOL Multiphysics’ tangential boundary options, you can 
represent the fracture as a 2D boundary rather than a 3D model domain. This 

300 s 550 s

800 s 1000 s
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approach produces high-resolution results and also eliminates the need for an 
enormous number of small elements.

Model Data

The coefficients and parameters in this model are as follows:

Model Library path: Earth_Science_Module/Fluid_Flow/fracture_porous

Modeling Using the Graphical User Interface

In this example, the geometry already exists as a COMSOL Multiphysics model file. 
Ordinarily to build a 3D model you start with the following steps.

M O D E L  N A V I G A T O R

1 Open the Model Navigator. In the Space dimension list select 3D.

2 In the list of application modes choose 
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis>Transient analysis.

3 Click OK.

VARIABLE UNITS DESCRIPTION EXPRESSION

 θs m3/m3 Porosity of matrix blocks 0.3

 χf s2·m/kg Compressibility of the fluid 4.4·10-10

 χs s2·m/kg Compressibility of the fluid 10-8

 κm m2 Permeability of matrix blocks 10-11

 df m Thickness of the fracture 0.0001

 Sf s2·m/kg Storage coefficient of the fracture  χf

 κf m2 Permeability of fracture 10-7

 η kg/m·s Viscosity 0.001

 gr m/s2 Gravity 9.82

 ρf kg/m3 Fluid density 1000

 pinlet kg/m·s2 Pressure at the fracture inlet 105

 poutlet kg/m·s2 Pressure at the fracture outlet  p0 − 10t

 p0 kg/m·s2 Initial pressure distribution 105
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S C A L A R  V A R I A B L E S

Because of the small model domain you can neglect the impact of gravity, so there is 
no need to alter the settings available from the Physics>Scalar Variables dialog box.

M O D E L  S E T T I N G S

1 Choose Physics>Model Settings.

2 Clear the Simplify expressions check box, then click OK.

G E O M E T R Y

1 Go to the Draw toolbar and click the Block button. Click OK to accept the default 
dimensions and create a unit block. Click the Zoom Extents button on the Main 
toolbar to center the block.

2 Now set up a 2D drawing plane to create the fracture. Select the menu item 
Draw>Work-Plane Settings. Click the Face Parallel tab. Expand the folder BLK1 and 
highlight Face 2. Click OK. Geometry 2 should appear with the outline of the box in 
the upper right corner. Click the Zoom Extents button on the Main toolbar to center 
the box in the window.

3 Changing the grid slightly makes it easier to draw the fracture. Select the menu item 
Options>Axes/Grid Settings. Click the Grid tab, then clear the Auto check box. In the 
x-spacing and y-spacing edit fields enter 0.25. Click OK.

4 Next draw a 3-segment line to represent the fracture. Select the menu item 
Draw>Specify Objects>Line. In the x-coordinates edit field enter the sequence 0 0.5 
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0.5 1, and in the y-coordinates edit field enter 0.75 0.75 0.25 0.25. Click OK. 
This sets up segments with endpoints at (0, 0.75) (0.5, 0.75) (0.5, 0.25) (1, 0.25).

5 Now extrude the lines by 1 m to create a 3D object. With the lines still highlighted, 
choose Draw>Extrude. In both the Scale x and Scale y edit fields type 1.

6 Click OK.

O P T I O N S

Define constants you need in building the model or during postprocessing.

1 Choose Options>Constants. Enter the following names, expressions, and 
descriptions (optional); when done, click OK.

2 Choose Options>Expressions>Scalar Expressions.

3 Enter these names, expressions, and descriptions (optional); when done, click OK.

P H Y S I C S — M A T R I X

Use the predefined equation options to set up the flow model for the matrix blocks.

1 Choose Physics>Subdomain Settings.

2 Select Subdomains 1 and 2, then enter the following settings:

NAME EXPRESSION DESCRIPTION

p0 1e5[Pa] Initial pressure

theta_s 0.3 Porosity matrix

S_frac 4.4e-10[1/Pa] Fracture storage coefficient

k_frac 1e-7[1/m^2] Fracture permeability

d_frac 0.1[mm] Fracture thickness

NAME EXPRESSION DESCRIPTION

weak_frac -(k_frac/eta_esdl)*d_frac* 
(pTx_test*pTx+pTy_test*pTy+pTz_test*pTz)

Fracture flow

dweak_frac S_frac*d_frac*p_time*p_test Fracture storage

SETTINGS SUBDOMAINS 1, 2 DESCRIPTION

 Storage term Specific Storage

 θs theta_s Volume fraction, fluids

 χf 4.4e-10 Compressibility, fluid

 χp 1e-8 Compressibility, solid

 κs 1e-11 Saturated permeability
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3 Click the Init tab. In the Initial value edit field enter p0, then click OK.

4 Choose Physics>Boundary Settings. Verify that the boundary condition is Zero flux/

Symmetry for all boundaries, then click OK to close the dialog box.

P H Y S I C S — F R A C T U R E

Now set up the flow model for the fracture.

1 Choose Physics>Edge Settings.

2 Click the Pressure tab. Select Edge 16 (the fracture inlet), then enter these settings:

3 Select Edge 6 (the fracture outlet), then enter these settings:

4 Click OK to close the Edge Settings dialog box.

5 Choose Physics>Equation Systems>Boundary Settings.

6 Click the Weak tab.

7 Select Boundaries 6, 8, and 9, then enter the following settings:

8 Click Differentiate to distribute the new information.

9 Click OK to close the Equation System - Boundary Settings dialog box.

 ρf 1000 Density, fluid

 η 0.001 Viscosity, fluid

QUANTITY VALUE/EXPRESSION DESCRIPTION

p0 p0 Pressure

ts 0 Starting time

tf 1000 Ending time

QUANTITY VALUE/EXPRESSION DESCRIPTION

p0 p0-10[Pa/s]*t Pressure

ts 0 Starting time

tf 1000 Ending time

TERM VALUE/EXPRESSION

weak weak_frac

dweak dweak_frac

constr 0

SETTINGS SUBDOMAINS 1, 2 DESCRIPTION
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M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 On the Global page, select Coarse from the Predefined mesh sizes list.

3 Click the Boundary tab. Select Boundaries 6, 8, and 9, then in the Maximum element 

size edit field enter 0.075.

4 Click the Edge tab. Select Edges 6 and 16, then in the Maximum element size edit 
field enter 0.025.

5 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, go to the Time stepping area and in the Times edit field type 
0 1 10 range(50,50,1000).

3 Go to the Linear system solver area and from the like-named list choose Conjugate 

gradients. From the Preconditioner list, select Algebraic multigrid. In the Quality of 

multigrid hierarchy edit field type 9.

4 Click OK to close the Solver Parameters dialog box.

5 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

COMSOL Multiphysics allows you to create arbitrary variables and use them in 
postprocessing. The plots for this model use linear velocities that you first define. 
Having creating these variables, you must update the model to recognize the new 
definitions.

1 Choose Options>Expressions>Subdomain Expressions.

2 Select Subdomains 1 and 2, then enter the following settings, each on its own row 
in the table; when done, click OK.

3 Choose Options>Expressions>Boundary Expressions.

NAME EXPRESSION

u_matrix_lin u_esdl/theta_s

v_matrix_lin v_esdl/theta_s

w_matrix_lin w_esdl/theta_s

U_matrix_lin U_esdl/theta_s
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4 Select Boundaries 6, 8, and 9, then enter the following settings, each on its own row 
in the table; when done, click OK.

5 Choose Options>Integration Coupling Variables>Boundary Variables.

6 Select Boundaries 6, 8, and 9.

7 Enter the following settings, each on its own row in the table:

The subdomain expression U_frac_lin_avg defined in this way is the mean value 
of the linear velocity vector’s norm in the fracture.

8 Click OK to close the Boundary Integration Variables dialog box, then choose 
Solve>Update Model to calculate the expressions you have just defined.

To generate Figure 2-29 on page 88, follow these instructions:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, go to the Plot type area and select the Isosurface, Boundary, and 
Arrow check boxes. Clear the Slice check box.

3 Click the Isosurface tab. On the Isosurface Data page, go to the Predefined quantities 
list and select Darcy’s Law (esdl)>Pressure. From the Unit list, select kPa. Click the 
Vector with isolevels option button, and in the associated edit field enter 
range(91.5,1.5,100).

4 Click the Boundary tab. In the Expression edit field, type U_frac_lin.

5 Click the Arrow tab. From the Plot arrows on list select Boundaries. In the 
x-component edit field, type u_frac_lin; in the y-component edit field, type 
v_frac_lin; and in the z-component edit field, type w_frac_lin. From the Arrow 

type list, select Cone.

6 Click OK to generate the plot and close the Plot Parameters dialog box.

7 Double-click on the GRID field at the bottom on the user interface. Click the 
Headlight button on the Camera toolbar to enhance the image with directed light.

NAME EXPRESSION

u_frac_lin -(k_frac/eta_esdl)*pTx

v_frac_lin -(k_frac/eta_esdl)*pTy

w_frac_lin -(k_frac/eta_esdl)*pTz

U_frac_lin sqrt(u_frac_lin^2+v_frac_lin^2+w_frac_lin^2)

NAME EXPRESSION

U_frac_lin_avg U_frac_lin/A_frac

A_frac 1
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To generate Figure 2-30 on page 89, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Still on the Arrow page, select Subdomains from the Plot arrows on list. In the 
x-component edit field, type u_matrix_lin; in the y-component edit field, type 
v_matrix_lin; and in the z-component edit field, type w_matrix_lin.

Add a slice plot to see the linear velocity in the matrix block relative to the average 
value of the linear velocity on the fracture.

3 Click the Slice tab. Select the Slice plot check box. In the Slice data area, type 
U_matrix_lin/U_frac_lin_avg in the Expression edit field. In the Slice positioning 
area, click the option button for x levels in the Vector with coordinates column, then 
type 0.9 in the associated edit field. Leave the Number of levels for both the y levels 
and z levels at their default zero value. In the Coloring and fill area, select Wireframe 
from the Fill style list. In the Slice color area, click the Color table button and in the 
associated drop-down list select Thermal.

4 On the General page, clear the Boundary check box in the Plot type area.

5 Switch among the output times from the figure by selecting them in the Solution at 

time list; after each selection, click Apply to generate the corresponding plot.

To animate the solution sequence, click the Plot Parameters button and then click the 
Animate tab. Edit the Movie settings as appropriate. Click the Start Animation button.

To create the image that appears when opening the model file, remove the slice plot 
and add streamlines for viewing the matrix and fracture velocities simultaneously. To 
do so, continue with these instructions:

1 Return to the Plot Parameters dialog box.

2 On the General page, clear the Slice check box and select the Streamline check box.

3 Click the Arrow tab. In the Plot arrows on list select Boundaries. Keep the settings on 
the Boundary Data page that you entered in Step 5 on page 127.

4 Click the Streamline tab. In the x component edit field, type u_matrix_lin; in the 
y component edit field, type v_matrix_lin; and in the z component edit field, type 
w_matrix_lin. On the Start Points page, set the Number of start points to 150. On 
the Line Color page, click first the Use expression button and then the Color Expression 
button. In the Streamline Color Expression dialog box, type U_matrix_lin in the 
Expression edit field. From the Unit list, select mm/s, then click OK.

5 Click OK to close the Plot Parameters dialog box and generate the plot.
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V a r i a b l y  S a t u r a t e d  F l ow

Introduction

This example uses the Richards’ Equation application mode to assess how well 
geophysical irrigation sensors detect the true level of fluid saturation in variably 
saturated soils. Andrew Hinnell, Alex Furman, and Ty Ferre from the Department of 
Hydrology and Water Resources at the University of Arizona brought the example to 
us. They originally worked out the problem in COMSOL Multiphysics’ PDE modes, 
but this discussion shares their elegant model reformulated in the Richards’ Equation 
application mode.

A major challenge when characterizing fluid movement in variably saturated porous 
media lies primarily in the need to describe how the capacity to transmit and store 
fluids changes as fluids enter and fill the pore spaces. Experimental data for these 
properties are difficult to obtain. Moreover, the properties that change value as the soil 
saturates happen to be equation coefficients, which makes the mathematics notoriously 
nonlinear. The Richards’ Equation application mode provides interfaces that automate 
the van Genuchten (Ref. 1) as well as the Brooks and Corey (Ref. 2) relationships for 
fluid retention and material properties that vary with the solution. This section 
discusses these interfaces and also explains how the application mode includes an 
interface that helps you use your own data or expressions to describe these properties 
(for details see “Interpolation for Unsaturated Flow” on page 114).

Figure 2-31: A variably saturated porous medium.

Water Table

Water

Air
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This example uses the model of Hinnell, Furman, and Ferre to characterize how the 
distribution of water changes around three impermeable sensors inserted into two 
different blocks of uniform soil partially saturated with water. The question for the 
model to address is this: Does the saturation localized around the sensor give a valid 
picture of the saturation within the total block?

This model demonstrates how to use the Richards’ Equation application mode 
including the van Genuchten (Ref. 1) as well as the Brooks and Corey (Ref. 2) 
interfaces. The step-by-step instructions assist you in learning how to set up two 
separate equation systems in one COMSOL Multiphysics model file and then solve 
them simultaneously. It also explains a method to automate boundary and subdomain 
integrations using coupling variables—here the integrations estimate the average 
saturation around the sensors and within the soil blocks. For an example in which the 
soil retention and permeability properties are defined with experimental data, see the 
model “Interpolation for Unsaturated Flow” on page 114.

The following pages start with an overview of the problem setup and a review of the 
equations and boundary conditions. Then follow a few details about implementing the 
integration-coupling variables and a table of the model data. The subsequent section 
presents the results of the simulations, and the final section gives detailed instructions 
for how to set up the model in the COMSOL Multiphysics user interface.

Model Definition

The problem setup is as follows. Two homogeneous columns of soil, each 2 m-by- 2 m 
on a face, are partially saturated with water. A plot of the hydraulic properties of the 
first soil (Soil Type 1) fits the van Genuchten retention and permeability formulas. The 
other soil (Soil Type 2) has material properties that suit the Brooks and Corey 
formulas. Within each soil column are three impermeable rods, each with a 0.1 m 
radius. The rods are spaced at 0.5 m increments so they run horizontally down the 
center line of each block; see Figure 2-32. Just after the rods are emplaced, the pressure 
head is still uniform, but water begins to move vertically downward in steady drainage. 
Because all vertical slices down a block are identical, you can model a 2D cross section 
and observe the changes in the flow field for 900 s or 15 minutes.
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Figure 2-32: Soil block with three rods. The shaded plane represents a vertical cross section.

G O V E R N I N G  E Q U A T I O N

Richards’ equation describes the unsaturated-saturated flow of water in the soils. In 
this problem you can use Richards’ equation only for water because the air in the soil 
stays at atmospheric pressure because this model does not close the surface to the 
atmosphere or otherwise ramp up the air pressures. The governing equation for the 
model is

 (2-3)

Pressure head, Hp (m), is the dependent variable. C denotes specific moisture capacity 
(m−1), Se is the effective saturation, S is a storage coefficient (m−1), t is time, K 
denotes the hydraulic conductivity (m/s), and D is the coordinate (for example x, y, 
or z) for the vertical elevation (m). The equation does not show the volumetric fraction 
of water, θ, which is a constitutive relation that depends on Hp. Nonlinearities appear 
because C, Se, and K change with Hp and θ.

The first term in the equation explains that fluid storage can change with time during 
both unsaturated and saturated conditions. When the soil is unsaturated, the pores fill 
with (or drain) water. After the pore spaces completely fill, there is slight compression 
of the fluid and the pore space. The specific moisture capacity C = ∂θ/∂Hp describes the 
change in fluid volume fraction θ with pressure head. The storage coefficient addresses 
storage changes due to compression and expansion of the pore spaces and the water 
when the soil is fully wet. To model the storage coefficient, this example uses the 

C SeS+[ ]
Hp∂
t∂

---------- ∇+ K∇ Hp D+( )–[ ]⋅ 0=
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specific storage option, which sets S = ρf  g (χp + θχf). Here, ρf is the fluid density (kg/
m3), g is acceleration of gravity, while χp and χf are the compressibilities of the solid 
particles and fluid, respectively (m·s2/kg).

The van Genuchten and the Brooks and Corey formulas that describe the change in C, 
Se, K, and θ with Hp require data for the saturated and liquid volume fractions, θs and 
θr, as well as for other constants α, n, m, and l, which specify a particular type of 
medium. With the van Genuchten equations that follow, you consider the soil as being 
saturated when fluid pressure is atmospheric (that is, Hp = 0):

With the Brooks and Corey approach, an air-entry pressure distinguishes saturated 
(Hp > −1/α) and unsaturated (Hp < −1/α) soil as in

θ =
θr Se θs θr–( )+
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To find a unique solution to this problem, you must specify initial and boundary 
conditions. Initially, the column has uniform pressure head of Hp0. The boundary 
conditions are

where n is the unit vector normal to the boundary.

COMSOL Multiphysics Implementation—Integration Coupling 
Variables

Integration coupling variables in COMSOL Multiphysics calculate integrals for 
arbitrary expressions on a given type of model domain (the source) and make that 
information available elsewhere in the model (the destination). As such, you can 
classify coupling variables by the source of the information. For example, boundaries, 
subdomains, and points are different types of sources that arise within every 2D model. 

θ =
θr Se θs θr–( )+
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To calculate the average value of the effective saturation, Se, at the rod and throughout 
the soil requires two types of integration coupling variables: boundary coupling 
variables for the rod-soil boundary, and subdomain coupling variables for the soil. In 
both cases the average saturation can be calculated as

,

where σ denotes the domain. The expression consists of two integrals. The numerator 
sums the effective saturation values along the boundary or within the subdomain. The 
denominator sums the boundary length or subdomain area (2D).

This model makes modest use of coupling variables to calculate saturations and 
compares them during postprocessing. Because coupling variables are so clever, it is 
worth mentioning a use or two. You can use them to evaluate, for example, a flux on 
an outlet and return the information as a source term on the inlet to link physics on 
separately meshed geometries within one model. And this is just the beginning. For 
more information on this topic, refer to “Using Coupling Variables” on page 269 in 
the COMSOL Multiphysics User’s Guide.

M O D E L  D A T A

The following table gives the data needed to complete the two example problems:

VARIABLE UNITS DESCRIPTION VAN GENUCHTEN BROOKS & COREY

 g m/s2 Gravity 9.82 9.82

 ρf kg/m3 Fluid density 1000 1000

 χp m·s2/kg Compressibility of solid particles 10-8 10-8

 χf m·s2/kg Compressibility of fluid 4.4·10-10 4.4·10-10

 Ks m/s Saturated hydraulic conductivity 8.25·10-5 5.83·10-5

 θs Porosity/void fraction 0.43 0.417

 θr Residual saturation 0.045 0.02

 α m-1 alpha parameter 14.5 13.8

 n n parameter 2.68 0.592

 m m parameter 1-1/n n/a

 l Pore connectivity parameter 0.5 1

 Hp0 m Specified pressure -0.06 -0.2

 Hp0 m Initial pressure -0.06 -0.2

Se
Se σd∫

σd∫
------------------=
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Results and Discussion

Figure 2-33 and Figure 2-34 are solutions to the Richards’ equation problem of Prof. 
Ty Ferre, Andrew Hinnell, and Alex Furman from the University of Arizona’s 
Department of Hydrology and Water Resources. Each figure gives results for similar 
variably saturated flow problem posed for different soil types. Each snapshot shows 
effective fluid saturation (surface plot), pressure head (contours), and fluid velocities 
(arrows). The flow field varies around the rods but remains largely uniform over the 
remainder of each block.

Figure 2-33: Solution for effective saturation (surface plot), pressure head (contours), and 
velocity (arrows) at 30 minutes for Soil Type 1 (van Genuchten).
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Figure 2-34: Solution for effective saturation (surface plot), pressure head (contours), and 
velocity (arrows) at 30 minutes for Soil Type 2 (Brooks and Corey).

Figure 2-35 shows the effective saturation evolving over time at the rod-soil boundary. 
The intervals (−180°, 0°) and (0°, 180°) for the angular coordinate along the 
horizontal axis correspond to the boundary’s lower and upper halves, respectively. In 
the figure, the solid lines denote the solution for Soil Type 1, and the dashed lines 
correspond to Soil Type 2. In the results, the initial value of effective saturation plots 
as a horizontal line. The soil is wetter just above the rods than below them. That the 
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saturation around Soil Type 1 extends to the lower half circle suggests that the entire 
boundary will get completely wet with time.

Figure 2-35: Effective saturation around the center rod in Soil Type 1 (solid lines) and 
Soil Type 2 (dashed lines). Results are for 0 s, 60 s, 300 s, 600 s, and 900 s.

Figure 2-36 compares the average fluid saturations at the rod boundary with the 
average within the two blocks of soil. The range of effective saturation estimates at the 
rod boundary appears as a scatter plot for different time steps. The solid line is the 
integral of the effective saturation at the rod boundary. The dashed line is the integral 
of effective saturation for the block. Clearly the average effective saturation at the rods 
increases with time, but the average for the block does not change. While the effects 
shown here are more pronounced in Soil Type 1 than Soil Type 2, the results call to 
question whether the sensors can accurately assess soil moisture if kept in situ for long 
times.
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Figure 2-36: Average effective saturation at sensor circumference (solid lines) and overall 
soil block (dashed lines) for Soil Type 1 (top set) and Soil Type 2 (bottom set). Also shown 
is the range of effective saturation at the rod circumference for Soil Type 1 (circles) and 
Soil Type 2 (squares).
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Model Library path: Earth_Science_Module/Fluid_Flow/
variably_saturated_flow
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Modeling Using the Graphical User Interface

To begin the model, first set up a geometry with an xz-axis, then add two Richards’ 
Equation application modes.

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and in the Space dimension list select 2D.

2 Click the Multiphysics button.

3 Click the Add Geometry button. In the Independent variables edit field change the 
entry to read x z y in that order. Click OK.

4 In the list of application modes select Earth Science Module>Fluid Flow>Richards’ 

Equation>Pressure head analysis>Transient analysis. In the Application mode name 
edit field replace the current data with bc (for the Brooks & Corey method). Click 
the Add button and leave the dialog box open.

5 With the application mode Earth Science Module>Fluid Flow>Richards’ 

equation>Pressure head analysis>Transient analysis still selected, go to the Application 

mode name edit field and enter vg (for the van Genuchten analysis). Click Add, then 
click OK.

A P P L I C A T I O N  S C A L A R  V A R I A B L E S

To set the vertical direction in the model, go to the Physics menu and select Scalar 
Variables. Make the following modifications to the defaults, and then click OK.

G E O M E T R Y  M O D E L I N G

Create the geometry by drawing a rectangle and subtracting three circles from it.

1 Press Shift and click the Rectangle/Square (Centered) button on the Draw toolbar.

2 In the Square dialog box that opens, draw a square centered at the origin, with the 
upper-left corner at x = −1, z = 1 and the lower-right corner at x = 1, z = −1. When 
done, click OK to close the dialog box.

3 Shift-click the Ellipse/Circle (Centered) button on the Draw toolbar.

NAME EXPRESSION

D_vg z

D_bc z
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4 In the Circle dialog box enter the following settings for the radius and centerpoint 
coordinates; when done, click OK.

5 Click the Array button on the Draw toolbar.

6 In the Array dialog box, go to the Displacement area and type 0.5 in the x edit field. 
In the Array size area, type 3 in the x edit field, then click OK.

7 Press Ctrl+A to select all the objects, then click the Difference button on the Draw 
toolbar.

8 Click the Zoom Extents button on the Main toolbar to center the geometry in the 
drawing area.

O P T I O N S  A N D  S E T T I N G S

Now set up variables to integrate the effective saturation in the subdomain and along 
the rod boundary.

1 Choose Options>Integration Coupling Variables>Subdomain Variables.

2 In the Subdomain Integration Variables dialog box, select Subdomain 1

3 Enter data from following table; when done, click OK.

4 Choose Options>Integration Coupling Variables>Boundary Variables.

5 In the Boundary Integration Variables dialog box, select Boundaries 9–12.

6 Enter data from the following table; when done, click OK.

NAME EXPRESSION

Radius 0.1

x -0.5

z 0

NAME EXPRESSION

A_soil 1

Se_mean_soil_vg Se_vg/A_soil

Se_mean_soil_bc Se_bc/A_soil

NAME EXPRESSION

s_rod 1

Se_mean_rod_vg Se_vg/s_rod

Se_mean_rod_bc Se_bc/s_rod
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P H Y S I C S  S E T T I N G S

Subdomain Settings—Soil Type 1 (van Genuchten)
First set up the model for Soil Type 1, which you build with the van Genuchten 
retention and permeability relationships.

1 From the Multiphysics menu, select Richards’ Equation (vg).

2 Choose Physics>Subdomain Settings.

3 On the Coefficients page, enter the following settings:

4 On the van Genuchten page, enter the following settings:

5 Click the Init tab. In the Initial value edit field for Hpt(0) enter -0.06.

6 Click OK.

Boundary conditions
1 From the Physics menu, select Boundary Settings.

2 Set the following boundary conditions; when done, click OK.

PROPERTY VALUE

Constitutive relation van Genuchten

 θs 0.43

 θr 0.045

Storage term Specific storage

 χf 4.4e-10

 χp 1e-8

KS 8.25e-5

 ρf 1000

PROPERTY VALUE

 α 14.5

 n 2.68

 l 0.5

SETTINGS BOUNDARIES 1, 4–16 BOUNDARIES 2, 3

Boundary condition Zero flux/Symmetry Pressure head

Hp0 -0.06
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Subdomain Settings—Soil Type 2 (Brooks and Corey)
Create a second application in the same model file for Soil Type 2 using the Brooks 
and Corey parameterization approach.

1 From the Multiphysics menu, select Richards’ Equation (bc).

2 From the Physics menu, select Subdomain Settings.

3 On the Coefficients page, enter the following expressions:

4 On the Brooks & Corey page, then enter the following settings:

5 Click the Init tab. In the Initial value edit field for Hpt(0) enter -0.2.

6 Click OK.

Boundary conditions
1 From the Physics menu, select Boundary Settings.

2 Set these boundary conditions; when done, click OK.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

PROPERTY VALUE

Constitutive relation Brooks & Corey

 θs 0.417

 θr 0.02

Storage term Specific storage

 χf 4.4e-10

χp 1e-8

 KS 5.8333e-5

 ρf 1000

PROPERTY VALUE

 α 13.8

 n 0.592

 l 1

SETTINGS BOUNDARIES 1, 4–16 BOUNDARIES 2, 3

Boundary condition Zero flux/Symmetry Pressure head

Hp0 -0.2
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2 Click the Boundary tab. Select the three circles in the model domain; to do so, 
left-click the mouse in the user interface and draw a box around the circles. Then in 
the Maximum element size edit field enter 0.025. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Choose Solve>Solver Parameters.

2 Find the Solver list, and verify that Time dependent is selected.

3 Go to the Time stepping area and enter 0 60 300 600 900 in the Times edit field 
to specify output times for the model. Click OK.

4 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2-33 on page 103, follow these steps:

1 Choose Postprocessing>Plot Parameters.

2 Go to the General page. In the Plot type area select the Surface, Contour, and Arrow 
check boxes. 

3 Click the Surface tab. On the Surface Data page, go to the Predefined quantities list 
and select Richards’ Equation (vg)>Effective saturation.

4 Click the Contour tab. On the Contour Data page, go to the Predefined quantities list 
and select Richards’ Equation (vg)>Pressure head.

5 In the Contour color area, clear the Color legend check box. Click first the Uniform 

color option button and then the Color button. In the Contour Color dialog box, 
select black, then click OK.

6 Click the Arrow tab. On the Subdomain Data page, go to the Predefined quantities list 
and select Richards’ Equation (vg)>Velocity field.

7 Go to the Arrow positioning area. In the Number of points edit fields for both x points 
and z points enter 40. Click the Color button, then choose gray; click OK.

8 Click Apply to generate the plot.

To create Figure 2-34, repeat Steps 3, 4, and 6 for Figure 2-33 above, except this time 
select the application mode Richards’ equation (bc) instead of Richards’ Equation (vg). 
Finish by clicking OK to close the Plot Parameters dialog box and generate the plot.

To generate Figure 2-35, continue with these steps:

1 Choose Postprocessing>Domain Plot Parameters.

2 Click the Line/Extrusion tab. From the Boundary selection list, select 9 through 12.
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3 Go to the y-axis data area and in the Expression edit field enter Se_vg (the effective 
saturation for the application mode named vg). 

4 In the x-axis data area, click first the lower option button and then the Expression 
button. In the X-Axis Data dialog box, enter the Expression atan2(z,x). Select o 
from the Unit list, then click OK. Click Apply to generate the first set of curves.

5 On the General page, select the Keep current plot check box.

6 Return to the Line/Extrusion page and in the Expression edit field enter Se_bc.

7 Click the Line Settings button. Set the Line style to Dashed line, then click OK.

8 Click OK to complete the plot you just created by adding the results for Soil Type 2.

Finally, generate Figure 2-36 with these instructions:

1 Choose Postprocessing>Domain Plot Parameters.

2 On the General page, select New figure from the Plot in list and select the Keep current 

plot check box.

First plot the distribution of effective saturation estimates at each output time:

3 On the Line/Extrusion page, go to the y-axis data area and in the Expression edit field 
enter Se_vg. In the Boundary selection list select 9 through 12.

4 Go to the x-axis data area and click the Expression option button. In the Expression 
edit field enter t, then click OK.

5 Click the Line Settings button at the bottom of the dialog box. From the Line color 
list select Color, and set the Line marker to Circle. Click OK to close the Line Settings 
dialog box.

6 Click Apply.

7 In the y-axis data area, change the Expression to Se_bc.

8 Click the Line Settings button. Click the Color button. Select blue, then click OK.

9 From the Line marker list select Square, then click OK.

10 Click Apply.

11 On the Point page, select an arbitrary point in the Point selection list or by clicking 
in the drawing area.

12 In the y-axis data area, enter the Expression Se_mean_rod_vg.

13 Click the Line Settings button.

14 From the Line color list select Color, then click OK.

15 Click Apply.

16 In the y-axis data area, change the Expression to Se_mean_soil_vg.
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17 Click the Line Settings button. From the Line style list select Dashed line. Click OK.

18 Click Apply.

19 In the y-axis data area, change the Expression to Se_mean_soil_bc.

20 Click the Line Settings button. From the Line color list select Cycle. Click OK.

21 Click Apply.

22 In the y-axis data area, change the Expression to Se_mean_rod_bc.

23 Click the Line Settings button. From the Line style list select Dashed line. Click OK.

24 Click OK to generate the final plot and close the Domain Plot Parameters dialog box.

25 Click the Edit Plot toolbar button in the figure window and finalize the plot by 
editing the x limits, Title, x label, and y label as desired.
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I n t e r p o l a t i o n  f o r  Un s a t u r a t e d  F l ow

Variably saturated flow models are notoriously difficult to parameterize because several 
material and hydraulic properties change values as the pressure and saturation levels 
fluctuate. Ideally, experimentalists prefer to use their hard-earned data in a model 
rather than finding best-fit analytical expressions. This example demonstrates how to 
incorporate experimental data directly into a simulation. Nathan Miller of Michigan 
State University pioneered this approach in his COMSOL Multiphysics model of fluid, 
heat, and gas movement to a turtle nest.

Figure 2-37: Estimates of properties that depend on Hp. Shown for the upper soil layer 
(dashed line) and lower soil layer (solid line) are: hydraulic conductivity, K (a); liquid 
volume fraction, θ (b); effective saturation, Se, (c); and specific moisture capacity, C (d).

(a) (c)

(b) (d)
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This example uses interpolation between experimental data points to estimate values 
of the equation coefficients Se, θ,  K, and C (see Equation 2-3 on page 99) that fit the 
solution for the pressure head,  Hp, during a flow simulation.

The interpolation model described here builds on the flow model described in 
“Variably Saturated Flow” on page 97. In variably saturated transport, you define the 
equation coefficients Se, θ,  K, and C, which vary with pressure head,  Hp, using 
analytic expressions from van Genuchten (Ref. 1) and that are available in the Richards’ 
Equation application mode. For this interpolation model, the author parameterized 
the same basic flow problem by sampling from analytic calculations to obtain a 
fictitious experimental dataset and interpolating between the scattered points. At the 
close of the model, this discussion compares results from interpolated material 
properties to those obtained with analytical calculations.

Model Definition

Example 4 from the SWMS2D manual (Ref. 2) inspired the basic flow problem set out 
in this model. In that example, a ring of 0.25 m radius sits at the ground surface. 
Within it water ponds to a depth of 0.01 m. The ring is bottomless, so water moves 
from the ring into the soil. The problem examines the flow into a 1.3 m long soil 
column of radius 1.25 m.

Figure 2-38: Geometry showing infiltration ring on top of a soil column.
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The soil is layered; the upper soil layer is 0.4 m thick, and the lower layer sits on top of 
relatively impermeable soil. At the ground surface beyond the ring, there is no entry. 
The only flow exit is a small amount of leakage from the base. The center line of the 
ring is an axis of symmetry. The distribution of pressure head is known at an initial 
time. For more information about this flow model, see the example “Variably 
Saturated Flow” on page 97.

F L U I D  F L O W

Richards’ equation governs fluid flow in variably saturated porous media. A benefit of 
the form of Richards’ equation used here is that it allows for changes in storage related 
to increasing and decreasing moisture as well as storage changes due to compression 
and expansion when the soil is fully wet. The equation is 

where C is specific moisture capacity (m−1); Se is the effective saturation; S denotes 
the storage coefficient (m−1); Hp equals the pressure head (m); t is the time (d);  Ks 
represents the hydraulic conductivity (m/d); kr gives the relative permeability; D is the 
coordinate (for example x, y, or z) for the vertical elevation (m); and Qs represents the 
fluid source defined by volumetric flow rate per unit volume of soil (d−1). Here S 
equals the difference between the liquid volume fraction at saturation, θs, and the 
residual liquid volume fraction, θr, or specific yield per unit length.

Changes in pressure head and elevation head drive fluid through the soil. K, θ, C, and 
Se vary under unsaturated conditions (for example, Hp < 0), and they reach a constant 
value when the system saturates (for example, Hp ≥ 0). In a typical experimental 
station, you conduct simultaneous tests to identify how the hydraulic conductivity 
function K = Ks kr (m/d) and the volume fraction of fluid in the soil, θ, change with 
Hp. The specific moisture capacity, C, relates changes observed in the soil moisture, θ, 
to the change in pressure head, Hp. The relative permeability, kr, explains how the 
transmissive properties of the soil, K, vary with pressure head, Hp. The effective 
saturation, Se, denotes the value of θ scaled to a maximum of 1.

This example employs interpolation functions with a fictional set of experimental data 
consisting of K and θ data for different values of Hp. It uses interpolation when the soil 
is unsaturated (Hp < 0) to estimate K and θ for different values of the solution, Hp. 
The model defines C by the “slope” in the θ versus Hp values. Se is a scaled version of 
the θ results. The parameterization is as follows:

C Se S+( )
Hp∂
t∂

---------- ∇+ Kskr∇ Hp D+( )–[ ]⋅ Qs=
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where pressure head at saturation is atmospheric (that is, Hp = 0). Here, θs and Ks 
denote the soil’s total porosity and the saturated hydraulic conductivity.

For the boundary conditions, the pressure head in the ring is constant, and no flow 
exits in the surface outside the pressure ring. The sides are impermeable. The vertical 
boundary on the inside of the ring is a line of symmetry, and the model approximates 
the small amount of leakage from the base, N0, as being 0.01Ks. In summary, the 
boundary conditions are

where n is the outward unit normal to the boundary. Initially, the column has a 
specified distribution of pressure head of Hp0. Here, you define the initial pressures 
with an equation that approximates the distribution shown for June 1982 in 
Example 4 from SWMS2D (Ref. 2).

Implementation: Interpolation from Scattered Data

The “experimental data” are 25 data points sampled at regular Hp intervals from K and 
θ values calculated with the following formulas (Ref. 1). The data also include repeats 

θ =
f Hp( )

θs
⎩
⎪
⎨
⎪
⎧

Hp 0<

Hp 0≥

Se =
θ θr–( ) θs θr–( )⁄

1⎩
⎨
⎧ Hp 0<

Hp 0≥

C =
∂θ ∂Hp⁄

0⎩
⎨
⎧ Hp 0<

Hp 0≥

kr
K
Ks
------=

f Hp( )

1⎩
⎨
⎧ Hp 0<

Hp 0≥

Hp Hp0= ∂Ω Ring

n Kskr∇ Hp D+( )–[ ]⋅ 0= ∂Ω Surface

n Kskr∇ Hp D+( )–[ ]⋅ 0= ∂Ω Sides

n Kskr∇ Hp D+( )–[ ]⋅ 0= ∂Ω Symmetry

n Kskr∇ Hp D+( )–[ ]⋅ N0= ∂Ω Base
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of the constants for extreme pressure heads to prevent extrapolating beyond the range 
of physical property values. You can calculate the sampled distributions from

where α, n, and l are constants that characterize the type of medium, and m = 1 − 1/n.

Implementation: Interpolation from Experimental Data

This analysis finds the correct value of K = Kskr and θ for the solution Hp using 
COMSOL Multiphysics commands to interpolate between experimental data points. 
You calculate Se based on the interpolated θ estimates, then use COMSOL 
Multiphysics’ automated differentiation commands (for example, diff and pdiff) to 
define C as the derivative of θ with respect to Hp.

Interpolation in COMSOL Multiphysics is straightforward. You open a dialog box 
from the Options menu, import data from a text file, assign a name to the interpolation 
function, and use that name where the function is needed, here the Subdomain Settings 
dialog boxes.

The step-by-step instructions that follow create interpolation functions for each K and 
θ in two layers, giving a total of four functions. The example laid out here uses 
precreated files that contain the pressure head with corresponding property values. For 

θ =
θr Se θs θr–( )+

θs
⎩
⎪
⎨
⎪
⎧

Hp 0<

Hp 0≥

Se =

1

1 αHp
n

+[ ]
m

-------------------------------------

1⎩
⎪
⎨
⎪
⎧

Hp 0<

Hp 0≥

C =
αm

1 m–
-------------- θs θr–( )Se

1
m
-----

1 Se

1
m
-----

–
⎝ ⎠
⎜ ⎟
⎛ ⎞

m

0⎩
⎪
⎪
⎨
⎪
⎪
⎧

Hp 0<

Hp 0≥

kr
K
Ks
------= Sel 1 1 Se

1
m
-----

–
⎝ ⎠
⎜ ⎟
⎛ ⎞

m

–

2

1⎩
⎪
⎪
⎨
⎪
⎪
⎧

Hp 0<

Hp 0≥
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the hydraulic conductivity function, K = Ks  kr, in Subdomain 1, the name of the data 
file is K_sub1.txt. Within that file, the pressure-head data make up the first string of 
numbers, and the corresponding hydraulic-conductivity values follow. For example, 
the final five entries from K_sub1.txt read

%grid
-0.3 -0.2 -0.1 0.0 100
%data
 0.0903 0.1376 0.2199 0.4540 0.454

In this sample from the data file, grid denotes that Hp data follow, and data denotes 
that corresponding K data come next.

Note: The file gives only unsaturated properties, but you repeat the saturated 
hydraulic conductivity, Ks, of 0.454 m/d for a positive pressure head of 100 m to 
prevent interpolation beyond the range of the data.

To activate the new functions you just created, simply enter the function name (for 
example, K_sub1) along with the argument (for example, the pressure head Hp). For 
the relative permeability, kr, the command is:

kr = K_sub1(Hp)/Ks

Find out more about interpolation commands by referring to the COMSOL 
Multiphysics User’s Guide. You can use the interpolation commands with spatial data 
as well. For a model that employs these interpolation commands to map out spatially 
varying material properties, see “A Rock Fracture Flow Model” on page 283 in the 
COMSOL Multiphysics Model Library.

D A T A

The following table provides the constants and the expressions used in this model. The 
data come from the example in Ref. 2. The expressions for implementing the 
interpolation commands appear in the user-interface instructions.

VARIABLE UNIT DESCRIPTION UPPER LAYER LOWER LAYER

 Ks m/d Saturated hydraulic 
conductivity

0.298 0.454

 qs Porosity/void fraction 0.399 0.339

 qr Residual saturation 0.0001 0.0001
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The next table summarizes the parameters used in calculating the van Genuchten 
distributions for Se, K, and θ.

Results

Figure 2-37 on page 114 shows the values for K, θ, Se, and C estimated here by 
interpolation from “experimental” datasets consisting of 25 points sampled from 
analytic distributions (Ref. 1). The sets of interpolated and analytic estimates for the 
upper and the lower soil layers match closely.

 Hps m Pressure head in ring 0.01

 Hp0 m Initial pressure head -(z+1.2)* 
(z<-0.4)+ 
(-(z+1.2)- 
.2*(z+0.4))* 
(-0.4<=z)

-(z+1.2)* 
(z<-0.4)+ 
(-(z+1.2)- 
.2*(z+0.4))* 
(-0.4<=z)

VARIABLE UNITS DESCRIPTION UPPER LAYER LOWER LAYER

 Ks m/d Saturated hydraulic conductivity 0.298 0.454

 qs Porosity/void fraction 0.399 0.339

 qr Residual saturation 0.0001 0.0001

 α m-1 alpha parameter 1.74 1.39

 n n parameter 1.3757 1.6024

 m m parameter 1-1/n

 l Pore connectivity parameter 0.5 0.5

VARIABLE UNIT DESCRIPTION UPPER LAYER LOWER LAYER
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Figure 2-39: Solution for variably saturated flow simulated with properties interpolated 
from experimental data. Results shown are effective saturation (surface plot), pressure 
head (contours), and velocity (arrows) at 0.3 days.

Figure 2-40: Solution for variably saturated flow simulated with material properties 
interpolated from experimental data. Results shown are effective saturation (surface 
plot), pressure head (contours), and velocity (arrows) at 1 day.
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The two nearby figures show the solutions of variably saturated flow modeled with 
interpolated K, θ, Se, and C values at 0.25 days and 1 day. They show effective 
saturation (surface plot), pressure head (contours), and velocities (arrows). At 
day 0.25, the fluid moves primarily below the ponded region.

By the end of Day 1, the water moves deeper within the volume. Because very little 
fluid exits from the base, the soil gradually saturates upward with time. The results are 
so similar to values obtained with closed-form equations to define K, θ, Se, and C that 
this discussion does not repeat them; the curious reader should refer to “Variably 
Saturated Flow” on page 97.

Figure 2-41 is a plot of pressure heads simulated in COMSOL Multiphysics with linear 
and nearest neighbor interpolation to define K, θ, Se, and C from experimental data. 
It shows results at a selection of positions, and it also illustrates similar values for 
simulations with closed-form analytic estimates of K, θ, Se, and C. Which interpolation 
method is appropriate for a model depends on the property values and the number of 
data, among other things.

Figure 2-41: Pressure heads simulated with linear interpolation (solid lines) and analytic 
formulas (dashed lines) for retention and permeability functions. Results are for 
(x, y)-coordinates, in m, (0.2, -0.1), (0.6, -0.4), and (1.0, -0.7).
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This example demonstrates how to simulate variably saturated flow using 
fluid-retention and permeability values obtained by interpolation from experimental 
data, which you here import into COMSOL Multiphysics as a text file. Then use the 
COMSOL Multiphysics interpolation functions and the Richards’ equation 
user-definition options to parameterize the model. The user-definition options also 
allow you to enter arbitrary expressions for these properties, for example, to define 
how permeability and moisture content vary during unsaturated conditions, and 
COMSOL Multiphysics can automate finding the solution.
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Model Library path: Earth_Science_Module/Fluid_Flow/interpolation

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator. From the Space dimension list select Axial symmetry (2D).

2 From the list of application modes select Earth Science Module>Fluid Flow> 
Richards’ Equation>Pressure head analysis>Transient analysis, then click OK.

G E O M E T R Y  M O D E L I N G

Create the geometry by drawing one rectangle and adding two lines.

1 From the Draw menu select Specify Objects>Rectangle.

2 Enter the following settings; when done, click OK.

PARAMETER EXPRESSION

width 1.25

height 1.3
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3 Click the Zoom Extents button on the Main toolbar.

4 Return to the Draw menu and select Specify Objects>Rectangle.

5 Specify the following shape; when done, click OK.

6 Return to the Draw menu and select Specify Objects>Line. In the r coordinate edit 
field enter 0 0.25, and in the z coordinate edit field enter 0 0. Click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, select Constants.

2 Define the following constant that you will use later; when done, click OK.

Functions
Now set up the interpolation routines. You interpolate for six data sets. Import the data 
as files and assign a name that you use elsewhere to call for the interpolated values. In 
the data files, the Hp values are the “grid,” and the corresponding parameter values are 
the “data.” The datafiles are available once the Earth Science Module has been 
installed.

1 Choose Options>Functions. In the Defined Functions area, click the New button.

2 To define the hydraulic conductivity in Subdomain 1 (the lower layer), go to the 
Function name edit field and enter K_sub1. Select Interpolation and choose File from 
the Use data from list. Click Browse. Locate the file K_sub1.txt in Models/
Earth_Science_Module/Fluid_Flow in the COMSOL installation directory, 
then click OK.

r 0

z -1.3

PARAMETER EXPRESSION

width 1.25

height 0.4

r 0

z -0.4

NAME EXPRESSION DESCRIPTION

SPD 1[d/s] Seconds per day

PARAMETER EXPRESSION
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3 Repeat this process for the files th_sub1.txt, K_sub2.txt, and th_sub2.txt. Be 
sure to click New before starting to create each new function. After you have named 
and imported data for each function, click Apply.

4 Click OK to close the Functions dialog box.

P H Y S I C S  S E T T I N G S

Application Scalar Variables
Next, set the vertical direction and gravitational constant in the model.

1 From the Physics menu, select Scalar Variables.

2 Make the following modifications to the defaults:

Here you effectively convert the basic time unit in the model from seconds to days 
by multiplying by the gravitational acceleration measured in m/s2 by the number of 
seconds per day squared. Thus, when the user interface displays seconds, you should 
read days instead. Note that this also applies to quantities that involve the time 
dimension implicitly, such as pressure with SI unit 1 Pa = 1 kg/(m·s2).

3 Click OK.

Subdomain Settings
Set up the material properties and how the interpolation should proceed.

1 Choose Physics>Subdomain Settings. On the Coefficients page, enter the settings in 
the table below.

NAME EXPRESSION

D_esvr z

g_esvr 9.82[m/s^2]*SPD^2

TERM SUBDOMAIN 1 SUBDOMAIN 2

Constitutive relation User defined User defined

 θs 0.339 0.399

 θr 0.0001 0.0001

Storage term User defined User defined

S 1e-8 1e-8

KS 0.454 0.298

 ρf 1000 1000
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2 On the User Defined page, enter the settings in the table below. Make sure to click 
Apply after you have finished changing the values for each subdomain.

3 Click the Init tab. In the Subdomain selection list, choose both subdomains 
simultaneously. Then enter the following expression in the Initial value edit field and, 
when done, click OK.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Set the following conditions; when done, click OK.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 On the Global page, select Finer from the Predefined mesh sizes list.

3 On the Boundary page, select Boundaries 4 and 6. In the Maximum element size edit 
field, enter 0.02.

4 Select Boundary 5. In the Maximum element size edit field, enter 0.002.

5 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box.

2 In the Solver list, choose Time dependent if it is not already selected.

3 In the Times edit field, enter 0 10^(range(-3,0.1,-1)) range(0.2,0.1,1) 
range(2,10) to generate outputs at the start time 0, then 21 exponentially 

TERM SUBDOMAIN 1 SUBDOMAIN 2

 θ th_sub1(Hp_esvr[1/m]) th_sub2(Hp_esvr[1/m])

 kr K_sub1(Hp_esvr[1/m])/0.454 K_sub2(Hp_esvr[1/m])/0.298

INITIAL VALUE SUBDOMAINS 1, 2

Hp(t0) -(z+1.2)*(z<-0.4)+(-(z+1.2)-0.2*(z+0.4))*(-0.4<=z)

SETTINGS BOUNDARY 1, 3, 6–8 BOUNDARY 2 BOUNDARY 5

Boundary 
condition

Zero flux/Symmetry Inward flux Pressure head

N0 -0.454/100

Hp0 0.01
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increasing outputs between 0.001 and 0.1 days followed by 0.1-day increments 
until the end of day 1, and finally 1-day increments through day 10.

4 Set the Relative tolerance to 0.001 and the Absolute tolerance to 1e9.

5 On the Time Stepping page, select the Manual tuning of step size check box. In the 
Initial time step edit field, type 1e-10.

6 Click OK.

7 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2-39 on page 121, follow these steps:

1 From the Postprocessing menu, select Plot Parameters.

2 Click the General tab. In the Plot type area select the Surface, Contour, and Arrow 
check boxes. In the Solution at time list select 0.3.

3 Click the Surface tab. In the Expression edit field enter Se_esvr, typing over current 
information. Note that Se_esvr stands for effective saturation (Se) calculated with 
this application mode (named esvr). 

4 Click the Contour tab. From the Predefined quantities list choose Pressure head. 
Select the option button next to the Vector with isolevels label, and in the associated 
edit field enter range(-2,0.1,2). Go to the Contour color area and click the 
Uniform color option button. Click the Color button. Change the color to white, then 
click OK. Clear the Color legend check box.

5 Click the Arrow tab. In the Predefined quantities list, select Velocity field. Go to the 
Arrow positioning area, and in the Number of edit points edit fields for both r points 

and z points enter 25. Go to the Arrow parameters area, click the Color button, 
choose white, and then click OK. Clear the Auto check box, and in the associated edit 
field enter 0.5.

6 Click Apply.

To generate Figure 2-40 on page 121, click the General tab, and in the Solution at time 

list select 1. Click OK.

To generate Figure 2-41 on page 122, continue with these steps:

1 Choose Postprocessing>Cross-Section Plot Parameters. 

2 Click the Point tab. In the Predefined quantities list, select Pressure head. Go to the 
Coordinates area; in the r edit field enter 0.2 0.6 1, and in the z edit field enter 
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-0.1 -0.4 -0.7. Click OK. You should now see a window designated Figure 1; do 
not close this window.

To add results from a simulation with the van Genuchten analytic formulas proceed 
as follows:

3 Choose Physics>Subdomain Settings. On the Coefficients page, go to the Subdomain 

selection list and choose both 1 and 2. Find the Constitutive relation list and select 
van Genuchten.

4 Click the van Genuchten tab, then enter the following settings; when done, click OK.

5 Click the Solve button on the Main toolbar.

6 When the simulation is finished, return to the Postprocessing>Cross-Section Plot 

Parameters dialog box, click the General tab, and then select the Keep current plot 
check box. Go to the Plot in list and select Figure 1. Click the Point tab, click the Line 

settings button, and in the Line style list select Dashed line; click OK, then click OK.

TERM SUBDOMAIN 1 SUBDOMAIN 2

 α 1.39 1.74

 n 1.6 1.38

 l 0.5 0.5
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Two -Pha s e  F l ow

Introduction

The following example analyzes two-phase flow in porous media. Describing how 
fluids that do not mix then move simultaneously through one pore space is key to 
answering many environmental and industrial questions. Unfortunately, multiphase 
analyses are complicated by the need to solve for multiple dependent variables along 
with a variety of unknowns. Among them are hydraulic properties that depend on the 
pressure and saturation levels of each fluid phase.

This problem demonstrates two-phase flow following a U.S. Environmental 
Protection Agency experimental setup (Ref. 1). This straightforward experiment 
matches observations for a laboratory column to numerical estimates of two-phase 
flow. With these column experiments, the researchers evaluate flow for varying fluid 
pairs (air-water, air-oil, and oil-water) and then match the experimental results to those 
from computer simulations that employ analytic expressions for retention and 
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permeability. This discussion addresses their work for the Lincoln soil and use formulas 
from Mualem (Ref. 2) and van Genuchten (Ref. 3) to give hydraulic properties.

Figure 2-42: Geometry of the two-phase flow column experiments in Hopmans and others 
(Ref. 1).

This is a multipart example. The first part sets up the two-phase flow model for water 
and air; the equations solve for pressures. Saturation varies with the solution. An 
underlying assumption is that at least some residual air and water exist throughout the 
soil column at all times. The model tracks the gas front as it displaces a wetting fluid 
by observing saturation rather than assuming a discrete interface. The second part 
modifies the air-water simulation for air-oil and oil-water systems.

Model Definition

In the experimental setup for air and water, the experiment injects air over the surface 
of a laboratory column filled with water and sand. The incoming air (the nonwetting 
phase for this fluid pair) forces the water (the wetting phase) toward the outlet at the 
base of the column. At the inlet, air pressure increases by steps in time, and no water 
exits through the column top. In moving to the outlet, the water passes through a disc 
that is impermeable to air flow. Neither the air nor the water can pass through the 
vertical column walls. The water pressure at the outlet, which changes in time, 
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corresponds to the height of fluid rise in a receiving buret. The column has a total 
length of 8.34 cm, a 6-cm radius, and the disk is 0.74 cm thick. The experiment covers 
170 hours.

This discussion lays out the two-phase flow simulation in the following order. First it 
reviews the governing equations and the analytic relationships (Ref. 2 and Ref. 3) that 
define fluid retention and permeability. Next comes a few implementation details and 
a table of the model data. The results follow. Finally come step-by-step instructions to 
build the model in the graphical user interface.

G O V E R N I N G  E Q U A T I O N S  A N D  B O U N D A R Y  C O N D I T I O N S

Two-phase flow in porous media follows separate equations for the wetting (w) and 
nonwetting (nw) fluids:

 (2-4)

 (2-5)

where θs is the total porosity or saturated volume fraction; Se is effective saturation 
function; t is time (s); κint is the intrinsic permeability of the porous medium (m2); kr 
is the relative permeability function for a given fluid; η is the fluid’s dynamic viscosity 
(kg/(m·s)); p is pressure (kg/(m·s2)); ρ is the fluid density (kg/m3); g is acceleration 
of gravity; and D is the coordinate (for example, x, y, or z) of vertical elevation (m).

If the fluid distribution is continuous, neither fluid ever completely fills the soil, giving 
a volume fraction for the wetting phase, θw, and nonwetting phase, θnw, at all times. 
For the wetting phase, θ varies from zero or a small residual value θr to the total 
porosity, θs. The effective saturation, Se, comes from scaling θ with respect to θs and 
θr and so varies from 0 to 1. Both θ and Se are functions of the pressures of all fluids 
in the system. You define capillary pressure:

.  (2-6)

The pore space can be completely filled with one fluid at a given time:

.  (2-7)

How effective saturation changes with capillary pressure, therefore, is

θs
Sew∂

t∂
------------- ∇+

κintkr w,
ηw

--------------------- p∇ w ρwg D∇+( )–⋅ 0=

θs
Senw∂

t∂
----------------- ∇+

κintkr nw,
ηnw

------------------------ p∇ nw ρnwg D∇+( )–⋅ 0=

pc pnw pw–=

Sew Senw+ 1=
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 (2-8)

where C is the specific capacity, and the subscript “p” denotes units of pressure.

Using Equation 2-6, Equation 2-7, and Equation 2-8 in Equation 2-4 and 
Equation 2-5 simplifies the numerical model. The governing equations become:

 (2-9)

.  (2-10)

You can solve this system of equations simultaneously for pw and pnw. In this example, 
the two fluids are incompressible, but that need not be the case.

Initially, the water and air in the column follow hydrostatic distributions. The 
boundary conditions allow the water to exit only from the base of the soil column. For 
the wetting phase, the boundary conditions are

 (2-11)

where n is the unit vector normal to the boundary.

Because air enters at the column top but never exits, the boundary conditions for the 
nonwetting phase are

 (2-12)

Cp w, Cp nw, θs
Sew∂
pc∂

-------------=–=

Cp w, t∂
∂ pnw pw–( ) ∇+

κintkr w,
ηw

--------------------- p∇ w ρwg D∇+( )–⋅ 0=

Cp w,–
t∂

∂ pnw pw–( ) ∇+
κintkr nw,

ηnw
------------------------ p∇ nw ρnwg D∇+( )–⋅ 0=

n κ
η
--- p∇ w ρwg D∇+( )–⋅ 0= Ω Inlet∂

n κ
η
--- p∇ w ρwg D∇+( )–⋅ 0= Ω Sides∂

pw pw0 t( )= Ω Base∂

n κ
η
--- p∇ nw ρnwg D∇+( )–⋅ 0= Ω Surface∂

n κ
η
--- p∇ nw ρnwg D∇+( )–⋅ 0= Ω Sides∂

pnw pnw0 t( )= Ω Base∂
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R E T E N T I O N  A N D  P E R M E A B I L I T Y  R E L A T I O N S H I P S

You can set up this two-phase flow analysis using interpolation from experimental data, 
arbitrary mathematical formulas, and results from other equations in the model to 
define how θ, C, Se, kr, and pc vary simultaneously. The existing model uses retention 
and permeability relationships from Ref. 2 and Ref. 3 that express changes in θ, C, Se, 
and kr as a function of pc. Because pc is large and because changes in θ, C, Se, and kr 
are small, these expressions transform capillary pressure to the equivalent height of 
water or capillary pressure head as in Hc = pc/(ρwater g). The hydraulic properties 
relative to the wetting fluid are

 (2-13)

where α, n, m, and L are the van Genuchten parameters that denote soil 
characteristics. Note that with two-phase flow, the van Genuchten-Mualem formulas 
hinge on the value of Hc.

For the nonwetting fluid, the properties

θw =
θr w, Sew θs w, θr w,–( )+

θs w,
⎩
⎪
⎨
⎪
⎧

Hc 0>

Hc 0≤

Sew =

1

1 αHc
n

+[ ]
m

------------------------------------

1⎩
⎪
⎨
⎪
⎧

Hc 0>

Hc 0≤

Cw =
αm

1 m–
-------------- θs w, θr w,–( )Sew

1
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-----
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1
m
-----

–
⎝ ⎠
⎜ ⎟
⎛ ⎞

m

0⎩
⎪
⎪
⎨
⎪
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 (2-14)

arise naturally from the definitions for the wetting phase.

D I F F E R E N T  F L U I D  P A I R S

When switching between air-water, air-oil, and oil-water experiments, the authors used 
clever scaling with interfacial tensions according to Leverett (Ref. 4). The Leverett 
scaling adjusts the nonwetting phase pressure at the column top to produce the same 
volume of wetting fluid outflow at the column bottom regardless of the fluid pair. With 
Leverett scaling, switching between fluid pairs requires using the correct fluid 
properties ρ and η for the fluid pair and adjusting the boundary and initial pressures 
according to

In these equations, σ represents the interfacial tension between the different fluids, and 
the subscripts denote the fluid pair. These values appear in a table at the end of this 
section. For example, σao/σaw equals 0.373, and σwo/σaw equals 0.534; further, the 
first nonwetting phase pressure head (in meters of water) is 0.4 m for the air-water 
system, 0.1 m for the air-oil system, and 0.2 m for the water-oil system.

Because relative permeability and retention properties for a porous medium depend on 
the fluid moving through it, switching fluid pairs also requires switching the retention 
and permeability properties in the model. This requirement can mean inserting new 
experimental data or adjusting mathematical formulas. In this model, the authors 
assessed the permeability and retention parameters were assessed by curve fitting to 
analytic formulas. They adjusted the parameters α, n, κs, and θr to get the best fit for 
each fluid. A review of the data tables that follow reveals that the ratios in the α values 
for the different fluid pairs roughly equals the σ ratios just given.

θnw = θs w, θw–

Senw = 1 Sew–

Cnw = C– w

kr nw, = 1 Sew–( )L 1 Sew

1
m
-----

–
⎝ ⎠
⎜ ⎟
⎛ ⎞

m2

σaw pc aw, σaw pc aw,=

σaw pc aw, σaw pc ao,=

σaw pc aw, σaw pc ow,=
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Implementation: Numerical Differentiation to Estimate C

This example employs analytic expressions to estimate the specific moisture capacity, 
C. Because C is the slope of the curve q versus Hc, it also is possible to use the 
COMSOL Multiphysics differentiation operator pdiff to define C such as in

Cp,w(pw) = pdiff(theta_w,Hc) ρwater
−1g−1

Thus you can write arbitrary expressions or use data for θ. This equation differentiates 
fluid volume fraction with respect to capillary pressure head. Here you divide by the 
weight of water to convert the expression for use in equations with dependent variable 
pressure. The same type of syntax works with the differentiation operator diff. The 
distinction between the two operators is that diff recognizes space and time 
derivatives already defined in COMSOL Multiphysics (for example, px, py, pt), whereas 
pdiff is purely symbolic and does not apply the chain rule for dependent variables.

Implementation: Step Change on a Boundary

The following step-by-step instructions define the timing of the stepped nonwetting 
phase pressures at the inlet by using an interpolation function. Interpolating in 
COMSOL Multiphysics is straightforward. You open a dialog box in the Options 
menu, set up the table with the times and corresponding pressure heads, assign a name 
to the interpolation function, and use the name for where the function is needed, here 
in the Subdomain Settings dialog boxes. To activate the functions created, simply enter 
the function name (for example, p_nw) along with the argument, that is the time t in 
parenthesis. The command is

p_nw(t) = H_nw_t(t)*rho_water*g_w

The density of water appears in the equation because Ref. 1 defines the boundary 
pressure as a height of water.

Data

The data used in this model correspond to the air-water experiments for the Lincoln 
sand as reported in Ref. 1:

VARIABLE DESCRIPTION UNIT EXPRESSION

 gr Acceleration due to gravity m/s2 9.82

 ρfw Fluid density, water kg/m3 1000

 ηw Dynamic viscosity, water Pa·s 1·10-3
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The van Genuchten parameters for the different fluid pairs are the following:

Pressure head at the air inlet increments in time according to the table below.

At the water outlet, the fluid level in the receiving buret increases linearly in time from 
0 m to 0.1 m.

 ρfg Fluid density, gas kg/m3 1.28

 ηg Dynamic viscosity, gas Pa·s 1.81·10-5

 κint Intrinsic permeability, column m2 2.48·10-12

 κs Permeability, disc m2 1.33·10-14

 qs,w Saturated volume fraction, column 0.32

 qs,w Saturated volume fraction, disc 0.5

 pnw,top Initial nonwetting phase pressure head, inlet m water 0.2

VARIABLE DESCRIPTION UNIT AIR-WATER AIR-OIL OIL-WATER

 qr,w Residual volume fraction 0.021 0.00001 0.0072

 α alpha parameter m-1 1.89 5.29 3.58

 n n parameter, column 2.811 3.002 3.1365

 L L parameter, column 0.5 0.5 0.5

 κs Permeability, disc m-2 2.48·10-12 1.09·10-12 0.94·10-12

PRESSURE HEAD (m water) START TIME (hours)

0.4 0

0.6 21.25

0.8 45.25

1.0 69

1.5 93

2 122.5

4 155

VARIABLE DESCRIPTION UNIT EXPRESSION
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Results and Discussion

Figure 2-43 shows an early-time snapshot from the COMSOL Multiphysics solution 
for two-phase flow in a laboratory column. The shading depicts the effective saturation 
of the nonwetting phase (air), while the arrows give the wetting phase (water) 
velocities.

Figure 2-43: Solution to two-phase flow model at 0.1 hours: nonwetting phase saturation 
(surface plot), wetting-phase velocities (arrows). Results correspond to air-water 
experiment on Lincoln soil from the US EPA (Ref. 1).

The image illustrates the nonwetting fluid entering the soil column and displacing the 
wetting fluid. The nonwetting phase enters because it is being forced into the inlet 
with a multistep pressure change.

Figure 2-44 shows the stepped pressure head used at the inlet boundary along with the 
capillary pressure in the column at various elevations. Specifying the point locations 
during postprocessing circumvents the need to plan observation sites during input. 
The solution to the two-phase flow problem provided is an excellent match to the 
results of Ref. 1.

That the capillary pressure head and the air inlet pressure in Figure 2-44 track together 
is what made the laboratory setup successful. To get high resolution on the 
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permeability and retention behaviors, the authors in Ref. 1 set the pressure steps large 
enough that the impact is instantaneous in the soil column. As shown in Figure 2-45, 
the permeability changes instantaneously throughout the column.

Figure 2-44: Inlet air pressure head (solid line) and capillary pressure head (dashed lines) 
for air-water flow in Lincoln soil (taken from the US EPA, Ref. 1).
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Figure 2-45: Permeability functions for water (solid lines) and air (dashed lines) for 
Lincoln soil at x = 0.03 m (taken from the US EPA, Ref. 1).
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Solutions for two-phase flow for the air-oil and oil-water systems appear in Figure 2-46 
and Figure 2-47, respectively.

Figure 2-46: Inlet-air pressure head (solid line) and capillary pressure head (dashed lines) 
for air-oil flow in Lincoln soil (taken from the US EPA, Ref. 1).
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Figure 2-47: Inlet-air pressure head (solid line) and capillary pressure head (dashed lines) 
for oil-water flow in Lincoln soil (taken from the US EPA, Ref. 1).

The COMSOL Multiphysics results for the air-oil and oil-water two-phase flow 
problems prove to be excellent matches to the results shown in Ref. 1. Through 
Leverett scaling you set the inlet pressure so that the air-oil and oil-water systems 
would produce the volume outflow rate from the air-water experiment. As with the 
air-water system, the capillary pressure head and air-inlet pressure for the air-oil 
experiment track instantaneously. For the water-oil system, however, there is a lag 
between the nonwetting and wetting phase pressures.
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Model Library path: Earth_Science_Module/Fluid_Flow/
twophase_flow_air_water

Modeling Using the Graphical User Interface: Air-Water System

M O D E L  N A V I G A T O R

1 Open the Model Navigator to the New page, and in the Space dimension list select 2D.

2 From the list of application modes select 
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis>Transient analysis.

3 In the Dependent variables edit field enter p_w, and in the Application mode name edit 
field enter w. 

4 Click the Multiphysics button, then click Add.

5 In the list of application modes once again select 
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis>Transient analysis.

6 Repeating the procedure you just followed, change the Dependent variables to p_nw 
and the Application mode name to nw. Click the Multiphysics button, then click Add.

7 Click OK.

G E O M E T R Y  M O D E L I N G

Create the geometry by drawing two rectangles.

1 From the Draw menu select Specify Objects>Rectangle.

2 Enter the following settings; when done, click OK.

PARAMETER VALUE

Width 0.06

Height 0.0074

x 0

z 0
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3 Repeat that process except with these settings:

4 Click the Zoom Extents button on the Main toolbar.

O P T I O N S

1 Choose Options>Constants.

2 Enter the following names, expressions, and descriptions (optional); when done, 
click OK.

3 From the Options menu select Expressions>Scalar Expressions. Enter the following 
names and expressions (they go all on one line); when done, click OK.

PARAMETER VALUE

Width 0.06

Height 0.0834

x 0

z 0

NAME EXPRESSION DESCRIPTION

SPH 1[h/s] Seconds per hour

rho_water 1000[kg/m^3] Density, water

rho_w 1000[kg/m^3] Density, wetting fluid

etaw 0.001[Pa*s]*SPH Dynamic viscosity, wetting fluid

rho_nw 1.28[kg/m^3] Density, nonwetting fluid

etanw 0.0000181[Pa*s]*SPH Dynamic viscosity, nonwetting fluid

NAME EXPRESSION

p_nw_top 0.2[m]*rho_water*g_nw

p_nw_init p_nw_top+(8.34[cm]-y)*rho_nw*g_nw

p_w_init -rho_w*g_w*y

p_w0 0.1[m]*rho_water*g_w*(t/170[s])

Hc (p_nw-p_w)/(rho_water*g_w)

Se_w (1+abs(alpha*Hc)^N)^(-M)*(Hc>0)+1*(Hc<=0)

theta_w (theta_r+Se_w*(theta_s-theta_r))*(Hc>0)+theta_s*(Hc<=0)

kr_w ((Se_w^L*(1-(1-Se_w^(1/M))^M)^2)+eps)*(Hc>0)+1*(Hc<=0)

Cp ((alpha*M/(1-M)*(theta_s-theta_r)*Se_w^(1/M)* 
(1-Se_w^(1/M))^M))/(rho_water*g_w)*(Hc>0)

Se_nw 1-Se_w
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4 From the Options menu select Expressions>Subdomain Expressions. Enter the 
following names and expressions for the two subdomains; when done, click OK.

Now set up the stepped pressures for the nonwetting phase boundary using 
interpolation.

5 From the Options menu, select Functions.

6 Click the New button.

7 In the Function name edit field enter Hp_nw_t and choose the option Interpolation.

8 Click OK.

9 Enter the following values in the table; when finished, click OK.

theta_nw theta_s-theta_w

kr_nw ((1-Se_w)^L*(1-Se_w^(1/M))^(2*M))*(Hc>0)+eps

NAME SUBDOMAIN 1 SUBDOMAIN 2

theta_s 0.5 0.32

theta_r 0.0211

kap_s 1.34e-14 2.48e-12

alpha 1.89

N 2.811

M 1-1/N

L 0.5

X Y

0 0.4

21.20 0.4

21.25 0.6

45.20 0.6

45.25 0.8

68.95 0.8

69 1.0

92.95 1.0

93 1.5

122.45 1.5

122.5 2

154.95 2

NAME EXPRESSION
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P H Y S I C S

In the following stage you first set up the material properties, initial conditions, and 
boundary conditions for each phase, then link the two equations.

Application Scalar Variables
To set the vertical direction and gravitational constant in the model, go to the Physics 
menu and select Scalar Variables. Make the following modifications to the defaults; 
when done, click OK.

This step converts the basic time unit in the model from seconds to hours. Thus, 
whenever the time unit second appears in the user interface—either explicitly, as in m/
s, or implicitly, as in Pa (= kg/(m·s2))—read hour instead.

Subdomain Settings—Wetting Phase
1 From the Multiphysics menu select Darcy’s Law (w).

2 From the Physics menu select Subdomain Settings. Enter the following settings, then 
click Apply.

3 Click the Init tab. Select Subdomains 1 and 2 simultaneously, and in the p_w(t0) edit 
field for Pressure enter p_w_init. Click OK.

155 4

200 4

NAME EXPRESSION

D_w y

g_w 9.82[m/s^2]*SPH^2

D_nw y

g_nw 9.82[m/s^2]*SPH^2

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

 Storage term User defined User defined

 S 0 Cp

 kS kap_s kap_s*kr_w

 ρf rho_w rho_w

 η etaw etaw

X Y
TW O - P H A S E  F L O W  |  145



146 |  C H A P T E R
Boundary Conditions—Wetting Phase
From Physics choose Boundary Settings, then set the following conditions; when done, 
click OK.

Subdomain Settings—Nonwetting Phase
1 From the Multiphysics menu select Darcy’s Law (nw).

2 From the Physics menu select Subdomain Settings. In the Subdomain selection list 
choose 1, then clear the Active in this domain check box.

3 Select Subdomain 2. Enter the following settings.

4 Click the Init tab. Select both Subdomains 1 and 2 simultaneously, and in the 
p_nw(t0) edit field for Pressure enter p_nw_init. Click OK.

Boundary Conditions—Nonwetting Phase
1 From the Physics menu, choose Boundary Settings.

2 Set the following conditions; when done, click OK.

Equation Systems
1 From the Physics menu, select Equation System>Subdomain Settings.

With the information in this dialog box, COMSOL Multiphysics transforms the 
inputs you enter to coefficients it uses to solve the finite element model. The box 
contains entries for each type of model domain: subdomains, boundaries, and points 
in a 2D problem.

SETTINGS BOUNDARY 2 BOUNDARIES 1, 3, 5–7

Boundary condition Pressure Zero flux/Symmetry

p0 p_w0

SETTINGS SUBDOMAIN 2

 Storage term User defined

 S Cp

 κS kap_s*kr_nw

 ρf rho_nw

 η etanw

SETTINGS BOUNDARIES 3, 4, 7 BOUNDARY 5

Boundary condition Zero flux/Symmetry Pressure

p0 Hp_nw_t(t)*rho_water*g_nw
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2 Click the da tab. Here is where the coefficients that are multiplied by the time rate 
of change in pressure appear. The 4-element matrix originally has entries on the 
diagonal: one for the wetting-phase pressure, pw, for the wetting phase equation; 
and one for nonwetting phase pressure, pnw, for the nonwetting phase equation. 
Because the two-phase problem has storage terms for both nonwetting and wetting 
phases in each equation, you fill in the matrix with the appropriate terms. Modify 
the matrix so it reads as follows:

Note that eps is a very small number.

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters. 

2 Click the Boundary tab. Using the Ctrl key select both Boundaries 4 and 5. In the 
Maximum element size edit field enter 0.001.

3 Select Boundary 2, and in the Maximum element size edit field enter 0.005.

4 Click the Remesh button, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box. In the Solver list select 
Time dependent (if it is not already selected).

2 In the Times edit field, enter range(0,0.01,0.1) range(0.2,0.1,1) 
range(2,170). Click OK.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2-43, follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 In the Plot type area, select the Surface and Arrow check boxes. In the Solution at time 
list choose 0.1.

3 Click the Surface tab, and in the Expression edit field enter Se_nw, which stands for 
effective saturation (Se) calculated with the application mode named nw.

PW PNW

Cp+eps -Cp+eps

-Cp+eps Cp+eps
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4 Click the Arrow tab. In the Predefined quantities list select 
Darcy’s Law (w)>Velocity field. Go to the Arrow positioning area. In the Number of 

points column, and in both the x points and y points edit fields enter 25. Go to the 
Arrow parameters area. Click the Color button, change the color to black, and click 
OK. Clear the Auto check box, and in the Scale factor edit field enter 0.5.

5 Click OK.

To generate the plot in Figure 2-44, continue with these steps:

1 From the Postprocessing menu, open the Cross-Section Plot Parameters dialog box.

2 Click the Point tab. In the Expression edit field, enter Hc. In the Coordinates section, 
in the x edit field enter 0.03 0.03 0.03, and in the y edit field enter 0.02 0.04 
0.06.

3 Click the Line Settings button. Set the Line style to Dashed line, then click OK.

4 Click Apply.

5 In the Expression edit field, type p_nw/(rho_water*g_nw). In the Coordinates area, 
in the x edit field enter 0.03, and in the y edit field enter 0.0834.

6 Click the Line Settings button. Set the Line style to Solid line, then click OK.

7 Click the General tab. Select the Keep current plot check box, then click Apply.

To generate the plot in Figure 2-45, continue with these steps:

1 Still on the General page, select New figure from the Plot in list.

2 Click the Point tab. In the Expression edit field enter kr_nw.

3 In the Coordinates section, in the x edit field enter 0.03 0.03 0.03, and in the y 
edit field enter 0.02 0.04 0.06.

4 Click the Line Settings button. Set the Line style to Dashed line, then click OK.

5 Click Apply.

6 In the Expression edit field, enter kr_w.

7 Click the Line Settings button. Set the Line style to Solid line, then click OK.

8 Click the General tab. Select the Keep current plot check box, then click OK.

Two-Phase Flow: Switching Fluid Pairs

This is the second part of the two-phase flow example. Here you modify the air-water 
model file created in the first part of this example to simulate two-phase flow for the 
air-oil and oil-water systems discussed in Ref. 1. In the air-oil system, oil is the wetting 
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phase and air is the nonwetting phase. In the oil-water system, water is the wetting 
phase.

Switching from the air-water system to the air-oil or oil-water systems requires 
changing the fluid properties and several porous-media parameters. To get the 
different fluid pairs to produce wetting-phase outflow rates that are similar to those 
produced with the air-water simulation, you scale the pressure increments at the inlet 
by interfacial tensions as discussed earlier.

Model Library path: Earth_Science_Module/Fluid_Flow/
twophase_flow_air_oil

Model Library path: Earth_Science_Module/Fluid_Flow/
twophase_flow_oil_water

Modeling Using the Graphical User Interface:  
Air-Oil and Oil-Water

In the following section you open the file twophase_flow_air_water.mph and 
modify it for the air-oil and oil-water systems. The following tables and instructions 
describe the changes needed to simulate both two-phase systems.

M O D E L  N A V I G A T O R

1 Open the Model Navigator and click the Model Library tab.

2 In the list of library models select Earth Science Module>Fluid 

Flow>twophase flow air water.

3 Click OK.
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O P T I O N S

1 From the Options menu, open the Constants dialog box. Modify the entries for 
density, viscosity, and add interfacial tensions as in the following table; when done, 
click OK.

2 Choose Options>Expressions>Scalar Expressions.

3 Modify the following expressions; when done, click OK.

4 Choose Options>Expressions>Subdomain Expressions.

5 In the Subdomain selection list, choose 2.

6 Change the values for the following expressions; when done, click OK.

P H Y S I C S — N O N W E T T I N G

From the Multiphysics menu, select Darcy’s law (nw).

Boundary Conditions—Nonwetting Phase
1 From the Physics menu, select Boundary Settings.

2 In the Boundary selection list choose 5.

CONSTANT AIR-OIL OIL-WATER

rho_w 800[kg/m^3] 1000[kg/m^3]

etaw 0.00392[Pa*s]*SPH 0.001[Pa*s]*SPH

rho_nw 1.28[kg/m^3] 800[kg/m^3]

etanw 0.0000181[Pa*s]*SPH 0.00392[Pa*s]*SPH

sigma_ao 0.0259

sigma_aw 0.0681 0.0681

sigma_ow 0.0364

TERM AIR-OIL OIL-WATER

p_nw_top 0.2[m]*rho_water*g_nw* 
sigma_ao/sigma_aw

0.2[m]*rho_water*g_nw* 
sigma_ow/sigma_aw

p_w0 0.1[m]*rho_w*g_w*(sigma_ao/ 
sigma_aw)*(t/170[s])

0.1[m]*rho_w*g_w*(sigma_ow/
sigma_aw)*(t/170[s])

NAME EXPRESSION

kap_s 0.94e-12

theta_r 0.0072

alpha 3.58

N 3.1365
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3 Set the following conditions; when done, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 From the Solve menu, open the Solver Parameters dialog box.

2 In the Solver list, select Time dependent (if it is not already selected).

3 Go to the Time stepping area. In the Times edit field, enter 
range(0,0.01,0.1) range(0.2,0.1,1) range(2,170). Click OK.

4 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plots in Figure 2-46 and Figure 2-47, repeat the steps described for 
Figure 2-44.

BOUNDARY CONDITION VARIABLE EXPRESSION

Pressure  
(for Air/Oil model)

p0 Hp_nw_t(t)*rho_water* 
g_nw*sigma_ao/sigma_aw

Pressure  
(for Oil/Water model)

p0 Hp_nw_t(t)*rho_water* 
g_nw*sigma_ow/sigma_aw
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Aqu i f e r  Cha r a c t e r i z a t i o n 1

Introduction

This model illustrates how you can use COMSOL Multiphysics’ Optimization 
application mode in combination with a PDE or physics application mode to solve 
inverse-modeling problems (sometimes referred to as parameter-estimation or 
history-matching problems). The modeling techniques presented here in the context 
of flow in an aquifer with spatially variable hydraulic conductivity are generally 
applicable for solving underdetermined optimization problems with COMSOL 
Multiphysics.

Note: This model requires the Optimization Lab.

I N V E R S E - M O D E L I N G  B A C K G R O U N D

Consider data consisting of the following components:

• a model—for example, a PDE—of a natural or engineered system with a set of 
unknown coefficients or parameters

• a set of measurements or observations with associated measurement errors.

Inverse modeling is the practice of using data of this kind as input to estimate the 
unknown parameters of the model, which in this context is called the forward model. 
In particular, if the number of unknown parameters, n, is larger than the number of 
measurement values, m, the inverse problem is called underdetermined. The model in 
the present example belongs to this class of inverse problems.

When, as in this case, the forward model is a PDE and the unknown coefficient is a 
spatially varying field, the number of unknown parameters is infinite. Even an ordinary 
finite element discretization typically gives too many unknown parameters by some 
orders of magnitude. Obtaining a tractable problem that can be solved numerically 
instead requires a separate regularization.

For underdetermined inverse problems, data fitting alone is not sufficient to single out 
an optimal solution; achieving this aim requires some additional criterion and an 

1. The formulation of this model is courtesy of Mr. Michael A. Cardiff and Prof. Peter K. Kitanidis of Stanford 
University, who have kindly made their own model version available (Ref. 1).
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associated penalty function that ranks the solutions according how well they satisfy the 
criterion in question.

The objective function for an underdetermined inverse problem can thus be written as 
the sum of a fitness term and a penalty term:

 (2-15)

The fitness term

 (2-16)

measures how well the model fits with the observations. Here y denotes an 
m-dimensional row vector of measurement values; s is an n-dimensional row vector of 
parameter values; h: Rn → Rm is the forward model, which maps from parameter 
values to expected measurements; and R is the m-by-m covariance matrix of 
measurement errors. Assuming, for the purpose of this model, that the measurement 
errors are independent and identically distributed with variance σR

2, it follows that 
R = σR

2I, where I denotes the m-by-m identity matrix.

The penalty term is relevant for problems where the number of parameters, n, exceeds 
the number of measurement values, m. It serves to discriminate between solutions 
with comparable fitness values. Through geostatistical reasoning, Kitanidis (Ref. 2) 
arrives at the penalty term

 (2-17)

where Q−1 is the inverse of the spatial covariance matrix Q ≡ E[(s − Xβ)(s − Xβ)T], 
with E[ ] denoting the expectation value, X being an n-dimensional row vector whose 
elements all equal 1, and β referring to the scalar constant mean of the parameter field.

By averaging over β, it is possible to eliminate this unknown parameter from the 
penalty function (Ref. 2). This procedure results in the equivalent penalty function

 (2-18)

which is the one used in Ref. 1, and also the one you will implement in this model. In 
practical applications, it has the advantage over the penalty function in Equation 2-17 
of not requiring estimates of β during the optimization.

L y s,( ) Lfitness y s,( ) Lpenalty s( )+=

Lfitness y s,( ) y h s( )–( )TR 1– y h s( )–( )=

Lpenalty s Xβ–( )TQ 1– s Xβ–( )=

Lpenalty sTGs,= G Q 1– Q 1– XXTQ 1–

XTQ
1–
X

---------------------------------–≡
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Model Definition

F O R W A R D  M O D E L

Consider a square zone in a confined 2D aquifer of side b = 100 m and with spatially 
variable hydraulic conductivity, Ks (m/s), which is of interest for transport modeling 
or other purposes. In a simple model, assume that the area outside of this zone is an 
area of large extent known to have roughly constant hydraulic conductivity, Ks0. 
Neglecting any differences in elevation, the hydraulic potential governing the flow 
through the aquifer and its surroundings can be represented by the pressure head 
H ≡ p/(ρf g) (m), where p is the fluid pressure (Pa), ρf (kg/m3) is the (constant) fluid 
density, and g (m/s2) is the acceleration due to gravity. The pressure head, or the 
hydraulic head, obeys Darcy’s Law

where Qs (1/s) represents sources and sinks. At the modeling domain’s boundary, 
assumed to be a square of side a = 12,000 m, any effects of spatial inhomogeneities are 
negligible and you specify the condition H = 0 to complete the forward model. Note 
that this choice implies that the variable H in this model refers to the change in 
hydraulic head from a reference state where no pumping occurs rather than the 
hydraulic head itself.

I N V E R S E  M O D E L

The inverse problem you solve in this model is to estimate the hydraulic-conductivity 
field in the aquifer using experimental data in the form of hydraulic-head 
measurements from four dipole-pump tests. More specifically, consider eight wells 
(represented as points) at the corners and midpoints of the zone being characterized. 
While injecting fluid at one point, fluid is extracted at the same rate at the opposite 
point on the rim across the aquifer, and the hydraulic-head values at the six remaining 
points are recorded. Repeating this procedure for the other three cross-aquifer point 
pairs, gives a total of 4 sets of 6 observations each. The hydraulic-head measurements 
are assumed to be independent and have an accuracy on the order of ∆H = 1 cm , 
resulting in the fitness term (see Equation 2-16)

 (2-19)

To make use of the experimental data, you must reduce the infinite number of degrees 
of freedom in the hydraulic-conductivity field to a finite number of unknown 

∇ K– s H∇( )⋅ Qs=

Lfitness
y h s( )–

2

H2∆
-----------------------------=
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parameters. To this end, decompose the quadratic aquifer domain into a 10-by-10 grid 
of squares of side c = 10 m, and assume that the hydraulic conductivity takes a constant 
value in each square. The number of parameters characterizing the aquifer is then 100, 
which gives a well-defined underdetermined inverse model that can be solved quickly 
as an example problem.

A common assumption in the geological sciences is that spatially distributed 
parameters follow a geostatistical distribution defined by some variogram. Thus, for 
the penalty term, Equation 2-18, choose the elements of the covariance matrix Q as

 (2-20)

where γ(h) = σ2(1 − e−h/l) is an exponential variogram with variance σ2 = 1 (the sill 
parameter) and correlation length l = 50 m (the range). Furthermore, xi represents 
the centroid of the square affected by the parameter si. For the purpose of this model, 
assume that the parameters σ and l are known; Kitanidis (Ref. 2) gives methods for 
estimating their values in the case where they are unknown.

In Figure 2-48, the eight points on the rim of the area being characterized are 
numbered pairwise as 1±, 2±, 3±, 4±, with plus and minus signs denoting injection 
wells and pumping wells, respectively. The squares in the grid are indexed from 1 to 
100 in an order determined by the internal mesh-element numbering in COMSOL 

Qij 2γ xi xj–( ),= i j, 1 … n, , =100=
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Multiphysics. You can access and inspect this numbering using the meshelement 
variable.

Figure 2-48: Discretization of the hydraulic-conductivity parameter field. Each 
10 m-by-10 m square zone is associated with a degree of freedom encoding the constant 
log10 Ksvalue in the zone. The numbers in blue, outside the square grid, are labels for the 
dipole-pump pairs (“+” for injection wells and “-” for pumping wells).

M O D E L  D A T A

The data required for setting up the model are supplied in text files included in your 
COMSOL installation:

• A text file with reference synthetically generated field data, containing the log10 
values of the regularized hydraulic-conductivity parameter field that is used to 
generate fictitious hydraulic-head measurements. This allows you to evaluate the 
optimization solver’s performance and accuracy, and to test and calibrate the inverse 
model. For example, you can try out different penalty terms in the objective 
function and investigate the solution’s dependence on the number of observations 
used.

The log10 Ks field for the reference model is visualized in Figure 2-49. It was 
generated with the exponential variogram, γ, used to define the covariance 
matrix 2-20.

1+

1-

2+ 2-

3+

3-4+

4-
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• Four text files contain the hydraulic-head measurement data series. These data sets 
were generated by solving the reference forward model for the four different 
dipole-pump configurations.

• The elements of the matrix G that appears in the penalty term (see Equation 2-18) 
are supplied in a text file.

• Because each parameter value is associated with a subdomain in the model 
geometry, calls of the G matrix data file are made through an intermediate 1-to-1 
map associating subdomain numbers (as determined by the software’s internal 
ordering) with parameter indices in the range 1, …, 100. This map is supplied in a 
separate text file.

Figure 2-49: Discretized hydraulic-conductivity field for the reference forward model.

The four simulated dipole-pump tests for the reference forward model give the 
combined results listed in Table 2-3, here rounded off to the nearest millimeter; the 
model uses these numbers as fictitious measurement values.

TABLE 2-3:  HYDRAULIC HEAD (METERS) MEASURED AT WELLS FOR THE FOUR DIPOLE PUMP TESTS

TEST 1+ 1- 2+ 2- 3+ 3- 4+ 4-

1 - -  1.425 -0.718 -0.028  0.333  1.197 -1.330

2  0.568 -1.576 - -  1.425 -1.176 -0.641 -0.689
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Although the normalization of the fitness term (see Equation 2-19) assumes a 
measurement accuracy of 1 cm, this model (in contrast to Ref. 1) adds no random 
error component to the above data. This is because the primary aim here is to 
investigate the software’s performance rather than the viability of the method for 
aquifer characterization.

Results and Discussion

Figure 2-50 and Figure 2-51 on page 159 show the optimization results for the 
hydraulic conductivity obtained using only the first measurement series and all four 
measurement series, respectively. The corresponding values of the total mean square 
error are 0.3416 (0.316) and 0.0864 (0.087), where the values in parentheses are 
those obtained by Cardiff and Kitanidis (Ref. 1). Note that the error estimates are 
slightly different because Cardiff and Kitanidis include a synthetic measurement error 
of the order 1% in their observations.Figure 2-52 on page 160 compares the results 
from four different inverse-modeling simulations, using 1, 2, 3, and 4 measurement 
series, respectively. As the figure shows, the improvement in accuracy is most marked 
when going from 1 to 2 pump tests (that is, from 6 to 12 observations). Including 
additional measurements appears to yield comparatively small benefits in accuracy. 
However, ass discussed in Ref. 2, the posterior uncertainty in parameter estimates 
decreases as more measurements are added.

3 -0.801 -0.439  1.187 -1.414 - - -1.565  0.958

4  1.636 -0.891  0.501  0.453 -1.272  1.251 - -

TABLE 2-3:  HYDRAULIC HEAD (METERS) MEASURED AT WELLS FOR THE FOUR DIPOLE PUMP TESTS

TEST 1+ 1- 2+ 2- 3+ 3- 4+ 4-
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Figure 2-50: Inverse-modeling solution for the hydraulic conductivity logarithm 
parameter field obtained using only the first measurement series (dipole pair number 1).

Figure 2-51: Hydraulic conductivity obtained by inverse modeling using 24 observations.
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Figure 2-52: Inverse-modeling results for the hydraulic conductivity field with different 
numbers of hydraulic-head observations taken into account: 6 (upper left), 12 (upper 
right), 18 (lower left), and 24 (lower right). For a color-scale legend, see Figure 2-49.
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Model Library path: Earth_Science_Module/Fluid_Flow/
aquifer_characterization
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator.

2 From the Space dimension list, select 2D.

3 In the Application Modes tree, select Earth Science Module>Fluid Flow>Darcy’s 

Law>Hydraulic head analysis. Click the Multiphysics button, then click Add.

4 Click the Add Geometry button. In the dialog box that opens, click OK to accept the 
default settings, which gives a second 2D geometry labeled Geom2.

5 In the Application Modes tree, select 
COMSOL Multiphysics>Optimization and Sensitivity>Optimization.

6 Click Add, then click OK.

G E O M E T R Y  M O D E L I N G

First create the geometry for the forward model, which consists of the square aquifer 
domain of side 100 m and an outer domain of side 12,000 m.

1 Click the Geom1 tab above the drawing area to place the primary geometry in focus.

2 Shift-click the Point button in the Draw toolbar to open the Point dialog box.

3 In the Coordinates area, set x to -50 and y to 0, then click OK.

4 Repeat Steps 2 and 3 to add three more points at the following coordinates:

5 Click the Zoom Extents button on the Main toolbar.

6 Shift-click the Rectangle/Square (Centered) button on the Draw toolbar.

7 In the Square dialog box, type 100 in the Width edit field and select Center from the 
Base list. Click OK.

8 Repeat Steps 6 and 7 to add a second square, but this time set the Width to 12000.

SETTINGS PT 2 PT 3 PT 4

x 0 0 50

y -50 50 0
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The primary geometry is now complete, and the view in the drawing area should look 
like that in the following figure:

The forward-model geometry.

Next, create the auxiliary geometry on which the Optimization application mode is 
defined. This geometry is a copy of the aquifer domain, except that you do not need 
to include vertices at the positions of the sources and sinks.

1 Click the Geom2 tab.

2 Shift-click the Rectangle/Square (Centered) button on the Draw toolbar.

3 In the Square dialog box, type 100 in the Width edit field and select Center from the 
Base list. Click OK.

4 Click the Zoom Extents button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, choose Constants.

2 Specify the following constants; when done, click OK.

NAME EXPRESSION DESCRIPTION

N0 1e-4[m^2/s] Hydraulic head point-source strength

deltaH 0.01[m] Hydraulic head measurement error

logKs0 -5 Hydraulic conductivity, initial log10 value

th 1 Measurement-series index
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Functions
As already mentioned, defining the model requires a number of external data files:

• The hydraulic-head measurement data series are stored in four text files included in 
your COMSOL installation.

• A text file with the forward-model data for the log-transmittivity parameter field is 
provided to allow you to evaluate the optimization solver’s performance and 
accuracy, and to test and calibrate the inverse model. For example, you can try out 
different penalty terms in the objective function and investigate the solution’s 
dependence on the number of observations used.

• The elements of the matrix G that appears in the penalty term (see Equation 2-17) 
are supplied in a text file. Alternatively, if you have a MATLAB license, you can run 
a script that generates the G matrix elements for the current mesh in the auxiliary 
geometry, and then import the result from the MATLAB workspace. This method 
is described in detail later; it has the advantages of being both flexible and general, 
making it easy to adapt and apply to your own inverse-modeling problems and to 
experiment with different meshes.

To make the data available in the COMSOL Multiphysics user interface, create a 
number of interpolation functions in the following way:

1 From the Options menu, open the Functions dialog box.

2 Click the New button to open the New Function dialog box.

3 In the Function name edit field, type H_obs1.

4 Click the Interpolation button, then select File from the Use data from list.

5 Click the Browse button.

6 In the Open Data dialog box, navigate to the directory models/
Earth_Science_Module/Fluid_Flow in your COMSOL installation root 
directory. Select the file aquifer_characterization_H_obs1.txt, then click 
Open.

7 Optionally, select the Store data in model check box. This setting has the advantage 
of making the model MPH-file self-contained. The drawback is that you need to 
recreate the function if you modify the function data.

8 Click OK to close the New Function dialog box and return to the Functions dialog box.

9 From the Interpolation method list, select Nearest neighbor.

10 From the Extrapolation method list, select Specific number. In the Value outside range 
edit field, type 0.
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11 Repeat Steps 2–10 for the function names and data files in the following table; if you 
want to generate it in MATLAB you can skip G at this stage.

12 Repeat Steps 2–10 also for the following function except in Step 10 choose Constant 
as Extrapolation method:

13 Click OK to close the Functions dialog box.

Proceed with defining Lfitness, the fitness part of the objective function.

Point Expressions—Geometry 1
1 If it is not already selected, click the Geom1 tab to activate the forward-model 

geometry.

2 Choose Options>Expressions>Point Expressions.

3 Specify expressions for the hydraulic-head measurements and their associated 
contributions to the fitness function according to the following table. Note that you 
must write each named expression on a separate line.

Integration Coupling Variables—Geometry 1
1 Choose Options>Integration Coupling Variables>Point Variables.

FUNCTION NAME FILE NAME

H_obs2 aquifer_characterization_H_obs2.txt

H_obs3 aquifer_characterization_H_obs3.txt

H_obs4 aquifer_characterization_H_obs4.txt

G aquifer_characterization_G.txt

FUNCTION NAME FILE NAME

logKs_ref aquifer_characterization_logKs_ref.txt

POINT SELECTION NAME EXPRESSION

4–9 H_obs1 H_obs1(x,y)

q_fitness1 (H_obs1-H_esdl)^2/deltaH^2

3, 5–8, 10 H_obs2 H_obs2(x,y)

q_fitness2 (H_obs2-H_esdl)^2/deltaH^2

3, 4, 6, 7, 9, 10 H_obs3 H_obs3(x,y)

q_fitness3 (H_obs3-H_esdl)^2/deltaH^2

3–5, 8–10 H_obs4 H_obs4(x,y)

q_fitness4 (H_obs4-H_esdl)^2/deltaH^2
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2 Define an integral (that is, a sum) for the fitness function with the Name L_fitness, 
and with contributions from the measurements at the wells according to the 
following table. Note that all entries in the Expression column go on the same line.

The Boolean expressions ensure that each term is counted only once when the 
parametric solver sums over the measurement series parameter th.

Next turn to the objective function’s penalty part, Lpenalty, which is evaluated on the 
auxiliary geometry.

Subdomain Expressions—Geometry 2
1 Click the Geom2 tab, then choose Options>Expressions>Subdomain Expressions.

2 Select Subdomain 1, then define an expression for the reference forward model 
parameter field according to the following table; when done, click OK.

Integration Coupling Variables—Geometry 2
1 Choose Options>Integration Coupling Variables>Subdomain Variables.

2 Select Subdomain 1, then define integration coupling variables according to the 
table below; in all cases, set the Integration order to 0 (the expressions are constant).

Here, A_aquifer is the area of the aquifer domain, and the acronym MSE stands 
for mean square error.

The last two integrals together evaluate the penalty function Lpenalty = −sTGs in 
two steps. In the first step, G_times_s implements the matrix operation Gs. The 

POINT 
SELECTION

EXPRESSION

3, 10 q_fitness2*(th==2)+q_fitness3*(th==3)+q_fitness4*(th==4)

4, 9 q_fitness1*(th==1)+q_fitness3*(th==3)+q_fitness4*(th==4)

5, 8 q_fitness1*(th==1)+q_fitness2*(th==2)+q_fitness4*(th==4)

6, 7 q_fitness1*(th==1)+q_fitness2*(th==2)+q_fitness3*(th==3)

NAME EXPRESSION

logKs_ref logKs_ref(x,y)

NAME EXPRESSION

A_aquifer 1

MSE (logKs-logKs_ref)^2/A_aquifer

G_times_s G(dest(meshelement),meshelement)*logKs/dvol

L_penalty if(th==1,-logKs*G_times_s/dvol,0)
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dest operator in the expression for this variable instructs the software to evaluate 
the enclosed argument on the destination side. This makes G_times_s an 
expression defined on the auxiliary geometry, rather than a globally defined scalar. 
To implement this restriction, change the destination for G_times_s as follows:

3 Clear the Global destination check box for G_times_s, then click the Destination tab.

4 On the Destination page, select Geom2 from the Geometry list and Subdomain from 
the Level list, then select the Use selected subdomains as destination check box.

Also appearing in the expression for G_times_s, meshelement is a predefined 
variable for the mesh-element number; it is used here because the software’s internal 
numbering of the mesh elements is ideal for indexing the parameter values in the 
vector s, that is, the degrees of freedom for the design variable logKs.

Dividing by the predefined variable dvol is necessary to cancel the mesh-element 
area resulting from the integration; more specifically, dvol is the volume scale factor 
that the software uses internally when mapping between dimensionless local 
element coordinates and the model geometry’s global coordinate system shown in 
the user interface. The mesh-element volume in the local element coordinate system 
multiplied by dvol therefore gives the mesh-element volume in the global 
coordinates. In 2D, the mesh-element area in element coordinates is 1 for 
quadrilateral meshes and 1/2 for triangular meshes. Thus, for a triangular mesh in 
the auxiliary geometry, the correct area expression would be dvol/2.

Finally, in the expression for L_penalty, the if command ensures that this term 
gets the correct weight in the total objective function by calculating it only once also 
when the measurement-series parameter th runs over more than one value. Note 
that if you perform an optimization that does not include the first measurement 
series, you need to modify the measurement index in this factor.

5 Click OK to close the Subdomain Integration Variables dialog box.

Extrusion Coupling Variables
Use a subdomain extrusion coupling variable to connect the design variable on the 
auxiliary geometry that you shortly will define with the forward model.

1 With the auxiliary geometry (Geom2) active, choose 
Options>Extrusion Coupling Variables>Subdomain Variables.

2 On the Source page, select Subdomain 1.

3 Define a variable with the Name logKs_darcy by the Expression logKs.

4 Click the General transformation button. Leave the source transformation settings at 
their default values.
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5 Click the Destination tab; the forward-model geometry is automatically activated.

6 With Geom1 selected in the Geometry list, specify the Level as Subdomain.

7 Select Subdomain 2 (the aquifer domain).

8 Select the Use selected subdomains as destination check box.

9 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Darcy’s Law
1 From the Multiphysics menu, select 1 Geom1: Darcy’s Law (esdl) or click the Geom1 

tab.

2 From the Physics menu, select Subdomain Settings.

3 Select the outer subdomain (Subdomain 1), then type 10^logKs0 in the Ks edit 
field.

4 Select the aquifer subdomain (Subdomain 2), then type 10^logKs_darcy in the Ks 
edit field.

5 Click OK.

Boundary Conditions—Darcy’s Law
1 From the Physics menu, select Boundary Settings.

2 From the Boundary selection list, select 1, 2, 3, and 12 (the modeling domain’s outer 
boundaries).

3 From the Boundary condition list, select Hydraulic head. Leave the default value 0 in 
the H0 edit field.
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4 Click OK.

Point Settings—Darcy’s Law
1 From the Physics menu, select Point Settings. Click the Flux tab.

2 Specify the following dipole-pump flux values; when done, click OK.

The boolean factors allow you to control which dipole pump to activate through the 
parameter th. Note that a point-flux value of zero is the default condition, so setting 
N0 to zero has no effect on the model equations.

Point Settings—Optimization
1 From the Multiphysics menu, select 2 Geom2: Optimization (opt) or click the Geom2 

tab.

2 From the Physics menu, select Subdomain Settings.

3 Click the Variables tab.

4 Select Subdomain 1. On the first table row, enter the following settings:

This gives discontinuous elements of order zero for the design variable logKs—a 
choice that ensures that each auxiliary-geometry mesh element carries a single 
degree of freedom.

5 Click the Pointwise Constraints tab.

6 On the first table row, enter the following constraint; when done, click OK.

Scalar Settings—Optimization
1 From the Physics menu, select Scalar Settings.

2 On the Objective page, type L_fitness+L_penalty in the Qs edit field.

3 Click OK.

SETTING POINT 3 POINT 4 POINT 5 POINT 6

N0 N0*(th==1) N0*(th==2) N0*(th==3) N0*(th==4)

SETTING POINT 7 POINT 8 POINT 9 POINT 10

N0 -N0*(th==4) -N0*(th==3) -N0*(th==2) -N0*(th==1)

NAME INIT ELEMENT

logKs logKs0 Discontinuous - Constant

LB EXPRESSION UB CONSTRAINT ORDER

-7 logKs -3 1
 2 :  F L U I D  F L O W  M O D E L S



M E S H  G E N E R A T I O N — G E O M E T R Y  1

1 Click the Geom1 tab. From the Mesh menu, select Free Mesh Parameters.

2 Click the Subdomain tab. Press Ctrl+A to select both subdomains, then set the 
Method to Triangle. Select only Subdomain 2 and set the Maximum element size to 5.

3 Click the Point tab. Select the dipole-pump vertices (Points 3–10).

4 In the Point mesh parameters area, set the Maximum element size to 0.1.

5 Click the Remesh button, then click OK to close the Free Mesh Parameters dialog box.

M E S H  G E N E R A T I O N — G E O M E T R Y  2

1 Click the Geom2 tab. From the Mesh menu, select Mapped Mesh Parameters.

2 Click the Boundary tab, then select Boundaries 1 and 2.

3 Select the Constrained edge element distribution, then set the Number of edge 

elements to 10.

4 Click the Remesh button, then click OK.

If you already created the interpolation function G using the supplied text file, you can 
now skip to the section “Computing the Solution—Using a Single Measurement 
Series” on page 171. Otherwise, if you have a MATLAB license you can proceed as 
follows to generate the matrix elements of the penalty-function matrix G based on the 
actual mesh for the auxiliary geometry. The instructions assume that you run 
COMSOL with an active MATLAB connection.

1 Choose File>Export>FEM Structure as 'fem' (or press Ctrl+F) to export the FEM 
structure to the MATLAB workspace.
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2 If you are reading an electronic version of this document, use Ctrl+C to copy the 
following script, paste it on the command line with Ctrl+V, and then press Enter:

% Generate the penalty-function matrix G and place it in a struct.

fem.xmesh = meshextend(fem);

% Extract Gauss-point coordinates and mesh-element numbers from fem:
me_td = posteval(fem,'meshelement','geomnum',2,'spoint',postgp('tri',1));
me_qd = posteval(fem,'meshelement','geomnum',2,'bpoint',postgp('quad',1));
  
p = [me_td.p, me_qd.p]; % first-order Gauss-point coordinates
me_numbers = [me_td.d, me_qd.d]; % mesh-element numbers 

n = length(me_numbers); % number of parameters

for i = 1:n
  pos(i) = find(me_numbers == i);
end

[x1,x2] = meshgrid(p(1,pos(:)),p(1,pos(:)));
xdist2 = (x2-x1).^2;
[y1,y2] = meshgrid(p(2,pos(:)),p(2,pos(:)));
ydist2 = (y2-y1).^2;
dist = (xdist2 + ydist2).^(1/2);

% Calculate the covariance matrix and its inverse:
sigma2 = 1; l = 50; % variogram sill and range parameters
Q = 2*sigma2*(1-exp(-dist/l));
Q_inv = inv(Q); Q_inv = 0.5*(Q_inv+Q_inv'); % restore symmetry

% Calculate G:
X = ones(n,1);
G = Q_inv - Q_inv*X*X'*Q_inv/(X'*Q_inv*X); G = 0.5*(G+G');

% Define structs for Q_inv and G:
rng = 1:n;
Q_inv_struct.x = rng; Q_inv_struct.y = rng; Q_inv_struct.data = Q_inv;
G_struct.x = rng; G_struct.y = rng; G_struct.data = G;

The script is also available as an M-file. To call it, type pwd on the command line to 
display the current work directory, then use the cd command to navigate to the 
directory models/Earth_Science_Module/Fluid_Flow under the main 
COMSOL installation directory, and finally run the M-file with the command

aquifer_characterization_generate_G

Now G_struct is defined in the MATLAB workspace and ready for import to your 
COMSOL Multiphysics session:

3 Return to the COMSOL Multiphysics window and select Options>Functions.

4 Click the New button. In the Function name edit field, type G.
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5 Click the Interpolation button, then go to the Use data from list and select MATLAB. 
In the Variable name edit field, type G_struct.

6 Click OK to close the New Function dialog box and return to the Functions dialog box.

7 From the Interpolation method list, select Nearest neighbor.

8 From the Extrapolation method list, select Specific number. In the Value outside range 
edit field, type 0.

9 Click OK to close the Functions dialog box.

The inverse covariance matrix is now available in the graphical user interface as the 
function G defined on the set of mesh elements for the auxiliary geometry.

C O M P U T I N G  T H E  S O L U T I O N — U S I N G  A  S I N G L E  M E A S U R E M E N T  S E R I E S

First solve the forward problem to verify that you have implemented the physics 
correctly. To do this, simply click the Solve button on the Main toolbar.

The solution takes a few seconds to compute. When the solver has finished, the default 
solution plot in the forward-model geometry should look like that in the figure below.

Hydraulic head field for dipole-pump configuration 1 and Ks = 10−5 m/s.

Next, turn to the optimization problem.

1 Click the Solver Parameters button on the Main toolbar.

2 Select the Optimization/Sensitivity check box.

3 Optionally, select the Plot while solving check box to view the optimization solver’s 
progress after each model evaluation in a separate figure window. If you select this 
option, perform the steps in the section “Postprocessing and Visualization” on page 
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173 before starting the solver; because the software uses the current settings in the 
Plot Parameters dialog box for the plot, you can then monitor the inverse solution 
for the hydraulic conductivity field as it evolves.

4 Click the Optimization/Sensitivity tab. From the Analysis list, select Optimization.

5 In the Tolerances area, raise the Optimality tolerance to 0.1. It is good modeling 
practice to begin by solving the optimization problem with a high tolerance value 
to get an idea of the convergence rate.

6 Click OK to close the Solver Parameters dialog box.

7 Click the Solve button on the Main toolbar to start the optimization solver.

The solver converges after about 125 model evaluations and a solution time around 
2 minutes.

8 From the Postprocessing menu, select Data Display>Global. In the Expression edit 
field, type MSE, then click OK.

The result for the mean square error shown in the message log at the bottom of the 
user interface should be near the value 0.3491.

After this initial run, tighten the tolerance and solve again using the current solution 
as the starting point:

1 Click the Solver Parameters button on the Main toolbar.

2 Set the Optimality tolerance to 0.05, then click OK.

3 Click the Solver Manager button on the Main toolbar.

4 On the Initial Value page, go to the Initial value area and click the Current solution 
option button.

5 Click OK.

6 Click the Solve button on the Main toolbar.

The solver finishes after just a few model evaluations.

7 From the Postprocessing menu, select Data Display>Global. Click OK to calculate the 
new mean square error.

The result in the message log should be close to 0.3416.

As the mean square error obtained with the smaller optimality tolerance value does not 
differ much from the previous value, it is reasonable to conclude that the tolerance 
value 0.05 is sufficiently small. For this model, tightening the tolerance further can 
increase the solution time considerably without any significant gain in accuracy.
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default auxiliary-geometry plot shows the design variable, logKs. To reproduce 
the plot in Figure 2-50, follow these steps:

1 Click the Geom2 tab.

2 Click the Plot Parameters button on the Main toolbar.

3 On the Surface page, click the Range button.

4 Clear the Auto check box. Set the Min value to -7 and the Max value to -3. Click OK.

5 Clear the Smooth check box.

6 Click Apply to reproduce the upper-left plot in Figure 2-52.

7 On the Max/Min page, select the Max/min marker check box.

8 Click OK to generate the plot in Figure 2-50.

The max and min markers appear in the lower-left corners of the squares where the 
respective extreme values are attained.

C O M P U T I N G  T H E  S O L U T I O N — U S I N G  M U L T I P L E  M E A S U R E M E N T  S E R I E S

First solve the parametric forward model to ensure that its setup is correct.

1 Click the Solver Parameters button on the Main toolbar.

2 From the Solver list, select Parametric.

3 Enter the Parameter names th and the Parameter values 1 2 3 4.

This choice corresponds to incorporating all four measurement series. You can select 
any combination of the four series. However, if you do not include the first series 
(that is, the th value 1), you need to adapt the definition of L_penalty; see page 
165.

4 Clear the Optimization/Sensitivity check box, then click OK.

5 Click the Solve button on the Main toolbar.

The solution time is a few seconds. Next plot the hydraulic-head field for each 
parameter value to verify that you have defined the dipole sources correctly:

6 Click the Geom1 tab, then click the Plot Parameters button on the Main toolbar.

7 On the Surface page, select Darcy’s Law (esdl)>Hydraulic head from the 
Predefined quantities list.

8 Return to the General page. From the Solution at time list, select in turn the th 
parameter values 1, 2, 3, and 4, clicking Apply in between to generate the 
corresponding plots hydraulic-head field. When done, click Cancel or OK.
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The resulting plots should closely resemble those in the following figure. Note that the 
the initial solution for the hydraulic-conductivity field was the one obtained in the 
optimization with respect to the first measurement series.

Hydraulic-head field for the four dipole-pump configurations and Ks = 10−5 m/s.

Proceed to solve the inverse model.

1 Click the Solver Parameters button on the Main toolbar.

2 Select the Optimization/Sensitivity check box, then click OK.

3 Click the Solve button on the Main toolbar.

Note: The solution time is roughly 22 minutes on a standard PC.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Switch to the auxiliary geometry by clicking the Geom2 tab. The plot in the drawing 
area should look like that in Figure 2-51.
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Fo r c hh e ime r  F l ow

Introduction

This is a tutorial model of the coupling between flow of a fluid in an open channel and 
a porous block attached to one of the channel walls. The flow is described by the 
Navier-Stokes equation in the free region and a Forchheimer-corrected version of the 
Brinkman equations in the porous region.

Figure 2-53: Depiction of the modeling geometry and domain. The 3D geometry can be 
reduced to a 2D representation assuming that changes through the thickness are negligible.

The coupling of free media flow with porous media flow is common in the fields of 
earth science and chemical engineering. Perhaps the most frequent way to deal with 
coupled free and porous media flow is to incorporate Darcy’s law adjacent to 
Navier-Stokes because it is usually numerically easy to solve. However, this approach 
does not account for viscous effects arising from the free media flow, which may still 
be important in the region close to the free-porous structure interface. Depending on 
the pore size and pore distribution, but also the fluid’s properties, it can therefore be 
an oversimplification to employ Darcy’s law. The Brinkman equations account for 
momentum transport by macroscopic viscous effects as well as pressure gradients 
(stemming from microscopic shear effects inside each pore channel) and can be 
considered an extension of Darcy’s Law.

Still, the Brinkman equations assume completely laminar flow. Looking at processes in 
relatively open structures, like gas flow through packed beds, there is also a turbulent 
contribution to the resistance to flow. In those cases, an additional term accounts for 

Free flow Porous structure
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the turbulent contribution to the resistance to flow in the porous domain. The 
Forchheimer equation (also accredited to Ergun) is widely used to predict pressure 
drops in packed beds. This equation can generally be written as

The left-hand side is the pressure drop per unit length of traveled distance through the 
bed. The first term on the right-hand side represents the Blake-Kozeny equation for 
laminar flow. The pressure drop depends linearly on the average linear velocity u for 
laminar flow, corresponding to Darcy flow. The second term is from the purely 
turbulent Burke-Plummer equation where the pressure drop is proportional to the 
square of the velocity. To describe intermediate flow, where both the laminar and 
turbulent effects are important, requires the two-term Forchheimer equation. The 
coefficients α1 and α2 are functions of porosity, viscosity, average pore diameter, and 
fluid density.

Implementation in COMSOL Multiphysics

To implement the Forchheimer pressure drop relation in a differential equation 
framework, this example uses an approach suggested in Ref. 1 in which the Brinkman 
momentum balance is amended with a Forchheimer term. The system studied in this 
example is that of a 2D cross section of a rectangular channel with a porous layer 
attached to one of its walls. Flow enters the volume with a uniform velocity profile and 
develops throughout the length of the channel.

∆p
L

------- α1u α2u2
+=
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Model Definition

Figure 2-54 below shows the model domain and notations for the boundary 
conditions.

Figure 2-54: Modeled domain and boundary notations. Flow enters at the bottom and 
leaves at the top. The region of porous structure is not as long as the free channel.

Flow in the free channel is described by the Navier-Stokes equations:

 (2-21)

where η denotes the dynamic viscosity (Pa·s), u refers to the velocity in the open 
channel (m/s), ρ is the fluid’s density (kg/m3), and p is the pressure (Pa). In the 
porous subdomain, the Brinkman equations with Forchheimer correction describe the 
flow:

 (2-22)

Here k denotes the permeability of the porous medium (m2), and εp is the porosity 
(dimensionless), and the dimensionless friction coefficient is (Ref. 1)

Outlet

No slipNo slip

Navier-Stokes
Brinkman boundary

Inlet

ρ u ∇⋅( )u ∇ p– I η ∇u ∇u( )T
+( )+[ ]⋅–=

∇ u⋅ 0=

η
k
---u ∇ p– I η

εp
----- ∇u ∇u( )T

+( )+⋅
ρεpCf

k
---------------u u–=

∇ u⋅ 0=
F O R C H H E I M E R  F L O W  |  177



178 |  C H A P T E R
 (2-23)

As Equation 2-21 and Equation 2-22 reveal, the momentum transport equations are 
closely related. The term on the left-hand side of the Navier-Stokes formulation 
corresponds to momentum transfered by convection in free flow. The Brinkman 
formulation replaces this term by a contribution associated with the drag force 
experienced by the fluid flowing through a porous medium. In addition, the last term 
in the right-hand side of Equation 2-22 presents the Forchheimer correction for 
turbulent drag contribution.

In COMSOL Multiphysics you can combine free flow and porous media flow 
effortlessly. However, the implementation of the extra Forchheimer terms requires use 
of the volume force terms that are available in the application mode. Thus, you set

 (2-24)

The boundary conditions are

 (2-25)

where the pressure level at the outlet is used as a reference value.

The following table lists the input data for the model:

PROPERTY VALUE DESCRIPTION

 η 10-3 kg/(m·s) Dynamic viscosity

 ρ 1000 kg/m3 Density

 k 10-7 m2 Permeability

εp 0.4 Porosity

 v0 2 cm/s Inlet velocity

Cf
1.75

150εp
3

--------------------=

Fx
ρεpC

k
-------------u u2 v2

+–=

Fy
ρεpC

k
-------------v u2 v2

+–=

u u0 v0,( )= Inlet (velocity)

u 0= Wall (no slip)

p 0= η ∇u ∇u( )T
+( ) 0=, Outlet (pressure, no viscous stress)
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Results and Discussion

Figure 2-55 shows the velocity field in the open channel and porous structure. The 
plot reveals that there are slight disturbances in the velocity at the porous wall, which 
suggests momentum transport by viscous effects.

Figure 2-55: Velocity field in both the free channel and the porous media.

The velocity profile along a horizontal cross section in the middle of the channel is 
depicted in Figure 2-56. The plot confirms the existence of velocity gradients in the 
porous structure in that the velocity is continuous across the interface between the free 
channel and the porous structure. Further postprocessing would show that the shear 
rate perpendicular to the flow is also continuous. This implies that there is significant 
viscous momentum transfer across the interface and into the porous material, a 
transport that is not accounted for by Darcy’s law. Coupling Darcy’s law to the 
Navier-Stokes equations in this example, would give a substantially different profile in 
which the velocity in the free channel falls to a much smaller value in the free channel. 
Furthermore, a constant velocity equal to the flat part of the curve in Figure 2-56 
would describe all transport in the porous media.

Figure 2-56 contains a cross-sectional velocity plot. It shows that without the 
Forchheimer correction, the resistance to flow is underestimated in the porous 
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domain. The added correction gives a solution with slower flow in the porous domain 
and subsequently faster in the free domain, due to incompressibility.

Figure 2-56: Cross section of the velocity field (modulus of velocity) in the middle of the 
modeling domain with and without the Forchheimer correction (solid and dashed lines, 
respectively).

Reference

1. A. Amiri and K. Vafai, “Transient analysis of incompressible flow through a packed 
bed”, Int. J. Heat and Mass Transfer, vol. 41, pp. 4259–4279, 1998.

Model Library path: Earth_Science_Module/Fluid_Flow/forchheimer_flow

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.
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2 From the list of application modes, choose 
Earth Science Module>Fluid Flow>Incompressible Navier-Stokes.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Define the following constants (the descriptions are optional); when done, click OK.

3 From the Options>Expressions menu, choose Scalar Expressions.

4 In the Scalar Expressions dialog box, enter the following names, expressions, and 
(optionally) descriptions: 

Note that you get a double-check that you typed in the right expressions through 
the Unit column: fx and fy should compute to N/m3, which is the correct unit for 
a volume force.

5 Click OK.

G E O M E T R Y  M O D E L I N G

1 Press the Shift key and click the Rectangle/Square button on the Draw toolbar.

2 Specify the following parameters in the corresponding edit fields:

NAME EXPRESSION DESCRIPTION

rho 1000[kg/m^3] Density

eta 1e-3[Pa*s] Viscosity

epsilon 0.4 Porosity

k 1e-7[m^2] Permeability

v0 2[cm/s] Inlet velocity

Cf 1.75/sqrt(150*epsilon^3) Friction coefficient

fs 1 Switch for Forchheimer terms

NAME EXPRESSION DESCRIPTION

fx -Cf*epsilon*rho*u*sqrt(u^2+v^2)/sqrt(k) Force term, x-component

fy -Cf*epsilon*rho*v*sqrt(u^2+v^2)/sqrt(k) Force term, y-component

PROPERTY VALUE

Width 1e-3

Height 6e-3

Base Corner
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3 Click OK.

4 Press the Shift key and click the Rectangle/Square button.

5 Draw a second rectangle by entering the values below:

6 Click OK.

7 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1. 

3 Set the Density to rho and the Dynamic viscosity to eta.

4 Select Subdomain 2.

5 Select the Flow in porous media (Brinkman equations) check box.

6 Set the Density to rho, the Dynamic viscosity to eta, the Porosity to epsilon, and 
the Permeability to k.

7 Set the force terms as follows: Fx to nojac(fs*fx) and Fy to nojac(fs*fy).

x 0

y -3e-3

PROPERTY VALUE

Width 1e-3

Height 8e-3

Base Corner

x -1e-3

y -4e-3

PROPERTY VALUE
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Note: COMSOL performs a symbolic differentiation of the different terms in the 
equations for the Jacobian contribution. In this case, the F-term contains a  
expression, of which the implicit derivative contains a  factor. When u 
and v approach 0 (for example, at walls), a division by zero occurs. The nojac 
operator tells COMSOL not to make any Jacobian contribution of its argument, 
thereby avoiding this risk of numerical breakdown. Note that convergence gets slower 
with the nojac operator, which is why it must be used with caution.

8 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Select the appropriate entry from the Boundary selection list and enter boundary 
conditions according to the following table:

3 Click OK.

M E S H  G E N E R A T I O N

To resolve the velocity profile close to the interface between the open channel and the 
porous domain, create a finer mesh at that boundary (Edge 5).

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Custom mesh size button.

3 In the Maximum element size edit field, type 2e-4.

4 Click the Boundary tab.

5 Select Edge 5, then set the Maximum element size to 1e-4.

6 Click the Remesh button.

7 When the mesher has finished, click OK.

SETTINGS BOUNDARY 2 BOUNDARY 3

Boundary type Inlet Outlet

Boundary condition Velocity Pressure, no viscous stress

u0 0

v0 v0

p0 0

u2 v2
+

1 u2 v2
+( )⁄
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C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Change the Solver to Parametric.

3 Type fs in the Parameter names edit field and 0 1 in the Parameter values edit field.

4 Click OK.

5 Click the Solve button on the Main toolbar.

Postprocessing and Visualization
1 From the Postprocessing menu, select Plot Parameters.

2 Select the Arrow check box. In the lower left area, set Plot in to New Figure.

3 Click OK to reproduce the plot in Figure 2-55.

To visualize the velocity profile with and without Forchheimer correction, follow these 
steps:

1 From the Postprocessing menu, select Cross-Section Plot Parameters.

2 From the Solution to use list, select 0, then click the Line/Extrusion tab.

3 In the y-axis data area, leave the default entry in the Predefined quantities list but 
change the Unit to mm/s.

4 In the x-axis data area, click the lower option button and then click Expression.

5 In the X-Axis Data dialog box, select Geometry and Mesh>x-coordinate from the 
Predefined quantities list. Set the Unit to mm, then click OK.

6 In the Cross-section line data area, set x0 to -1e-3 and x1 to 1e-3; leave both y0 and 
y1 at their default zero values.

7 Click the Line Settings button. Change the Line style to Dashed line, then click OK.

8 Click Apply to plot the velocity profile computed without the Forchheimer 
correction.

9 Click the General tab. From the Solution to use list, select 1. Select the Keep current 

plot check box.

10 Click the Line/Extrusion tab. Click the Line Settings button. Change the Line style 
back to Solid line, then click OK.

11 Click OK to plot the velocity profile computed with the Forchheimer correction, 
thus completing Figure 2-56.
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This chapter contains models with a focus on compaction and poroelasticity.
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Compa c t i o n  and Po r o e l a s t i c i t y

Introduction

Fluids that move through pore spaces in an aquifer or reservoir can shield the porous 
medium from stress because they bear part of the load from, for instance, overlying 
rocks, sediments, fluids, and buildings. Withdrawing fluids from the pore space 
increases the stress the solids bear, sometimes to the degree that the reservoir 
measurably compacts. The reduction in the pore space loops back and alters the fluid 
pressures. The feedback brings about more fluid movement, and the cycle continues.

In the Central Valley of California, only a few years of unmanaged pumping irrevocably 
lowered the ground surface by roughly 9 m and etched out extensive lateral fissures. 
This model describes the impacts of pumping for a deep basin filled with sediments 
draping an impervious bedrock step or fault block. That the step is impermeable to 
fluids is important because the contrast in material properties gives rise to steep 
pressure gradients and large strains with the potential to produce fissuring or collapse 
infrastructure elements such as well casings and pipes.

Figure 3-1: Fluid movement in a sedimentary basin with bedrock fault blocks.

This example demonstrates two methods for analyzing ground displacement 
associated with changing subsurface fluid flow. Both models come directly from the 
bedrock step problem of Leake and Hsieh (Ref. 1). The first analysis, Terzaghi 
Compaction, describes a conventional flow model and uses the results in 
postprocessing to calculate vertical compaction following Terzaghi theory (Ref. 2). 
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The second example, Biot Poroelasticity, models the two-way interaction between the 
fluid movement and the solid displacement following the linear poroelastic theory of 
Biot (Ref. 3). The poroelasticity analysis predicts a similar vertical compaction and also 
predicts the horizontal displacements that compensate for the change in vertical 
thickness. The results from poroelastic analyses such as these ones naturally fold into 
criteria that predict fissuring and compaction at the soil surface as well as failure of 
wells, pipes, and other infrastructure elements.

Following these two example models, this section shows how to use COMSOL 
Multiphysics’ Darcy’s Law application mode and the Plane Strain application mode.

Model Definition

The two models that follow analyze fluid and solid behavior within three sedimentary 
layers overlying impermeable bedrock in a basin. The bedrock is faulted, which creates 
a step near a mountain front. The sediment stack totals 420 m at the centerline of the 
basin (x = 0 m) and thins to 120 m above the step (x > 4000 m). The top two layers 
are each 20 m thick.

Figure 3-2: Model geometry showing boundary segments (from Leake and Hsieh, Ref. 1).

Pumping from the lower aquifer reduces hydraulic head down the centerline of the 
basin by 6 m per year. The head drop moves fluid away from the step. The middle layer 
is relatively impermeable. The pumping does not diminish the supply of fluids in the 
unpumped reservoir above it. The flow field is initially at steady state. The period of 
interest is 10 years.

This discussion first covers the Terzaghi Compaction model and follows with the Biot 
Poroelasticity analysis. Each model description begins with governing equations and 
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boundary conditions followed by particulars related to the COMSOL Multiphysics 
implementation. A data table comes next, concluding with step-by-step instructions 
that describe how to build the model in COMSOL Multiphysics.
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T e r z a gh i  C ompa c t i o n

Introduction

This example sets up a traditional flow model and analyzes the vertical displacement 
during postprocessing. The flow field is fully described using the Darcy velocity in an 
equation of continuity

where S is the storage coefficient (m−1), K equals hydraulic conductivity (m/s), and 
H represents hydraulic head (m). In most conventional flow models, S represents small 
changes in fluid volume and pore space in that it combines terms that describe the 
fluid’s compressibility, the solids’ compressibility, and the reservoir’s porosity. In the 
original research (Ref. 1) and in this model, S is the compressibility of the solid 
skeleton, Ssk; the original study does not consider fluid compressibility.

Because the aquifer is at equilibrium prior to pumping, you set up this model to predict 
the change in hydraulic head rather than the hydraulic head values themselves. The 
main advantage to this approach lies in establishing initial and boundary conditions. 
Here you specify that the hydraulic head decreases linearly by 60 m over ten years, then 
simply state that hydraulic head H0 is zero and remains so where heads do not change 
in time.

The boundary and initial conditions are

where n is the normal to the boundary. The letters  A through  E, taken from Leake 
and Hsieh (Ref. 1), denote the boundary (see Figure 3-2).

Terzaghi theory uses skeletal specific storage or aquifer compressibility to calculate the 
vertical compaction ∆b (m) of the aquifer sediments in a given representative volume as

S H∂
t∂

------- ∇+ K ∇H–( )⋅ 0=

n K H∇⋅ 0= Ω base∂ A
n K H∇⋅ 0= Ω other∂ B
H H0= Ω upper edge∂ C

H H0= Ω surface∂ D

H H t( )= Ω outlet   ∂ E

∆b Sskb H0 H–( )=
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where b is standard notation for the vertical thickness of aquifer sediments (m).

Model Data

The following table gives the data for the Terzaghi compaction model:

Results and Discussion

Figure 3-3 shows a Year-10 snapshot from the COMSOL Multiphysics solution to the 
Terzaghi compaction example. The results describe conventional Darcy flow toward 
the centering of a basin, moving away from a bedrock step (x > 4000 m). The shading 
represents the change in hydraulic head brought on by pumping at x = 0 m. The 
streamlines and arrows denote the direction and magnitude of the fluid velocity. The 
flow goes from vertical near the surface to horizontal at the outlet. Where the 
sediments thicken at the edge of the step, the hydraulic gradient and the fluid velocities 
change abruptly.

TABLE 3-1:  MODEL DATA

VARIABLE DESCRIPTION VALUE

 g Acceleration due to gravity 9.82 m/s2

 ρf Fluid density 1000 kg/m3

 Ssk Skeletal specific storage, aquifer layers 1·10-5 m-1

 Ssk Skeletal specific storage, confining layer 1·10-4 m-1

 Ks Hydraulic conductivity, aquifer layers 25 m/d

 Ks Hydraulic conductivity, confining layer 0.01 m/d

 H0 Initial hydraulic head 0 m

 H(t) Declining head boundary (6 m/year)·t
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Figure 3-3: COMSOL Multiphysics solution to a Terzaghi flow problem. The figure shows 
change in hydraulic head(surface plot) and fluid velocity (streamlines and arrows). Note 
that the vertical axis is expanded for clarity.

Figure 3-4 depicts the vertical compaction predicted for the flow field in Figure 3-3 
according to Terzaghi theory. In COMSOL Multiphysics you can define arbitrary 
expressions that the software evaluates throughout the solution. The 
vertical-compaction estimates from this analysis are based on such user-defined 
expressions. The predicted compaction is greatest at the basin centering and declines 
gradually to the bedrock step. The apparent discontinuity at the step results because 
the Terzaghi formulas depend linearly on the sediment thickness.
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Figure 3-4: Vertical compaction (surface plot and contours) from Terzaghi theory for the 
Year-10 flow field in Figure 3-3. The vertical axis is expanded for clarity. The coordinate 
h denotes the height above the bedrock.

References

Reference numbers for this model refer to the reference list on page 188.

Model Library path: Earth_Science_Module/Flow_and_Deformation/
terzaghi_compaction

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator.

2 In the Application Modes tree, select Earth Science Module>Fluid Flow>Darcy’s 

Law>Hydraulic head analysis>Transient analysis. Click OK.
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G E O M E T R Y

1 From the Options menu, select Axes/Grid Settings. On the Axis page, clear the Axis 

equal check box and then enter the following x-y limits:

2 Click the Grid tab. Clear the Auto check box, then enter the following settings; when 
done, click OK.

3 Choose Draw>Specify Objects>Rectangle (or shift-click the Rectangle/Square button 
on the Draw toolbar). In the Rectangle dialog box, enter the following properties; 
when done, click OK.

4 Follow the same procedure to create another rectangle with these properties:

TERM EXPRESSION

x min -100

x max 5300

y min -500

y max 50

TERM EXPRESSION

x spacing 1000

Extra x 4000 5200

y spacing 100

Extra y -20 -40

PROPERTY VALUE

Width 5200

Height 440

Base Corner

x 0

y -440

PROPERTY VALUE

Width 1200

Height 320

Base Corner

x 4000

y -440
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5 Choose Draw>Create Composite Object or click the Create Composite Object button 
on the Draw toolbar. In the Set formula edit field, type R1-R2, then click OK.

6 Click the Zoom Extents button on the Main toolbar.

7 Create a break between the layers by adding lines across the rectangle. Go to the 
Draw toolbar on the left of the COMSOL Multiphysics user interface and click the 
Line symbol. Draw a line across the rectangle at y = −40; right-click to end the line. 
Draw another line across the rectangle at y = −20.

O P T I O N S  A N D  S E T T I N G S

Constants
1 Choose Options>Constants.

2 In the Constants dialog box, enter the following names, expressions, and 
descriptions (optional:.

The constant SPY is useful for changing the time unit for the model from the default 
unit second to the more convenient unit year, as you do in this model. This means 
that wherever the time appears explicitly in the user interface, you should read years 
instead.

3 Click OK.

Subdomain Expressions
Next define expressions for the skeletal specific storage, Ssk, and the hydraulic 
conductivity, Ks.

Choose Options>Expressions>Subdomain Expressions and enter the following names 
and expressions for the designated subdomains; when done, click OK.

The factor 365 in the expressions for the hydraulic conductivity gives this property in 
the unit m/year (see Table 3-1).

NAME EXPRESSION DESCRIPTION

rho_f 1000[kg/m^3] Fluid density

SPY 1[year/s] Seconds per year

NAME SUBDOMAINS 1, 3 SUBDOMAIN 2

S_sk 1e-5 1e-4

K_s 25*365 0.01*365
 3 :  F L O W  A N D  S O L I D  D E F O R M A T I O N  M O D E L S



P H Y S I C S

Application Scalar Variables
1 Choose Physics>Scalar Variables.

2 In the Expression edit field for Elevation/vertical axis, type y, then click OK.

Model Settings
Choose Physics>Model Settings. Clear the Simplify expressions check box, then click OK.

Subdomain Settings
1 Choose Physics>Subdomain Settings.

2 On the Coefficients page, select all three subdomains, then enter data according to 
the table below.

Because the default initial condition is zero, you need not specify it explicitly.

3 Click the Scaling Factors tab. In the δS edit field, type 1/SPY.

This scaling of the time-derivative effectively changes the time unit from seconds to 
years.

QUANTITY SELECTION/DESCRIPTION VALUE

 S User defined S_sk

 Ks Hydraulic conductivity K_s

 ρf Density, liquid rho_f
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4 Click OK to close the Subdomain Settings dialog box.

5 From the Physics menu, select Boundary Settings.

6 Specify boundary conditions according to the table below.

In the expression for H0 on Boundary 1 (the outlet), the rate of decline in hydraulic 
head is 6 m/year, but because of the time-unit rescaling you enter seconds instead 
of years. (If you leave out the unit bracket, you get a warning message but the result 
will still be correct because the numerical constant is specified so that the resulting 
expression has the unit displayed to the right of the edit field.)

7 Click OK.

M E S H  G E N E R A T I O N

Click the Initialize Mesh button on the Main toolbar to generate a mesh with the default 
settings.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, go to the Time stepping area and in the Times edit field type 
range(0,10). Because the effective time unit for the model is 1 year, this setting 
instructs COMSOL Multiphysics to compute the solution for years 0 to 10 in 1-year 
intervals.

SETTINGS BOUNDARY 1 BOUNDARIES 2, 3, 8–11 BOUNDARIES 5, 7, 12

Boundary condition Hydraulic head Zero flux/Symmetry Hydraulic head

H0 -6[m/s]*t - 0
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3 Click OK, then click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G

To generate Figure 3-3 on page 191, proceed as follows:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, verify that the selection in the Solution at time list is 10. In the 
Plot type area, select the Surface, Arrow, and Streamline check boxes. Clear all the 
others except for Geometry edges.

3 Click the Surface tab. On the Surface Data page, find the Predefined quantities list and 
select Hydraulic head.

4 Click the Range button. Clear the Auto check box, then click OK. This step keeps the 
current range when plotting earlier time steps.

5 In the Surface color area, select Rainbow from the Color table list.

6 Click the Streamline tab.

7 Go to the Streamline Data page, and in the Predefined quantities list select Velocity 

field. On the Start Points page, click the Specify start point coordinates option button. 
In the x edit field, type 0, and in the y edit field, type range(-450,50,-50).

8 At the bottom of the Streamline page, click the Advanced button. In the Maximum 

number of integration steps edit field, type 10000, and in the Stationary point stop 

tolerance edit field, type 1e-5. Click OK.

9 Click the Line Color tab, then click the Color button. In the Streamline Color dialog 
box, select an appropriate color, then click OK.

10 Click the Arrow tab. Go to the Subdomain Data page, and in the Predefined quantities 
list choose Velocity field. In the Number of points edit fields for x and y enter 25 and 
15, respectively. Go to the Arrow parameters area. Clear the Auto check box for the 
Scale factor, then in the associated edit field type 0.2.

11 Click the Color button. In the Arrow Color dialog box, select an appropriate color, 
then click OK.

12 Click Apply to generate the plot.

To animate all the time steps, proceed with the following instructions:

13 Click the Animate tab. In the Movie settings area, change the resolution as desired, 
then click Start Animation.

14 Click OK to close the Plot Parameters dialog box.
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To reproduce Figure 3-4 on page 192 you need MATLAB to cumulatively sum the 
compaction along a vertical column and then contour the results.

To generate the plot, first create a data matrix where each entry represents a square 
10 m on a side. Then, cumulatively sum the results going up a column. Finally, contour 
the cumulative. In more detail, the procedure for this task is as follows:

1 To export the data as a matrix, choose File>Export>Postprocessing Data.

2 Click the Subdomain tab. In the Expression edit field, type -S_sk*H_esdl*10. Go to 
the Location area and click the Regular grid option button. In the Regular grid 

specification area, find the x points edit field and enter 520; then in the y points edit 
field enter 44. Now each entry represents the compaction in a thickness of 10 m.

3 Click the General tab. For Solution to use, select only the final time step, 10. In the 
Export to file edit field, type the file name terzaghi.txt. Click the Browse button 
so you can save it in your MATLAB working directory, then click OK.

If you are to perform the cumulative sum, all entries must have a numeric value. 
However, the terzaghi.txt file you just created contains headers, and NaN 
(not-a-number) appears where the geometry is not defined, such as at the bedrock 
step. To remove the headers and replace the NaNs with zeros, follow these steps: 

1 Open terzaghi.txt with a text editor.

2 Delete the first few lines of text down to and including the second comment line 
beginning with % Data.

3 Use the editor’s Find/Replace function to replace all instances of NaN with a 
number 0.

4 Save the file.

To perform the cumulative summation and contour the results proceed as follows:

1 Go to the MATLAB command line and enter the following command sequence:

load terzaghi.txt;
compact = cumsum(terzaghi);
contourf(compact,[min(min(compact)):0.02:max(max(compact))])
colorbar; hold on
contour(compact,[min(min(compact)):0.02:max(max(compact))],'k')

2 Use the tools in the figure window to modify the plot title and axis labels.

To save the compaction data in a text file, compact.txt, give the following command:

save -ascii compact.txt compact
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Introduction

Poroelastic models describe the linked interaction between fluids and deformation in 
porous media. The fluids in a reservoir absorb stress, which registers as fluid pressure 
or equally hydraulic head. For example, if pumping significantly reduces pore fluid 
pressures, sediments could shift due to the increased load. Because the reduction in the 
pore space brings about more fluid movement, the reservoir could compact further. It 
follows that lateral stretching must compensate for the vertical compaction.

The Biot poroelasticity analysis in this example uses the Poroelasticity predefined 
multiphysics coupling that bidirectionally couples the Darcy’s Law application mode 
in the Earth Science Module with the Plane Strain application mode in the Structural 
Mechanics Module or the MEMS Module.

The U.S. Geological Survey report of Leake and Hsieh (Ref. 1) inspired the Biot 
poroelasticity model of flow that produces vertical and horizontal displacements as well 
as the flow-based Terzaghi vertical compaction study already described (see “Terzaghi 
Compaction” on page 189). The geometry and model description for both analyses 
are identical; what changes is the link to the solid deformation.

Figure 3-5: Model geometry showing boundary segments (based on Leake and Hsieh, Ref. 
1).
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Model Definition

Three sedimentary layers overlay impermeable bedrock in a basin where faulting 
creates a bedrock step near the mountain front. The sediment stack totals 420 m at the 
deepest point of the basin (x = 0 m) but thins to 120 m above the step (x > 4000 m). 
The top two layers of the sequence are each 20 m thick. The first and third layers are 
aquifers; the middle layer is relatively impermeable to flow. As given by the problem 
statement, the materials here are homogeneous and isotropic within a layer.

The flow field is initially at steady state, but pumping from the lower aquifer reduces 
hydraulic head by 6 m per year at the basin center. The head drop moves fluid away 
from the step. The fluid supply in the upper reservoir is limitless. The period of interest 
is 10 years.

Governing Equations

When creating this model, begin the Biot poroelasticity analysis by opening the 
Terzaghi Compaction model file. Rather than reusing that model’s Darcy’s Law 
application mode, remove it and select the Poroelasticity predefined multiphysics 
coupling, which includes the time rate of change in strain from the solid-deformation 
equations in the Darcy’s Law application mode and the fluid pressure gradient in the 
Plane Strain application mode. The following sections describe the equations that are 
built into the application modes when using the Poroelasticity predefined multiphysics 
coupling as well as the boundary conditions and initial conditions for this model.

F L U I D  F L O W

Use the Darcy’s Law application mode to estimate the flow field in the poroelastic 
model. The fluid equation is 

 (3-1)

where ∂εvol/∂t is the time rate of change of volumetric strain (s−1) from the equation 
for solid displacements and αb is an empirical constant usually termed the Biot-Willis 
coefficient; in this model the Biot-Willis coefficient equals 1, which is the default value 
in the Darcy’s Law application mode for the Poroelasticity predefined multiphysics 
coupling. You can interpret the term on the right-hand side as the time rate of 
expansion of the solid matrix. The volume fraction available for liquid will increase and 
thereby give rise to liquid sink, which is why the sign is reversed in the source term. 
Leake and Hsieh (Ref. 1) defined  using coefficients from the solids equation, the 

Sα
H∂
t∂

------- ∇+ K∇H–[ ]⋅ α– b
∂
t∂

-----εvol=

Sα
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Young’s modulus, E, and Poisson’s ratio, ν. For a further discussion about the 
quantities in the above equation, see the section “Terzaghi Compaction” on page 189. 
Debate over poroelastic storage coefficients is heated (Ref. 4), and the subscript α here 
denotes that conventional storage terms might need redefinition for poroelasticity 
models.

The only differences between the Terzaghi Compaction model already described and 
this poroelastic analysis lie in material coefficients and sources; the boundary 
conditions are identical. As in the Terzaghi Compaction model, H is the offset in 
hydraulic head since an initial steady-state distribution of H0. This subtle twist 
simplifies describing the boundary conditions: the value at the outlet boundary 
becomes the decline in hydraulic head with time, and at the upper aquifer, the 
hydraulic head is fixed at H0. All other boundaries have symmetry or no-flow 
conditions. The boundary and initial conditions for the Darcy’s law analysis are

where n is the normal to the boundary. The letters A through E come from Leake and 
Hsieh (Ref. 1), each letter denoting a specific boundary (see Figure 3-2). 

S O L I D S  D E F O R M A T I O N

You can define the solids deformation on plane strain. The governing equation in 
Leake and Hsieh (Ref. 1) is

 (3-2)

where E is Young’s modulus (kg/(m·d2)), ν is Poisson’s ratio, and u is the 
displacement vector composed of orthogonal displacements u and v (m). The term 

 (N/m3) amounts to the fluid pressure gradient in the x and y directions 
multiplied by the poroelastic constant and is often described as the fluid-to-structure 
coupling expression. COMSOL Multiphysics efficiently solves the plane-strain 
problem by converting it to a convenient system of equations as described in the next 
section.

Parallel to the flow model, the poroelasticity model uses Equation 3-2 to describe 
change in stresses, σ, strains, ε, and displacement, u, from an initial state. This focus 

n K∇H⋅ 0= Ω base∂ A
n K∇H⋅ 0= Ω other∂ B
H H0= Ω upper edge∂ C

H H0= Ω surface∂ D

H H t( )= Ω outlet∂ E

E
2 1 ν+( )
---------------------∇2u E

2 1 ν+( ) 1 2ν–( )
------------------------------------------∇+ u∇( )⋅ αbρf g H∇=

αbρf g H∇
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on change in displacement is standard in solids modeling and greatly simplifies 
specifying loads, boundaries, and initial conditions. For example, a separate body force 
for gravity need not appear because the changes in load related to the shifting of the 
water are already described in the coupling term. Moreover, Equation 3-2 defines a 
state of static equilibrium because the changes in the solid equilibrate quickly, unlike 
vibrations or waves. Still the time rate of change in strain appears as a coupling term in 
the poroelastic model because the solids equation becomes quasi-static when solved 
simultaneously with a time-dependent flow model.

The boundary conditions are a series of constraints on displacement that allow for 
horizontal movement at the surface and throughout the basin. The base of the 
sediments is fixed, which means you constrain horizontal and vertical displacement to 
zero. The upper surface is free to vary in the horizontal and the vertical directions. 
There is otherwise no horizontal displacement. These conditions result in the 
following boundary expressions

where, once again, the letters A through E come from Leake and Hsieh, and denote 
the boundaries in Figure 3-2.

T H E  P L A N E  S T R A I N  A P P L I C A T I O N  M O D E

The governing equation for the bedrock step problem describes the deformation state 
of plane strain, which is the norm for 2D poroelasticity problems (Ref. 1 and Ref. 4). 
With plane strain, the directional displacements u and v are functions of location in the 
model plane. The strain, ε, normal to the plane or “into the page” equals zero.

With the Plane Strain application mode, COMSOL Multiphysics solves Equation 3-2 
using Navier’s equations, a system of expressions that relate stresses, σ, strains, ε, and 
displacements, u, in solids. For equilibrium conditions, the stresses are

 (3-3)

where [σ] is the stress tensor, and F is the vector that contains the fluid pressure 
gradient (that is, the fluid-to-structure coupling term) and other body forces when 
present.

u v 0= = Ω base∂ A
u 0= Ω other∂ B
u 0= Ω upper edge∂ C
free Ω surface∂ D
u 0= Ω outlet∂ E

∇– σ[ ]⋅ F=
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The stress-strain relationship for an isotropic material under plane strain conditions 
reads

where τ and γ denote shear stress and shear strain, respectively. 

With small deformations, the normal strains εxx, εyy, εzz and shear strains εxy, εyz, εxz 
relate to the directional displacements u and v for plane strain analyses as

 (3-4)

where strains are defined on directional displacements. 

Inserting the relationships from these equations into Equation 3-3 gives the equation 
that COMSOL Multiphysics solves:

Here c is a tensor defined on the relationships between stresses, σ, strains, ε, and 
displacements, u.

Readers curious about the impacts of different assumptions for poroelastic analyses 
should try switching to one of the time-dependent analyses or even testing large 
deformations or elastoplastic material laws if working in the Structural Mechanics 
Module. To find out more about solids analyses, see the section dedicated to Structural 
Mechanics in the COMSOL Multiphysics Modeling Guide, or examine the Structural 
Mechanics Module User’s Guide for advanced deformation analysis.

Model Data

The coefficients and parameters for the poroelasticity model are as follows:

VARIABLE DESCRIPTION VALUE

 g Gravity 9.82 m/s2

 ρf Fluid density 1000 kg/m3

 ρs Solids density 2750 kg/m3

 Poroelastic storage coefficient, aquifer layers 1·10-6 m-1

σx

σy

τxy

E
1 ν+( ) 1 2ν–( )

---------------------------------------

1 ν– ν 0
ν 1 ν– 0

0 0 1 2ν–
2
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Results and Discussion

Figure 3-6, Figure 3-7, and Figure 3-8 are Year 2, Year 5, and Year 10 snapshots, 
respectively, from the COMSOL Multiphysics solution to a well-known problem of 
linked fluid flow and solid deformation near a bedrock step in a sedimentary basin (Ref. 
1). The shading and arrows, respectively, represent the change in hydraulic head and 
velocities brought about by pumping from the basin interior at x = 0 m. The fluid 
moves from the surface toward the well screens in the lower aquifer, with an abrupt 
change in direction and velocity near the bedrock step. In this way, the flow solution 
here is remarkably similar to the Terzaghi results in Figure 3-3.

The results for the solids displacement tell another story. In Figure 3-6, Figure 3-7, 
and Figure 3-8, contours and deformed shapes illustrate the total displacement. The 
plot sequence illustrates the evolution of lateral deformations that compensate for the 
changing surface elevation above the bedrock step.

Poroelastic storage coefficient, confining layer 1·10-5 m-1

 K Hydraulic conductivity, aquifer layers 25 m/d

 K Hydraulic conductivity, confining layer 0.01 m/d

 αb Biot-Willis coefficient 1

 H0 Initial hydraulic head 0 m

 H(t) Declining head boundary (6 m/y)·t

 E Young’s modulus, aquifer layers 8·108 N/m

 E Hydraulic conductivity, confining layer 8·107 N/m

 ν Poisson’s ratio, all regions 0.25

VARIABLE DESCRIPTION VALUE

Sα
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Figure 3-6: Solution for a poroelasticity analysis of the bedrock step problem of Leake and 
Hsieh (Ref. 1): Hydraulic head(surface plot), displacement (contours and deformations), 
and fluid velocities (arrows) at Year 2. The vertical axis is expanded for clarity.

Figure 3-7: Hydraulic head(surface plot), displacement (contours and deformations), 
and fluid velocities (arrows) at Year 5.
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Figure 3-8: Hydraulic head(surface plot), displacement (contours and deformations) and 
fluid velocities (arrows) at Year 10.

Figure 3-9 directly compares the 10-year solutions from the Biot analysis (dashed 
lines) and Terzaghi analysis (solid lines). Even at a glance you can notice the similarities 
in the deep part of the basin as well as the marked departure between the two solutions 
near the impermeable steep at the mountain front. The results shown here almost 
perfectly match Figure 3 from Leake and Hsieh (Ref. 1).
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Figure 3-9: COMSOL Multiphysics estimates of displacement from poroelastic analysis 
(dashed lines) and Terzaghi compaction (solid lines) for the bedrock step problem of Leake 
and Hsieh (Ref. 1).

In Figure 3-10, streamlines and shading represent the coupling terms that link the 
fluid and structure equations. The shading gives the structure-to-fluid link, which is 
the negative of the time rate of change in strain (see Equation 3-1). The streamlines 
depict the fluid-to-structure couplings that depend on the fluid pressure gradient (see 
Equation 3-2).
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Figure 3-10: The fluid-to-solid (surface plot) and solid-to-fluid (streamlines) coupling 
terms evaluated at Year 10 with the poroelastic analysis. Note that the actual unit for the 
liquid source is 1/year (not 1/s) because of the change in time scale.

The Terzaghi and Biot solutions differ most when it comes to predicting the horizontal 
strain at the edge of the bedrock step. The Biot poroelasticity analysis predicts 
horizontal strain; the Terzaghi compaction analysis does not. The horizontal strains at 
the ground surface from the Biot poroelasticity approach appear in Figure 3-11. It 
depicts negative strain or compaction immediately on the basin side of the step; the 
positive strains correspond to tension or lengthening on the mountain side.
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Figure 3-11: COMSOL Multiphysics estimates of horizontal strain from poroelastic 
analysis for the bedrock step problem of Leake and Hsieh: Year 2 (blue, solid line), Year 5 
(green, dotted line), and Year 10 (red, dashed line).

Failure criteria or expressions defining a critical threshold for stress, strain, or 
displacements facilitate evaluating whether the strain differential at the bedrock steps 
is big enough to produce fissures. Figure 3-12 plots von Mises stresses (surface plot), 
fluid velocities (streamlines), and total displacement (deformation). The von Mises 
stresses are postprocessing variables defined by COMSOL Multiphysics in all 
structural-deformation analyses. The von Mises stresses are variables in many failure 
expressions and you can also use them as yield functions in the elasto-plastic materials 
dialog boxes.
B I O T  P O R O E L A S T I C I T Y  |  209



210 |  C H A P T E R
Figure 3-12: COMSOL Multiphysics estimates of von Mises stresses (surface plot), fluid 
velocities (streamlines), and displacement (deformation) at Year 10. These results 
correspond to the porelastic analysis from Leake and Hsieh (Ref. 1). The vertical axis and 
deformation are exaggerated for clarity.

References

Reference numbers for this model refer to the reference list on page 188.

Note: This model requires the Earth Science Module and the Structural Mechanics 
Module or the MEMS Module.

Model Library path: Earth_Science_Module/Flow_and_Deformation/
biot_poroelasticity
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 From the File menu, select Open Model Library. From the Model Library tree, select 
Earth Science Module>Flow and Deformation>terzaghi compaction. Click OK.

2 From the Multiphysics menu, select Model Navigator. In the Multiphysics area, select 
Darcy’s Law (fluid), then click Remove.

3 From the list of application modes, select 
Earth Science Module>Poroelasticity>Plane Strain, Hydraulic head.

4 Edit the text in the Application mode name edit field so that it reads darcy strain.

5 Click Add, then click OK to close the Model Navigator.

6 From the Multiphysics menu, select Darcy’s Law (darcy) (you set up the flow model 
before beginning with the solids-deformation problem; note that the application 
mode name you specified in the Model Navigator now appears in the user interface).

O P T I O N S  A N D  S E T T I N G S

1 Choose Options>Constants.

2 Add the following name, expression, and description (optional) to those already 
present in the table; when done, click OK.

3 Choose Options>Expressions>Subdomain Expressions. Add the following expressions 
to the table; when done, click OK.

P H Y S I C S

Subdomain Settings—Darcy’s Law
1 Choose Physics>Subdomain Settings.

2 In the Subdomain selection list, select all three subdomains.

NAME EXPRESSION DESCRIPTION

rho_s 2750[kg/m^3] Solid density

NAME SUBDOMAINS 1, 3 SUBDOMAIN 2

S_alpha 1e-6 1e-5

nu 0.25 0.25

E 800[MPa] 80[MPa]
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3 On the Coefficients page, enter the following quantities:

4 Click the Scaling Factors tab. In the δS edit field, type 1/SPY to change the time unit 
in the model from seconds to years. (Because of the vast difference in time scales 
between the fluid and solid equations, the Plane Strain application mode uses static 
analysis; therefore, no further time-derivative scalings are necessary.)

5 Click OK to close the dialog box.

Boundary Conditions—Darcy’s Law
1 From the Physics menu, select Boundary Settings.

2 Specify boundary conditions according to the table below.

In the expression for H0 on Boundary 1 (the outlet), the rate of decline in hydraulic 
head is 6 m/year, but because of the time-unit rescaling you enter seconds instead 
of years. (If you leave out the unit bracket, you get a warning message but the result 
will still be correct because the numerical constant is specified so that the resulting 
expression has the unit displayed to the right of the edit field.)

3 Click OK.

Subdomain Settings—Plane Strain
4 Return to the Multiphysics menu and select Plane Strain (strain).

5 Choose Physics>Subdomain Settings.

6 Go to the Material page. In the Subdomain selection list select all three subdomains 
and then enter these settings:

QUANTITY SELECTION/DESCRIPTION VALUE

 S User defined S_alpha

 Ks Hydraulic conductivity K_s

 ρf Density, liquid rho_f

SETTINGS BOUNDARY 1 BOUNDARIES 2, 3, 8–11 BOUNDARIES 5, 7, 12

Boundary condition Hydraulic head Zero flux/Symmetry Hydraulic head

H0 -6[m/s]*t - 0

QUANTITY VALUE/EXPRESSION

 E E

 ν nu

 ρ rho_s
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7 Click OK.

Boundary Conditions
1 Choose Physics>Boundary Settings and then click the Constraints tab.

2 Select Boundaries 2, 8, and 9 (the bottom boundaries). Select Fixed from the 
Constraint condition list.

3 Similarly select Boundaries 1, 3, 5, and 10–12 (the sides of the domain). Select Roller 
from the Constraint condition list. When done, click OK.

Note that the surface and sides of the upper aquifer are free, so they need no 
boundary conditions.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Fine. Click OK.

3 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

The solver time steps should already be specified. If you want to check this, open the 
Solver Parameters dialog box. Having verified that the entry in the Times edit field is 
range(0,10)—corresponding to a 10-year range divided into 1-year intervals—click 
OK.

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G

To generate the plots in Figure 3-6, Figure 3-7, and Figure 3-8, proceed as follows:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select 2 from the Solution at time list.

3 In the Plot type area, select the Surface, Contour, Arrow, and Deformed shape check 
boxes. Clear the Streamline check box.

4 Click the Surface tab. On the Surface Data page, verify that the selection in the 
Predefined quantities list is Darcy’s Law (darcy)>Hydraulic head.

5 Click the Range button, select the Auto check box, and then click OK. 

6 Click the Contour tab. On the Contour Data page, select Plane Strain (strain)>Total 

displacement from the Predefined quantities list.
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7 Go to the Contour levels area and in the Vector with isolevels edit field, type 
range(0,0.02,0.4). In the Contour color area, click first the Uniform color option 
button and then the Color button. Select black, then click OK.

8 Click the Arrow tab. On the Subdomain Data page, verify that the selection in the 
Predefined quantities list is Darcy’s Law (darcy)>Velocity field. Keep also the other 
settings imported from the Terzaghi Compaction model.

9 Click the Deform tab. From the Predefined quantities list on the Subdomain Data page, 
select Plane Strain (strain)>Displacement.

10 Clear the Auto check box for the Scale factor, and in the associated edit field type 100.

11 Click Apply to generate the plot in Figure 3-6.

12 Generate the plots in Figure 3-7 and Figure 3-8 by changing the selection in the 
Solution at time list in Step 2 to 5 and 10, respectively, and then clicking Apply.

To animate all the time steps, do as follows:

1 Back in the Plot Parameters dialog box, click the Animate tab.

2 In the Movie settings area, change the resolution as desired, then click Start 
Animation.

Note: To generate the following figure you must run COMSOL Multiphysics with 
MATLAB.

To generate Figure 3-9 on page 207, contour the Terzaghi compaction estimates in 
the file compact.txt and then overlay the plot of total displacement estimates from 
the Biot poroelasticity analysis by completing the following steps:

1 Choose File>Export>Postprocessing Data.

2 Click the General tab. As the Solution to use, select only the final time step, 10. 
Browse to your MATLAB working directory and specify the export file name 
displacement.txt.

3 Click the Subdomain tab. In the Expression edit field, type -disp_strain (the 
negative of the total displacement). In the Location area, click the Regular grid option 
button. Locate the Number of points column in the Regular grid specification area and 
enter 520 in the x points edit field and 44 in the y points edit field.

The resulting file, displacement.txt, contains headings, and NaN (not a number) 
appears where the geometry is not defined. You must clear these items before 
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plotting the data. To do so, open displacement.txt in a text editor, delete the 
upper headers up to and including the line beginning with % Data, replace all NaN 
entries with the number 0, and then save the file.

4 To contour the compaction and displacement results, go to the MATLAB command 
line; if necessary, change the current working directory to the directory where you 
saved the data files compact.txt (see page 198) and displacement.txt; and then 
enter the following sequence:

load compact.txt
load displacement.txt
min_d = min(min(displacement));
max_d = max(max(displacement));
contour(compact,[min_d:0.02:max_d],'k-')
hold on
contour(displacement,[min_d:0.02:max_d],'b--')

5 Uset the edit tools in the figure window to modify the plot title and axis labels.

To generate Figure 3-10 on page 208, perform these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, examine the Solution at time list and verify that the final output 
time 10 is selected. In the Plot type area, select the Streamline check box and clear 
the Contour, Arrow, and Deformed shape check boxes; keep the selections for the 
other plot types.

3 Click the Surface tab. In the Predefined quantities list on the Surface Data page, select 
Darcy’s Law (darcy)>Liquid source.

4 Click the Streamline tab. In the Predefined quantities list on the Streamline Data page, 
select Plane Strain (strain)>Global force. Keep the other settings imported from the 
Terzaghi Compaction model.

5 Finally, click OK to close the Plot Parameters dialog box and generate the plot.

To reproduce the plot in Figure 3-11 on page 209, continue with these steps:

1 Choose Postprocessing>Cross-Section Plot Parameters.

2 On the General page, in the Solutions to use list select 2, 5, and 10.

3 Click the Line/Extrusion tab. In the y-axis data area select Plane Strain (strain)>ex 

normal strain global sys. from the Predefined quantities list.

4 In the x-axis data area, click the lower option button, then click the Expression 
button. In the X-Axis Data dialog box, type x in the Expression edit field. Click OK.
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5 In the Cross-section line data area, set x0 to 1000 and x1 to 5000; leave both y0 and 
y1 at 0. Click OK.

Finally, to generate Figure 3-12 on page 210, follow these instructions:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Deformed shape check box in the Plot type area.

3 Click the Surface tab. In the Predefined quantities list on the Surface Data page, select 
Plane Strain (strain)>von Mises stress.

4 Click the Streamline tab. In the Predefined quantities list on the Streamline Data page, 
select Darcy’s Law (darcy)>Velocity field. Keep the previously specified start points.

5 Click OK.
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Po r o e l a s t i c  F l ow and De f o rma t i o n :  
Open -Ho l e  Mu l t i l a t e r a l  We l l

Introduction

Multilateral wells—those with multiple legs that branch off from a single conduit—can 
produce oil efficiently because the legs can tap multiple productive zones and navigate 
around impermeable ones. Unfortunately, drilling engineers must often mechanically 
stabilize multilateral wells with a liner or casing, which can cost millions of dollars. 
Leaving the wellbore uncased reduces construction costs, but it runs a relatively high 
risk of catastrophic failure both during installation and after pumping begins. 

This model examines the mechanical stability of an open-hole multilateral well during 
pumping using poroelastic simulations with Coulomb failure criteria. The data and 
geometry come from E-base, a proprietary database from TerraTek 
(www.terratek.com) that holds data concerning well and rock mechanics. The model 
itself builds on theory outlined by Roberto Suarez-Rivera of TerraTek (Ref. 1).

Figure 3-13: Geometry for an analysis of a horizontal open-hole multilateral well.

40 inches

80 inches

80 inches
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The poroelastic simulations estimate 3D compaction related to pumping by taking 
subsurface fluid flow with Darcy’s law and coupling it to structural displacements with 
a stress-strain analysis. The simulation results feed into the Coulomb expression that 
maps where the compaction from the pumping is enough to have the well fail. The 
discussion in Ref. 1 couples flow and deformation analyses with failure criteria to 
predict if the well fails both during emplacement and as a result of pumping. This 
model focuses on elastic displacements brought on by changing fluid pressures when 
pumping begins. Related analyses for elasto-plastic deformations are straightforward 
using material laws automated in the Structural Mechanics Module.

Model Definition: Flow and Deformation Simulation

The modeled geometry (Figure 3-13) is the lower half of a branching junction, a 
segment from a larger well network. The junction lies roughly 25 feet from the start 
of the well. The entire well network extends much further, perhaps hundreds of feet. 
The well is 8.5 inches in diameter and sits in a cube 80 inches on each side. Pumps 
move fluid from the reservoir into the well. Fluid exits the geometry only through the 
well. The displacement at the reservoir edge is constrained. The walls of the well, 
however, deform freely. The goal is to solve for the change in fluid pressure, stress, 
strain, and displacement that the pumping causes rather than their absolute values. 

F L U I D  F L O W

To describe fluid flow, you insert the Darcy velocity into an equation of continuity

where κ is the permeability, η is the viscosity, and p equals the pressure of the oil in the 
pore space.

For the flow boundaries, you already know the change in fluid pressure from the well 
to the reservoir edge. The planar surface adjacent to the well (between the upper and 
lower blocks) is a symmetry boundary. Because the well is the only exit for the fluid, 
there is no flow to or from connecting well segments. In summary,

∇ κ
η
---∇p–⋅ 0=
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where n is the normal to the boundary. 

S O L I D  D E F O R M A T I O N

The system of equations that describes the solids deformation is

where u is a vector of the directional displacements u, v, and w, and the directional 
components of the gradient in fluid pressure, p, make up a vector forces, F. The 
coefficient c relates the displacements to the stresses and the strains in this way:

where ε is the strain tensor, and σ denotes the stress tensor. The terms ε and σ are 
related by σ = D ε . D, a 36-entry tensor, is a function of Young’s modulus, E, and 
Poisson’s ratio, ν. 

For the boundary conditions, the model constrains movement at all external 
boundaries. The well opening is free to deform. In summary:
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Results: Flow and Deformation Simulation

The following figures show results from simulations for coupled fluid flow and 
reservoir deformation following a poroelastic approach for the horizontal multilateral 
well reported in Ref. 1.

The isosurfaces in Figure 3-14 indicate the fluid pressure throughout the well’s lower 
half. The streamlines show the fluid paths and velocities. Fluid pressure drops from the 
reservoir toward the well opening. The velocity typically increases toward the well but 
remains close to zero near the branching legs of the junction.

Figure 3-14: COMSOL Multiphysics poroelastic analysis of a multilateral well. Results 
are fluid pressure (the isosurfaces), pressure gradient (streamlines), and fluid velocities 
(streamline shading).

Results for elastic deformation appear in Figure 3-15. The surface shading denotes 
total displacement. The plot illustrates directional displacements by shifting the 
shading relative to an outline of the original geometry. For a clear view, the 
displacements are exaggerated. The uncased surface yields slightly because the 
deformed shading fills in the hollows of the well. The largest displacements occur just 
above the split in the well.
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Figure 3-15: COMSOL Multiphysics estimates of displacement. Shading indicates the 
total displacement, and the geometry appears as lines. Even as the deformed shape shifts, 
those lines remain steady; the shaded image shows movement relative to the geometry 
outlines.

Figure 3-16 plots the pressure isosurfaces and the velocity streamlines from 
Figure 3-14 with the displacements from Figure 3-15 using wire-mesh options directly 
available from the COMSOL Multiphysics postprocessing user interface.
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Figure 3-16: Poroelastic analysis near a branch in a multilateral well showing fluid 
pressures (the isosurfaces), velocity (streamtubes), total displacement (the mesh), and 
directional displacements (the deformed shape).

Failure Criterion

This model allows the evaluation of failures during postprocessing using results from 
the fluid-flow and solid-deformation simulations shown in the preceding figures. This 
discussion follows calculations that Ref. 1 uses to map calculations indicating where 
pumping could compact the reservoir enough (see Figure 3-15) that the well will fail. 
Refer to Ref. 1 to estimate the critical rock strength required to successfully emplace 
the well, and also to learn more about calibration to data.

The 3D Coulomb failure criterion in Ref. 1 relates rock failure, the three principal 
stresses (σ1, σ2, and σ3), and the fluid pressures as follows:

 (3-5)
fail σ3 p+( ) Q σ1 p+( ) N 1

σ2 σ1–( )
σ3 σ1–( )

-----------------------+⎝ ⎠
⎛ ⎞+–=

Q 1 φsin+
1 φsin–
----------------------,           N 2 φcos

1 φsin–
---------------------So==
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Here So is the Coulomb cohesion and  is the Coulomb friction angle. When properly 
calibrated, fail = 0 indicates the onset of rock failure; fail < 0 denotes catastrophic 
failure; and fail > 0 predicts stability. Because this model solves for the pressure change 
brought on by pumping as well as the stresses, strains, and displacements that the 
pressure change triggers, it calculates the expression just given using the change in 
pressure than its absolute value.

Results: Failure Criterion

The values for the fail function appear in Figure 3-17. When the fail values become 
increasingly negative, the potential for failure is higher. As expected, the fail function 
estimates show the greatest potential for failure just above the split in the well. 

Figure 3-17: Values of the fail function calculated with results from a poroelastic model 
for the branching junction in an open-hole multilateral well. A negative value for the fail 
function denotes greater potential for failure.

Conclusions

This example couples fluid flow and solid deformation for a poroelastic analysis using 
easy-to-use application modes from COMSOL Multiphysics. The analysis provides 
estimates of the pressure change brought on by pumping as well as the stresses, strains, 

φ
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and displacements that the pressure drop triggers. Combining the simulation results 
with a 3D Coulomb failure expression, maps vulnerability to mechanical failure from 
the pumping. The data and geometry for this model come from petroleum industry 
analyses by TerraTek (Ref. 1), which in turn use failure criteria to map the potential for 
failure during emplacement of the well in addition to the potential for failure when the 
well is pumped.

Data

This model uses the coefficients and parameters listed in Table 3-2.

Reference

1. R. Suarez-Rivera, B.J. Begnaud, and W.J. Martin, “Numerical analysis of open-hole 
multilateral completions minimizes the risk of costly junction failures,” Rio Oil & Gas 
Expo and Conference (IBP096_04), 2004.

Model Library path: Earth_Science_Module/Flow_and_Deformation/
multilateral_well

TABLE 3-2:  MODEL DATA

VARIABLE DESCRIPTION VALUE

 ρf Fluid density 0.0361 lb/in3

 κ Permeability 1·10-13 in2

 η Viscosity 1·10-7 psi·s

 E Young’s modulus 0.43·106 psi

 ν Poisson’s ratio 0.16

 ρs Solids density 0.0861 lb/in3

 pr Pressure in reservoir 122.45 psi

 pw Pressure in well 0 psi

 So Coulomb cohesion 850 psi

Coulomb friction angle 31 degrees

 C1 Calibration constant 1 14.7

 C2 Calibration constant 2 40

φ
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator.

2 From the Space dimension list, choose 3D.

3 In the list of application modes, select Earth Science Module>Fluid Flow>Darcy’s 

Law>Pressure analysis. Click the Multiphysics button, then click Add.

4 In the list of application modes select COMSOL Multiphysics>Structural Mechanics> 

Solid, Stress-Strain. Click Add.

5 Click OK.

G E O M E T R Y  M O D E L I N G

In this example, the geometry already exists in a COMSOL Multiphysics model file.

1 Choose File>Import>CAD Data From File.

2 Browse to the folder Earth_Science_Module>Flow_and_Deformation in the 
Model Library root directory.

3 Select the file multilateral_well.mphbin, then click Import.

The length unit used for the CAD geometry is 1 in. Because the default base unit 
system is SI, with basic length unit 1 m, you need to scale the geometry by the factor 
0.0254 along all three coordinate axes to keep the default base unit system. 
Alternatively, you can change the base unit system to Gravitational IPS, which uses the 
inch as basic length unit.

As a third option, which is the one exemplified in these modeling instructions, you can 
scale the geometry by a factor 1/12 and change the base unit system to British 
engineering units, with basic length unit 1 ft. Thus, complete the geometry-modeling 
stage with the following steps:

1 Click the Scale button on the Draw toolbar.

2 In the Scale factor edit fields for x, y, and z, type 1/12. Leave the Scale base point at 
(0, 0, 0).

3 Click OK.

4 Click the Zoom Extents button on the Main toolbar.

The length unit in the drawing area is now 1 ft.
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M O D E L  S E T T I N G S

The model data in Table 3-2 is given in pounds and inches. As long as you include the 
units when entering the data and scale the geometry if required, as just discussed, the 
unit-handling functionality in COMSOL Multiphysics allows you choose whether to 
use these units also when analyzing the model or change to some other system. Here, 
to change to British engineering units, proceed as follows:

1 From the Physics menu, select Model Settings.

2 From the Base unit system list, select British engineering units.

3 Click OK.

O P T I O N S

Constants
Define constants you need in the model or during postprocessing.

1 From the Options menu, open the Constants dialog box.

2 Enter the following constants in the following table:

NAME EXPRESSION DESCRIPTION

kappa_s 1e-13[in^2] Permeability

rho_f 0.0361[lb/in^3] Fluid density

eta 1e-7[psi*s] Dynamic viscosity

E 0.43e6[psi] Young’s modulus

nu 0.16 Poisson’s ratio

rho_s 0.0861[lb/in^3] Solids density

p_r 122.45[psi] Pressure in reservoir

p_w 0[psi] Pressure in well

So 850[psi] Coulomb cohesion

phi 31*pi[rad]/180 Friction angle

C1 14.7 Calibration constant 1

C2 40 Calibration constant 2
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3 Click OK to close the Constants dialog box.

Scalar Expressions
1 From the Options menu, choose Expressions>Scalar Expressions.

2 Define the following scalar expressions (the descriptions are optional):

Note that the expression fail defined in Equation 3-5 has the dimension of stress. 
By appending the operator [1/psi] to the dimensionful expression enclosed within 
parentheses you extract its value in psi, which is what Ref. 1 uses. This way, you can 
analyze the risk for rock failure using the same criteria as in Ref. 1 independently of 
your choice of base unit system.

3 Click OK.

P H Y S I C S  S E T T I N G S — D A R C Y ’ S  L A W

Subdomain Settings
1 From the Multiphysics menu, select Darcy’s Law (esdl).

2 From the Physics menu, select Subdomain Settings.

NAME EXPRESSION DESCRIPTION

N 2*So*cos(phi)/(1-sin(phi)) Fail parameter

Q (1+sin(phi))/(1-sin(phi)) Fail parameter

fail (((s3_sld+C1*(p_r-p))- 
Q*(s1_sld+C1*(p_r-p))+ 
N*(1+(s2_sld-s1_sld)/ 
(s3_sld-s1_sld)))/C2)[1/psi]

Fail expression

support_x 0 Well support, x-component

support_y 0 Well support, y-component

support_z 0 Well support, z-component
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3 Select Subdomain 1.

4 On the Coefficients page, select Permeability from the drop-down list.

5 Enter the following settings; when done, click OK.

6 On the Init page, type p_r in the p(t0) edit field, then click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Enter the following settings; when done, click OK.

P H Y S I C S  S E T T I N G S — S O L I D  S T R E S S  S T R A I N

Subdomain Settings
1 From the Multiphysics menu, select Solid, Stress-Strain (sld).

2 From the Physics menu, select Subdomain Settings.

3 On the Material page, enter the following settings:

4 On the Load page, enter these settings:

5 Click OK.

QUANTITY VALUE

 κs kappa_s

 ρf rho_f

 η eta

SETTINGS BOUNDARIES 1, 3, 13 BOUNDARIES 6–10 BOUNDARIES 2, 4, 5, 11, 12

Boundary condition Pressure Pressure Zero flux/Symmetry

p0 p_r p_w

QUANTITY VALUE/EXPRESSION

 E E

 ν nu

 ρ rho_s

QUANTITY VALUE/EXPRESSION

Fx -px

Fy -py

Fz -pz
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Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 On the Constraints page, enter these settings:

3 On the Load page, enter the following settings:

4 Click OK.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 On the Global page, select Coarse from the Predefined mesh sizes list. Click OK.

3 Click the Initialize Mesh button on the Main toolbar.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar to start the analysis with the default solver 
settings.

CONSTRAINT BOUNDARY EXPRESSION

Rx 1, 3, 13 0

Ry 1–3, 5, 13 0

Rz 1, 3, 4, 11–13 0

QUANTITY BOUNDARIES EXPRESSION

Fx 6–10 -support_x

Fy 6–10 -support_y

Fz 6–10 -support_z
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 3-14 on page 220:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, go to the Plot type area and select the Isosurface and Streamline 
check boxes. Clear the Slice check box.

3 Click the Isosurface tab. On the Isosurface Data page, set the Expression to p and the 
Unit to psi.

4 Click the Streamline tab. On the Streamline Data page, choose Darcy’s Law 

(esdl)>Pressure gradient from the Predefined quantities list. On the Start Points page, 
type 60 in the Number of start points edit field. On the Line Color page, click the Use 

expression button, then click the Color Expression button. From the Predefined 

quantities list, choose Darcy’s Law (esdl)>Velocity field. Clear the Color legend check 
box, then click OK. Select Tube in the Line type list. Click the Tube Radius button, 
then clear the Auto check box for Radius scale factor and type 0.4 in the associated 
edit field. Click OK to close the Tube Radius Parameters dialog box.

5 Click Apply to generate the plot.

6 Click the Headlight button on the Camera toolbar to add directed light.

To generate Figure 3-15 on page 221:

1 In the Plot Parameters dialog box, click the General tab.

2 Clear the Isosurface and Streamline check boxes and select the Boundary and 
Deformed shape check boxes in the Plot type area.

3 Click the Boundary tab.

4 In the Boundary data area, select Solid, Stress-Strain (sld)>Total displacement from the 
Predefined quantities list. From the Unit list, select in.

5 Click the Deform tab and select Solid, Stress-Strain (sld)>Displacement from the 
Predefined quantities list on the Subdomain Data page. Click Apply.

To generate Figure 3-16 on page 222:

1 Click the General tab, then select the Isosurface and Streamline check boxes in the 
Plot type area. Leave the Boundary and Deformed shape check boxes unchanged.

2 Click the Boundary tab. From the Fill style list, select Wireframe. Click Apply.

3 Click the Zoom In button on the Main toolbar.

To generate Figure 3-17 on page 223:
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1 Click the General tab. In the Plot type area, clear the Streamline, Boundary, and 
Deformed shape check boxes. Select the Slice and Subdomain check boxes.

2 Click the Isosurface tab. On the Isosurface Data page, enter fail in the Expression 
edit field. Click the Vector with isolevels option button and enter 
range(-20,10,20) in the associated edit field. From the Color table list, choose 
WaveLight. With this choice, negative values, zero, and positive values appear in 
shades of blue, white, and shades of red, respectively.

3 Click the Subdomain tab. In the Color data area, type fail<=-20 in the Expression 
edit field. Click the Range button. Clear the Auto check box. For min and max enter 
0.001 and 1.00, respectively. Click OK. In the Element color area, click the Uniform 

color option button, the click the Color button. Choose black, then click OK.

This string of steps begins with the expression that assigns fail values less than or 
equal to −20 with a value of 1 and those greater than −20 with a value of zero. The 
minimum and maximum data levels serve to cut off values of zero from the plot, so 
only fail less than or equal to −20 are denoted with a uniform color of black.

4 Finally go to the Slice page. In the Slice data area, type fail>21 in the Expression 
edit field. Click the Range button. Clear the Auto check box. For min and max enter 
0.001 and 1.00, respectively. Click OK. In the Number of levels edit fields in the Slice 
positioning area, set the number of x levels and z levels to 0, and the number of 
y levels to 5. In the Slice color area, click the Uniform color option button, then click 
Color. Choose a gray shade, then click OK. Choose Wireframe from the Fill style list.

5 Click OK.
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S o l u t e  T r a n s p o r t  M o d e l s
In this chapter you find models of solute transport, including solute injection, 
variably saturated flow, and pesticide transport and reaction.
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S o l u t e  I n j e c t i o n

Introduction

Predicting the transport of contaminants that move with subsurface fluids generally 
means analyzing at least two physics. This model tracks a contaminant that enters an 

at a point, such as an injection well or toxic spill, and spreads through the aquifer with 
time. The model has an analytic solution developed by Wilson and Miller (Ref. 1), 
which has been used to test several dedicated fluid flow and transport codes. The 
particular problem in this model comes from the MT3DMS manual of Zheng and 
Wang (Ref. 2).

The analysis models steady-state fluid flow and follows up with a transient 
solute-transport simulation; it employs the Darcy’s Law application mode and the 
Solute Transport application mode from the Earth Science Module. In COMSOL 
Multiphysics it is straightforward to specify a fluid velocity without solving a flow 
problem. This example solves for the velocities to demonstrate the mechanics of 
coupling flow and transport simulations in one model file.

The example also shows how to use the solver settings for the combined steady-state 
and transient solution. The instructions detail how to model a point source using the 
point flux settings available in the Earth Science Module.

The first section in this discussion gives an overview of the problem. Next it gives the 
equations and describes how the fluid flow and the solute transport application modes 
link in COMSOL Multiphysics. Next come a few implementation details including a 
table of model data. The results shown next then illustrate various postprocessing 
options. The last section describes how to build the model using the COMSOL 
Multiphysics graphical user interface.

Model Definition

In this example, there is regional flow from left to right across a 450 m-by-300 m 
aquifer. The fluid moves at a Darcy velocity of 0.11 m/d. The aquifer has 
homogeneous and isotropic material properties. A point source releases a small amount 
of fluid into the aquifer at 1 m3/d, a release rate small enough for the flow field to 
remain uniform. The injected fluid carries a nonreactive solute at a concentration of 
1000 ppm. The contaminant migrates by advection and dispersion and never reaches 
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a boundary. The aquifer is initially pristine with concentrations everywhere equal to 
zero. The only source of contaminant is the injection, so flow through the inlet has 
zero concentration. The period of interest is one year.

F L U I D  F L O W

Darcy’s law describes the fluid flow in this problem. With the hydraulic-head 
formulation, the governing equation is

where K is hydraulic conductivity (m/d), H is hydraulic head (m), and Qs is the 
volume flow rate of fluid per unit volume of aquifer (d−1).

The point source is

where W is the volumetric pumping rate W (m3/d); b is the aquifer thickness (m); and 
δ denotes the Dirac delta function, which is nonzero only in the point (xi, yi), where 
xi and yi are the well coordinates.

Because the flow field is at steady state, you can obtain a unique solution by specifying 
the model geometry, the point source, the material properties, and the boundary 
conditions. The problem statement gives the hydraulic head at the inlet and the outlet 
and indicates symmetry conditions on the sides. In the Darcy’s Law application mode, 
you express these boundary conditions as

where n is the unit vector normal to the boundary.

C O U P L I N G

The groundwater-flow and solute-transport equations given here are linked by the 
Darcy velocity, , which gives the specific flux (m/d) of fluid across an 
infinitesimal surface representing both the solids and the pore spaces. COMSOL 
Multiphysics computes the Darcy velocity vector u, which consists of the x and y 
directional velocities denoted by u and v, respectively.

∇ K∇H–( )⋅ Qs=

Qs
W
b
-----δ x xi y yi–,–( )=

n K∇H( )⋅ 0= ∂Ω  Sides
H Hin= ∂Ω  Inlet

H 0= ∂Ω  Outlet

u K∇H–=
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S O L U T E  TR A N S P O R T

The advection-dispersion equation governs solute transport in this problem:

Here DL is the hydrodynamic dispersion tensor (m2/d); θs denotes the fluid volume 
fraction; c gives the dissolved concentration (kg/m3); u is the Darcy velocity (m/d); 
and Sc represents the quantity of solute added per unit volume of porous medium per 
unit time (kg/(m3·d)).

The entries for the dispersion tensor are

where DLii are the principal components of the dispersion tensor; DLij are the cross 
terms; α represents the dispersivity (m); and the subscripts “1” and “2” denote 
longitudinal and transverse flow, respectively.

In this problem, Sc represents the solute injected at the point well, which is defined by

where cQ is the concentration of the solute in the water (kg/m3). You implement the 
solute injection with the same logic as the fluid point source.

The problem statement specifies that the only contaminant source in the aquifer is the 
point well, and that the boundaries far enough from the injection well for the 
contaminant never to leave the model domain. You thus set the inlet concentration to 
zero and assign the other boundaries an advective flux. The expressions for these 
boundary conditions are

where n is the unit vector normal to the boundary.

θs
c∂
t∂

----- ∇ θs– DL c uc+∇( )⋅+ Sc=

θDLii α1
ui

2

u
------- α2

uj
2

u
-------+=

θDLij θDLji α1 α2–( )
uiuj

u
-----------= =

Sc QscQ
W
b
-----cQδ x xi y yi–,–( )= =

n θs– DL c∇( )⋅ 0= ∂Ω Sides

c 0= ∂Ω Inlet
n θs– DL c∇( )⋅ 0=   ∂Ω Outlet
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Model Data

Build the model with the following data:

PARAMETER NAME VALUE

 K Hydraulic conductivity 1 m/d

 ρf Fluid density 1000 kg/m3

 g Gravity 9.82 m/s2

 u Darcy velocity 0.11 m/d

 W Pumping rate 1 m3/d

 b Aquifer thickness 10 m

 Hin Inlet head 45 m

 θs Porosity 0.3

 α1 Longitudinal dispersivity 10 m

 α2 Transverse horizontal dispersivity 3 m

 cs Solute concentration at source 1000 ppm
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Results

Figure 4-1 shows the solution to the steady-state flow problem. The hydraulic head 
drops from the inlet to the outlet, and the velocity field is almost uniform, as required 
in the problem statement (Ref. 1).

Figure 4-1: COMSOL Multiphysics solution of almost uniform Darcy flow in a domain 
with a small point leak. Shown are the hydraulic head (surface plot) and velocity field 
(arrows).
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Figure 4-2: COMSOL Multiphysics results for the solute-transport problem are a near 
perfect match to the analytic solution of Ref. 1, which is shown with the numerical 
estimates of Ref. 2.

Figure 4-3 illustrates the evolution of the contaminant plume with snapshots at 
30 days, 100 days, and 360 days. The solute plume spreads with time but never 
reaches the boundary. In creating these plots, the author clipped off concentrations 
below 0.1 ppm and used an expression containing logical operators to give the same 
shading to zones with concentrations of 50 ppm or greater.
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Figure 4-3: Concentrations at 30 days (top left), 100 days (top right), and 360 days 
(bottom) for 2D fluid flow and solute transport for a continuously injecting point source; 
shown are concentrations from 0.1 ppm to 50 ppm or greater.

In the user interface you can interactively view the value at a given point by either 
clicking at the point of interest or entering the point coordinates to trigger a numeric 
readout. You can also obtain numeric results for the arbitrary expressions along a line 
or within a subdomain using cross-section and domain plots. The cross sections in 
Figure 4-4 and Figure 4-5, for example, illustrate the advective and dispersive 
components of the solute flux. The flux from chemical diffusion is zero. The 
COMSOL Multiphysics solution shown here gives results along the line y = 150 m at 
10, 30, 90, 180, and 360 days.
 4 :  S O L U T E  TR A N S P O R T  M O D E L S



Figure 4-4: Advective flux along y = 150 m at 10, 30, 90, 180, and 360 days.

Figure 4-5: Dispersive flux along y = 150 m at 10, 30, 90, 180, and 360 days.
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Figure 4-6 gives the solute concentration as a combined color and height plot.

Figure 4-6: Solute concentrations from 0.1 ppm to 50 ppm at 360 days.
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Model Library path: Earth_Science_Module/Solute_Transport/
solute_injection

Modeling Using the Graphical User Interface

The first step is to open COMSOL Multiphysics and set up two application modes.
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M O D E L  N A V I G A T O R

1 Open the Model Navigator, and from the Space dimension list select 2D.

2 From the list of application modes choose  
Earth Science Module>Fluid Flow>Darcy’s Law>Hydraulic head analysis.

3 Click the Multiphysics button, then click Add.

4 From the list of application modes choose  
Earth Science Module>Solute Transport>Saturated Porous Media>Transient analysis.

5 Click Add, then click OK.

G E O M E T R Y  M O D E L I N G

1 Go to the Draw menu and select Specify Objects>Rectangle.

2 Specify a Width of 450 and Height of 300. Click OK.

3 Click the Zoom Extents button on the Main toolbar to center the rectangle in the 
field of view.

4 Choose the menu item Draw>Specify Objects>Point. In both the x and y edit fields 
enter 150. Click OK.

O P T I O N S  A N D  S E T T I N G S

Constants
1 From the Options menu, select Constants.

2 Enter the following names, expressions, and descriptions (the descriptions are 
optional); when done, click OK.

Scalar Expressions
1 From the Options menu, select Expressions>Scalar Expressions.

NAME EXPRESSION DESCRIPTION

W 1[m^3/s] Pumping rate

b 10[m] Aquifer thickness

H_in 45[m] Inlet head

rho_f 1000[kg/m^3] Fluid density

c_s 1[kg/m^3] Solute concentration at source

SPD 1[day/s] Seconds per day
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2 Define the following expression for the solute concentration expressed in parts per 
million:

3 Click OK.

A P P L I C A T I O N  S C A L A R  V A R I A B L E S

In the Darcy’s Law application mode (esdl), the gravitational acceleration g_esdl is 
9.82 m/s2. To change the time unit to 1 day, you need to modify the value of g_esdl.

1 From the Physics menu, choose Scalar Variables.

2 In the Expression edit field for g_esdl, type 9.82[m/s^2]*SPD^2.

With this change of g_edsl, the effective time unit in the model becomes 1 day. 
Thus, wherever the user interface displays the time unit 1 s, read 1 day instead. This 
also applies in postprocessing, so you must multiply any quantity containing the 
dimension time to some power n by SPDn for the units displayed in the user 
interface and in plots to be correct. For example, when plotting the pressure, p, use 
the expression p/SPD^2, because pressure scales with time, T, as T−2.

3 Click OK.

P H Y S I C S  S E T T I N G S — D A R C Y ’ S  L A W

To set up the steady-state flow model you activate the Darcy’s Law application mode, 
enter material properties for the subdomain, give the boundary conditions, and then 
set the point flux.

Subdomain Settings
1 From the Multiphysics menu, select Darcy’s Law (esdl).

2 From the Physics menu select Subdomain Settings.

3 Verify that the model defaults are the coefficient values you need; when done, click 
OK.

NAME EXPRESSION DESCRIPTION

c_ppm 1e6*c/rho_f Solute concentration in ppm

PROPERTY VALUE

 Ks 1

 ρf 1000
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Boundary Conditions
From the Physics menu select Boundary Settings, then enter the following data; when 
done, click OK.

Point Settings
1 From the Physics menu, select Point Settings.

2 Click the Flux tab and Select Point 3.

3 In the N0 edit field for the flux, type W/b.

4 Click OK.

P H Y S I C S — S O L U T E  TR A N S P O R T

To set up the transient solute-transport model, you activate the corresponding 
application mode, enter material and solute properties for the subdomain, specify 
boundary conditions, and finish with the point flux.

Subdomain Settings
1 From the Multiphysics menu, select Solute Transport (esst).

2 From the Physics menu, select Subdomain Settings.

3 On the Flow and Media page specify information about the flow field and velocities 
from the Darcy’s Law (esdl) application mode.

Unless you specify otherwise, COMSOL Multiphysics denotes the x- and 
y-velocities as u and v. Because velocities are not dependent variables in the Darcy’s 
Law application mode, they are application mode variables that COMSOL 
Multiphysics evaluates using information from the solution. The software denotes 
application mode variables according to application mode name; here it is u_esdl for 
the x-velocity and v_esdl for the y-velocity.

SETTINGS BOUNDARY 1 BOUNDARIES 2, 3 BOUNDARY 4

Boundary condition Hydraulic head Zero flux/
Symmetry

Hydraulic head

H0 H_in 0

PARAMETER EXPRESSION

 θs 0.3

 u u_esdl

 v v_esdl
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4 On the Liquid page, set the dispersivities that describe spreading for solutes in the 
liquid phase as follows:

You normally set initial conditions on the Init page. However, the default initial 
value for solute concentrations is zero, which is the value that applies here.

5 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Enter the following settings; when done, click OK.

Point Settings
1 From the Physics menu, select Point Settings.

2 On the Flux, c page, select Point 3.

3 In the N0 edit field for the flux, type c_s*W/b.

4 In the tN0 edit field for the starting time, type 0.

5 In the tNf edit field for the ending time, type 360.

6 Click OK.

M E S H  G E N E R A T I O N

1 Select the menu item Mesh>Free Mesh Parameters.

2 Click the Subdomain tab, then select Subdomain 1. In the Maximum element size edit 
field enter 20.

3 Click the Point tab. Select Point 3, then set the Maximum element size to 1.

4 Click OK.

5 Go to the Main toolbar and click the Initialize Mesh button.

PARAMETER EXPRESSION

α1 10

α2 3

SETTINGS BOUNDARY 1 BOUNDARIES 2–4

Boundary condition Concentration Advective flux

c0 0
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C O M P U T I N G  T H E  S O L U T I O N

The solution requires two steps: First compute the steady-state solution to the flow 
problem. Then, using the velocities from the first solution step, solve the transient 
solute-transport model.

To solve the flow problem, proceed as follows:

1 Click the Solver Manager button on the Main toolbar.

2 On the Solve For page, select Darcy’s Law (esdl); make sure it is the only application 
mode selected, then click OK.

3 Click the Solve button on the Main toolbar.

To solve for solute concentrations, continue with these steps:

1 Click the Solver Parameters button on the Main toolbar.

2 From the Analysis list, select Transient. To generate outputs in 10-day increments 
from time 0 to time 360, go to the Times edit field and enter range(0,10,360). 
Click OK.

3 Click the Solver Manager button on the Main toolbar.

4 On the Solve For page, select only Solute Transport (esst). Click OK.

5 Click the Restart button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 4-1 proceed as follows:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, go to the Plot type area and select the Surface and Arrow check 
boxes.

3 Click the Surface tab. On the Surface Data page, choose Darcy’s Law (esdl)>Hydraulic 

head from the Predefined quantities list.

4 On the Arrow page, click the Subdomain Data tab. From the Predefined quantities list 
choose Darcy’s Law (esdl)>Velocity field. Go to the Arrow positioning area, and in the 
Number of points edit fields for both x points and y points enter 15. Click the Color 
button. Change the selection to black, then click OK.

5 Click Apply to generate the plot.

To generate the plot in the upper left panel of Figure 4-3, continue with these steps:

1 On the General page, find the Plot type area and clear the Arrow check box. In the 
Solution at time list select 30.
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2 Click the Surface tab. On the Surface Data page, enter c*(c<50)+50*(c>=50) in the 
Expression edit field. Click the Range button and clear the Auto check box. In the Min 
edit field enter 0.1, and in the Max edit field keep the default value (50). Click OK.

3 Click OK.

To generate the other two plots, follow these steps:

1 Choose Postprocessing>Plot Parameters and click the General tab.

2 From the Solution at time list select 90. Click Apply.

3 Repeat Step 2 but this time with a value of 360.

To generate Figure 4-4 continue with these steps:

1 From the Postprocessing menu select Cross-Section Plot Parameters.

2 In the Solution to use list select 10, 30, 90, 180, and 360. (You can choose multiple 
solution times by pressing the Ctrl key.)

3 Click the Line/Extrusion tab. Go to the y-axis data area and from the Predefined 

quantities list choose Solute Transport (esst)>Advective flux c. Edit the resulting entry 
in the Expression edit field to read adflux_c_esst/SPD. Edit the entry in the Unit 
edit field to read kg/(m^2*day). With these modifications, the y-axis gets the 
correct unit in the plot (recall the discussion under “Application Scalar Variables” 
on page 244).

4 In the Cross-section line data area, set x0 to 0, x1 to 450, and both y0 and y1 to 150.

5 In the x-axis data area, click first the lower option button and then the Expression 
button. In the X-Axis Data dialog box, type x in the Expression edit field. Click OK.

6 Click Apply.

To generate Figure 4-5, continue with these steps:

1 From the Postprocessing menu, choose Cross-Section Plot Parameters.

2 Click the Line/Extrusion tab. Go to the y-axis data area and in the Predefined 

quantities list choose Solute Transport (esst)>Dispersive flux, c. Edit the resulting 
entry in the Expression edit field to read dflux_c_esst/SPD. Edit the entry in the 
Unit edit field to read kg/(m^2*day).

3 Click OK.

To generate Figure 4-6, proceed as follows:

1 From the Options menu select Axes/Grid Settings. Click the Grid tab and clear the Auto 

check box. Clear the Auto check box in the z grid area. In the z spacing edit field 
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enter 10. Although z is not a model coordinate, you need z gridding to make a 
height plot. Click OK.

2 From the Postprocessing menu, choose Plot Parameters.

3 On the General page, click the Title button. In the edit field enter the title Solute 
concentrations in the range 0.1 ppm to 0.5 ppm [kg/m<sup>3</sup>]. 
Click OK.

4 Click the Surface tab. On the Surface Data page, the entry in the Expression edit field 
should read c_ppm*(c_ppm<50)+50*(c_ppm>=50). Click the Range button, then 
verify that the Auto check box is cleared and that the settings are 0.1 for Min and 50 
for Max. Click OK.

5 Still on the Surface page, click the Height Data tab and then select the Height data 
check box. In the Expression edit field use the same one as you entered on the Surface 

Data page. You can copy and paste the expression 
c_ppm*(c_ppm<50)+50*(c_ppm>=50) into the edit field.

6 Click Apply.

7 To view solutions for all time steps as a movie, click the Animate tab and then click 
the Start Animation button.
S O L U T E  I N J E C T I O N  |  249



250 |  C H A P T E R
Buoyan c y  F l ow w i t h  Da r c y ’ s  L aw :  T h e  
E l d e r  P r ob l em

Introduction

Density variations can initiate flow even in a still fluid. In earth systems, density 
variations can arise from naturally occurring salts, subsurface temperature changes, or 
migrating pollution. This buoyant or density-driven flow factors into fluid movement 
in salt-lake systems, saline-disposal basins, dense contaminant and leachate plumes, and 
geothermal reservoirs, to name just a few.

This example duplicates a benchmark problem for time-dependent buoyant flow in 
porous media. Known as the Elder problem (Ref. 1), it follows a laboratory experiment 
to study thermal convection. When Voss and Souza (Ref. 2) recast the Elder problem 
for salt concentrations, it became a benchmark that many researchers have used to test 
a number of variable-density flow codes including SUTRA (Ref. 3) and SEAWAT (Ref. 
4).

This model examines the Elder problem for concentrations through a 2-way coupling 
of two application modes from the Earth Science Module: Darcy’s Law and Solute 
Transport.
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Model Definition

Figure 4-7: Geometry for modeling the Elder problem. In this cross section of 
water-saturated porous media, high salt concentrations exist in the top-right region.

In this model (Figure 4-7) a vertical cross section of water-saturated porous media 
extends 300 m in the x direction and 150 m in the y direction. The material properties 
are homogeneous and isotropic. A vertical line at x = 300 m represents a symmetry 
boundary with a mirror image of the cross section extending beyond it. There is no 
flow across the geometry edges. High salt concentrations exist at the upper boundary 
(along y = 150 m) from x = 150 to 300 m. Salt concentration is zero along the lower 
boundary. The water is initially stationary (with a hydrostatic pressure distribution) and 
pristine (with zero concentration). When the density increases near the 
high-concentration boundary, flow develops. The period of interest is 20 years.

F L U I D  F L O W

You can describe the fluid flow in this problem using Darcy’s law with an extra term:

where the pressure, p (in units of kg/(s2·m)), and the concentration, c (kg/m3), are 
dependent variables. In this equation ρ is the density (kg/m3); S is the storage 
coefficient (s2·m/kg); t is the time (s); and θ is the porosity. The divergence operator 
has a velocity multiplied by a fluid density where κ equals the permeability (m2), η is 
the viscosity (kg/(s·m)), g is gravity (m/s2); and D is the vertical coordinate, y (m).

Now define density as a function of concentration according to
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Multiplying the time-rate change in concentration by γ gives the change in mass stored 
per time as a function of concentration.

The density, ρ, appears as a multiplier to the time-rate change in pressure and also as a 
scalar multiplier of the velocity

where u is the vector of directional seepage rates, also known as Darcy velocities. 
Storage is negligible in the Elder problem, and storage changes come from variations 
in density as a function of concentration.

The symmetry or zero flow on all boundaries fix only the change in pressure. For a 
unique solution, you must also specify a reference pressure. In this case, choose a point. 
Then, with the Darcy’s Law application mode, you express all these conditions as

where n is the unit vector normal to the boundary.

S O L U T E  TR A N S P O R T

The governing equation for this problem is the conservative form of the Solute 
Transport application mode

where DL is the hydrodynamic dispersion tensor (m2/d); θs is the fluid volume 
fraction; c is the dissolved concentration (kg/m3); u is the Darcy velocity (m/d); and 
Sc is the quantity of solute added per unit volume of porous medium per unit time 
(kg/(m3·d)).

In the Elder problem, the contaminant spreads only by advection and molecular 
diffusion. With a typical transport problem, the hydrodynamic dispersion tensor, DL, 

ρ ρ0 γ c c0–( ) ρ0
ρs ρ0–
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----------------- c c0–( )+=+=

u κ
η
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n κ
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θs
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----- ∇ θs– DL c uc+∇[ ]⋅+ 0=
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also contains mechanical mixing owing to variations in velocity. The diagonal 
components, DLii, of the tensor are

where α is the dispersivity (m); the subscripts “1” and “2” denote longitudinal and 
transverse flow, respectively; τ is tortuosity; and Dm is the coefficient of molecular 
diffusion (m2/s). Because the Elder problem requires diffusion alone, the first two 
terms in this expression equal zero.

The only contaminant source in the model domain is the salt concentration along the 
right half of the upper boundary. The vertical edge at x = 300 m is a symmetry 
boundary. The remaining boundaries have zero flux. The initial concentration is zero. 
The following equations represent these conditions:

where n is the unit vector normal to the boundary.

Model Data

The model works with the following data:

PARAMETER NAME VALUE

 ρ0 Fresh-water density 1000 kg/m3

 ρs Salt-water density 1200 kg/m3

 κ Permeability 4.85·10-13 m2

 η Dynamic viscosity 0.001 kg/(m·s)

 g Gravity 9.81 m/s2

 θs Porosity 0.1

 τDm Molecular diffusion rate 3.56·10-6 m2/s

 cs Salt-water concentration 285.7 kg/m3

 c0 Fresh-water concentration 0 kg/m3

θDLii α1
ui

2

u
------- α2

uj
2

u
------- τDm+ +=

n θs– DL c uc+∇[ ]⋅ 0= ∂Ω  Sides

c cs= ∂Ω  Salt

c x y 0, ,( ) 0= t 0=
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Results and Discussion

The following results come from the COMSOL Multiphysics solution to a benchmark 
buoyancy problem that is often used for both temperatures (Ref. 1) and concentrations 
(Ref. 2).

Figure 4-8 gives snapshots of concentrations at six times during the 20-year simulation 
period. Initially the water is pristine. By the end of the first year, concentrations spread 
by diffusion, creating a density gradient. The buoyancy flow begins at the edge of the 
salt contact, where there is a sharp contrast in fluid density. By the end of year three, 
the fingering of high concentrations into the reservoir is mature. By year 10, the salt 
concentrations have spread over roughly 60% of the model domain.

Figure 4-8: Snapshots of concentrations from the COMSOL Multiphysics solution to the 
buoyancy-flow benchmark developed by Voss and Souza (Ref. 2) for the Elder problem.

1 year 10 years

2 years 15 years

3 years 20 years
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Figure 4-9 shows results from Elder (Ref. 1) along with numerical estimates from the 
SUTRA (Ref. 3) and SEAWAT (Ref. 4) manuals. The COMSOL Multiphysics solution 
in Figure 4-8 is in excellent agreement with that from Elder.

Figure 4-9: Results from the Elder problem shown with concentration estimates from 
SEAWAT and SUTRA (adapted from Ref. 4).

Of interest in the Elder problem is the development of convection cells. The 
COMSOL Multiphysics plots in Figure 4-10 reveal the convection cells with the help 
of velocity streamlines, which the figure shows simultaneously with concentrations for 
Years 5, 10, 15, and 20. At early times, small convection cells develop between the 
individual fingers of the plume. At late times, a single convection cell covers the model 
domain.
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Figure 4-10: Salt concentrations (surface plot) and velocities (streamlines) from the 
COMSOL Multiphysics solution to a buoyancy benchmark problem (Ref. 2).

This example shows COMSOL Multiphysics applied to a well-known benchmark 
problem applicable to flow driven by density variations related to either temperature 
or concentration. The COMSOL Multiphysics results, here for concentration, closely 
match the benchmark solution (Ref. 2). This buoyant flow is straightforward to set up 
directly on top of a standard fluid flow and solute-transport model.
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Model Library path: Earth_Science_Module/Solute_Transport/
buoyancy_darcy_elder

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator, click the New tab, and in the Space dimension list select 2D.

2 From the list of application modes choose  
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis>Transient analysis.

3 Click the Multiphysics button. Click Add.

4 From the list of application modes choose  
Earth Science Module>Solute Transport>Saturated Porous Media>Transient analysis. 
Click Add.

5 Click the Application Mode Properties button.

6 In the Equation form list select Conservative (this step moves the velocity term inside 
the divergence operator). In the Material list select Liquid. Click OK.

7 Click OK.

G E O M E T R Y  M O D E L I N G

1 Press Shift and click the Rectangle/Square button on the Draw toolbar.

2 In the Rectangle dialog box that opens, specify the Width as 300 and the Height as 
150. Click OK to confirm the settings and close the dialog box.

3 Click the Zoom Extents button on the Main toolbar to center the rectangle in the 
field of view.

4 Shift-click the Line button on the Draw toolbar.

5 In the Line dialog box, specify a line from (x, y) = (150, 150) to (300, 150) by 
entering the space-separated values 150 300 for x and 150 150 for y, and then 
clicking OK.
B U O Y A N C Y  F L O W  W I T H  D A R C Y ’ S  L A W :  T H E  E L D E R  P R O B L E M  |  257



258 |  C H A P T E R
A P P L I C A T I O N  S C A L A R  V A R I A B L E S

The Darcy’s Law (esdl) application mode assumes that gravity g_esdl equals 9.82 m/s2 
and that the vertical dimension D_esdl is the screen’s y-axis. To set up these conditions, 
select the menu item Physics>Scalar Variables. In the g_esdl edit field enter 9.81, and 
for D_esdl enter y. Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 In the Constants dialog box, enter the following names, expressions, and 
(optionally) descriptions; when done, click OK.

3 From the Options menu, select Expressions>Scalar Expressions.

NAME EXPRESSION DESCRIPTION

rho0 1000[kg/m^3] Fresh-water density

rho_s 1200[kg/m^3] Salt-water density

kappa 4.85e-13[m^2] Permeability

eta 0.001[kg/(m*s)] Dynamic viscosity

theta_s 0.1 Porosity

tauD_m 3.56e-6[m^2/s] Molecular diffusion rate

c_s 285.7[kg/m^3] Salt-water concentration at upper right 
boundary

c0 0[kg/m^3] Fresh-water concentration at upper right 
boundary
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4 In the Scalar Expressions dialog box, enter the following names, expressions, and 
descriptions; when done, click OK.

P H Y S I C S  S E T T I N G S — D A R C Y ’ S  L A W

To set up the flow model, perform these steps: activate the Darcy’s Law application 
mode; enter material properties for the subdomain; insert the varying density as a 
scaling term; give the boundary conditions; and then add to the equation the time 
change in density with concentration.

Multiphysics
From the Multiphysics menu, select Darcy’s Law (esdl).

Subdomain Settings
1 From the Physics menu, select Subdomain Settings. Select Subdomain 1.

NAME EXPRESSION DESCRIPTION

gamma (rho_s-rho0)/(c_s-c0) Density-concentration ratio

rho rho0+gamma*c*(c>0) Density

u -kaps_esdl/eta_esdl*px Darcy velocity, x-component

v -kaps_esdl/eta_esdl* 
(py+rho*g_esdl)

Darcy velocity, y-component

c_scaled c/c_s*(c>0) Normalized dissolved concentration
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2 On the Coefficients page, enter the following values:

Here, you use the machine precision constant eps to get a small transient term that 
helps the solver to converge on a solution. The term is sufficiently small not to affect 
the solution obtained.

3 On the Scaling Factors page, enter the following settings:

Note that these settings only scale the complete equation by an overall factor (δQ is 
irrelevant because this model does not include a distributed source). This is done to 
improve convergence.

PROPERTY VALUE

 S eps

 κs kappa

ρf rho

 η eta

 Qs 0

PROPERTY VALUE

 δS rho[m^3/kg]

 δK rho[m^3/kg]
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4 On the Init page, define the initial hydrostatic pressure distribution by entering 
rho0*g_esdl*(150[m]-y) in the p(t0) edit field.

5 Click OK.

Boundary Conditions
From the Physics menu, select Boundary Settings. Verify that all the boundaries 
(numbers 1 through 5) are no-flow; for each boundary, the entry in the Boundary 

condition list should read Zero flux/Symmetry. When done, click OK.

Point Settings
With all boundaries being flux statements, you must set the pressure at a point to get 
a unique solution.

1 From the Physics menu, select Point Settings.

2 In the Point Settings dialog box, click the Pressure tab.

3 Select Point 2. For each of the variables p0 and tp0, go the corresponding Value/

Expression edit field and enter 0.

4 In the Value/Expression edit field for tpf type 20*360[d].

5 Click OK.

Equation System Settings
1 Select the menu item Physics>Equation System>Subdomain Settings.

Here you enhance the flow equation with the time change in density with 
concentration. Entries in the Subdomain Settings - Equation System dialog box 
actually change the way COMSOL Multiphysics solves a problem, so following any 
changes, COMSOL Multiphysics displays a lock on the subdomain number.
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2 Click the da tab to go where COMSOL Multiphysics picks up coefficients that 
multiply the time change in the dependent variables in this problem. Edit the 
mass-coefficient entries so they read as follows:

3 Click the Differentiate button to distribute the change throughout the equation 
system.

4 Click OK.

P H Y S I C S  S E T T I N G S — S O L U T E  TR A N S P O R T

To set up the solute-transport model, you activate the application mode, enter material 
and solute properties for the subdomain, and specify boundary conditions. You must 
also change how COMSOL Multiphysics defines the dispersion tensor to exclude 
mechanical mixing. 

Multiphysics
From the Multiphysics menu, select Solute Transport (esst).

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

Next specify the flow field and the velocities you defined earlier in the Scalar 
Expressions dialog box. You do not use the predefined velocities u_esdl and v_esdl 
from the Darcy’s Law (esdl) application mode. The reason is that with the extra 

P C

S_esdl gamma*theta_s

0 Cts_esst*theta_s_esst
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density term added inside the divergence operator, the predefined variables now 
represent mass flux instead of velocity.

2 Select Subdomain 1. On the Flow and Media page, enter the expressions in the 
following table:

3 Click the Solute tab to set the dispersivities that describe spreading for solutes in the 
liquid phase. Enter the expressions in the following table:

4 You can always set initial conditions on the Init page. However, the default initial 
value for solute concentrations is zero, which is the value needed here.

5 Click OK.

PROPERTY VALUE

 θs theta_s

u u

v v

PROPERTY VALUE

 α1 0

 α2 0

TL 1

DmL tauD_m
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Boundary Conditions
From the Physics menu, select Boundary Settings. Set the conditions and enter 
expressions for the various boundaries as in this table; when done, click OK.

Equation System Settings
1 Choose Physics>Equation System>Subdomain Settings, then click the Variables tab.

Here you change the preset definitions for the Application mode subdomain variables 
that dictate how COMSOL Multiphysics calculates the dispersion tensor 
components.

2 Scroll down the list of predefined variables until you find the following and edit 
them so they read as follows:

3 Click Differentiate, then click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Fine. Click the Custom mesh size option 
button and in the Element growth rate edit field type 1.15.

3 Click the Boundary tab, then select Boundaries 1–3 and 5. In the Maximum element 

size edit field type 10. For Boundary 4, enter a Maximum element size of 5.

4 Click the Point tab. Select Point 3, then enter a Maximum element size of 1. For 
Point 5 enter a Maximum element size of 3.

5 Click Remesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

COMSOL Multiphysics solves the flow and transport problems simultaneously.

SETTINGS BOUNDARY 2 BOUNDARY 4 BOUNDARIES 1, 3, 5

Boundary condition Concentration Concentration No flux/Symmetry

c0 c0 c_s

NAME EXPRESSION

thDLxx_c_esst theta_s_esst*tauL_c_esst*DmL_c_esst

thDLxy_c_esst 0

thDLyx_c_esst 0

thDLyy_c_esst theta_s_esst*tauL_c_esst*DmL_c_esst
 4 :  S O L U T E  TR A N S P O R T  M O D E L S



1 From the Solve menu, choose Solver Parameters. Look in the Solver list and verify 
that the Time dependent solver is selected.

2 In the Times edit field, type 360*86400*range(0,24) to generate outputs from 0 
to 20 years in 1-year increments.

3 As the Absolute tolerance expression, enter p 0.1 c 0.001. Doing so sets a different 
error tolerance for pressure than concentration because their magnitudes differ 
significantly.

4 Click OK to close the dialog box, then click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the images in Figure 4-8 proceed as follows:

1 From the Postprocessing menu, select Plot Parameters.

2 Click the Surface tab. In the Expression edit field on the Surface Data page, type 
c_scaled.

3 Click the Contour tab. Select the Contour plot check box. In the Expression edit field 
on the Contour Data page, type c_scaled.
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4 In the Contour levels area, click the Vector with isolevels option button, and in the 
corresponding edit field type 0.2 0.6 0.8.

5 Click the General tab.

6 From the Solution at time list, choose the first nonzero entry then click Apply to 
generate the plot for Year 1.

To generate the plot for the subsequent years, recall that the solutions in the list 
correspond to 0 to 20 years with 1-year increments.

7 To view the solutions for all time steps as a movie, go to the Animate page and click 
Start Animation.

To generate the images in Figure 4-10, follow these steps:

1 Return to the Plot Parameters dialog box and click the General tab. In the Plot type 
area, clear the Contour check box and select the Streamline check box. Make a 
selection in the Solution at time list as desired.

2 Click the Streamline tab. From the Predefined quantities list on the Streamline Data 
page, select Darcy’s Law (esdl)>Velocity field.

3 From the Streamline plot type list, select Magnitude controlled. On the Density page, 
set the Density to 10.

4 Click the Line Color tab. Click the Uniform color option button, then click the Color 
button. In the Streamline Color dialog box, select black, then click OK.

5 Click Apply to generate the first plot.

6 Return to the General page and select the desired solutions in the Solution at time 
list, clicking Apply in-between to generate the plots.

7 To view the solutions for all time steps as a movie, go to the Animate page and click 
Start Animation.
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V a r i a b l y  S a t u r a t e d  F l ow and 
T r a n s po r t :  S o r b i n g  S o l u t e

Introduction

This example details two assessments of time-dependent fluid flow and solute transport 
for a variably saturated system. In the first transport scenario, “Sorbing Solute,” a 
chemical sorbs to soil particles and biodegrades. In the second scenario, “Pesticide 
Transport and Reaction in Soil” on page 288, the pesticide aldicarb transforms to 
daughter products, which you then track. The inspiration for the two problems comes 
from the manuals of SWMS_2D (Ref. 1) and HYDRUS-2D (Ref. 2).

Figure 4-11: Geometry of the infiltration ring and soil column.

The two chemical-transport scenarios from this example build on top of the same 
variably saturated flow model. It uses the Richards’ equation interfaces to define 
nonlinear relationships with retention and permeability properties according to van 
Genuchten (Ref. 3). In the Richards’ Equation application mode you can also define 
these material properties by interpolation from experimental data (see “Interpolation 
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for Unsaturated Flow” on page 114) and the Brooks and Corey analytic permeability 
and retention formulas (Ref. 4).

The two variably saturated flow and solute-transport models included here are inspired 
by but do not exactly duplicate the SWMS2D and HYDRUS2D examples. The main 
distinction lies in the governing equations. SWMS2D and HYDRUS2D use a form of 
Richards’ equation that accounts for change in fluid volume fraction with time. The 
Richards’ Equation application mode additionally accounts for changes in storage 
related to variations in pressure head according to Bear (Ref. 5) among others. 
Another point of departure is that with the storage terms, the solute-transport 
equations in the Earth Science Module also account explicitly for time change in liquid 
and air content. Moreover, the problems here address isothermal conditions. For 
nonisothermal flow see “Free Convection in Porous Media” on page 338.

Model Definition—Sorbing Solute

In the fluid-flow model, water moves from a ring on the ground into the subsurface. 
The 0.25-m radius ring ponds the water to a depth of 0.01 m but is open to the ground 
surface. Permeable soils exist to a depth of 1.3 m. The soil in the uppermost 0.4 m is 
slightly less permeable than the one 0.9 m below it. The lower layer sits above relatively 
impermeable soil, so only a very small amount of leakage exits from the base. The flow 
is symmetric about the line x = 0. No flow crosses the surface outside the ring. 
According to the problem statement there is no flow across the line x = 1.25 m. The 
initial distribution of pressure heads is known. 

The water in the ring contains a dissolved solute at a constant concentration, c0. The 
solute enters the ground with the water and moves through the subsurface by 
advection and dispersion. Additionally, the solute sorbs or attaches to solid surfaces, 
which reduces the aqueous concentrations and also slows solute movement relative to 
the water. Microbial degradation also reduces both the liquid- and the solid-phase 
concentrations. The sorption and the biodegradation are linearly proportional to 
aqueous concentrations. The fluid in the ring is the only chemical source, and the 
solute is free to leave the soil column with the fluid flux. Initially the soil is free of the 
solute. You track its transport for ten days.

F L U I D  F L O W

Richards’ equation governs the saturated-unsaturated flow of water in the soil. The soil 
air is open to the atmosphere, so you can assume that pressure changes in air do not 
affect the flow and use Richards’ equation here for single-phase flow. Given by Ref. 5, 
Richards’ equation reads
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where C denotes specific moisture capacity (m−1); Se is the effective saturation of the 
soil (dimensionless); S is a storage coefficient (m−1); Hp represents the dependent 
variable pressure head (m); t is time (d); K equals the hydraulic conductivity function 
(m/d); D is the coordinate (for example, x, y, or z) that represents vertical elevation 
(m); and Qs is a fluid source defined by volumetric flow rate per unit volume of soil 
(d−1). In this problem, S = (θs − θr)/(1 m) where θs and θr denote the volume fraction 
of fluid at saturation and after drainage, respectively. 

With variably saturated flow, fluid moves through but may or may not completely fill 
the pores in the soil, and θ denotes the volume fraction of fluid within the soil. The 
coefficients C, Se, and K vary with the pressure head, Hp, and with θ, making Richards’ 
equation nonlinear. The specific moisture capacity, C, relates variations in soil moisture 
to pressure head as C = ∂θ/∂Hp. In the governing equation, C defines storage changes 
produced by varying fluid content because C ∂Hp/∂t = ∂θ/∂t. Because C, the first term 
in the time coefficient, goes to zero at saturation, time change in storage relates to 
compression of the aquifer and water under saturated conditions. The saturated 
storage comes about with the effective saturation, as represented by the second term 
in the time-coefficient. Furthermore, K is a function that defines how readily the 
porous media transmits fluid. The relative permeability of the soil, kr, increases with 
fluid content giving K = Kskr, where Ks (m/d) is the constant hydraulic conductivity 
at saturation.

This example uses predefined interfaces for van Genuchten (Ref. 3) formulas to 
represent how the four retention and permeability properties θ, C, Se, and kr = K/Ks 
vary with the solution Hp. The van Genuchten expressions read as follows:

C SeS+( )
Hp∂
t∂

---------- ∇ K Hp D+( )∇–( )⋅+ Qs=
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where α, n, m, and l are constants that specify the type of medium, with m = 1 − 1/n. 
In the equations, the system reaches saturation when fluid pressure is atmospheric (that 
is, Hp = 0). When the soil fully saturates, the four parameters reach constant values. 

The problem statement records all the boundary conditions you need for this model. 
The level of water in the ring is known at 0.01 m, giving a Dirichlet constraint on 
pressure head. Approximate the small leak from the base, N0, as 0.01Ks. With no flow 
crossing the surface outside of the pressure ring or the vertical walls, the following 
expressions summarize the boundary conditions:

In these expressions, n is the unit vector normal to the bounding surface.

θ =
θr Se θs θr–( )+

θs
⎩
⎪
⎨
⎪
⎧

Hp 0<

Hp 0≥

Se =

1

1 αHp
n

+[ ]
m

-------------------------------------

1⎩
⎪
⎨
⎪
⎧

Hp 0<

Hp 0≥

C =
αm

1 m–
-------------- θs θr–( )Se

1
m
-----

1 Se

1
m
-----

–
⎝ ⎠
⎜ ⎟
⎛ ⎞

m

0⎩
⎪
⎪
⎨
⎪
⎪
⎧

Hp 0<

Hp 0≥

kr = SeL 1 1 Se

1
m
-----

–
⎝ ⎠
⎜ ⎟
⎛ ⎞

m

–

2

1⎩
⎪
⎪
⎨
⎪
⎪
⎧

Hp 0<

Hp 0≥

Hp Hp0= ∂Ω Ring

n Kskr∇ Hp D+( )–[ ]⋅ 0= ∂Ω Surface

n Kskr∇ Hp D+( )–[ ]⋅ 0= ∂Ω Sides

n Kskr∇ Hp D+( )–[ ]⋅ 0= ∂Ω Symmetry

n Kskr∇ Hp D+( )–[ ]⋅ N0= ∂Ω Base
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A unique solution to a time-dependent problem requires an initial condition. In the 
problem statement, the initial condition came from results of another simulation. For 
this example model, you fit a simple equation to the June 1982 results shown in 
Example 4 from SWMS2D (Ref. 1) and run a short simulation without the ring to 
warm up the flow field. That simulation also assumes that there is no flow across the 
surface beneath the ring.

M U L T I P H Y S I C S  C O U P L I N G

Groundwater flow and solute transport are linked by fluid velocities. With the form of 
the transport equation that follows, the fluid velocities need to come from Darcy’s law:

 (4-1)

In this expression, u is a vector of directional velocities often termed specific discharge 
(m/d). In COMSOL Multiphysics, u and v denote the velocities in the x and 
y directions, respectively, that make up u.

S O L U T E  TR A N S P O R T

The equation that governs advection, dispersion, sorption, and decay of solutes in 
groundwater is

It describes time rate of change in two terms: c denotes dissolved concentration (kg/
m), and cP is the mass of adsorbed contaminant per dry unit weight of solid (mg/kg). 
Further, θ denotes the volume fluid fraction (dimensionless), and ρb is the bulk density 
(kg/m3). Because ρb amounts to the dried solid mass per bulk volume of the solids 
and pores together, the term ρb cP gives solute mass attached to the soil as a 
concentration. In the equation, DL is the hydrodynamic dispersion tensor (m2/d); RL 
represents reactions in water (kg/(m3·d)); and RP equals reactions involving solutes 
attached to soil particles (kg/(m3·d)). Finally, Sc is solute added per unit volume of 
soil per unit time (kg/(m3·d)). 

It is far more convenient to solve the above equation only for dissolved concentration. 
This requires expanding the left side to

and inserting a few definitions.

u Kskr Hp D+( )∇=

t∂
∂ θc( )

t∂
∂ ρbcP( ) ∇ θ– DL c uc+∇[ ]⋅+ + ΣRL ΣRP S+ + c=

t∂
∂ θc( )

t∂
∂ ρbcP( )+ θ c∂

t∂
----- c θ∂

t∂
------ ρb

cp∂
c∂

-------- c∂
t∂

-----+ +=
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In this problem, solute mass per solid mass, cP, relates to dissolved concentration, c, 
through a linear isotherm or partition coefficient kP (m

3/kg) where cP = kP c. Because 
the relationship is linear, the derivative is kp = ∂cP/∂c. Making those substitutions gives 
the form of the solute transport problem you solve:

In the equation,  and  denote the decay rates (d−1) for the dissolved and sorbed 
solute concentrations, respectively.

Note that you employ results from the flow equation in the solute-transport model as

You enter this directly into the COMSOL Multiphysics user interface using the 
time-rate change in pressure head. Note that COMSOL Multiphysics solves for 
pressure, p, and converts to Hp based on the fluid weight.

The hydrodynamic dispersion tensor, DL, describes mechanical spreading from 
groundwater movement in addition to chemical diffusion:

where DLii are the diagonal entries in the dispersion tensor; DLij are the cross terms; 
α is the dispersivity (m); the subscripts “1” and “2” denote longitudinal and transverse 
flow, respectively; Dm denotes the coefficient of molecular diffusion (m2/d); and τL is 
a tortuosity factor that reduces impacts of molecular diffusion for porous media relative 
to free water. Here τL = θ 7/3 θs

−2.

The boundary and initial conditions in the sorbing-solute problem are straightforward. 
The solute enters only with the water from the ring at a concentration c0. The solute 
is free to leave, but there is only minimal leakage from the lower boundary and no flow 
from the sides. Transport is symmetric about the line x = 0. The boundary conditions 
in this problem are:

θ ρbkp+[ ] c∂
t∂

----- c θ∂
t∂

------ ∇ θ– DL c uc+∇[ ]⋅+ + θφLc ρbkpφPc S+ + c=

φL φP

c θ∂
t∂

------ cC
Hp∂
t∂

----------=

θDLii α1
ui

2

u
------- α2

uj
2

u
------- θDmτL+ +=

θDLij θDLij α1 α2–( )
uiuj

u
-----------= =
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where n is the unit vector normal to the boundary. Because the soil is pristine at the 
start of the experiment, the initial condition is one of zero concentration.

I M P L E M E N T A T I O N — L O G I C A L  O P E R A T O R S

This analysis uses logical operators to “warm up” the flow model for 0.1 days. The 
warm-up time smooths out the approximate equation for initial head to produce the 
smoothly varying, physically based velocity field needed to yield reasonable solute 
concentrations. You can use the Solver Parameters and Solver Manager dialog boxes to 
run a warm-up flow simulation first and use those results as initial conditions in the 
coupled-flow and transport problem as a follow-up step. The virtue of using logical 
operators here is that they circumvent the staged or multistep process.

Logical statements involve relational operators, which can be powerful tools for 
modeling in COMSOL Multiphysics. Multiplication of a constant or expression by a 
logical statement qualifies when, where, and how a model uses that expression or 
constant. For example, specifying c as c0*(t>1) means that the concentration equals 
c0 for all times greater than 1, whereas multiplication by (t>1)*(t<5) means all times 
between t = 1 day and t = 5 days.

This model uses the logical expressions as boundary conditions. For the flow problem, 
you need zero flow across the boundary during the warm-up time and a constant 
pressure head of 0.01 m thereafter. If you start the simulation at t = −0.1 days, you 
then turn on the constant pressure head and concentration at the ring at t = 0 with 
these equations:

c c0= ∂Ω Ring

n θ– DL c∇[ ]⋅ 0= ∂Ω Surface

n θ– DL c∇[ ]⋅ 0= ∂Ω Sides

n θ– DL c uc+∇[ ]⋅ 0= ∂Ω Symmetry

n θ– DL c∇[ ]⋅ 0= ∂Ω Base

Hp
n– K– skr Hp D+( )∇[ ]⋅ 0=

Hp 0.01 m=
⎩
⎪
⎨
⎪
⎧

t 0<
0 t≤

∂Ω Ring

c n θsDL c∇ uc–( )⋅ 0=

c 1 kg/m3
=⎩

⎪
⎨
⎪
⎧

t 0<
0 t≤

∂Ω Ring
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Using logical operators, you can implement the expressions for pressure head. Use the 
general Neumann boundary condition

On the right side of the equation, Hp is the solution, D is the current elevation, and 
all other terms are constants that you can define arbitrarily. Here set q0 = 0, 
Rb = 1 d−1, Hpb = 0.01 m, and Db = D for t > 0 by multiplication with logical 
operators. Hpb=0.01*(t>=0) means Hpb has a value of 0.01 m for all times greater 
than or equal to zero.

For concentration, use modified logic with the flux boundary expression

During the flow model’s warm-up there is no solute moving from the pressure ring 
N0 = 0. This is a Neumann condition on flux. Throughout the coupled-flow and 
transport problem, however, the solute concentration cring = 1 kg/m3, which is a 
Dirichlet condition on concentration. The logical operators use what is known as a 
“stiff-spring” condition to implement the switch between the two boundary types.

I M P L E M E N T A T I O N — S T I F F - S P R I N G  C O N D I T I O N

A stiff-spring condition uses weighting to make a Neumann statement about flux but 
achieves a Dirichlet condition on pressure head. The stiff-spring expression

specifies the flux using a heavily weighted equivalence for concentration. Rephrased, 
the stiff-spring statement

sets cring to 1 kg/m3 plus some small number. Because this offers virtually no 
information about the flux, it varies freely. In this model, set 
N0 = (106 m/d)· (c − 1 kg/m3) (t ≥ 0).

n– K– skr Hp D+( )∇[ ]⋅ q0 Rb Hpb Hp–( ) Db D–( )+[ ]+=

n θsDL c∇ uc–( )⋅ N0=

n θsDL c∇ uc–[ ]⋅ N0 106 cring 1 kg/m3
–( ) m

d
-----= =

cring 1 kg/m3 n θsDL c∇ uc–( )⋅

106 m/d
-----------------------------------------------+=
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M O D E L  D A T A

The following table provides data for the fluid-flow model:

The inputs needed for the solute-transport model are:

Results and Discussion

Figure 4-12 and Figure 4-13 give the solution to the fluid-flow problem at 0.3 and 
1 day, respectively. The images show effective saturation (surface plot), pressure head 
(contours), and velocities (arrows). The figures illustrate the soil wetting with time. As 

VARIABL
E

UNIT DESCRIPTION UPPER LAYER LOWER LAYER

 Ks m/d Saturated hydraulic conductivity 0.298 0.454

 θs Porosity/void fraction 0.399 0.339

 θr Residual saturation 0.0001 0.0001

 α m-1 alpha parameter 1.74 1.39

 n n parameter 1.38 1.60

 m m parameter 1-1/n 1-1/n

 l Pore connectivity parameter n/a

  Hps m Pressure head in ring 0.01

  Hp0 m Initial pressure head -(y+1.2)* (y<-0.4)+ 
(-(y+1.2)-0.2* 
(y+0.4))* (-0.4<=y)

-(y+1.2)* (y<-0.4)+ 
(-(y+1.2)-0.2* 
(y+0.4))* (-0.4<=y)

VARIABL
E

UNITS DESCRIPTION VALUE

 rb kg/m3 Bulk density 1400

 kp m3/kg Partition coefficient 0.0001

 Dm m2/d Coefficient of molecular diffusion 0.00374

 τL Tortuosity factor  θ7/3 θs
-2

 α1 m Longitudinal dispersivity 0.005

 α2 m Transverse dispersivity 0.001

 d-1 Decay rate in liquid 0.05

 d-1 Decay rate on solid 0.01

 cs kg/m3 Solute concentration in ring 1.0

 c0 kg/m3 Initial solute concentration in soil 0

φL

φP
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the arrows indicate, the velocities just below the ring are high relative to the remainder 
of the soil column.

Figure 4-12: Estimates of effective saturation (surface plot), pressure head (contours), and 
velocity (arrows) in variably saturated soil after 0.3 days.
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Figure 4-13: Estimates of effective saturation (surface plot), pressure head (contours), and 
velocity (arrows) in variably saturated soil after 1 day.

Figure 4-14 and Figure 4-15 give the concentrations for 0.3 days and 1 day, 
respectively, along with the retardation factor. They illustrate how the solute 
concentrations (surface plot) enter and move through the soil. Because the retardation 
factor depends on soil moisture, its value varies with the solution.
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Figure 4-14: Solution for dissolved concentrations (surface plot) and retardation factor 
(contours) at 0.3 days.
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Figure 4-15: Solution for dissolved concentrations (surface plot) and retardation factor 
(contours) at 1 day.

Figure 4-16 shows an image of the retardation factor at the end of the simulation time 
interval. For variably saturated solute transport, the retardation factor changes with 
time. As shown in this image, the process of sorption has the greatest potential to slow 
the contaminant where the soils are relatively dry for this example. The retardation 
coefficient here ranges from roughly 1.35 to 1.55, and the solute moves at 
approximately the velocity of the groundwater.
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Figure 4-16: Snapshot of the retardation factor (surface and contours) at 5 days.
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Model Library path: Earth_Science_Module/Solute_Transport/
sorbing_solute

Modeling Using the Graphical User Interface

The following steps walk you through this model, setting up both the Richards’ 
Equation application mode and the Solute Transport application mode. You can easily 
bypass a few of the details by using the example “Interpolation for Unsaturated Flow” 
on page 114 and adding to it the transport application. To do so, open the model file, 
add the Solute Transport application mode as described in the following description 
and then skip to the section “Physics Settings—Solute Transport”.

To start from scratch, first add the Richards’ Equation application mode:

M O D E L  N A V I G A T O R

1 Open the Model Navigator. From the Space dimension list, select Axial symmetry (2D).

2 In the list of application modes, select Earth Science Module>Fluid Flow>Richards’ 

Equation>Pressure head analysis>Transient analysis.

3 Click the Multiphysics button, then click Add.

4 In the list of application modes, select Earth Science Module>Solute Transport> 
Variably Saturated Porous Media>Transient analysis. Click Add.

5 Click OK.

G E O M E T R Y  M O D E L I N G

You create the geometry by drawing two rectangles and then adding line.

1 Choose Draw>Specify Objects>Rectangle.

2 Specify the following settings; when done, click OK.

3 Click the Zoom Extents button on the Main toolbar.

PARAMETER EXPRESSION

Width 1.25

Height 1.3

r 0

z -1.3
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4 Again choose Draw>Specify Objects>Rectangle.

5 Specify the following settings; when done, click OK.

6 Choose Draw>Specify Objects>Line. In the r edit field enter 0 0.25, and in the z edit 
field enter 0 0. Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Choose Options>Constants.

2 In the Constants dialog box, enter the following data (the descriptions are optional); 
when done, click OK.

P H Y S I C S  S E T T I N G S — R I C H A R D S ’  E Q U A T I O N

Application Scalar Variables
To set the vertical direction and gravitational constant in the model, go to the Physics 
menu and open the Scalar Variables dialog box. Make the following modifications to 
the defaults. Here you convert from seconds to days and square the quantity because 
you are dealing with acceleration. When done, click OK.

Subdomain Settings—Richards’ Equation
1 From the Multiphysics menu, choose Richards’ Equation (esvr).

2 Choose Physics>Subdomain Settings.

PARAMETER EXPRESSION

Width 1.25

Height 0.4

r 0

z -0.4

NAME EXPRESSION DESCRIPTION

phiL 0.05[1/s] Decay rate in liquid

phiP 0.01[1/s] Decay rate on solid

rhob 1400[kg/m^3] Bulk density

kp 0.0001[m^3/kg] Partition coefficient

NAME EXPRESSION

D_esvr z

g_esvr 9.82*86400^2
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3 On the Coefficients page, enter the following settings:

4 On the van Genuchten page, make the following changes:

5 Click the Init tab. Select both subdomains simultaneously using the Ctrl key, then 
enter the following expression:

6 Click OK.

Boundary Conditions—Richards’ Equation
1 From the Physics menu, choose Boundary Settings.

2 In the Boundary Settings dialog box, enter these settings; when done, click OK.

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

 Constitutive relation van Genuchten van Genuchten

 θs 0.339 0.399

 θr 0 0.0001

 Storage term User defined User defined

 S 0.339 0.399

 Ks 0.454 0.298

 ρf 1000 1000

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

 α 1.39 1.74

 n 1.6 1.38

 l 0.5 0.5

SETTING SUBDOMAINS 1, 2

HP(t0) -(z+1.2)*(z<-0.4)+(-(z+1.2)-0.2*(z+0.4))*(-0.4<=z)

SETTINGS BOUNDARIES 1, 3, 4, 6–8 BOUNDARY 2 BOUNDARY 5

Boundary 
condition

Zero flux/Symmetry Inward flux Mixed

N0 -0.454/100 0

Rb 1*(t>=0)

Hpb 0.01*(t>=0)

Db D_esvr*(t>=0)
V A R I A B L Y  S A T U R A T E D  F L O W  A N D  TR A N S P O R T :  S O R B I N G  S O L U T E  |  283



284 |  C H A P T E R
P H Y S I C S  S E T T I N G S — S O L U T E  TR A N S P O R T

Subdomain Settings—Solute Transport
1 From the Multiphysics menu, select Solute Transport (esst).

2 Choose Physics>Subdomain Settings.

3 On the Flow and Media page, enter the following settings:

4 On the Liquid page, make the following changes:

5 On the Solid page, make the following changes;

6 Click OK.

Boundary Conditions—Solute Transport
1 From the Physics menu, choose Boundary Settings.

SETTINGS SUBDOMAINS 1, 2

 θ theta_esvr

 θs thetas_esvr

u u_esvr

v v_esvr

SETTINGS SUBDOMAINS 1, 2

 α1 0.005

 α2 0.001

DmL 0.00374

RL -phiL*theta_esvr*c

So -c*C_esvr*pt

TERM SUBDOMAINS 1, 2

 ρb rhob

KP kp

RP phiP*kp*rhob*c
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2 In the Boundary Settings dialog box enter the following settings:

The factor 106 m/d is a large velocity that implements the stiff-spring condition 
(see “Implementation—Stiff-Spring Condition” on page 274); it should not be 
interpreted as a physical velocity. The added unit makes the flux expression 
dimensionally correct.

3 Click OK.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 Click the Boundary tab. Select the upper surface and the break between the two soil 
layers (Boundaries 4–6). Set the Maximum element size to 0.02, then click OK.

3 Click the Initialize Mesh button on the Main toolbar. 

C O M P U T I N G  T H E  S O L U T I O N

1 Select the menu item Solve>Solver Parameters.

2 On the General page, find the Time stepping area and in the Times edit field enter 
-0.1 0 10^(range(-3,0.1,-1)) range(0.2,0.1,1) range(2,5).

This gives you 21 exponentially increasing inputs from 0.001 to 0.1 day; 0.1-day 
increments through Day 1; and 1-day increments until Day 5.

3 Click the Advanced tab. Set the Type of scaling to Manual. Enter p 1e10 c 1 in the 
Manual scaling edit field. Click OK. 

4 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 4-12, follow these steps:

1 Choose Postprocessing>Plot Parameters.

2 On the General page, go to the Plot type area and select the Surface, Contour, and 
Arrow check boxes. In the Solution at time list select 0.3.

3 Click the Surface tab. In the Expression edit field, type Se_esvr, which stands for the 
effective saturation, Se, calculated with this application mode, named esvr.

SETTINGS BOUNDARIES 1, 3, 6 BOUNDARIES 2, 7, 8 BOUNDARY 5

Boundary condition No flux/Symmetry Advective flux Flux

N0 1e6[m/s]* 
(-c+1)*(t>=0)
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4 Click the Contour tab. From the Predefined quantities list, select Richards’ Equation 

(esvr)>Pressure head. In the Contour levels area, click the option button associated 
with Vector with isolevels, then type range(-2,0.1,2) in the associated edit field. 
In the Contour color area, click first the Uniform color option button and then the 
Color button. Change the color to black, then click OK. Clear the Color legend check 
box.

5 Click the Arrow tab. From the Predefined quantities list, select Richards’ Equation 

(esvr)>Velocity field. In the Arrow parameters area, click the Color button. Choose 
black as the color, then click OK. Clear the Auto check box and change the Scale factor 
to 0.5. Click Apply.

To generate Figure 4-13 on page 277, proceed as follows:

1 Still in the Plot Parameters dialog box, click the General tab.

2 In the Solution at time list select 1, then click Apply.

To generate the plot in Figure 4-14 and Figure 4-15, continue with these steps:

1 On the General page, clear the Arrow check box and choose 0.3 from the Solution at 

time list.

2 Click the Surface tab. From the Predefined quantities list, select Solute Transport 

(esst)>Concentration, c.

3 Click the Contour tab. From the Predefined quantities list, select 
Solute Transport (esst)>Retardation factor of c. In the Contour levels area, click the 
Number of levels option button and then type 10 in the associated edit field. In the 
Contour color area, click the Color button. Change the color to white, then click OK.

4 Click Apply to generate the plot in Figure 4-14.

5 Return to the General page. In the Solution at time list select 1.

6 Click Apply to generate the plot in Figure 4-15.

Finally, to generate Figure 4-16 on page 280, follow these steps:

1 While still on the General page, select 5 from the Solution at time list.

2 Click the Surface tab. From the Predefined quantities list, select 
Solute Transport (esst)>Retardation factor of c.

3 Click the Contour tab. In the Contour color area, click the Color button. Change the 
color to black, then click OK. Click OK to generate the plot.
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S A V I N G  T H E  M O D E L

This completes the model. In the following sections you add new equations and terms. 
To save the current model, choose File>Save As, enter a file name, and then click Save.
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Pe s t i c i d e  T r a n s po r t  and R e a c t i o n  i n  
S o i l

Introduction

Aldicarb is a commercial pesticide, used on a variety of crops, including cotton, sugar 
beet, citrus fruits, potatoes, and beans. The general population may be exposed to 
aldicarb primarily through the ingestion of contaminated water and foods.

This example looks at the degradation kinetics of aldicarb and its toxic by-products, 
investigating both the degradation time-scale as well as the spatial concentration 
distribution of toxic components. In the first model the chemicals are contained in a 
water pond, treated as a perfectly mixed system. The second model tracks the detailed 
distribution of chemicals in soil as the pesticide leaches out of the pond and is 
transported in water through the ground.

The reaction kinetics describing the degradation pathways of aldicarb is exported to 
the Solute Transport application mode of the Earth Science Module. In COMSOL 
Multiphysics the solute transport is coupled to fluid flow as described by Richards’ 
equation.

Note: This model requires the COMSOL Reaction Engineering Lab and the Earth 
Science Module.

Model Definition

Aldicarb degrades by transformation to the corresponding sulfoxide and the sulfone 
(both of which are toxic), and is detoxified by hydrolysis to oximes and nitriles. The 
chain of reactions is illustrated in Figure 4-17. The toxicity of a chemical species is 
indicated by its LD50 value, signifying the dose (mg/kg) lethal to half of a test 
population of rats. As indicated, both the sulfoxide and solfone analogues of aldicarb 
are also relatively toxic.
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Figure 4-17: Reaction pathways of aldicarb degradation.

Each of the j  unimolecular reactions outlined above has a rate expression of the form

Note that in this example the concentration unit is kg/m3 and the rate constants are 
expressed in 1/day.

PE R F E C T L Y  M I X E D  S Y S T E M

The first model solves for the decomposition kinetics of aldicarb occurring in a water 
pond. The pond is treated as a closed and perfectly mixed system. The reaction 
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mechanism illustrated in Figure 4-17 translates into the following mass balance 
equations:

• For aldicarb (a)

• For aldicarb sulfoxide (asx)

• For aldicarb sulfone (asn)

• For aldicarb oxime (ao)

• For aldicarb sulfoxide oxime (asxo)

• For aldicarb sulfone oxime (asno)

Solving this set of coupled ODEs outlined above provides information on the time 
scale of the degradation processes.

S P A C E -  A N D  T I M E - D E P E N D E N T  S Y S T E M

In a more detailed model, you assume that aldicarb moves from the pond into 
relatively dry soil. In the soil, the aldicarb decomposes according to the mechanism 
illustrated in Figure 4-17. In addition, the pesticide and its decay products are 
transported by advection, dispersion, sorption, and volatilization.

td

dca r1– r3–=

td

dcasx r1 r2– r4–=

td

dcasn r2 r5–=

td

dcao r3=

td

dcasxo r4=

td

dcasno r5=
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Geometry
Water is ponded by a ring sitting on the ground. The soil is layered and rests on rocks. 
Water moves through the bottom of the ring into the soil. The water level in the ring 
is known. There is no flow through the vertical walls or the surface outside of the ring.

Figure 4-18: Geometry of the infiltration ring and soil column.

Aldicarb moves with water from the pond into the soil at a constant concentration. In 
the soil, the chemicals react and also sorb onto soil particles. Aldicarb and the aldicarb 
sulfone volatilize to the atmosphere. The sorption, biodegradation, and volatilization 
proceed in linear proportion to the aqueous concentrations. The soil is initially pristine 
with zero concentration of the involved chemicals. At the ground surface outside the 
ring, there is volatilization to the atmosphere for ca and casn. The vertical axis is a line 
of symmetry. The other boundaries are posed such that the solutes can freely leave the 
soil column with the fluid flow. You can model the problem with 2D axisymmetry and 
track the solute transport for 10 days.

Fluid Flow
Richards’ equation governs the saturated-unsaturated flow of water in soil (Ref. 1) and 
is implemented in the Richards’ equation application mode:
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Here, C denotes specific moisture capacity (m−1), Se is the effective saturation of the 
soil, S is a storage coefficient (m−1), Hp represents the dependent variable pressure 
head (m), t is time (d), K = Ks kr equals the hydraulic conductivity function (m/d), D 
is the coordinate representing vertical elevation (for example, x, y, or z; m), and Qs is 
a fluid source defined by volumetric flow rate per unit volume of soil (d−1). In this 
problem, S = θs − θr, where θs and θr denote the volume fraction of fluid at saturation 
and after drainage, respectively. 

You can find more details on the Richards’ Equation application mode in the Earth 
Science Module User’s Guide.

Mass Transport
The governing equation for solute transport describes advection and dispersion of a 
sorbing, volatilizing, and decaying solute in variably saturated soil.

 (4-2)

Equation 4-2 is implemented in the Solute Transport application mode. The first 
bracketed term explains the change in solute mass per volume per time for the liquid-, 
solid-, and air-phase concentrations. The second term explains the changes in storage 
because the water content in the soil varies in time. The third bracketed expression 
represents the overall solute flux due to liquid dispersion, diffusion (liquid and air), and 
advection with moving water. The right side explains reactions and generalized 
sources.

Solute spreading now includes mechanical dispersion in water plus molecular diffusion 
for water and air. These three processes appear in the liquid-gas dispersion tensor, 
whose entries are

 (4-3)

 (4-4)
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In this equation, DLGii are the principal components of the liquid-gas dispersion 
tensor; DLGij and DLGji are the cross terms; α is the dispersivity (m) where the 
subscripts “1” and “2” denote longitudinal and transverse flow, respectively. Dm and 
DG (m2/d) are molecular diffusion, while τL and τG give the tortuosity factors for 
liquid (water) and gas (air), respectively. 

The three solutes—aldicarb, aldicarb sulfoxide, and aldicarb sulfone—have different 
decay terms, RLi, partition coefficients, kPi, and volatilization constants, kGi. All of the 
solutes attach to soil particles. Two of the solutes volatilize; sulfoxide does not.

Results

First, review the results of the perfectly mixed reactor model, solved in COMSOL 
Reaction Engineering Lab.

Figure 4-19 shows the concentration profile of aldicarb and all of its decay products. 
Only small amounts of aldicarb remain after 10 days. Figure 4-20 shows concentration 
transients of the most toxic species aldicarb, aldicarb sulfoxide, and aldicarb sulfone, as 
well as the sum of these three components (see Figure 4-17 for LD50 values). 
Considering the summed contributions, contamination levels clearly remain high even 
after several months.

Figure 4-19: Concentration profiles (kg/m3) as reactions occur during a 100 day time 
period.
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Figure 4-20: Concentration transients of the most toxic species, aldicarb (c_a), aldicarb 
sulfoxide (c_asx), and aldicarb sulfone (c_asn).

Results shown below come from the space and time-dependent model set up and 
solved in COMSOL Multiphysics.

Figure 4-21 shows the fluid flow in soil after 0.3 days (left) and 1.0 day (right). The 
plots illustrate the wetting of the soil with time. As indicated by the arrows, the fluid 
velocities are relatively high beneath the ponded water.

Figure 4-21: The effective saturation (surface plot), pressure head (contours), and flow 
velocity (arrows) in a variably saturated soil after 0.3 days (left) and 1 day (right).
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Figure 4-22 through Figure 4-24 show the concentration distribution of aldicarb and 
the equally toxic aldicarb sulfoxide, after 1, 5, and 10 days of infiltration. Consistent 
with the evolving flow field, the main direction of transport is in the vertical direction.

Figure 4-22: Concentration of aldicarb (left) and aldicarb sulfoxide (right) after 1 day.

Figure 4-23: Concentration of aldicarb (left) and aldicarb sulfoxide (right) after 5 days.

Figure 4-24: Concentration of aldicarb (left) and aldicarb sulfoxide (right) after 10 
days.
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The distribution of aldicarb has clearly reached steady-state conditions after 10 days. 
This time frame was also predicted by the ideal reactor model. Results also show that 
the soil contamination is rather local with respect to the aldicarb source. The aldicarb 
sulfoxide, on the other hand, can be expected to affect a considerably larger soil 
volume for a significantly longer time.
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Model Library path: Earth_Science_Module/Solute_Transport/
pesticide_transport

Modeling Using the COMSOL Reaction Engineering Lab

M O D E L  N A V I G A T O R

1 Start COMSOL Reaction Engineering Lab.

2 Click New in the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 Click the Model Settings button on the Main toolbar.

2 Select the Liquid from the Reacting fluid list.

3 Select the Calculate thermodynamic properties check box.

4 Select the Calculate species transport properties check box.

5 Click Close.

R E A C T I O N S  I N T E R F A C E

1 Click the Reaction Settings button on the Main toolbar.

2 Make sure the Reactions page is active. Create five entries in the Reaction selection 

list by clicking the New button
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3 Enter the following reaction formulas by first selecting the appropriate row in the 
Reaction selection list and then entering the corresponding text in the Formula edit 
field.

4 Type in the following rate constants by first selecting the appropriate row in the 
Reaction selection list and then entering the corresponding value in the kf edit field.

S P E C I E S  I N T E R F A C E

1 Click the Species tab.

2 Select the entry a from the Species selection list and type 1 in the c0 edit field.

3 Go to the Transport page.

4 Select all entries in the Species selection list by pressing Ctrl+A and clicking the list.

5 Click the Specify diffusivity check box and type 0.00374 in the Diffusivity edit field.

6 Click Close.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 Go to the Times edit field and enter 100. Note that the time unit in this example is 
days.

3 Click OK.

4 Compute the solution by clicking the Solve button on the Main toolbar.

REACTION ID # REACTION FORMULA

1 a=>asx

2 asx=>asn

3 a=>ao

4 asx=>asxo

5 asn=>asno

REACTION ID # FORWARD RATE CONSTANT

1 0.36

2 0.024

3 0.2

4 0.01

5 0.0524
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PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The concentration transients of all species are plotted by default as shown in 
Figure 4-19. Reproduce Figure 4-20 with the following steps:

1 Click the Plot Parameters button on the Main toolbar.

2 Remove the entries ao, asxo, and asno from the Quantities to plot list by selecting 
them and clicking the < button.

3 Type c_a+c_asx+c_asn in the Expression edit field and click the associated > 
button.

4 Click OK.

Now, move on to export the reaction model to COMSOL Multiphysics and solve the 
time and space-dependent transport and reaction problem.

S P E C I E S  I N T E R F A C E

This model focuses on the concentration of the highly toxic species aldicarb (a), 
aldicarb sulfoxide (asx), and aldicarb sulfone (asn). Therefore, you can disregard the 
mass balances for the hydrogenolysis products (ao, asxo, and asno). Before exporting 
the reaction model you therefore deactivate these species.

1 Click the Reaction Settings button on the Main toolbar.

2 Click the Species page.

3 Select ao from the Species selection list and deactivate this species by clearing the 
check box immediately to the left of the species name.

4 In the same way, deactivate the species asxo and asno.

5 Click Close.

E X P O R T  S E T T I N G S

1 Click the Export to COMSOL Multiphysics button on the Main toolbar.

2 Select Axial symmetry (2D) from the Space dimension list, then click OK.

3 The Export to COMSOL Multiphysics dialog box appears.

4 Go to the Export mass balance area, and in the Application mode list select Solute 

Transport: New.

5 In the Group name edit field type reactions.

6 Move to the Export energy balance area and clear the check box in the upper left 
corner.
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7 Go to the Export momentum balance area and clear the check box in the upper left 
corner.

8 Click the Export button at the bottom of the dialog box.

Modeling Using COMSOL Multiphysics

Click the COMSOL Multiphysics window.

1 Choose Multiphysics>Model Navigator.

Note how the model already contains the application mode Solute Transport, created 
by the export from Reaction Engineering Lab.

2 In the list of application modes select Earth Science Module>Fluid Flow>Richards’ 

Equation>Pressure head analysis>Transient analysis.

3 Click the Add button.

4 Click OK.

A P P L I C A T I O N  S C A L A R  V A R I A B L E S

To set the vertical direction and gravitational constant in the model, go to the Physics 
menu and choose Scalar Variables. Make the following modifications to the defaults. 
Here you convert from seconds to days and square the quantity because you are 
dealing with acceleration. When done, click OK.

G E O M E T R Y  M O D E L I N G

You create the geometry by drawing two rectangles and adding one line.

1 Choose Draw>Specify Objects>Rectangle. Specify the following settings, then click 
OK.

2 Go to the Main toolbar and click the Zoom Extents button. 

NAME EXPRESSION

g_esvr 9.82*86400*86400

D_esvr z

PARAMETER EXPRESSION

Width 1.25

Height 1.3

r 0

z -1.3
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3 Again select Draw>Specify Objects>Rectangle. Specify the following settings, then 
click OK.

4 Choose Draw>Specify Objects>Line. In the r edit field enter 0 0.25, and in the z edit 
field enter 0 0. Click OK.

P H Y S I C S — S O L U T E  TR A N S P O R T

1 Choose Multiphysics>Solute Transport (esst).

2 Choose Physics>Properties.

3 Select Liquid/Solid/Gas from the Material drop down list, then click OK. You change 
the default settings as a three phase system is being modeled.

4 Choose Physics>Subdomain Settings. In the Subdomain selection list simultaneously 
select Subdomains 1 and 2 by pressing the Ctrl key.

5 From the Group list, select reactions.

6 Go to the Flow and Media page, enter the following settings.

This couples the solute transport to the flow calculated by the Richards’ Equation 
(esvr) application mode.

7 Set the Time change in liquid volume fraction to Time change in pressure head and 
enter the following.

PARAMETER EXPRESSION

Width 1.25

Height 0.4

r 0

z -0.4

PROPERTY VALUE

 θ theta_esvr

 θs thetas_esvr

 u u_esvr

 v v_esvr

PROPERTY VALUE

 C C_esvr

 ∂Hp / ∂t pt
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8 Click the Liquid page. In the list of subdomains, simultaneously select 1 and 2 by 
pressing Ctrl. Make the changes in the following table, and note that you can copy 
and paste in the edit fields.

Note also that the DmL and RL edit fields have been filled out automatically as a result 
of the export from COMSOL Reaction Engineering Lab.

9 Click the Solid page. Select both Subdomain 1 and 2, then make the following 
changes:

10 Click the Gas page, select Subdomains 1 and 2, then make the following changes:

11 Go to the Init page and type 0 in the c_a(t0) edit field.

12 Click OK.

Boundary Conditions—Solute Transport
1 From the Physics menu choose Boundary Settings.

2 Verify that you are on the c_a page, then enter the following settings:

TERM C_A C_ASX C_ASN

α1 0.005 0.005 0.005

α2 0.0001 0.0001 0.0001

TERM C_A C_ASX C_ASN

 ρb 1300 1300 1300

 KP 0.0001 0.00005 0.0002

TERM C_A C_ASX C_ASN

kG 1.33e-7 0 1.33e-3

DmG 0.432 0.432 0.432

BOUNDARY CONDITION VARIABL
E

VALUE

1, 3 Axial symmetry

2, 7, 8 Advective flux

5 Flux N0 1e6*(1-c_a)*(t>=0)

6 No flow boundary volatilization d 0.005
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3 Click the c_asx page, then enter the following settings:

4 Click the c_asn page, then enter the following settings:

5 Click OK.

P H Y S I C S — R I C H A R D S ’  E Q U A T I O N

Subdomain Settings—Richards’ Equation
1 Go to the Multiphysics menu and choose Richards’ Equation (esvr).

2 Choose Physics>Subdomain Settings and click the Coefficients page. Enter the 
following settings, then click Apply.

3 Click the van Genuchten page and make the following changes:

BOUNDARY CONDITION VARIABLE VALUE

1, 3 Axial symmetry

6 No flux/Symmetry

2, 7, 8 Advective flux

5 Concentration c_asx0 0

BOUNDARY CONDITION VARIABLE VALUE

1, 3 Axial symmetry

2, 7, 8 Advective flux

5 Concentration c_asn0 0

6 No flow boundary volatilization d 0.005

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

 Constitutive relation van Genuchten van Genuchten

 θs 0.339 0.399

 θr 0 0.0001

 Storage term User defined User defined

 S 0.339 0.399

 KS 0.454 0.298

 ρf 1000 1000

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2

  α 1.39 1.74
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4 Click the Init page. Select both subdomains simultaneously using the Ctrl key, then 
in the edit field enter this expression:

5 Click OK.

Boundary Conditions—Richards’ Equation
1 From the Physics menu choose Boundary Settings and make these settings:

2 Click OK.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 Click the Boundary page. Select the upper surface and the break between the two 
soil layers (Boundaries 4–6). In the Maximum element size edit field enter 0.02.

3 Click OK.

4 Click the Initialize Mesh button on the Main toolbar. 

C O M P U T I N G  T H E  S O L U T I O N

This model has many degrees of freedom and is also nonlinear. It requires roughly an 
hour to solve on a fast computer.

1 Choose Solve>Solver Parameters.

2 In the Solver list choose Time dependent if it is not already selected.

  n 1.6 1.38

  l 0.5 0.5

SETTING SUBDOMAINS 1, 2

HP(t0) -(z+1.2)*(z<-0.4)+(-(z+1.2)-0.2*(z+0.4))*(-0.4<=z)

BOUNDARY BOUNDARY CONDITION VARIABLE EXPRESSION

1, 3 Axial symmetry

6–8 Zero flux/Symmetry

2 Inward flux N0 -0.454/100

5 Mixed Rb 1*(t>=0)

5 Hpb 0.01*(t>=0)

5 Db D_esvr*(t>=0)

SETTINGS SUBDOMAIN 1 SUBDOMAIN 2
P E S T I C I D E  TR A N S P O R T  A N D  R E A C T I O N  I N  S O I L  |  303



304 |  C H A P T E R
3 In the Times edit field enter -0.1 0 10^(range(-3,0.1,-1)) 
range(0.2,0.1,1) range(2,10). After the first two time steps −0.1 day and 0, 
this gives you 31 exponentially increasing inputs from 0.001 to 0.1 day; then 
0.1-day increments through Day 1; and finally 1-day increments until Day 10.

4 Click the Advanced page.

5 Change the Type of scaling to Manual.

6 Type p 1e10 c_a 1 c_asx 1 c_asn 1 in the Manual scaling edit field.

7 Click OK.

8 Click the Solve button on the Main toolbar. 

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To plot the flow solution in Figure 4-21, follow these steps.

1 Choose Postprocessing>Plot Parameters.

2 On the General page go to the Plot type area and select the Surface, Contour, and 
Arrow check boxes.

3 From the Solution at time list choose 0.3.

4 Click the Surface page, and in the Expression edit field enter Se_esvr.

5 Click the Contour page, and in the Predefined quantities list choose 
Richards’ Equation (esvr)>Pressure head.

6 In the Contour color area, click the Uniform color option button. Click the Color 
button, change the color to white, and click OK.

7 Click Apply.

8 Click the Arrow page.

9 From the list of Predefined quantities select Richards’ Equation (esvr)>Velocity field.

10 Click the Color button, choose white as the desired color, then click OK.

11 Clear the Auto check box, and in the Scale factor edit field enter 0.5.

12 Click Apply.

13 To generate the solution after 1 day, go to the General page and select 1 from the 
Solution at time list, and then click OK.

To generate the plots in Figure 4-22 through Figure 4-24, continue with these steps:

1 Select the menu item Postprocessing>Plot Parameters. 

2 On the General page, clear the Arrow and Contour check boxes.

3 Click the Surface page, then type c_a in the Expression edit field.
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4 Click Apply.

5 To generate the solution after 5 days and 10 days, go to the General page and select 
the corresponding entries from the Solution at time list, and click Apply.

6 To generate plots for the aldicarb sulfoxide concentrations, click the Surface page, 
type c_asx in the Expression edit field, then click Apply.
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Aqu i f e r  Wa t e r  T ab l e  C a l c u l a t i o n

Introduction

This model demonstrates COMSOL Multiphysics applied to a benchmark case of 
steady-state fluid flow and transient solute transport through a vertical cross section in 
an unconfined aquifer. The model estimates the height of the water table, the upper 
surface of the unconfined aquifer. Because of the profound geologic heterogeneity, the 
solute moves within a highly irregular flow field and undergoes strong anisotropic 
dispersion. Van der Heijde (Ref. 1) classifies this case as “Level 2” with enough 
potentially difficult parameter combinations to test a code’s ability to tackle realistic 
hydrologic situations. Sudicky (Ref. 2) developed this problem to demonstrate a 
Laplace transform Galerkin code. This problem subsequently has been used to evaluate 
other flow and transport models including MT3DMS by Zheng and Wang (Ref. 3).

This model makes use of several useful COMSOL Multiphysics features:

• Multiphysics coupling between fluid flow and solute transport

• ALE moving mesh application to calculate the initial water-table location

• An upper boundary, the water table, with time-dependent solute source

• Incorporation of subsurface geological heterogeneity

• Arbitrary expressions to set up the model and postprocess the results

Model Definition

Figure 4-25a illustrates the hydrologic setting (Ref. 2) for groundwater flow at steady 
state. The aquifer is composed largely of fine-grained silty sand of hydraulic 
conductivity K1 = 5·10−4 cm/s (equivalent to K1 = 5·10−6 m/s) with lenses of 
relatively coarse material of hydraulic conductivity K2 = 1·10−2 cm/s (equivalent to 
K2 = 1·10−4 m/s). Groundwater generally moves from the upper surface of the 
saturated zone, the water table, to the outlet at x = 250 m. The water table is a free 
surface: the exact location is unknown when you set up the model. Instead you solve 
for it knowing that the fluid pressure equals zero on the water table, and it receives 
recharge, R, of 10 cm/yr (equivalent to 3.215·10−9 m/s). The groundwater divide, a 
line of symmetry, occurs at x = 0. The base of the aquifer is impermeable.

Figure 4-25 (b) shows conditions related to solute transport. The aquifer initially is 
pristine, so concentrations equal zero. For the first five years, a contaminant with 
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relative concentration of 1.0 enters over the interval 40 m < x < 80 m of the water 
table. The solute source is removed in Year 5, so the concentration along this segment 
drops to zero. The contaminant migrates by advection and dispersion in the aquifer. 
The porosity, denoted by n, is 0.35; the longitudinal dispersivity, αL, and transverse 
vertical dispersivity, αT, are 0.5 m and 0.005 m, respectively; and the effective 
molecular diffusion coefficient, Dm, is 1.34.10−5 cm2/s (equivalent to 
1.34·10−9 m2/ s).

Figure 4-25: Problem definition for the flow field problem (a) and the transport of solute 
(b).

F L U I D  F L O W :  D O M A I N  E Q U A T I O N S  A N D  B O U N D A R Y  C O N D I T I O N S

The governing equations for fluid flow and solute transport are standard application 
modes in the Earth Sciences Module. You include the moving mesh capabilities in 
COMSOL Multiphysics to calculate the exact initial water-table profile.

Steady groundwater flow is generally expressed by a conservation equation built with 
Darcy’s law for velocity (Ref. 4 and Ref. 5):

(b)

(a)
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where K is hydraulic conductivity; R the volumetric rate of recharge to water table per 
unit volume of aquifer, and the dependent variable h is total hydraulic head. Total 
hydraulic head, the driving force for flow, is 

 (4-5)

where Hp is the pressure head; and y the elevation. With the base of the model at y = 
0, the total hydraulic head H at any point in the aquifer equals the height of the water 
column Hp above it plus the point’s elevation y along the vertical axis. 

The equation for groundwater flow and solute transport link through the Darcy 
velocity, u:

 (4-6)

The velocity vector u consists of x- and y-directed components denoted u and v.

Figure 4-25 (a) gives the boundary conditions for the groundwater flow problem. A 
zero flux Neumann condition corresponds to both the symmetry boundary at x = 0 m 
and the impermeable boundary at y = 0 m:

The hydraulic head at x = 250 m is the simple Dirichlet condition

At the water table the recharge is R; the pressure head Hp is zero since there is no water 
above it; still its height y is unknown. We first use a Neumann boundary to model the 
known recharge

Next we implicitly specify the pressure head Hp at the water table to zero and explicitly 
determine its height y using the ALE Moving Mesh application mode. Without 
moving mesh, the water table is a geometric boundary determined by trial-and-error 
iterations through adjusting the height and shape of the model geometry until the 
elevation shown on the geometry matches the hydraulic head calculated by the Darcy 
flow equation because H−y=0 at the water table. 

With moving mesh, you calculate the water table height automatically by setting mesh 
deformations to H−y=0, which gives the “pressure head = 0” contour solution from 

∇ K H∇( ) R+⋅ 0=

H Hp y+=

u K∇H–=

n K∇H⋅ 0=

H x t,( ) H0=

n K∇H⋅ R=
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Darcy’s law for the flow. The model starts with an arbitrary water-table geometry (a 
straight line). The moving mesh deforms it until the shape conforms to the zero 
pressure head contour. For transient analyses, you use the same tactic to track changes 
in level of the water table as rainfall rates change over time.

S O L U T E  TR A N S P O R T :  D O M A I N  E Q U A T I O N S ,  B O U N D A R Y  C O N D I T I O N S  

A N D  I N I T I A L  C O N D I T I O N S

Solute transport typically is time-dependent for geologic problems and is described 
with the advection-dispersion equation (Ref. 4 and Ref. 5):

where θ is the porosity (m3/m3); D is the hydrodynamic dispersion tensor (m2/s); C 
is the dissolved concentration (kg/m3); and t is time (s).

The dispersion represents solute spreading by mechanical mixing and molecular 
diffusion. The Solute Transport application mode automates the equations for the 
automated tensor entries with

where θDii are the principal components of the automated dispersion tensor built on 
the Darcy velocity (m2/s); θDij and θDji are the cross terms of the dispersion tensor 
(m2/s); the subscript “L” denotes longitudinal dispersivity (m); the subscript “T” 
denotes transverse dispersivity (m);  is the magnitude of the Darcy 
velocity vector (m/s); and D* represents effective molecular diffusion, Dm, in 
saturated porous media (m2/s). Note that D* < Dm << Dii and typically is neglected.

Now examine the boundary and initial conditions for solute transport in 
Figure 4-25 (b). Neumann conditions are used at the water table, where C(x, h, t) = 0, 
except for the segment 40 < x < 80 m. Here the solute flux is

θ
t∂

∂C ∇+ θD– ∇C uC+( )⋅ 0=

θDii αL
ui

2

u
------- αT

uj
2

u
------- D∗+ +=

θDij θDji αL αT–( )
uiuj

u
----------- D∗+= =

u ui
2 uj

2
+=

n θD– ∇C uC+( )⋅–
C0R 0 t 5 years≤<,

0 t 5 years>,⎩
⎨
⎧

=
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where the relative concentration C0 is 1.0 through Year 5. After the solute source is 
removed, and the flux along this segment drops to zero. You switch the source on and 
off using logical expressions with COMSOL Multiphysics boundary settings.

The Dirichlet condition at the left boundary is

.

A Neumann condition describes the zero flux boundaries 

At the exit, use the advective flux condition. The advective flux boundary is a type of 
“free” statement because you can avoid specifying the concentration and the advective 
or dominant component of the flux. It simply sets the dispersive or negligible 
component of the flux to zero.

Finally, the initial condition specifies that the aquifer is pristine, when

Results and Discussion

F L U I D  F L O W  A N D  WA T E R  T A B L E  C A L C U L A T I O N

Figure 4-26 provides hydraulic heads and velocity streamlines estimated with the 
COMSOL Multiphysics steady-state groundwater flow simulation. The solution 
corresponds nicely to the benchmark results provided by Sudicky (Ref. 2). The slight 
differences between the two plots result from meshing: in the COMSOL example the 
mesh size varies naturally with the geometry.

The flow calculation depends on the geometry of the flow domain—in other words, 
on the water table’s height. You establish an equilibrium starting location for the water 
table automatically with the ALE application modes. For this case all of the flow 
boundaries are constants—the flow stays at equilibrium and does not change over 
time, so the water table does not move once its shape is determined. If the flow 
situation were to change (more or less rainfall) then you could calculate the new level 
of the water table (deforming the flow domain), starting with the initial location 
determined here.

C 0 y t, ,( ) 0=

n θD– ∇C uC+( )⋅– 0=

n θD– ∇C( )⋅– 0=

C x y 0, ,( ) 0=
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The water-table calculation is straightforward: Specify an initial guess for the location 
for the water table. You see the starting point in Figure 2—a straight line running from 
x = 0 m to x = 250 m. Mesh the flow geometry based on the rough initial water table 
design. Link the (stationary) Darcy flow equation to the ALE moving mesh equations 
such that the top mesh boundary moves to the pressure head = 0 contour, and solve 
these two equations simultaneously. Finally, if the flow is actually transient (although 
it is not in this example problem), use the solution shown here as the initial condition 
for a subsequent transient flow and ALE problem. Barring numerical difficulties from 
large mesh deformations, the subsequent water table rise or fall conforms to changes 
in boundary fluxes from differing rainfall rates over time.

The water table geometry determined with COMSOL (see Figure 4-26) matches the 
benchmark geometry shown in Ref. 2.

Figure 4-26: COMSOL Multiphysics estimates of hydraulic head and flow lines. The 
solution reproduces the results of Ref. 3.

S O L U T E  TR A N S P O R T

Solute transport solutions from the model are almost identical to those presented in 
Ref. 2. At t = 0 a pollutant enters the aquifer through part of the water table surface. 
You simulate the transport of this chemical by both diffusion and advection in the 
steady-state flow field over the course of 20 years.
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The contours for three times shown in Figure 4-27 reveal how the solute plume travels 
through the aquifer. The COMSOL simulation results agree well with the benchmark 
studies. The minor variations between the results from COMSOL and the benchmark 
study arise from different mesh densities. In 1989, Sudicky concluded that the Ref. 2 
results are relatively free of numerical dispersion because the low concentration 
contours closely follow the flow pattern. The COMSOL results also display this 
property, as even the lowest concentrations in Figure 4-27 follow the irregular flow 
lines shown in Figure 4-26.

Figure 4-27: Plume concentrations calculated with COMSOL Multiphysics at three times:  
t = 8 years (a), t = 12 years (b), and t = 20 years (c).

The results from this model show that COMSOL Multiphysics is an effective tool for 
simulating fluid flow and solute transport in the heterogeneous porous media and 
highly irregular flow fields common to field-scale applications. The Moving Mesh 
(ALE) application mode proves to be highly efficient at calculating the water table 
boundary even for a steady state flow field focused upon here.
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Model Library path: Earth_Science_Module/Solute_Transport/
aquifer_water_table

Modeling Using the Graphical User Interface

1 Start COMSOL Multiphysics.

2 In the Model Navigator click the Multiphysics button. Select 2D from the Space 

dimension list.

3 In the list of application modes select COMSOL Multiphysics>Deformed Mesh>Moving 

Mesh (ALE)>Static analysis. Click Add.

4 Select the application mode Earth Science Module>Fluid Flow>Darcy’s Law>Hydraulic 

head analysis>Steady-state analysis. Click Add. The software solves for pressure p as 
the dependent variable and computes the hydraulic head (the variable H_esdl) 
based on the solution. All calculated terms get the suffix esdl, which is the 
application name for Darcy’s Law from the Earth Science module (unless you 
change it in the Model Navigator).

5 Select the application mode Earth Science Module>Solute Transport>Saturated Porous 

Media>Transient analysis. Notice in the lower left of the dialog box that the default 
dependent variable name is c and that the application mode name is esst.

6 Click Add. You now have Moving Mesh (ALE) (ale), Darcy’s Law (esdl), and Solute 

Transport (esst) in the Frame (ale) folder under Geom1 in the upper right of the dialog 
box.

7 Before clicking OK, select Solute Transport (esst) in the Frame (ale) folder, then click 
the Application Mode Properties button. Change the Material to Liquid, then click OK 
to close the Application Mode Properties dialog box.

8 Change the Ruling application mode to Solute Transport (esst); this step is not critical, 
it only ensures that the following steps match what is on your screen—particularly 
for the solver settings.

9 Click OK.
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 Define the following constants by entering their names, expressions, and 
(optionally) descriptions; when done, click OK.

G E O M E T R Y  M O D E L I N G

Here you create an approximation of the flow domain by first creating a trapezoidal 
region in which the top line is a rough estimate of the water table (which you later 
refine by coupling a moving mesh to the actual flow-pressure result). Then you add 
rectangular regions that represent different materials in the subsurface strata that 
influence the flow field.

1 Because the flow domain is much wider than it is high, double-click the EQUAL 
button on the status bar below the drawing area to turn off the default settings that 
restricts the scales on the x-axis and y-axis to be equal.

2 Shift-click the Line button on the Draw toolbar.

3 In the Line dialog box that opens, enter the following data:

4 Click OK to create a 4-sided trapezoid with vertical walls, a sloping top (the estimate 
to the water table), and a horizontal bottom.

NAME EXPRESSION DESCRIPTION

R 3.215e-9[m/s] Flux from rainfall

H_in 5.3486[m] Hydraulic head at outflow boundary

K1 5e-6[m/s] Hydraulic conductivity

K2 100e-6 Hydraulic conductivity of lenses

C_in 1[kg/m^3] Surface concentration

n 0.35 Pore volume fraction

alpha_L 0.5[m] Longitudinal dispersivity

alpha_T 5[mm] Transverse dispersivity

D_m 1.34e-9[m^2/s] Molecular diffusion coefficient

penalty 100 Weighting factor

PROPERTY VALUE/EXPRESSION

X 0 250 250 0 0

Y 0 0 5.35 6.645 0

Style Closed polyline (solid)
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5 Click the Zoom Extents button on the Main toolbar to make full use of the drawing 
area.

6 Shift-click the Rectangle/Square button on the Draw toolbar.

7 Define a rectangle of Width 120, Height 2, and a Base specified by the (lower-left) 
Corner at X equal to 0 and Y equal to 2. Click OK to create the rectangle.

8 Shift-click the Rectangle/Square button again.

9 Define a second rectangle of Width 70, Height 2, and a Base specified by the Corner, 
at X equal to 180 and Y equal to 2. Click OK to create the rectangle.

The geometry in the drawing area should now look like that in Figure 4-28.

Figure 4-28: Geometry with the upper edge as the water table estimate.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Darcy’s Law
1 Double-click Darcy’s Law (esdl)>Subdomain Settings in the Model Tree to open the 

Subdomain Settings dialog box for the Darcy’s Law application mode. Alternatively, 
first select the menu item Multiphysics>2 Darcy’s Law (esdl) and then 
Physics>Subdomain Settings.
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2 Enter material properties according to the following table (leave all other settings at 
their default values):

3 Click OK.

Boundary Conditions—Darcy’s Law
1 Double-click Darcy’s Law (esdl)>Boundary Settings in the Model Tree or choose 

Physics>Boundary Settings.

2 Enter boundary conditions according to the following table; when done, click OK.

Subdomain Settings—Solute Transport
1 Open the Solute Transport (esst)>Subdomain Settings dialog box by double-clicking 

in the Model Tree.

2 On the Flow and Media page, enter the following material properties:

By setting the solute velocity components to u_esdl and v_esdl, you link the 
advective term in this equation to the flow result governed by the Darcy flow 
equations.

3 On the Solute page, enter the following material properties:

4 Click OK.

SETTINGS SUBDOMAIN 1 SUBDOMAINS 2, 3

 Ks K1 K2

SETTINGS BOUNDARIES 1–3, 5 BOUNDARY 7 BOUNDARIES 12–14

Boundary 
condition

Zero flux/Symmetry Inward flux Hydraulic head

H0 H_in

N0 R

SETTINGS SUBDOMAINS 1–3

 θs n

 u u_esdl

 v v_esdl

SETTINGS SUBDOMAINS 1-3

 α1 alpha_L

 α2 alpha_T

 DmL D_m
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Boundary Conditions—Solute Transport
1 Choose Physics>Boundary Settings.

2 Enter boundary conditions according to the following table:

3 The inward flux value to enter on the top boundary (Boundary 7) is 
C_in*R*(40<=x)*(x<=80)*(t<=5[year]). This is a Boolean expression that 
deposits a flux of C_in*R along the top surface from x = 40 m to 80 m and from 
t = 0 until 5 years. Here you use COMSOL Multiphysics’ unit syntax to enter the 
time as 5[year], which is automatically converted to the corresponding value in 
seconds, the SI time unit.

4 Click OK.

Boundary Conditions—Moving Mesh (ALE)
Here you define how the deformable mesh can move. To do so, set all the exterior 
boundaries except the top one so they do not move. You allow the top boundary to 
move, but constrain it to move to the p = 0 pressure contour line calculated by the 
Darcy flow equations. This sets the level of the water table properly and defines the 
extent of the flow domain.

1 From the Multiphysics menu, choose 1 Moving Mesh (ALE).

2 Choose Physics>Boundary Settings.

3 Select the Interior boundaries check box to enable you to constrain mesh movement 
on the internal rectangular regions. Select all boundaries except Boundary 7 
(Boundaries 1–6 and 8–14), then select both the dx and dy check boxes to constrain 
the mesh displacement to zero in both directions.

4 Select the top boundary (Boundary 7) and select only the dy check box. In the Mesh 

displacement, y-direction edit field, type (H_esdl-y)*penalty. This links the mesh 
displacement to the water table by imposing that the total hydraulic head equal the 
elevation, because H_esdl-y=0 is the zero pressure contour line. Leave the dx check 
box cleared.

5 Click OK.

SETTINGS BOUNDARIES 1, 3, 5 BOUNDARY 2 BOUNDARY 7 BOUNDARIES 12–14

Boundary 
condition

Concentration No flux/ 
Symmetry

Flux Advective flux

c0 0

N0 See the next 
step
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Subdomain Settings—Moving Mesh (ALE)
1 In the Model Tree, double-click Moving Mesh (ALE) (ale)>Subdomain Settings.

2 Select all three subdomains and make sure that the Free displacement option button 
is selected. Click OK.

C R E A T E  I N I T I A L  M E S H

1 From the Mesh menu, choose Free Mesh Parameters.

2 On the Global page, click the Custom mesh size button.

3 Set the Resolution of narrow regions to 4. This number specifies the minimum 
number of mesh layers in narrow regions of the model geometry.

4 Click the Remesh button. You should get roughly 7590 elements.

These elements are likely to look very distorted. Remember that you have turned off 
the axis equal setting, so the geometry is visually distorted. You can see the actual 
(nonvisually distorted) mesh by returning to the default axis equal setting.

5 Double-click the (now grayed out) EQUAL button on the status bar below the 
drawing area. The geometry you see now is the nonvisually distorted geometry and 
mesh.

6 Again double-click the EQUAL button on the status bar to turn axis equal off, then 
click the Zoom Extents button on the Main toolbar.

S O L V E  F O R  T H E  F L O W  A N D  WA T E R  TA B L E  L O C A T I O N

This step establishes the initial flow and water table positioning. It is a stationary (not 
transient) solution that you must do even if the ultimate goal is to solve a transient-flow 
problem. This step adjusts the water-table profile from the initial estimate to the 
correct one based on the initial flow state. For this problem, the rainfall rate is constant, 
so the results of this step are the final results for the flow. 

1 Choose Solve>Solver Manager.

2 On the Solve For page, select the Moving Mesh (ALE) folder (thus highlighting and 
selecting all its variables). Hold down the Ctrl key and additionally select the Darcy’s 

Law folder (and thus its variable p). Do not select the Solute Transport folder and its 
variable, c.

3 Click OK to apply these selections and close the Solver Manager dialog box.

4 Choose Solve>Solver Parameters.
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5 Change the solver to Stationary.

6 Click OK.

7 Click the Solve button (=) on the Main toolbar. You should see the following plot 
(which as a default shows the x-direction deflection of the mesh):

Figure 4-29: Solution showing the x-displacement. It can be clearly seen that the upper 
edge has been deformed into the correct water table. The initial guess is shown as a black 
solid line.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — F L O W  A N D  W A T E R  T A B L E

1 From the Postprocessing menu choose Plot Parameters.

2 In the Plot Parameters dialog box, click the Surface page.

3 On the Surface Data page, select Darcy’s Law (esdl)>Velocity field from the Predefined 

quantities list.

4 Click the Streamline tab.

5 Select the Streamline plot check box in the upper-left corner.

6 In the Streamline data area select Darcy’s Law (esdl)>Velocity field from the Predefined 

quantities list.
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7 Click the Specify start point coordinates button and enter the following values:

8 Click the Advanced button and type 40000 in the Maximum number of integration 

steps edit field.

Figure 4-30: The velocity field in the domain. The velocity is larger in the right lens than 
in the rest of the domain.

9 Click OK twice.

Remember that you deformed the mesh to make the top surface correspond to where 
the hydraulic head is equal to the vertical dimension (H − y = 0). You can see that this 
has occurred by plotting contour lines of equal H − y (corresponding to zero pressure).

1 Open the Plot Parameters dialog box.

2 On the Surface page, clear the Color legend check box.

3 On the Contour page, select the Contour plot check box.

4 In the Expression edit field, type H_esdl-y.

x range(0,20,250)

y 5
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5 In the Contour levels area, click the Vector with isolevels option button and type 
range(0,0.2,1) in the edit field. This setup plots six lines starting with the line 
H − y = 0, which should correspond to the top surface of the deformed flow regime.

6 Click OK.

Figure 4-31: Velocity field and the expression H_esdl-y is plotted. By looking at the contour 
plot it can be seen that H_esdl-y is close to zero at the top surface, which means that the 
surface has deformed so that the hydraulic head is equal to the vertical dimension.

S O L V E  T H E  TR A N S I E N T  S O L U T E - TR A N S P O R T  P R O B L E M

With the water table position properly calculated and the steady-state flow pattern 
established, you can compute the transient solute-transport result. Here you are 
simulating the response over 20 years to a chemical that seeps into part of the top 
boundary for 5 years. The concentrate plume both diffuses by molecular diffusion and 
is advected by the slow subsurface flow calculated by the Darcy flow equation.

1 Choose Solve>Solver Manager.

2 On the Solve For page, select only the Solute Transport folder and its variable, c. Do 
not select any other folders or variables.
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3 Click Apply, then click the Initial Value tab.

It is very important to use the current solution for the mesh and flow when solving 
the solute-transport problem. If you are not careful, the solver could reset the mesh 
deflection and flow back to its initial condition of not deformed and zero flow. You 
can either state that you want to use the current solution or, better yet (in case you 
make a mistake later on), store the current solution and then use it as the initial value 
for the solute-transport calculation. This choice stores the deformed mesh and its 
calculated water-table position as well as the subsurface flow.

4 Click the Store Solution button near the bottom-left of the dialog box.

5 In the Initial value area (the top section), click the Stored solution option button.

6 In the Value of variables not solved for and linearization point area (the bottom 
section), click the Stored solution option button.

7 Click OK to apply these settings and close the Solver Manager dialog box.

8 Choose Solve>Solver Parameters.

9 From the Solver list, select Time dependent.

10 In the Times edit field, type 365*86400*range(0,20). This instructs the software 
to solve the problem from Year 0 to Year 20 in 1-year increments. Note that you 
must translate the times to seconds—the time unit in this simulation.

11 Select OK.

12 Click the Solve button (=) on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N — F L O W  A N D  W A T E R  T A B L E

1 From the Postprocessing menu, choose Plot Parameters.

2 In the Plot Parameters dialog box, click the Surface tab. Select Solute Transport 

(esst)>Concentration, c from the Predefined quantities list.
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3 Select the Color legend check box, then click Apply.

4 On the General page, select other times by choosing different entries in the Solution 

at time list. In Figure 4-32 on page 324 you see a sequence of 1, 5, 10, 15, and 
20 years.

Note that each time you plot a surface plot for an individual time, the range on the 
color bar adjusts to the current maximum. Thus the visual look of continued of high 
concentration conveyed by the red area can be misleading. Rescaling does not occur 
when you create animations. You can also set the color range manually.
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Figure 4-32: The concentration in the domain at different times. Note that the color range 
is rescaled at each time.

A N I M A T I N G  T H E  R E S U L T S

Before performing the next step it is a good idea to save your problem.

1 Select File>Save to save your problem to a convenient location that you can find 
again.

2 Click the Animate button on the Plot toolbar.

The movie generator creates one frame at a time until complete and then run the 
animation for one cycle. Pick the play button again to repeat it, or move the slider by 
hand with the mouse. Notice that the range of the color bar does not change as it did 
when choosing a separate time step.

Changing Time Units to Years

Most geologic processes occur over years rather than seconds. Nonetheless, many 
material properties are specified in standard SI units, which include seconds for time. 
COMSOL Multiphysics includes scaling terms in the equations that allow you to 
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change from seconds to years without changing the materials. Here is an outline of the 
steps needed to change the current problem to simulate using years as the time unit.

1 Double-click Constants in the Model Tree.

2 Define a constant with the Name ScaleTime defined by the Expression 1[s/year]. 
Press Enter and note that the number of years per seconds appears in the Value 
column.

3 Click OK.

4 From the Model Tree, choose Solute Transport (esst)>Subdomain Settings.

5 Select all three subdomains. On the Flow and Media page, change δts1 from 1 to 
ScaleTime. Click OK.

6 From the Model Tree, choose Solute Transport (esst)>Boundary Settings.

7 Select Boundary 7, then set the Inward flux to C_in*R*(40<=x)*(x<=80)*(t<=5).

8 Click OK.

9 In the Solver Parameters dialog box, change the Times to range(0,20).

10 Click OK to close the Solver Parameters dialog box.

11 Click the Solve button on the Main toolbar to re-solve the problem.
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 5
H e a t  T r a n s f e r  M o d e l s
The models in this chapter demonstrate phase change, buoyancy flow, and free 
convection in porous media.
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Buoyan c y  F l ow i n  F r e e  F l u i d s

Introduction

This example follows the benchmark buoyancy flow posed by de Vahl Davis (Ref. 1) 
for free fluids. Buoyancy flow of free fluids is very important in Earth sciences with 
temperature and concentration affecting density in moving fluids, for example, in 
pipes, along shorelines, and within lakes. Here the buoyancy flow results from density 
that varies with a temperature change. The COMSOL Multiphysics results match 
those from the published study (Ref. 1). The model was provided by John Kamel of 
the University of Notre Dame.

This example repeatedly solves a problem of buoyant flow in a square cavity. It thereby 
analyzes different temperature distributions and convective flow patterns from 
variations in, for example, fluid properties, cavity size, and temperature drops. The 
iterative process is tuned for a fast, efficient solution using nondimensional parameters 
and a Boussinesq term for the buoyant drive with the Incompressible Navier-Stokes 
and the Convection and Conduction application modes. Another method to solve for 
the buoyant flow of free fluids in COMSOL Multiphysics using these application 
modes is simply to trigger the non-isothermal flow option, which enables modeling 
with a fully compressible Navier-Stokes flow law.

Figure 5-1: Domain geometry and boundary conditions for the heat balance in this 
example of buoyant flow in free fluids.
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Model Definition

The previous figure illustrates the model geometry. The fluid fills a square cavity with 
impermeable walls so the fluid flows freely within it but does not exit from it. The right 
and left edges of the cavity are, respectively, the high and low temperature sources. The 
upper and lower boundaries are insulated. The temperature differential produces the 
density variation that drives the buoyant flow.

The flow and temperature application modes in this model are 2-way coupled. The 
Boussinesq term is a force defined on temperatures. The fluid velocities transport heat. 

It is possible to formulate the Navier-Stokes equations with a Boussinesq buoyancy 
term on the right-hand side to account for the lifting force due to thermal expansion:

 (5-1)

 (5-2)

In these expressions, the dependent variables for flow are u, a vector of directional 
velocities, and pressure, p. T represents temperature, T0 is a reference temperature, g 
denotes gravity acceleration, ρ0 gives the reference density, and β equals the thermal 
expansion coefficient.

The heat balance comes from the conduction-convection equation

 (5-3)

where Keq denotes the thermal conductivity, and CL is the volumetric heat capacity of 
the fluid (where CL = ρf  Cp, and Cp is the specific heat capacity).

For the Navier-Stokes equations, impermeable, no-slip boundary conditions apply. 
The no-slip condition results in zero velocity at the wall, with pressure within the 
domain remaining undefined. Because the lack of information about p makes it 
difficult to achieve convergence, you arbitrarily fix the pressure at a point.

The boundary conditions for the Convection and Conduction application mode are 
the fixed high and low temperatures on the vertical walls, with insulation conditions 
elsewhere, as shown in Figure 5-1.

Implementation: Nondimensional Solutions with Iterative Solver

The model addresses a wide range of cavity sizes, fluid properties, and temperature 
drops using material properties set up with nondimensional Raleigh and Prandtl 

ρ u ∇⋅( )u ∇p ∇+ η ∇u ∇u( )T
+( )⋅–= ρ0gβ T T0–( )+

∇ u⋅ 0=

CLu∇ T⋅ ∇– Keq T∇( )⋅ 0=
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numbers. The Raleigh number, Ra = (gβTL3)/(ηρ−1Keq CL
−1), gives the ratio of 

buoyant to viscous forces. Here L is the length of a side wall. The Prandtl number, 
Pr = (ηρ−1)/(Keq CL 

−1), gives the ratio of kinematic viscosity to thermal diffusivity.

Setting ρ = (Ra·Pr)0.5, Cp = Pr, and η = Keq = 1 produces nondimensional p, u, and 
T. The dimensional counterpart to the solution comes from the equations

where ' denotes dimensional quantities, and U is the magnitude of the velocity vector 
u.

As Ra increases, viscous forces decrease in importance. You can examine a wide range 
of scenarios using the parametric solver and sequencing through different values of Ra 
but keeping Pr constant. At high Ra values, starting with a good initial condition and 
a well-tuned mesh becomes increasingly important. Because the parametric solver uses 
the previous solution as the initial condition for the next one, it fulfills the first of these 
two requirements. Then getting a well-tuned mesh is straightforward: simply set up the 
mesh for the most difficult problem to solve—the one with the highest value of Ra. 
To that end, the element size near the prescribed temperature boundaries corresponds 
to the thickness of the boundary layer when Ra = 106.

Results and Discussion

As noted earlier, this COMSOL Multiphysics example reproduces a benchmark 
buoyant flow problem reported in Ref. 1. The composite images in Figure 5-2 
summarize temperatures (surface), velocity fields (arrows), and x-velocities (contours) 
for four Ra values. With the given definitions for the dimensionless variable, it follows 
that as Ra increases so does temperature. The results in the figure indicate how the 
vigor and complexity of the convection increase at higher values of Ra, as 
expected.These results are virtually identical to the benchmark solution except the 
COMSOL Multiphysics plots provide higher resolution than the images in the original 
publication.

xi' Lxi,= t' L
U
---- t,= ui'

ui
U
-----,= p'

p

ρ0U2
--------------,= T'

T Th–

Tc Th–
-------------------=
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Figure 5-2: Dimensionless solution for buoyancy flow in a fluid-filled cavity at increasing 
Raleigh number: Temperature (surface plot), velocity field (arrows), and x-velocity 
(contours). These results from the COMSOL Multiphysics simulation are in excellent 
agreement with the results published in Ref. 1.

The COMSOL Multiphysics model described here represents the buoyant drive with 
a Boussinesq term. As an alternative, you could use the automated non-isothermal flow 
options provided with the Navier-Stokes application mode. Using the Boussinesq 
approach, however, demonstrates a well-established method for reducing 
computational effort while still representing buoyant flow.

1,000 10,000

100,000 1,000,000
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Model Library path: Earth_Science_Module/Heat_Transfer/buoyancy_free

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Open the Model Navigator.

2 Click the Multiphysics button, and in the Space dimension list select 2D.

3 In the list of application modes select 
Earth Science Module>Fluid Flow>Incompressible Navier-Stokes. Click Add.

4 In the list of application modes select 
Earth Science Module>Heat Transfer>Convection and Conduction. Click Add.

5 Click the Application Mode Properties button. In the Material list choose Mobile fluid. 
Click OK.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square (Centered) button on the Draw toolbar on the left 
side of the user interface.

2 Accept the default settings in the dialog box to create a square with corners at (0, 0) 
and (1, 1); when done, click OK.

3 Click the Zoom Extents button on the Main toolbar to center the square within the 
viewing window.

O P T I O N S  A N D  S E T T I N G S

Model Settings
Because this is a nondimensional model, use no unit system:

1 From the Physics menu, choose Model Settings.
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2 From the Base unit system list, select None, then click OK.

Constants
1 From the Options menu, choose Constants.

2 Enter the following names, expressions, and descriptions; when done, click OK.

P H Y S I C S  S E T T I N G S — F L O W

From the Multiphysics menu, select Incompressible Navier-Stokes (chns).

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 Select Subdomain 1, then enter the following settings:

NAME EXPRESSION DESCRIPTION

Ra 1e6 Raleigh number

Pr 0.71 Prandtl number

Th 1 High temperature

Tc 0 Low temperature

COEFFICIENT EXPRESSION

 ρ (Ra/Pr)^0.5

 η 1

 Fx 0

 Fy (T-Tc)*(Ra/Pr)^0.5
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3 Leave the initial conditions for u, v, and p at their default values zero values, which 
you can inspect on the Init page.

4 Click OK to close the Subdomain Settings dialog box.

Boundary Conditions
The boundary conditions default to no-slip and need not be altered.

Point Settings
1 From the Physics menu, choose Point Settings.

2 Select Point 1, then select the Point constraint check box. Leave the p0 field at 0.

3 Click OK.

P H Y S I C S  S E T T I N G S — H E A T  TR A N S F E R

From the Multiphysics menu, select Convection and Conduction (eshcc).

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.

2 On the Materials page, enter the following settings:

3 Click the Time/Convection tab. Set the velocities in the heat transfer equation to the 
fluid velocities from the flow equation by entering these expressions for u and v:

4 Leave the initial condition for T at the default zero value.

5 Click OK.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Select Boundary 1. From the Boundary condition list select Temperature, then in the 
T0 edit field enter Tc.

VALUE EXPRESSION

 ρL (Ra/Pr)^0.5

 CpL Pr

 KL 1

VALUE EXPRESSIO
N

u u

v v
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3 Select Boundary 4. From the Boundary condition list select Temperature, then in the 
T0 edit field enter Th.

4 For Boundaries 2 and 3, leave the default boundary condition, thermal insulation.

5 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, choose Free Mesh Parameters.

2 Click the Boundary tab. Select Boundaries 1 and 4.

3 In the Maximum element size edit field enter 0.0065, and in the Element growth rate 
edit field enter 1.5.

4 Click Remesh. When the mesher has finished, click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 From the Solver list, select Parametric.
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3 In the Parameter names edit field, enter Ra, and in the Parameter values edit field, 
enter 1e1 1e2 1e3 1e4 1e5 1e6.

4 Click OK.

5 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 5-2 on page 331, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Surface, Contour, and Arrow check boxes. In the 
Solution to use list choose the appropriate value for Ra.

3 Click the Surface tab. In the Predefined quantities list, select Convection and 

Conduction in Porous Media (eshcc)>Temperature.

4 Click the Contour tab. In the Predefined quantities list, select Incompressible 

Navier-Stokes (chns)>x-velocity.

5 In the Contour color area, click first the Uniform color option button and then the 
Color button. In the Contour Color dialog box, choose white, then click OK.
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6 Click the Arrow tab. In the Predefined quantities list, select Incompressible 

Navier-Stokes (chns)>velocity field.

7 Go to the Arrow positioning area. For the Number of points, in both the x points and 
y points edit fields, enter 15.

8 Click Color, select black, then click OK.

9 Click Apply to generate the plot.

10 Return to the General page and choose another solution in the Solution to use list.

11 Click OK to close the Plot Parameters dialog box and generate the plot.

To sequence through the different solutions as an animation, open the Plot Parameters 

dialog box, click the Animate tab, and then click the Start Animation button.
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F r e e  Con v e c t i o n  i n  Po r ou s  Med i a

Introduction

This example describes subsurface flow in porous media driven by density variations 
that result from temperature changes. The model comes from Hossain and Wilson 
(Ref. 1) who use a specialized in-house code to solve this free-convection problem. 
This COMSOL Multiphysics example reproduces their work using the Brinkman 
Equation application mode and the Convection and Conduction application mode. 
The results of this model match those of the published study.

Model Definition

The following figure gives the model geometry. Water in a porous media slice can 
move within the slice but not exit from it. Temperatures vary from high to low along 
the outer edges. Initially the water is stagnant, but the temperature change alters 
density to the degree that buoyant flow ensues. The problem statement specifies that 
the flow is steady state.

Figure 5-3: Domain geometry and boundary conditions for the heat balance in the 
free-convection problem. Th is a higher temperature than Tc, while s is a variable that 
represents the relative length of a boundary segment and goes from 0 to 1 along the 
segment.
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You model this free-convection problem by introducing a Boussinesq buoyancy term 
defined with temperatures to the Brinkman equations, then link the resulting fluid 
velocities from the Brinkman equations to the heat transfer application mode. 

The Boussinesq buoyancy term that appears on the right side of the Brinkman 
equation shown next accounts for the lifting force due to thermal expansion

 (5-4)

.

In these expressions, T represents temperature while T0 is a reference temperature, g 
denotes the gravity acceleration, ρ0 gives the reference density, ε is the porosity, and β 
is the thermal expansion coefficient.

The heat balance comes from the conduction-convection equation

where Keq denotes the effective thermal conductivity of the fluid-solid mixture, and 
CL is the fluid’s volumetric heat capacity.

The boundary conditions for the Brinkman equations are all no-slip conditions. Using 
only velocity boundaries gives no information on the pressure within the domain, 
which means that the model produces estimates of the pressure change instead of the 
pressure field. However, without any seed information on pressure, the problem is 
unlikely to converge. The remedy is to arbitrarily fix the pressure at a point in the 
model using point settings. The boundary conditions for the Convection and 
Conduction application mode are the series of fixed temperatures in Figure 5-3.

Implementation: Initial Conditions for Boussinesq Approximation

The simple problem statement just given produces a strongly nonlinear problem that 
represents a difficult convergence task for most nonlinear solvers. Even without the 
new Boussinesq term, the Brinkman equations are nonlinear alone. To ease the 
numerical difficulties, you apply a relaxation factor damp in front of the Boussinesq 
term ρ0gβ(T − T0) in Equation 5-4 to gradually find a stable initial condition for 
solving the true problem. When damp = 0, the flow and temperature equations are 
uncoupled so the model easily converges. Then you gradually increase damp, using 
the previous solution as the initial guess for the next parametric step, and so on until 

∇ η
ε
--- ∇u ∇u( )T

+( )⋅–
η
κ
---u ∇p+⎝ ⎠
⎛ ⎞– ρ0gβ T T0–( )=

∇ u⋅ 0=

CLu∇ T⋅ ∇– Keq T∇( )⋅ 0=
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you reach damp = 1. The iteration protocol is an easy process with COMSOL 
Multiphysics’ parametric solver.

Results

This example reproduces a model reported by Hossain and Wilson (Ref. 1). After 
extracting the input data from the paper, the author constructed the model in less than 
an hour, including all the steps from geometry input to postprocessing of the results. 
Figure 5-4 shows the dimensionless temperature distribution throughout the porous 
media slice.

Figure 5-4: Dimensionless temperature in a porous structure subjected to temperature 
gradients and subsequent free convection. The COMSOL Multiphysics simulation is in 
excellent agreement with published results from Ref. 1.

Figure 5-5 gives the COMSOL Multiphysics solution for the flow field.
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Figure 5-5: Velocity field (surface color) and velocity arrows.
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Model Library path: Earth_Science_Module/Heat_Transfer/
free_conv_porous

Modeling Using the Graphical User Interface

1 In the Model Navigator, click the Multiphysics button, then in the Space dimension list 
select 2D.

2 In the list of application modes select 
Earth Science Module>Fluid Flow>Brinkman Equations. Click the Add button.
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3 In the list of application modes select 
Earth Science Module>Heat Transfer>Convection and Conduction. Click Add.

4 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the Options menu, select Axes/Grid Settings.

2 On the Axis page enter these settings; when done, click OK.

3 Click the Rectangle/Square button on the Draw toolbar, then using the cursor create 
a square with the corners at (0, 0) and (0.1, 0.1).

4 Again, choose Options>Axes/Grid Settings.

PARAMETER VALUE

x min -0.03

x max 0.13

y min -0.02

y max 0.12
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5 This time click the Grid tab. Clear the Auto check box, then in the Extra y edit field 
enter 0.01.

6 Click OK.

7 Click the Point button on the Draw toolbar and.

8 Create a point at the location (0.1, 0.01).

O P T I O N S  A N D  S E T T I N G S

Model Settings
Because this is a nondimensional model, use no unit system:

1 From the Physics menu, choose Model Settings.

2 Select None from the Base unit system list in the Model Settings dialog box.

3 Click OK.

Constants
1 From the Options menu, select Constants.

2 Enter the following names, expressions, and descriptions (optional); when done, 
click OK.

NAME EXPRESSION DESCRIPTION

rho 1e3 Density

mu 4e-4 Dynamic viscosity

cp1 4.2e3 Heat capacity

perm 1e-3 Permeability

beta 276e-6 Thermal expansion coefficient

Tc 0 Reference temperature

g 9.81 Acceleration due to gravity

damp 1 Relaxation factor
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Scalar Expressions
1 Choose Options>Expressions>Scalar Expressions.

2 Enter the following definitions (the descriptions are optional); when done, click OK.

P H Y S I C S  S E T T I N G S — B R I N K M A N  E Q U A T I O N S

From the Multiphysics menu, select Brinkman Equations (chns).

Subdomain Settings
Select the menu item Physics>Subdomain Settings, select subdomain 1, then enter the 
following specifications; when done, click OK.

Initial Conditions
Leave the initial conditions at their default values: u = v = p = 0.

Boundary Conditions
The boundary conditions default to No slip and need not be altered.

Point Settings
1 From the Physics menu, choose Point Settings.

NAME EXPRESSION DESCRIPTION

k1 cp1*mu/0.28 Thermal conductivity

Th Tc+0.0527 Higher temperature

QUANTITY EXPRESSION

 ρ rho

 η mu

 εp 0.4

 κ perm

 Fx 0

 Fy damp*rho*g*beta*(T-Tc)
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2 Select Point 5, then select the Point constraint check box. Leave the p0 edit field at 0.

3 Click OK.

P H Y S I C S  S E T T I N G S — C O N V E C T I O N  A N D  C O N D U C T I O N

From the Multiphysics menu, select Convection and Conduction in Porous Media (eshcc).

Subdomain Settings
1 Choose Physics>Subdomain Settings.

2 Click the Time/Convection tab.

3 Click the CL (user defined) button, then enter the following settings in the associated 
edit fields:

4 Click the Spreading tab. From the Equivalent thermal conductivity list select User 

defined, and in the keq edit field enter k1.

5 Click OK.

Initial Conditions
Keep the initial condition at the default value of T = 0.

Boundary Conditions
1 Select the menu item Physics>Boundary Settings. 

VALUE EXPRESSION

CL cp1*rho

u u

v v
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2 Select all boundaries in the list, then in the Boundary conditions list select 
Temperature. 

3 Select Boundaries 1 and 4, then in the T0 edit field enter Th-(Th-Tc)*s; for 
Boundaries 3 and 5 enter Tc in that edit field, and for Boundary 2 enter Th.

M E S H  G E N E R A T I O N

1 Choose Mesh>Free Mesh Parameters.

2 From the Predefined mesh sizes list, select Fine.

3 Click the Remesh button.

4 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 In the Solver list select Parametric.

3 In the Parameter names edit field enter damp, and in the Parameter values edit field 
enter range(0,0.1,1).

4 On the Advanced tab, set the Type of scaling to None.
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5 Click OK.

6 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 5-4, follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, go to the Plot type area and select the Surface and Contour 
check boxes.

3 Click the Surface tab. In the Expression edit field, enter (T-Tc)/(Th-Tc).

4 Click the Contour tab. In the Expression edit field, enter (T-Tc)/(Th-Tc).

5 Click the Uniform color option button, then click the Color button. Select black, then 
click OK.

6 Clear the Color legend check box, then click Apply.

To reproduce the plot in Figure 5-5, continue with these steps:

1 While still in the Plot Parameters dialog box, return to the General page.

2 In the Plot type area clear the Contour check box and select the Arrow check box.

3 Click the Surface tab. In the Predefined quantities list select Velocity field.

4 Click the Arrow tab. Verify that the x component edit field reads u, that the 
y component edit field reads v, and that the selected color is black.

5 Click OK to close the Plot Parameters dialog box and generate the plot.
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Pha s e  Chang e

Introduction

This example demonstrates how to model a phase change and predict its impact on a 
heat transfer analysis. When a material changes phase, for instance from solid to liquid, 
energy is added to the solid. Instead of creating a temperature rise, the energy alters 
the material’s molecular structure. Equations for the latent heat of phase changes 
appear in many texts (see Ref. 1, Ref. 2, and Ref. 3) but their implementation is 
nonstandard. Heat consumed or released by a phase change affects fluid flow, magma 
movement and production, chemical reactions, mineral stability, and many other 
earth-science applications.

This 1D example uses the Conduction in Porous Media application mode from the 
Earth Science Module to examine transient temperature transfer in a rod of ice that 
heats up and changes to water. In particular, the model demonstrates how to handle 
material properties that vary as a function of temperature.

Figure 5-6: Material properties as functions of temperature.

This model proceeds as follows. First, estimate the ice-to-water phase change using the 
transient conduction equation with the latent heat of fusion. Next, run additional 
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simulations to evaluate impacts of the temperature interval over which the phase 
change occurs. Finally, compare the solution from the analysis with the latent heat to 
estimates that neglect it.

Model Definition

This model describes the ice-to-water phase change along a 1-cm rod of ice. At its left 
end the rod is insulated, and at the other end it touches boiling water. Values for 
thermal properties depend on the phase. For ice, density is 918 kg/m3, the specific 
heat capacity is 2052 J/(kg·K), and the thermal conductivity is 2.31 W/(m·K). For 
water, the density, specific heat capacity, and thermal conductivity are 997 kg/m3, 
4179 J/(kg·K), and 0.613 W/(m·K), respectively. Reference temperatures are 265 K 
for ice and 300 K for water. The latent heat of fusion, λ, is 333 kJ/kg. The starting 
temperature in the rod is –20 °C.

The conduction equation is

.

where Ceq is the effective volumetric heat capacity (J/K·m3), T is temperature (K), Keq 
is the effective thermal conductivity (W/m·K), and Q is a heat source (W/m3).

Ceq and Keq typically are volume averages of the form

where θ is the volumetric content, ρ equals density (kg/m3), and Cp is the specific heat 
capacity (J/(K·kg)) of a liquid or a solid. In this problem, however, you modify Ceq to 
account for the latent heat of fusion so that

.

It describes latent heat using the latent heat of fusion λ (J/kg) for only the normalized 
pulse around a temperature transition D (K−1). 

The integral of D must equal unity to satisfy the following

δtsCeq
∂T

t∂
------- ∇+ Keq– T∇( )⋅ Q

i
∑=

Ceq θiρiCpi
i
∑=

Ceq θiρi Cpi Dλ+( )
i
∑=
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such that the pulse width denotes the range between the liquidus and solidus 
temperatures.

The boundary conditions for this model are insulating at x = 0 and fixed temperature 
at x = 0.01 where 

Implementation

Because the thermal properties differ between ice and water, you create a variable H, 
which goes from unity for water to zero for ice. In this way H amounts to the volume 
fraction θ of water within a model element. Therefore, the effective properties switch 
with the phase through multiplication with H.

The switch in H from 0 to 1 occurs over the liquid-to-solid interval using a smoothed 
Heaviside function. This model implements the Heaviside function with the 
expression H = flc2hs(T-Ttrans,dT); where the transition interval for the function 
is dT. In this way, the pulse D is the derivative of H with respect to temperature. You 
can then express D with the COMSOL Multiphysics differentiation operator, d, as in 
D = d(H,T).

To find out more about implementing this and other smoothing functions, see the 
COMSOL Multiphysics User’s Guide under “Specifying Discontinuous Functions” 
on page 149 as well as the COMSOL Multiphysics Reference Guide.

Results

Figure 5-7 shows images of the temperature distribution predicted with latent heat for 
output intervals of 100 s. The system is solid ice at t = 0, and water content increases 
with time. The distributions level out around the zero temperature point because not 

ρDλ Td
∞–

∞

∫ ρλ=

n Keq– T∇( )⋅ 0= Ω Origin∂

T T0= Ω Heat source∂
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all of the energy is going toward a temperature rise; some is being absorbed to change 
the molecular structure and change the phase.

Figure 5-7: Temperature estimates with latent heat at t = 0, 15, 45, 60  s and120, 180, 
…, 1200 s.
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Figure 5-8: Temperature estimates without latent heat a t = 0, 15, 45, 60  s and120, 180, 
…, 1200 s.

The solution in Figure 5-8 shows temperature estimates for the simulation without 
latent heat. The kink in the temperature curve results from differences in the thermal 
properties of ice and water.

Figure 5-9 shows results for different solid-to-liquid intervals at three times. The 
smaller the interval, the sharper the bend in the temperature profile at zero 
temperature, T. In the simulations, narrowing the temperature interval to a step 
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change, for example, comes at a large computational cost. In the figure, the results for 
the wide and narrow pulses compare closely.

Figure 5-9: Temperature estimates for different temperature intervals for latent heat 
consumption. Estimates are for dT intervals of 0.1 (solid line), 0.5 (dashed line), and 2.5 
(dotted line) at t = 30 s, 300 s, and 600 s.
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Model Library path: Earth_Science_Module/Heat_Transfer/phase_change
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator go to the Space dimension list and select 1D.

2 In the list of application modes select 
Earth Science Module>Heat Transfer>Conduction>Transient analysis.

3 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 Select the menu item Options>Constants, then enter the following names, 
expressions, and descriptions (optional); when done, click OK.

2 Select the menu item Options>Expressions>Scalar Expressions and enter the following 
names, expressions, and descriptions; when done, click OK.

G E O M E T R Y  M O D E L I N G

1 Select the menu item Draw>Specify Objects>Line. Define the end points by going to 
the x edit field and entering 0 0.01.

2 Click the Zoom Extents button on the Main toolbar to center the line in the field of 
view.

P H Y S I C S  S E T T I N G S

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 In the Boundary selection list, select 2, then in the Boundary condition list select 
Temperature.

3 To set the high temperature at the heat source go to the Temperature edit field and 
enter 100[degC].

NAME EXPRESSION DESCRIPTION

T_trans 0[degC] Transition temperature

dT 0.5[K] Transition interval

lm 333[kJ/kg] Latent heat of fusion

NAME EXPRESSION DESCRIPTION

H flc2hs((T-T_trans)[1/K],dT[1/K]) Heaviside function

D d(H,T) Temperature transition
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4 To accept the boundary conditions as entered, click OK.

Subdomain Settings
1 Select the menu item Physics>Subdomain Settings.

2 On the Materials page, select Subdomain 1 and enter the following liquid (L) and 
solid (P) property values; when done, click OK.

3 Click the Init tab and in the T(t0) edit field enter -20[degC].

SYMBOL EXPRESSION

 θL H+eps

 ρL 997

 CpL 4179+D*lm

 KL 0.613

 θP 1-H+eps

 ρP 918

 CpP 2052+D*lm

 KP 2.31
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4 Click the Element tab. In the Predefined elements list choose Lagrange-Linear.

The use of linear elements reduces computation time at a relatively small price in 
accuracy. This feature can be particularly helpful during concept-development 
stages, after which you might want to switch back to Lagrange-Quadratic elements.

M E S H  G E N E R A T I O N

1 Click the Initialize Mesh button on the Main toolbar. The mesh consists of 15 
elements, making it quite coarse.

2 Click the Refine Mesh button on the Main toolbar three times to obtain a relatively 
fine mesh with 120 elements.

C O M P U T I N G  T H E  S O L U T I O N

1 Select the menu item Solve>Solver Parameters.

2 Go to the Times edit field and enter range(0,15,60) range(120,60,1200). Click 
OK.

All the parameter values in this model have a time units of seconds, so the output 
time you enter here gives a total simulation time of 20 minutes.

3 Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate Figure 5-7, follow these steps:

1 Select the menu item Postprocessing>Domain Plot Parameters.

2 Click the Line/Extrusion tab, then in the Subdomain selection list choose 1.

3 In the y-axis data area go to the Predefined quantities list and select Temperature.

4 From the Unit list, select °C to display the temperature in degrees Celsius.

5 Click the General tab. Verify that all time steps in the Solutions to use list are selected, 
then click OK.

S A V I N G  T H E  F I L E

To save the current model, go to the menu item File>Save As, enter the file name 
phase_change, then click OK. Also leave the model file open.

Phase Change Without Latent Heat

To analyze the impact of the latent heat terms on the phase-change model, it is useful 
to estimate temperatures using the same approach but without the latent heat term.
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O P T I O N S  A N D  S E T T I N G S

From the Options menu select Constants. Find the name for latent heat (lm) and in the 
associated Expression edit field enter 0[kJ/kg]. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Solve the model by clicking the Solve button in the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To create Figure 5-8, use the postprocessing sequence described for Figure 5-7 on 
page 351.

Phase Change for Varying Transition Intervals

Solutions to the phase-change problem vary with the range in temperatures dT over 
which you assume the phase transition occurs. To visualize the impact of different 
transition widths, sample results from the original simulation and compare those 
estimates to results from simulations with varying dT values. 

S A M P L I N G  T H E  P R E V I O U S  R E S U L T S

To create Figure 5-9, follow these steps:

1 Reopen the model phase_change.mph.

2 Choose Postprocessing>Domain Plot Parameters.

3 On the General page, go to the Solutions to use list and select output times 60, 300, 
and 600. Select the Keep current plot check box.

4 Click OK to generate the plot; do not close the figure window.

O P T I O N S  A N D  S E T T I N G S

Choose Options>Constants. Change dT to another value, for instance 2.5[K]. Click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar. 

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The second part of creating Figure 5-9 is with these steps:

1 Choose Postprocessing>Domain Plot Parameters.

2 On the General page, leave the output times from the previous dT value in the 
Solutions to use list, that is, 60, 300, and 600.
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3 Next click the Title>Axis button and modify the settings as appropriate. Click OK.

4 To complete the comparison plot, go to the Line/Extrusion page, click the Line 

Settings button, change the line properties to distinguish the new set of results, and 
then click OK.

5 Click OK to close the dialog box and generate the plot.
 5 :  H E A T  TR A N S F E R  M O D E L S



 6
M u l t i p h y s i c s  M o d e l s
Two models in 2D and 3D of the electrokinetic and magnetic fields inside a 
volcano highlight the multiphysics modeling capabilities in COMSOL Multiphysics 
and the Earth Science Module.
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E l e c t r o k i n e t i c  and Magn e t i c  F i e l d s  
I n s i d e  a  Vo l c a no

Introduction

This multipart example examines several coupled geophysical phenomena: the 
electrokinetic voltages generated as fluid moves through a porous medium; the 
magnetic field the currents produce; and the feedback from the electric field to the 
fluid flow. Investigating these effects is important in many applications (Ref. 1, Ref. 2, 
and Ref. 3) such as tracking subsurface distribution and flow of fluids, estimating 
reservoir properties, predicting hydrothermal flow, and establishing innovative 
methods for mitigating subsurface contaminants, to name a few. The models described 
here couple the Darcy’s Law application mode of the Earth Science Module with the 
AC/DC Module’s Conductive Media DC and In-Plane Induction Currents, Magnetic 
Field application modes.

The first stages of this model couple fluid-flow equations to electric-field equations for 
a 2D geometry unidirectionally; the moving fluid generates a current that in turn 
generates magnetic fields, which you calculate with the In-Plane Induction Currents, 
Magnetic Field application mode. In the second step you compare the magnetic fields 
just calculated to those predicted with Biot-Savart’s law. After matching the analytic 
expression, you relax the restriction of unidirectional coupling and couple the 
fluid-flow and electric-field equations bidirectionally. The feedback from the electric 
field to the fluid flow equations adds electroosmotic forces to the fluid velocity.

This 2D model is based on research carried out at the University of Leipzig and ETH, 
Zürich. A detailed description of the underlying physics and consequences for 
volcanological exploration appears in Ref. 4.

Finally, this example develops a 3D version of the model using an elevation model 
contributed by Prof. Carl Gerstenecker of the Technical University of Darmstadt (Ref. 
5). Both model versions are available in the Earth Science Module Model Library.

Note: Both model versions require the AC/DC Module.
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Model Definition

Figure 6-1 shows the infiltration of rain water into a volcano conduit. The water is 
moving preferentially through highly permeable fractured rocks in a volcano’s neck, 
while water flows in the older impermeable parts of the edifice at a lower rate. 
Measuring the distribution of voltages and magnetic fields provides insight into the 
internal flow regime.

Figure 6-1: Vertical slice through a volcano with a permeable conduit.

F L U I D  F L O W

The fluid flow in this problem is stationary so you describe it with the continuity 
equation

where u is the fluid velocity (m/s).

In a first approximation, neglecting the electroosmotic drag, the fluid velocity is 
governed by Darcy’s law

where κ denotes the hydraulic permeability of the porous medium (m2), η is the fluid’s 
dynamic viscosity (Pa·s), and p refers to the pressure (Pa).

The boundary conditions for the hydraulic system are as follows: Infiltration occurs 
from above through the volcano’s surface. Assuming that water supplied to the system 

∇ u⋅ 0=

u κ
η
---∇p–=
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moves vertically under its own weight, implies seepage velocities in the negative 
y direction through the boundary of

 (6-1)

where i = 1 corresponds to the conduits and i = 2 to the less permeable surface 
sections. Here, ρ is the fluid density (kg/m3) and g is the gravitational acceleration 
(m/s2). At the bottom of the modeling domain, assume separate average outflux 
velocities, u1out ∝ κ1 and u2out ∝ κ2, obtained by equating the total outflow with the 
total inflow; details are given in the section “Topography” on page 364. Assume all 
other boundaries to be hydraulically insulating, u · n = 0.

F L O W - T O - E L E C T R I C  P O T E N T I A L  C O U P L I N G

In electrostatics, the continuity equation for electric charge reads

where J is the total current density (A/m2):

The first term on the right side is the ohmic current density, σ E, with σ denoting the 
rock’s electric conductivity (S/m),  the electric field (V/m), and V the 
electric potential (V). The second term is the current density generated by the fluid 
flow, , where p is the pressure and α refers to the electrokinetic coupling 
coefficient (A/m) given by

In this equation, ε is the dielectric permittivity (F/m), ζ denotes the zeta potential of 
the mineral-fluid interface (V), and F0 is the formation factor, that is, the ratio between 
fluid and rock resistivity (σfluid /σ).

The electric problem is completely insulated, J · n = 0. At the earth’s surface, no 
current leaves the rock into the air. The subsurface boundaries of the modeling domain 
are sufficiently far away from the sources to be unaffected by changes near the surface.

Because the hydraulic and electric problems both use only Neumann boundary 
conditions, you make them well posed by setting p = 0 and V = 0 at an arbitrary point.

uiin ρg
κi
η
-----= i 1 2,=

∇ J⋅ 0=

J σ V∇– Je
+=

E V∇–=

Je α– p∇=

α εζ
ηF0
----------=
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M A G N E T I C - F I E L D  E Q U A T I O N S

To calculate the magnetic field or magnetic flux density that corresponds to the electric 
current field resulting from the hydraulic flow, use the quasi-static approximation

.

Further, using Ampère’s law with the multiphysics definition for current density gives

where H is the magnetic field strength (A/m). The governing equation for the 
magnetic field therefore reads

.

Here the only boundary condition you need to apply is electric insulation.

In the postprocessing steps described later you compare these magnetic-flux estimates 
to those obtained with Biot-Savart’s law.

2D Model with Topography and Electroosmotic Force

A realistic geological model would need to account for two additional features: the 
effect of topography and the feedback from the electric field on the hydraulic flow.

In reality, the electric field influences the flow field and exerts electroosmotic drag. 
Moreover, topographical nuances figure prominently in generating the electric field. 
With a sloping surface you can no longer assume that all rainfall penetrates the ground 
surface. Instead some rainfall runs off, which affects the flow field.

E L E C T R O O S M O T I C  D R A G

To account for electroosmotic drag in Darcy’s law, use the reciprocity relations of 
Onsager (Ref. 2):

.

Here you implement the electric-field component by including it as a source term in 
the Earth Science Module’s Darcy’s Law application mode. You also define a modified 
velocity vector using subdomain expressions, which you plot during postprocessing.

∇ E× 0=

∇ H× J σE Je
+= =

∇ σ 1– ∇ H Je
–×( )( )× 0=

unew
κ
η
--- p∇– α V∇–=
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TO P O G R A P H Y

Modelers often prefer to obtain realistic topography models by importing geometries. 
Topography models can be conveniently imported by using one of COMSOL 
Multiphysics’ CAD interfaces (for example DXF in 2D or, using the CAD Import 
Module, most of the popular 3D CAD formats, including IGES, STEP, SAT, and 
Parasolid files). In this case you import the volcano geometry as a DXF file in the 
COMSOL Multiphysics user interface.

The geometry features three major fracture zones: one main conduit and two parasitic 
ones. One of the parasitic conduits developed itself fully to the surface, while the other 
one stalled and produced a cryptodome. Because the fracture zones are highly 
permeable, rainfall penetrates preferentially through the conduits that intersect the 
surface and exits the system through the conduits at depth. Through the sections with 
lower hydraulic permeability, rain penetrates and exits the system at correspondingly 
lower rates. Owing to the topography, only part of a rainfall penetrates the ground 
surface and a fraction runs off. Assuming the infiltration into the ground is a function 
of topographic slope, the fluid influx velocities are given by 

where useepage = (0, −u0) is the seepage velocity vector, with u0 defined in 
Equation 6-1, and n = (nx, ny) is the boundary’s outward normal vector.

At steady state, the total amount of water moving out of the system at any instant of 
time, Qout, must equal the total rainfall entering through the ground surface, Qin. 
Using, in addition, the relations Qout = w1u1out + w2u2out, where wi refers to the total 
width of the outflow boundary section with permeability κi, and u1out/κ1 = u2out/κ2, 
gives the average outflux velocities

In this example, you automate the calculation of u1out and u2out by defining 
integration coupling variables for the inflow, Qin, and the outwidths, w1 and w2.

Results—2D Model with Topography and Electroosmotic Force

Figure 6-2 illustrates the COMSOL Multiphysics solution for fluid pressure and fluid 
velocities in the volcano where a bidirectional coupling exists between fluid flow and 
electric potential. The fluid moves primarily within the fractured conduits reaching the 

uiin uiseepage n–( )⋅≡ ui in–( ) ny–( ) uiinny= =

uiout
κi

w1κ1 w2κ2+
----------------------------------Qin= i 1 2,=
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surface. The model modifies the fluid velocities to include a term that accounts for 
electroosmotic drag generated by the electric field.

Figure 6-2: Solution for pressure distribution (surface plot) and velocities (arrows).

Figure 6-3 shows the electric self potential and the total electric current density. 
Moving fluids initiate the electric potential. The plot marks negative values for the 
potential at the top of the two outcropping domes, whereas a positive potential is 
generated at the bottom of the main conduit.

Figure 6-4 plots the magnetic flux density with the current density. The flux densities 
are highest along the boundaries of the permeable conduits. The field is directed out 
of the plane on the left edges and into the plane on the right edge.
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Figure 6-3: Solution for electric potential (surface plot) and current density (arrows).

Figure 6-4: Solution for magnetic flux (surface plot) and current density (arrows).
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Magnetic Field Postprocessing—Biot-Savart’s Law

In this section you calculate the magnetic field with the Biot-Savart formula and 
compare these estimates to the COMSOL Multiphysics solution just reported. The 
comparison provides a good check for consistency and accuracy.

Assuming constant magnetic permeability µr = 1, you can calculate the magnetic flux 
density for an arbitrary current system j with Biot-Savart’s law

where µ0 = 4π · 10−7 V·s/(A·m) is the permeability of free space. For a point 
r0 = (x0, y0) in the xy-plane, you obtain the field components

Bx and By become zero when integrating in the z direction. For the remaining 
component, the identity

applies. Combining the expressions gives

.  (6-2)

To calculate the expression in Equation 6-2 at an arbitrary point (x0, y0), use the 
COMSOL Multiphysics interpolation command postint. You create the string to be 
integrated with the sprintf command. To generate the plots in Figure 6-5 with 
MATLAB, see the section “Modeling Using the Programming Language” on page 
376.

B r0( )
µ0
4π
------

j r0 r–( )×
r0 r–

---------------------------- rd∫=

Bx
µ0
4π
------

jxz–

x0 x–( )2 y0 y–( )2 z2
+ +( )

3 2⁄
---------------------------------------------------------------------------- xd yd zd∫=

By
µ0
4π
------

jyz

x0 x–( )2 y0 y–( )2 z2
+ +( )

3 2⁄
---------------------------------------------------------------------------- xd yd zd∫=

Bz
µ0
4π
------

jx y0 y–( ) jy x0 x–( )–

x0 x–( )2 y0 y–( )2 z2
+ +( )

3 2⁄
---------------------------------------------------------------------------- xd yd zd∫=

1

a2 z2
+

3
------------------------- zd

∞–

∞

∫ 2

a2
------=

Bz x0 y0,( )
µ0
2π
------

jx y0 y–( ) jy x0 x–( )–

x0 x–( )2 y0 y–( )2
+

------------------------------------------------------- xd yd∫=
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Results—Postprocessing the Magnetic Field

Figure 6-5 plots the COMSOL Multiphysics solution and the Biot-Savart estimates. 
The results agree well with an average percent difference of 4% along the profile. In 
the example with 17,700 elements the calculation of Biot-Savart requires about twice 
as much time as solving the magnetic PDE directly.

Figure 6-5: Left plot—Comparison of the Bz field evaluated directly from the PDE (solid 
line) and the Biot-Savart integration (o). Right plot—Relative difference between PDE 
solution and the integrated result. The rms error for the 17,700-element mesh is 4%.

3D Model of Fluid Flow, Electrostatics, and Magnetostatics

In a 3D model of coupled fluid flow, electrostatics, and magnetostatics for an 
approximately cylindrical/axisymmetric geometry, toroidal fields form around the 
volcanic conduits where fluid flow is fast. To examine these effects, extend the 2D 
model to 3D. For simplicity, neglect the inflow and outflow through the impermeable 
surfaces in the 3D model. You can review the model file and postprocess the results by 
opening the file electric_volcano_3d.mph in the Earth Science Module Model 
Library. The author created the 3D geometry using data provided by Carl 
Gerstenecker of TU Darmstadt based on his work with Tiede, Läufer, Wrobel, and 
Steineck (Ref. 5).

Results—3D Model of Fluid Flow, Electrostatics, and Magnetostatics

Figure 6-6 is a cutaway view of the COMSOL Multiphysics 3D solution for fluid 
pressure, electric potential, and magnetic field in the volcano for the case where fluid 
flow and electric potential are bidirectionally coupled. Switching the arrow plot to 
display the velocity field instead would show that the fluid moves primarily within the 
fractured conduits to reach the surface. The fluid velocities are driven by gradients in 
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pressure and electric potential. The magnetic field results from the electric current 
density. The visible toroidal effects center on the fast flow around the conduit.

Figure 6-6: COMSOL Multiphysics solution for coupled fluid flow, electrostatics, and 
magnetostatics in a volcano.
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Model Library path: Earth_Science_Module/Multiphysics/
electric_volcano_2d

Modeling Using the Graphical User Interface—2D Model

M O D E L  N A V I G A T O R

1 Open the Model Navigator, and in the Space dimension list select 2D.

2 In the list of application modes select  
Earth Science Module>Fluid Flow>Darcy’s Law>Pressure analysis.

3 Click the Multiphysics button.

4 Click the Add button to include the Darcy’s application mode in the model.

5 In the list of application modes select  
AC/DC Module>Statics, Electric>Conductive Media DC, then click Add.

6 In the list of application modes select  
AC/DC Module>Statics, Magnetic>In-Plane Induction Currents, Magnetic Field, then click 
Add.

7 Click OK.

G E O M E T R Y  M O D E L I N G

Import the volcano geometry from a DXF file by executing the following instructions:

1 Choose File>Import>CAD Data From File.

2 Find the folder models/Earth_Science_Module/Multiphysics in your 
COMSOL installation directory and then select the file 
electric_volcano_2d.dxf.

3 Click OK to accept the default settings for the geometry import.
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4 Click the Coerce to Solid button on the Draw toolbar.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Enter the following names, expressions, and (optionally) descriptions; when done, 
click OK.

NAME EXPRESSION DESCRIPTION

sigma1 0.1[S/m] Electric conductivity, permeable 
fracture

alpha1 5.0e-9[(F/m)*V/(Pa*s)] Electrokinetic coupling coefficient, 
permeable fracture

kappa1 1.0e-10[m^2] Hydraulic permeability, permeable 
fracture

sigma2 0.01[S/m] Electric conductivity, impermeable 
parts

alpha2 5.0e-9[(F/m)*V/(Pa*s)] Electrokinetic coupling coefficient, 
impermeable parts

kappa2 1.0e-12[m^2] Hydraulic permeability, impermeable 
parts

eta 8.9e-3[Pa*s] Dynamic viscosity

rho 1000[kg/m^3] Density
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3 From the Options menu, select Expressions>Subdomain Expressions.

4 Enter the following names and expressions to define new fluid-velocity components 
and a resulting velocity magnitude accounting for electroosmotic drag:

5 Click OK.

P H Y S I C S  S E T T I N G S — D A R C Y ’ S  L A W

From the Multiphysics menu, select Darcy’s Law (esdl).

Application Mode Properties
1 From the Physics menu select Scalar Variables.

2 In the Description column look for Elevation/vertical axis, and verify that the 
corresponding entry in the Expression edit field is 0. Click OK.

Subdomain Settings
1 From the Physics menu select Subdomain Settings.

2 Enter the settings from the following table; when done, click OK.

Boundary Conditions
For the boundary condition you need two integration coupling variables.

g 9.82[m/s^2] Acceleration due to gravity

u1 rho*g*kappa1/eta Seepage velocity, conduit surface 
sections

u2 rho*g*kappa2/eta Seepage velocity, impermeable 
surface sections

NAME EXPRESSION FOR SUBDOMAINS 1, 3, 4 EXPRESSION FOR SUBDOMAIN 2

u_new u_esdl-alpha2*Vx u_esdl-alpha1*Vx

v_new v_esdl-alpha2*Vy v_esdl-alpha1*Vy

U_new sqrt(u_new^2+v_new^2) sqrt(u_new^2+v_new^2)

SETTINGS SUBDOMAINS 1, 3, 4 SUBDOMAIN 2

 κs kappa2 kappa1

 η eta eta

 Qs alpha2*(Vxx+Vyy) alpha1*(Vxx+Vyy)

NAME EXPRESSION DESCRIPTION
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1 From the Options menu, select Integration Coupling Variables>Boundary Variables. 
Enter the following coupling variables, with each Name on its own row in the table; 
when done, click OK.

2 From the Physics menu, select Boundary Settings.

3 Enter the following settings for the specified boundaries; when done, click OK.

Because Q_in, w1, and w2 are integration coupling variables, COMSOL 
Multiphysics considers the units for the average inward flux at Boundaries 2, 54, and 
63 to be inconsistent with the model’s base unit system. You can disregard this 
warning.

Point Settings
1 From the Physics menu, select Point Settings.

2 Select Point 2 and in the Pressure(s) edit field enter 0. Click OK.

P H Y S I C S  S E T T I N G S — C O N D U C T I V E  M E D I A  D C

From the Multiphysics menu, select Conductive Media DC (emdc).

Subdomain Settings
1 From the Physics menu select Subdomain Settings.

NAME BOUNDARIES EXPRESSION INTEGRATION 
ORDER

GLOBAL 
DESTINATION

Q_in 35–37, 56–61 u1*ny 4 yes

3–34, 38–52, 65–111 u2*ny 4 yes

w1 54 1 4 yes

w2 2, 63 1 4 yes

SETTINGS BOUNDARIES 35–37, 56–61 BOUNDARY 3–34, 38–52, 65–111

Boundary condition Inward flux Inward flux

N0 u1*ny u2*ny

SETTINGS BOUNDARY 54 BOUNDARIES 2, 63

Boundary condition Inward flux Inward flux

N0 -Q_in*kappa1/ 
(kappa1*w1+kappa2*w2)

-Q_in*kappa2/ 
(kappa1*w1+kappa2*w2)
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2 Enter the following settings; when done, click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Select all the boundaries, and in the Boundary condition list select Electric insulation.

3 Click OK.

Point Settings
To make the system well defined, you must give the potential some reference value at 
a given point. In this case you lock the potential at Point 2.

1 From the Physics menu, select Point Settings.

2 In the Point selection list, select 2.

3 Click the Electric potential option button.

4 Make sure the electric potential is set to 0, then click OK.

P H Y S I C S  S E T T I N G S — I N - P L A N E  I N D U C E D  C U R R E N T S ,  M A G N E T I C  F I E L D

From the Multiphysics menu, select In-Plane Induction Currents, Magnetic Field (emqh).

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Enter the following settings; when done, click OK.

Boundary Conditions
1 From the Physics menu, choose Boundary Settings.

2 Select all boundaries, and in the Boundary condition list select Electric insulation.

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 Click the Boundary tab.

SETTINGS SUBDOMAIN 1, 3, 4 SUBDOMAIN 2

 σ (isotropic) sigma2 sigma1

 Je (-px*alpha2, -py*alpha2) (-px*alpha1, -py*alpha1)

SETTINGS SUBDOMAINS 1, 3, 4 SUBDOMAIN 2

 σ (isotropic) sigma2 sigma1

 J (-px*alpha2, -py*alpha2) (-px*alpha1, -py*alpha1)
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3 Select all interior boundaries (the boundaries on the volcano surface) and the outlet 
boundary (all boundaries except for 1, 2, 63, and 112).

4 In the Maximum element size edit field, type 20.

5 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot in Figure 6-2, follow these steps.

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Surface and Arrow check boxes in the Plot type area.

3 Click the Surface tab. From the Predefined quantities list on the Surface Data page, 
select Darcy’s Law (esdl)>Pressure. From the Unit list, select MPa.

4 Click the Arrow tab. On the Subdomain Data page, specify the x component as u_new 
and the y component as v_new.

5 In the Arrow positioning area, set the number of x points to 63 and the number of 
y points to 14.

6 Click the Color button in the Arrow parameters area. In the Arrow Color dialog box, 
select black, then click OK.

7 Click Apply to generate the plot.

To generate the plot in Figure 6-3 continue as follows:

1 Still on the Arrow page, select Conductive Media DC (emdc)>Total current density from 
the Predefined quantities list on the Subdomain Data page.

2 In the Arrow parameters area, clear the Auto check box and set the Scale factor to 1.5.

3 Click the Surface tab. From the Predefined quantities list, select Conductive Media DC 

(emdc)>Potential.

4 Click Apply to generate the plot.

Obtaining the plot in Figure 6-4 now requires only a minor change:

1 Change the entry in the Predefined quantities list to In-Plane Induction Currents, 

Magnetic Field (emqh)>Magnetic flux density, norm. From the Unit list, select nT.

2 Click Apply to generate the plot and close the Plot Parameters dialog box.
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The plot you see when you open the model from the Model Library combines the 
surface plot from Figure 6-4 and the arrow plot from Figure 6-2 with a contour plot 
of the pressure. Thus, you can reproduce it with the following instructions:

1 Click the Contour tab. Select the Contour plot check box. On the Contour Data page, 
verify that the entry in the Predefined quantities list is Pressure. In the Contour color 
area, set the Color table to Thermal and clear the Color legend check box.

2 Click the Arrow tab. On the Subdomain Data page, set the x component to u_new and 
the y component to v_new. In the Arrow parameters area, select the Auto check box 
for the Scale factor.

3 Click OK to generate the plot and close the Plot Parameters dialog box.

Modeling Using the Programming Language

To reproduce the plots in Figure 6-5, use the following code with MATLAB. The 
script is also available as the M-file electric_volcano_2d_Bz_plots.m located in 
the same directory as the model’s MPH-file (see the Model Library path on page 370).

% Create a set of coordinates along a line in the x direction
% at an altitude of 1000 m
x0 = -2000:100:2000;
y0 = x0*0+1000;

% Evaluate the Biot-Savart integral for each point
for i = 1:length(x0)
  st = sprintf(['2e-7*(Jx_emdc*(%f-y)-Jy_emdc*(%f-x))/' ...
  '((%f-x)^2+(%f-y)^2)'],y0(i),x0(i),x0(i),y0(i));
  Bz(i) = postint(fem,st);
end

% For comparison, evaluate the magnetic field directly from
% the COMSOL Multiphysics solution
Bz2 = postinterp(fem,'Bz_emqh',[x0;y0]);

figure, plot(x0,Bz2,x0,Bz,'o');
xlabel('x [m]');
ylabel('B_z [T]');

diff = 100*(Bz-Bz2)./Bz2;
figure, plot(x0,diff);
xlabel('x [m]');
ylabel('Rel. diff. [%]');
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Model Library path: Earth_Science_Module/Multiphysics/
electric_volcano_3d

Modeling Using the Graphical User Interface—3D Model

M O D E L  N A V I G A T O R

1 In the Model Navigator, select 3D from the Space dimension list.

2 In the Application Modes tree, open the Earth Science Module folder and select 
Fluid Flow>Darcy’s Law>Pressure analysis. Click Add.

3 From the Application Modes tree, open the AC/DC Module folder.

4 From this folder, select Statics, Electric>Conductive Media DC, then click Add.

5 From the same folder select Statics, Magnetic>Magnetostatics, Vector Potential, then 
click Add.

6 Click OK.

G E O M E T R Y  M O D E L I N G

1 From the File menu, choose Import>CAD Data From File.

2 In the Import CAD Data From File dialog box, make sure that the 
COMSOL Multiphysics file or All 3D CAD files is selected in the Files of type list.

3 From the models/Earth_Science_Module/Multiphysics directory under the 
COMSOL Multiphysics installation folder, locate the 
electric_vulcano_3d.mphbin file and click Import.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 Make the following entries in the Constants dialog box; when done, click OK.

NAME EXPRESSION DESCRIPTION

sigma1 0.1[S/m] Electric conductivity, permeable 
fracture

alpha1 1e-8[(F/m)*V/(Pa*s)] Electrokinetic coupling coefficient, 
permeable fracture

kappa1 1e-10[m^2] Hydraulic permeability, permeable 
fracture
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P H Y S I C S  S E T T I N G S — D A R C Y ’ S  L A W

From the Multiphysics menu, select Darcy’s Law (esdl).

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 2, then clear the Active in this domain check box.

3 Select both Subdomains 1 and 3. Set the Density to rho and the Viscosity to eta.

4 Select only Subdomain 1, then type kappa2 in the Saturated permeability edit field.

5 Select Subdomain 3, then type kappa1 in the Saturated permeability edit field.

6 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 Select the cylinder’s bottom surface in the geometry or select Boundary 12 from the 
Boundary selection list. From the Boundary condition list, select Pressure. Leave the 
specified pressure at its default zero value.

3 Select the cylinder’s top surface in the geometry or select Boundary 13 from the 
Boundary selection list. From the Boundary condition list, select Inward flux. Set the 
Inward flux to nz_esdl*u0. In this expression, nz_esdl is the z-component of the 
outward unit normal vector seen from the subdomain on which the esdl 
application mode is active.

Keep the default boundary condition, Zero flux/Symmetry for all other boundaries. 
This means that you neglect the small flux through the boundary surfaces with low 
permeability. 

4 Click OK.

sigma2 0.01[S/m] Electric conductivity, impermeable 
parts

alpha2 1e-8[(F/m)*V/(Pa*s)] Electrokinetic coupling coefficient, 
impermeable parts

kappa2 1e-12[m^2] Hydraulic permeability, impermeable 
parts

eta 8.9e-3[Pa*s] Dynamic viscosity

rho 1000[kg/m^3] Density

g 9.82[m/s^2] Acceleration due to gravity

u0 rho*g*kappa1/eta Seepage velocity, conduit surface

NAME EXPRESSION DESCRIPTION
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From the Multiphysics menu, select Conductive Media DC (emdc).

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 2, then clear the Active in this domain check box.

3 Select Subdomain 1. Set the Electric conductivity to sigma2.

4 In the edit fields for the External current density, type -alpha2*px, -alpha2*py, 
and -alpha2*pz.

5 Select Subdomain 3. Set the Electric conductivity to sigma1.

6 In the edit fields for the External current density, type -alpha1*px, -alpha1*py, 
and -alpha1*pz.

7 Click OK.

Boundary Conditions
1 From the Physics menu, select Boundary Settings.

2 In the Boundary Conditions dialog box, select all boundaries and set the boundary 
condition to Electric insulation.

3 Click OK.

Point Settings
1 From the Physics menu, select Point Settings.

2 Select Point 5 and click the V0 option button. Leave the potential at 0.

3 Click OK.

P H Y S I C S  S E T T I N G S — M A G N E T O S T A T I C S

From the Multiphysics menu, select Magnetostatics (emqa).

Subdomain Settings
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomains 1 and 3.

3 In the edit fields for the External current density, enter Jx_emdc, Jy_emdc, and 
Jz_emdc.

4 Leave the default settings for Subdomain 2.

5 Click OK.
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Boundary Conditions
Use the default boundary settings for the Magnetostatics application mode.

Application Mode Properties
You need to turn on the gauge fixing manually for this model, because it uses other 
solver settings than the default settings for the 3D Magnetostatics application mode, 
which provide numerical gauge fixing through the SOR gauge and SORU gauge pre- 
and postsmoothers.

1 From the Physics menu, choose Properties.

2 In the Application Mode Properties dialog box, select On from the Gauge fixing list.

3 Click OK.

M E S H  G E N E R A T I O N

1 From the Mesh menu, select Free Mesh Parameters.

2 On the Global page, select Fine from the Predefined mesh sizes list.

3 Click Remesh, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

Because the application modes are coupled only in one direction, you can solve them 
in sequence to reduce the memory consumption.

1 From the Solve menu, select Solver Parameters.

2 From the Linear system solver list, select GMRES.

3 From the Preconditioner list, select Incomplete LU. Set the Drop tolerance to 0.05.

4 Click OK to close the Solver Parameters dialog box.

5 From the Solve menu, select Solver Manager.

6 On the Solve For page, select only the Darcy’s Law (esdl) application mode.

7 On the Sequence page, click the Store Current Settings button.

8 In the Store Solver Settings dialog box, enter the Name darcy, then click OK.

9 Click the Initial Value tab.

10 In the Initial value area, click the Initial value expression evaluated using current 

solution button.

11 Click the Solve For tab. Select only the Conductive Media DC (emdc) application mode.

12 On the Sequence page, click the Store Current Settings button.

13 In the Store Solver Settings dialog box, enter the Name condmed, then click OK.
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14 Click the Solve For tab. Select only the Magnetostatics (emqa) application mode.

15 On the Sequence page, click the Store Current Settings button.

16 In the Store Solver Settings dialog box, enter the Name magnstat, then click OK.

17 Select all three entries in the Stored solver settings area, then click the > button to 
add them to the the Solver sequence area in the order that you entered them.

18 Select the Solve using solver sequence check box, then click OK.

19 Click the Solve button on the Main toolbar to start the simulation.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default visualization shows a pressure slice plot. To reproduce the plot shown in 
Figure 6-6, following these steps:

1 From the Postprocessing menu, select Plot Parameters.

2 Click the Subdomain tab. Select the Subdomain plot check box.

3 From the Predefined quantities list, select Darcy’s Law (esdl)>Pressure. From the Unit 
list, select MPa.

4 From the Color table list, select Thermal.

5 Click the Boundary tab. Select the Boundary plot check box

6 From the Predefined quantities list, select Conductive Media DC (emdc)>Electric 

potential.

7 In the Coloring and fill frame, select Wireframe from the Fill style list.

8 Click the Arrow tab. Select the Arrow plot check box.

9 From the Predefined quantities list on the Subdomain Data page, select Magnetostatics 

(emqa)>Magnetic field.

10 In the Arrow positioning frame, set the Number of points in x, y, and z to 21, 21, and 
7, respectively

11 In the Arrow parameters frame, click the Color button. In the Arrow Color dialog box, 
select black, then click OK.

12 Click the Slice tab. Select the Slice plot check box.

13 In the Expression edit field, type log10(normB_emqa).

14 In the Slice positioning frame, set the Number of levels for x, y, and z to 1, 1, and 0, 
respectively.

15 In the Slice color frame, clear the Color legend check box.

16 Click the General tab.
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17 To look into the volcano, exclude part of the geometry in the postprocessing. Select 
the Element selection check box and enter (x>0)||(y>0) in the Logical expression 

for inclusion edit field. This only includes parts with positive x- or y-coordinates, 
cutting away one quarter of the geometry.

18 Click OK to create the plot.
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I N D E X

A application mode

Brinkman Equations 53, 68, 328, 338

Conduction 348

Conductive Media 360

Convection and Conduction 328, 338

Darcy’s Law 53, 68, 186, 199, 234, 360

Darcy’s Law 1D 20, 30, 35

Darcy’s Law 3D 41

Navier-Stokes 177

Navier-Stokes Equation 8

Plane Strain 199

Richards’ Equation 97, 114, 267

Solute Transport 234, 267

aquifer

characterization of 152

unconfined 306

B Biot poroelasticity 199

Biot-Savart’s law 360, 367

Boussinesq

thermal expansion coefficient 329

Boussinesq approximation 329, 339

Brinkman equations

Forchheimer-corrected 175

buoyant flow

Boussinesq 329

C compaction and poroelasticity 186, 199

coupled flow laws 53, 68

D density variations

thermal expansion coefficient 329

drawdown 21

dynamic viscosity 177

E effective thermal conductivity 329

electrokinetic volcano 360

extrusion coupling variables 21

F finite radius well 20

fluid flow to wells 18

Forchheimer flow model 175

forchheimer_flow 175

free convection in porous media 328, 338

I integration coupling variables 43, 101

interpolation for variably saturated flow 

114

inverse modeling 152

L leaky confining unit 30

M multiphysics 199, 328, 338, 360

N Navier-Stokes application mode 177

P penalty function 153

perforated well 41

permeability of

porous media 177

pesticide transport 288

phase change 348

pore-scale flow 8

poroelasticity 199

porous media flow 175

Prandtl number 329

R Raleigh number 329

S seepage velocity 362

solute injection 234

sorbing solute 268

T Terzaghi compaction 186

thermal expansion coefficient 329

transitional flow 68

two-phase flow 129

air-oil 148

oil-water 148

typographical conventions 4
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U unconfined aquifer 306

V variably saturated flow 97, 114

volumetric heat capacity 329

W water table, height of 306

weak constraints 57, 72

well models 53, 68

finite radius well 20

leaky confining unit 30

perforated well 41

wellbore storage 35

wellbore storage 35


	CONTENTS
	Chapter 1: Introduction
	Chapter 2: Fluid Flow Models
	Pore-Scale Flow 8
	Fluid Flow to Wells 18
	Fluid Flow to Wells: Finite Radius Well 20
	Fluid Flow to Wells: Leaky Well 30
	Fluid Flow to Wells: Wellbore Storage 35
	Perforated Well 41
	Coupled Flow Laws 53
	Transitional Flow: Darcy-Brinkman-Navier-Stokes 68
	Porous Media Flow: Discrete Fracture 83
	Variably Saturated Flow 97
	Interpolation for Unsaturated Flow 114
	Two-Phase Flow 129
	Aquifer Characterization 152
	Forchheimer Flow 175

	Chapter 3: Flow and Solid Deformation Models
	Compaction and Poroelasticity 186
	Terzaghi Compaction 189
	Biot Poroelasticity 199
	Poroelastic Flow and Deformation: Open-Hole Multilateral Well 217

	Chapter 4: Solute Transport Models
	Solute Injection 234
	Buoyancy Flow with Darcy’s Law: The Elder Problem 250
	Variably Saturated Flow and Transport: Sorbing Solute 267
	Pesticide Transport and Reaction in Soil 288
	Aquifer Water Table Calculation 306

	Chapter 5: Heat Transfer Models
	Buoyancy Flow in Free Fluids 328
	Free Convection in Porous Media 338
	Phase Change 348

	Chapter 6: Multiphysics Models
	Electrokinetic and Magnetic Fields Inside a Volcano 360


	Introduction
	Model Library Guide
	Typographical Conventions

	Fluid Flow Models
	Pore-Scale Flow
	Introduction
	Model Definition
	Results and Discussion
	References
	Modeling Using the Graphical User Interface

	Fluid Flow to Wells
	Fluid Flow to Wells: Finite Radius Well
	Introduction
	Model Definition
	Implementation: Extrusion Coupling Variables
	Results
	References
	Modeling Using the Graphical User Interface

	Fluid Flow to Wells: Leaky Well
	Introduction
	Model Definition
	Results
	References
	Modeling Using the Graphical User Interface

	Fluid Flow to Wells: Wellbore Storage
	Introduction
	Model Definition
	Results
	Reference
	Modeling Using the Graphical User Interface

	Perforated Well
	Introduction
	Model Definition
	COMSOL Multiphysics Implementation-Boundary Flux
	COMSOL Multiphysics Implementation-High-Accuracy Flux Computation
	Model Data
	Results
	References
	Modeling Using the Graphical User Interface

	Coupled Flow Laws
	Introduction
	Model Definition
	Modeling in COMSOL Multiphysics
	Model Data
	Results and Discussion
	References
	Modeling Using the Graphical User Interface

	Transitional Flow: Darcy-Brinkman- Navier-Stokes
	Introduction
	Model Definition
	Darcy’s Law
	Brinkman Equations
	Navier-Stokes Equations
	Implementation: Navier-Stokes Initial Guess
	Implementation: Coupling with Weak Constraints
	Data
	Results
	Modeling Using the Graphical User Interface

	Porous Media Flow: Discrete Fracture
	Introduction
	Model Definition
	Implementation
	Results
	Conclusions
	Model Data
	Modeling Using the Graphical User Interface

	Variably Saturated Flow
	Introduction
	Model Definition
	COMSOL Multiphysics Implementation-Integration Coupling Variables
	Results and Discussion
	References
	Modeling Using the Graphical User Interface

	Interpolation for Unsaturated Flow
	Model Definition
	Implementation: Interpolation from Scattered Data
	Implementation: Interpolation from Experimental Data
	Results
	References
	Modeling Using the Graphical User Interface

	Two-Phase Flow
	Introduction
	Model Definition
	Implementation: Numerical Differentiation to Estimate C
	Implementation: Step Change on a Boundary
	Data
	Results and Discussion
	References
	Modeling Using the Graphical User Interface: Air-Water System
	Two-Phase Flow: Switching Fluid Pairs
	Modeling Using the Graphical User Interface: Air-Oil and Oil-Water

	Aquifer Characterization
	Introduction
	Model Definition
	Results and Discussion
	References
	Modeling Using the Graphical User Interface

	Forchheimer Flow
	Introduction
	Implementation in COMSOL Multiphysics
	Model Definition
	Results and Discussion
	Reference
	Modeling Using the Graphical User Interface


	Flow and Solid Deformation Models
	Compaction and Poroelasticity
	Introduction
	Model Definition
	References

	Terzaghi Compaction
	Introduction
	Model Data
	Results and Discussion
	References
	Modeling Using the Graphical User Interface

	Biot Poroelasticity
	Introduction
	Model Definition
	Governing Equations
	Model Data
	Results and Discussion
	References
	Modeling Using the Graphical User Interface

	Poroelastic Flow and Deformation: Open-Hole Multilateral Well
	Introduction
	Model Definition: Flow and Deformation Simulation
	Results: Flow and Deformation Simulation
	Failure Criterion
	Results: Failure Criterion
	Conclusions
	Data
	Reference
	Modeling Using the Graphical User Interface


	Solute Transport Models
	Solute Injection
	Introduction
	Model Definition
	Model Data
	Results
	References
	Modeling Using the Graphical User Interface

	Buoyancy Flow with Darcy’s Law: The Elder Problem
	Introduction
	Model Definition
	Model Data
	Results and Discussion
	References
	Modeling Using the Graphical User Interface

	Variably Saturated Flow and Transport: Sorbing Solute
	Introduction
	Model Definition-Sorbing Solute
	Results and Discussion
	References
	Modeling Using the Graphical User Interface

	Pesticide Transport and Reaction in Soil
	Introduction
	Model Definition
	Results
	References
	Modeling Using the COMSOL Reaction Engineering Lab
	Modeling Using COMSOL Multiphysics

	Aquifer Water Table Calculation
	Introduction
	Model Definition
	Results and Discussion
	References
	Modeling Using the Graphical User Interface
	Changing Time Units to Years


	Heat Transfer Models
	Buoyancy Flow in Free Fluids
	Introduction
	Model Definition
	Implementation: Nondimensional Solutions with Iterative Solver
	Results and Discussion
	References
	Modeling Using the Graphical User Interface

	Free Convection in Porous Media
	Introduction
	Model Definition
	Implementation: Initial Conditions for Boussinesq Approximation
	Results
	Reference
	Modeling Using the Graphical User Interface

	Phase Change
	Introduction
	Model Definition
	Implementation
	Results
	References
	Modeling Using the Graphical User Interface
	Phase Change Without Latent Heat
	Phase Change for Varying Transition Intervals


	Multiphysics Models
	Electrokinetic and Magnetic Fields Inside a Volcano
	Introduction
	Model Definition
	2D Model with Topography and Electroosmotic Force
	Results-2D Model with Topography and Electroosmotic Force
	Magnetic Field Postprocessing-Biot-Savart’s Law
	Results-Postprocessing the Magnetic Field
	3D Model of Fluid Flow, Electrostatics, and Magnetostatics
	Results-3D Model of Fluid Flow, Electrostatics, and Magnetostatics
	References
	Modeling Using the Graphical User Interface-2D Model
	Modeling Using the Programming Language
	Modeling Using the Graphical User Interface-3D Model


	INDEX
	A
	B
	C
	D
	E
	F
	I
	L
	M
	N
	P
	R
	S
	T
	U
	V
	W


